About Ray Dream 3D
With Ray Dream 3D you can create dazzling 3D illustrations in five easy steps:

¢ Build true three-dimensional (3D) objects with easy-to-use, intuitive modeling tools

¢ Paint colors and textures on your objects with realistic properties like transparency and reflection
¢ Arrange your objects together in a scene

¢ Light your scene to enhance realism and depth, and finally

e Render your scene with Ray Dream’s acclaimed ray-tracing engine to produce extraordinary, photorealistic
illustrations

The Ray Dream workspace is like a photographer’s studio. You can position multiple light sources and cameras, and
shift between cameras to gain different perspectives on your work. A Ray Dream 3D document is called a scene. A
scene is the collection of objects, light sources, and cameras, saved together in a file. You can use the Scene Wizard
to guide you through the process of creating 3D scenes. When your scene is completed, you can render it. Rendering
is the process of capturing a two-dimensional image, like a photograph, from your three-dimensional scene.

When the application opens for the first time, you see four windows: Perspective, Time Line/Hierarchy, Browser, and
Properties palette. These are the primary work windows. (If you are using a large monitor, additional windows may
appear.) As you work, you can resize windows, move them around on the screen, and customize your workspace.
When you quit, Ray Dream 3D remembers your settings and uses them the next time you launch the application. If
you like, you can save different workspace layouts in configuration profiles, which you can load at any time.



Perspective Window

The Perspective window shows a view of the 3D workspace, where objects, lights and camera are arranged to create
a scene. The workspace itself is called the universe. The view of your scene shown in the Perspective window is
taken through a camera. You can move this camera to see different views of your scene or you can add other
cameras to get more viewpoints.

The current zoom ratio (1:1, 2:1, etc.) is shown in the lower left of the window and the status (idle, drawing, shading,
etc.) of the application is displayed in the status area.



About the Working Box

The main area of the Perspective window is called the working box. The working box, represented by three
intersecting planes and it provides a framework for guiding you as you work in a three-dimensional universe with two-
dimensional devices—the mouse and monitor.

Each plane of the working box has a grid. Each grid represents an axis in three dimensional space: X, Y and Z.
When you’re arranging objects you’ll need a specific plane to act as a reference. This plane is called the active plane
and is displayed in light green. The active plane is plane of reference for many arranging operations like moving and
aligning.

You can hide or display the grids using the Display Plane tool. Planes that are visible are shown in dark gray. Invisible
planes are white.



About the Modeling Windows

When you “Jump Into” an object by double-clicking it, the Perspective window “zooms in” on the object (to the
exclusion of other objects), the menus change to display the modeler’s menu, and the Perspective toolbox changes
to the modeler toolbox.

The modeling and Perspective windows look similar but there are a few ways you can tell which window you’re in:

¢ In the Perspective window all the objects in your scene are visible, in a modeler only the object you’re modeling is
visible.

¢ The Done button appears at the bottom of the window.

¢ Many of the tools in the Perspective window, like the camera, lights and object creation tools, are not visible in the
modeling windows.



Previewing Objects
The Perspective window has five modes for displaying your objects:

¢ No Preview
¢ Bounding Box
¢ Wireframe

¢ Preview (Gouraud)

¢ Better Preview (Phong)

Better Preview mode shows details of the shape and color of your objects, but takes longer to calculate and draw. To
increase application efficiency, you might want to work in Wireframe or Preview mode at the outset of a project, then
switch to Better Preview mode as specific details become important.

You can also make specific objects invisible in the Perspective window. The Object Invisible command in the View
menu. Invisible object(s) will still appear in the Hierarchy/Timeline window with their names italicized.



Time Line/Hierarchy Window

The Time Line window shows a logical (as opposed to visual) representation of the scene. All objects, cameras, and
lights that you bring into the universe are represented by text items in the Objects panel of the Time Line. This
window also provides certain information on the scene’s construction that is not immediately apparent in the
Perspective window; for example, how several elements may be grouped.

The Time Line window has two modes: time line and hierarchy.

¢ Intime line mode, the window displays the events, transition and length of your animation. Scene elements are
displayed as a list of text items. This mode gives you control the events in your animation.

¢ In hierarchy mode, the window displays all the elements in your scene as icons. This mode gives you more
control over how elements are grouped and linked.



Browser Window
The Browser is a visual catalog of all the elements you can use to create a scene. The Browser can store:

e Shaders
* Objects
e Lights

e Cameras
¢ Behaviors

All the items in a Ray Dream scene can be stored as separate files on your system. The Browser lets you load theses
files and view them as visual libraries complete with previews of each item. You can retrieve any item by dragging
them out the Browser and into either the Hierarchy or Perspective windows.

Each tab can display a multiple number of directories. You can use the Browser commands to add and remove
directories. You can also add some items from the Hierarchy window by dragging them directly into the Browser. You
can view Browser items by small icon, large icon, or text using the Browser:View commands.

e Double-clicking a Shader or Behavior tab in the Browser opens the appropriate editor for the item. For example,
double-clicking a Shader opens the Shader Editor.

¢ Double-clicking an object light or camera, opens a new perspective window containing only the item.



Properties Palette

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’s name,
position, shading, behaviors, and rendering settings.

¢ When a light is selected, the palette displays the light’s properties and controls for changing the light type, color
and other properties.

e When a camera is selected, the palette displays the camera’s name, position and camera type properties.

¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.



Toolbars

Ray Dream 3D’s toolbars provide quick access to many of Ray Dream’s frequently used commands and functions.
There are eight different toolbars available in Ray Dream:

Standard

Zoom
Rendering
Time Controller
Status

Tools

Planes

Internet

You can use the Toolbar dialog available from the View menu to choose which toolbars you want to be displayed. The
tools available in the Tools toolbar change as you change between the Perspective, and Free Form windows.

Toolbars can be docked to application window or undocked as floating windows. When you float toolbars they appear
as windowson top of all other Ray Dream windows.

£|Related Topics



Thinking in 3D
Whether you’re used to working with 2D illustration applications or using a 3D illustration application for the first time,

there are several things you should consider. The scene you create and the objects you use to populate it, are all in
3D, so you need to consider how your scene will look in all three dimensions.

When you look at a real-world object, you may think it’s structurally complex. Its shapes curve, twist, join, and
separate in ways that may seem impossible to recreate in a computer art program, but Ray Dream 3D makes
constructing such objects easy, by building them one piece at a time.

Before beginning a complex object, examine its components. Keeping in mind the way Ray Dream’s modeling tools
work, divide the object into simple elements. For example, you can “disassemble” a mini-sub engine into the engine
housing, the blades, and an engine. Once you model each of these components separately, you can use the
positioning and alignment tools in the Perspective window to assemble the pieces.

When a subassembily is built, like the mini-sub engine, the components can be grouped. Grouping enables the
subassembly to be manipulated as a single object. Working in this way, there is no limit to the complexity of objects
that can be built. Finish the mini-sub, place it under water, put a terrain and some ruins, and an underwater scene is
created.



Using Shading

Different objects can also be shaded to provide depth and lighting effects. Shading involves not only color, but also
textures, like gravel on a sea floor, and surface properties, like shininess.



Using Lighting

To enhance realism and three-dimensional effects, light sources can be created in your scene. In fact, lighting is
necessary for the same reasons it is required in photography—nothing can be seen without it! With special lighting,
the underwater scene can be changed from a shallow lake at midday to the murky depths of the ocean. In a shallow
lake, the lighting is bright white and comes from overhead, the shadows are short, directly beneath the objects. In the
murky depths, the light is fainter and shadows only appear when objects are lit directly. In the depths, the ambient
light is very dim and dark blue and the mini-sub’s spotlights create high contrast shadows on the ruins.



Viewing your scene

You can view your scene from any angle and at any degree of magnification during scene development. In Ray

Dream 3D, different views can be created simply by placing cameras at different positions in your three-dimensional
workspace.

For example, a bird’s-eye view can be taken looking down at your underwater scene. The scene can also be viewed
from below, or shown from the view of a diver on the sea floor watching the mini-sub glide by. It’s the same scene,
but what appears in the window depends entirely on the selected viewpoint.



Rendering a Scene

Rendering is the culmination of a Ray Dream 3D project. Rendering, like taking a photograph, reduces your three-
dimensional scene to a two-dimensional image. The rendered image, which potentially has a much higher resolution
than can be seen on the screen, can be printed directly from Ray Dream 3D, or opened in virtually any Macintosh or
Windows graphics application.

If the rendering doesn’t turn out quite right, you can always go back into your scene and adjust the viewpoint, lighting,
shading, or even the shape of objects. Then, simply take another rendering.



Animation Overview

Animation with Ray Dream 3D is a matter of adding a fourth dimension—time—to your 3D illustrations. Animation is
the process of arranging your scene at key points in time and then Ray Dream 3D fills in the gaps to complete the
animation.

Nearly everything in your scene can be animated:
¢ the motion of objects, lights, and cameras

e objects’ sizes, shapes, and shading attributes
e camera and light parameters

e ambient lighting, background, backdrop, and atmospheric effects



The Animation Process

The steps for creating an animation are almost the same as creating scene, except that for animations you change
the properties of your scene at different points in time to create changes in action.

The steps to creating an animation are:
¢ Create objects using the Free Form modeler.
¢ Build the scene by arranging objects and setting lights and cameras.

¢ Animate the scene by making changes to the properties of the elements in your scene at different points in time.
Each change of properties is called a Key Event. Ray Dream creates the illusion of motion by filling in the
transitions between key events.

¢ Render the final animation. You can save your rendered animation as an AVI (Windows) movie or as a series of
sequential bitmap files in a variety of Windows formats.



Time Line Window

The Time Line window is the principle tool for creating animations. The window displays a graphical representation of
your animation.

The Time Line window consists of three areas:

¢ The hierarchy area which shows the scene’s hierarchical structure, including links and groups. Individual objects
and effects in the Time Line window’s hierarchy area can be expanded to show their animation properties. This
allows you to animate each property individually.

¢ The time line area to the right of the hierarchy area which displays a time track for each item (object, effect, or
property) currently shown in the hierarchy area. A key event marker on a particular time line track indicates the
occurrence of a key event that modifies the associated object, effect, or property. Key event markers can be
created, copied, deleted, or moved along the Time Axis by dragging them in the time line area.

The Time Axis which extends across the bottom of the window and acts as a time ruler, with marks indicating time
increments (minutes, seconds, and frames). The location of the Current Time Bar along the Time Axis indicates the
current time—the point in the animation that is currently being edited and displayed in the Perspective window. You
can change the current time by dragging the Current Time Bar along the Time Axis.

Note: If you are working on an illustration project in Ray Dream 3D and prefer to work with an iconic hierarchy view
rather than the time line view, choose Vertical or Horizontal from the View menu when the Hierarchy window is active.
This replaces the Time Line window with the standard Ray Dream Designer Hierarchy Window.



Time Controller Toolbar

The Time Controller’s VCR-like controls allow you to preview your animation within the Perspective window. The
Time Controller can also be used to change the current time.

If the Time Controller toolbar is not visible you can choose the View/Toolbars command and select it in the dialog that
appears.




Customizing your Workspace for Animation

You can optimize the layout of your Ray Dream 3D windows by choosing a workspace designed specifically for
animation. Ray Dream 3D includes preset animation workspaces to fit most popular screen resolutions.

Generally, the preset animation workspaces widen the Time Line Window and display it in the lower portion of your
screen, moving the Browser to the upper right corner. The wider Time Line window allows you to see more of the time
line without scrolling.

You can also create your own custom animation workspace by arranging the windows in the position you want and
then saving the configuration.



Special Animation Features
There are several animation features available in Ray Dream 3D to let you enhance your animations:

e Tweeners

e Behaviors

¢ Animating with the Modelers
¢ Rotoscoping



Tweeners

Ray Dream 3D uses formulas called tweeners (from in-between) to calculate the state of each object between key
events. By specifying which tweener to use for each transition, you can control the rate of change between key
events in your animation.

Ray Dream 3D includes four different types of tweeners:

e linear—for a constant rate of change

e Bezier—for smooth motion paths and greater control over acceleration and deceleration
e discrete—for instantaneous change

e oscillate—for alternating back and forth between key events



Behaviors

Behaviors are a class of tools which help to automate the animation process, saving you time and effort. Some
behaviors, like Bounce and Spin, automatically animate common types of motion. Others, like Point At and Track,
automatically animate one object, based on the position or orientation of a second object.



Animating with the Modelers

You can animate the shape of any model you create using the Free Form or Mesh Form modelers by modifying its

cross sections and sweep path over time. This enables you to achieve fluid, Bezier-based animation and object
metamorphosis.



Rotoscoping

Rotoscoping lets you add live action or moving textures to your scene by incorporating existing animations or
digitized videos (movies) into your animation. You can use QuickTime and Microsoft Video (AVI) files as texture maps
or paint shapes on objects, backgrounds, backdrops, and light gels.



Storyboarding

Storyboarding is a convention borrowed from traditional cel animation which helps you to plan the sequence of events
in your animation. A storyboard is a series of drawn images that describes an animation’s action scene by scene as it
unfolds over time. Refining your animation at the storyboard stage, before you start modeling, can help you avoid
unnecessary work and save you considerable time. If you are attempting anything other than a brief animation, try
creating a storyboard first.

Your storyboard for working in Ray Dream 3D might be a series of sketches that shows the overall action of the
animation as viewed through the rendering camera, accompanied by diagrams that show the position of objects,
lights, and cameras at crucial points.

You can make sample storyboards by drawing a series of horizontal screen outlines on a sheet of paper, using a 4 to
3 aspect ratio (ratio of width to height). Draw the screens as large as necessary, and leave a block of space for the
narration or description. You can also purchase cartooning storyboards at art supply stores.



Simplifying Your Scenes

In general, the 3D scenes you create for animation need not be as complex as a typical illustration scene. The eye
tends to be drawn toward motion and elements in the immediate foreground; static objects and background elements
are scanned only casually.

When preparing a scene for animation, keep the following guidelines in mind. By reducing unnecessary detail, you
can reduce rendering times dramatically and keep the size of your scene files manageable:

¢ Refine your animation. Keep the objects as simple as possible. Detail is usually lost in an animation.

e Use fewer rather than more objects in the animation; especially limit the number of reflective and transparent
objects.

¢ Use the minimum number of lights required to achieve an effect. (Each additional light adds significantly to the
rendering time.)

e Limit texture map size, and use 8-bit texture maps instead of 24 bit.
¢ |If a complex model remains in the background for the duration of the animation, try substituting a simpler version.
¢ When you can, use a rotoscoped, bitmapped or procedural background instead of a modeled background.

¢ If your camera view remains unchanged for an entire scene, consider rendering a still image with just the scene’s
background elements. Then use this image as a bitmap backdrop and animate only the foreground elements.
This technique requires some planning to make sure that shadows and transparent objects do not give the “trick”
away.



Rendering without Compression

If you are not pressed for hard disk space, it usually makes sense to render your animation without compression. This
ensures that you will have a high-quality copy of the animation to work with. There is nothing more disappointing than
waiting several hours for an lengthy animation to render, only to find that too much quality was lost in compression.

Working from your uncompressed original, you can save copies, experimenting with various compression settings
until you are satisfied with both the image quality and the playback rate.

You should always render without compression if you intend to do any post-processing in another application, since
an animation compressed multiple times degrades significantly.



Motion and Timing Principles

As an animator, the most important skill you can master is the ability to portray motion convincingly, whether it is
intended to be realistic or exaggerated and cartoonish. No matter how good a 3D modeler you are, the timing of the
events in your animation are of paramount importance.

Many of the principles of timing and motion developed by cel animators over the years apply to 3D animation with
Ray Dream 3D as well. Many of these principles apply especially to character animation, but most will be useful no
matter what your subject matter.



Squash and Stretch

Squash and stretch are animator’s terms for the exaggerated re-distribution of an object’s mass as it moves or shifts
positions. Squash and stretch portray the qualities of elasticity and weight in a character or an object. Think of a
bouncing rubber ball. As it falls it stretches; as soon as it hits the ground it is squashed. If the ball failed to change
shape, the audience would interpret it as a solid, rigid mass.

Squash and stretch can be accomplished in Ray Dream 3D by using the Free Form Modeler to animate objects’
shapes.



Lag and Overlap

When an object moves from one point to another, not everything has to move at once. For true to life movement,
action that is secondary to the main activity can lag and overlap. For example, when you animate a character in
pursuit of a bus, different parts of the body move at different speeds. The character’s head may lead, followed by his
torso, and finally by his arms and legs.

A flag waving back and forth is another example of lag and overlap; it lags at one end of the arc and overlaps when
moved in the opposite direction. You can use Ray Dream 3D’s Free Form Modeler to create lagging and overlapping
effects.



Arc versus Straight Line Movement

Character motion appears more realistic if it follows an arc or curved path instead of a straight line. Objects affected
by gravity also follow curved, rather than straight trajectories.

Ray Dream 3D’s Bezier tweener is optimized for arc type movements. Try experimenting with its Tighten In and
Tighten Out settings to produce narrower or wider arcs.




Secondary Motion

Secondary motion adds realism and credibility to a scene. A character turning his head to stare at something in
disbelief shouldn’t just turn his head; his jaw should drop and his eyes should blink as well. The viewer focuses on
the main action, but registers the secondary motion as supporting it. Ray Dream’s time line gives you enough control
to manage even the finest details of your animation, making it possible to add secondary motion.



Anticipation and Follow-through

In anticipation of a major action, an animated character often makes a small preliminary action in the opposite
direction. For example, a character about to move screen right might first make a slight movement screen left, then
strike a pose before finally moving screen right.

Follow-through is the continuance of motion after a major action is completed. A baseball bat does not stop moving
after hitting the ball; rather, it continues along its arc of motion. Anticipation and follow-through make actions more
believable.



Exaggeration

Exaggerating an action emphasizes it, making it more prominent. If intrigue is called for, have a character sneak
instead of walk. If you want your animation to resemble footage from a hand-held camera, give your camera an
exaggerated bobbing motion. Virtually any type of action can be exaggerated to get an idea across.



Timing

Timing is as important in animation as it is in any dramatic form. A different impression can be conveyed simply
through the timing of a movement. Consider the difference between an abrupt stop and a gradual slowdown. In
general, a motion that continues at the same pace lacks interest and seems unreal. If you are trying to animate

realistic character action, act out the sequence yourself, timing how long each pose is held and how long each action
takes with a stopwatch.

Timing is one of the most difficult aspects of animation to master. The key events you define at different points on the
time line need to be synchronized with those which came before and those which follow. Fortunately, you can use the
interactive nature of computer animation to fine-tune your timing. Test your animation frequently by previewing it in
the Perspective window or by dragging the Current Time Bar back and forth from key event to key event, making
adjustments until you are satisfied with the timing.



Learning about files

Everything in Ray Dream 3D can be saved as a file. You can save entire scenes as .RDS files which store all the
information in the scene including objects, lights cameras and render settings, or you can save the individual
components of a scene as separate files.

Objects, Shaders, and Behaviors can all be saved as individual files (.BRW) that can only be opened by the Browser.
Once loaded into the Browser, they can be dragged into your scene. They can also be stored in different folders to
create libraries of components like Shader nd Object libraries. The Browser commands let you save, add and remove
different folders, or families, from the Browser.

Light and camera can be saved either as part of scene where they are stored along with all the other scene
information, or as separate scene files and then placed into the browser where they can be used in any number of
scenes. In this way can create libraries of lighting and camera setups the same way you would Shader libraries.



Display colors

Ray Dream 3D is a full-color application. For the best preview display, use the Windows Setup options or your video
adapter control panel to set your display to the highest color depth possible.



About the Scratch Disk o 2_#¥i =W

Ray Dream 3D uses free space on your hard drive to store portions of the scene you are working on. The program
periodically reads and writes to this disk space as you zoom in or make changes in your scene. The disk space used
by Ray Dream 3D for this purpose is called the “scratch disk.”

Ray Dream 3D works more efficiently when the selected scratch disk is fast and has plenty of free space. If scratch

disk space and memory are limited, zooming is limited. You may want to use a disk utility to keep your scratch disk

optimized.

By default, Ray Dream 3D chooses the disk where the application is installed as the scratch disk. However, you can
select any of your hard disks as the scratch disk.



Selecting a Scratch Disk LYSIYIEW i V|

To select the scratch disk:
1.Choose File>Preferences.

1. Choose Imaging, Scratch Disk from the pulldown menu.
2. Select the disk you want to use as the Scratch Disk.

3.Click OK.



Using Extensions owie =V

Ray Dream 3D is designed along an extensible, open architecture. Application developers can create extensions to
integrate with 3D. Extensions might include a new modeler (a tool set for shaping objects), procedural shaders, new
types of lights, cameras, or even an alternative rendering engine.

The complete Extensions Toolkit and API for creating Ray Dream 3D extensions is available on the Ray Dream 3D
CD-ROM. Refer to the Extensions Portfolio User Guide for more information on developing extensions.



Adding Extensions XS Y (v V|

To add an extension:

1. Locate the directory Ray Dream 3D\EXT.
Inside this extensions folder are the sub-folders for the program extensions, including those for many of the

features delivered with Ray Dream 3D.

1. Place the new extension in the appropriate folder.

Note: If you move any of these folders from this location or remove an element from them, you may lose access to
some of the program’s features.

At any time when the program is running, you can get information on the Ray Dream 3D extensions installed in your
system by choosing About from the Window’s Help menu.



Using Plug-Ins 22 1@ #%:i ==Vl

Plug-in filters let you apply image editing filters to you rendered images. Ray Dream supports all Adobe Compatible
Plug-ins. By default all plug-ins are located in the Plug-ins folder. However you set a new folder using the Preferences
dialog.



Setting a Default Plug-In Directory Lyevew [ |

To set a default plug-in directory:
1.Choose File>Preferences.

1. Choose Imaging, Scratch Disk from the pulldown menu.

1. Click Set Directory.
A dialog appears which lets you choose a directory on system.

1. Choose the directory you want to use and click Select.



Setting Application Preferences 0 =N

Ray Dream’s Preferences let you customize many of the default settings used in the application. Some preferences
affect the entire application, such as the measure system and color of the interface elements.



Setting Units of Measure XYY [ vl

To set the default units of measure:
1.Choose File>Preferences.

1.Choose General from the pulldown menu.

1.Choose a measure system from Default 3D pulldown menu.
Your selection becomes the default units of measure for all 3D objects.

1.Choose a measure system from the Default Image Size pulldown menu.
Your selection becomes the default units of measure for all imported or rendered images.



Setting Interface Colors Lrervew (e e

To set interface element colors:
1.Choose File>Preferences.

1. Choose Color from the pulldown menu.

2. Click the color swatch next to the element whose color you want to change.

3. Select a color from the color picker that appears.

1. Enable Custom color in the Motion Path controls, if you want to pick a custom color for motion paths.

1. Enable Custom Color in the Bounding Boxes controls, if you want to pick a custom color for object and group
bounding boxes.



Setting Up Your Workspace © =N

Your Ray Dream 3D workspace refers to the configuration of windows and toolbars the you’ll use to create 3D
illustrations. Most of Ray Dream’s windows and toolbars can be customized to suit the way you work. Ray Dream
also has a number of preset configurations which are especially suited for specific display sizes.



Setting Up Your Workspace for your Display UYervIew ;g ol

To set the best workspace for your display:
1. Choose Windows>Workspace> 1024x768 or 800x600.

2.You can also choose Large Font setting for each resolution.
Large font settings take into account the extra room needed when you use your operating system’s Large Font
settings.

As you work you’ll probably configure Ray Dream’s windows and palettes to best suit certain task. You may have
different configuration for animating and modeling. Ray Dream lets you save these configurations for later use.



Saving a Workspace Configuration Lvervew (e |

To save a workspace configuration:

1. Choose Windows>Workspace>Save Current.
The Save Workspace dialog appears.

1. Enter a name for your configuration and click OK.
Saved configurations appear at the bottom of the Workspace menu.



Hiding and Displaying Windows 22X (Vi Tl

To hide/display windows:

Choose Windows> the name of the window you want to hide/display. A checkmark beside the window’s name
indicates that its displayed.



Setting up the Working box
The working box is the area where you position and arrange objects.

To set the default size of the working box:
1.Choose File>Preferences.

1.Choose Perspective from the pulldown menu.

1.Enter a value in the Size box.
This value sets the initial size of the working box in inches.



Setting up the Grid
The Grid in Ray Dream can be an invaluable tool for placing objects in 3D space.

To set up the default grid properties:
1.Choose File>Preferences.

1.Choose Perspective from the pulldown menu.

1. Enter a value in the Space box.
This value sets the initial spacing between lines.

2.Enter a value into the Draw a line every box.
This value indicates interval between lines.



Displaying Grid Planes
The grid in Ray Dream exists in 3D, meaning that the grid is visible in the X, Y and Z planes.

To display/hide grid planes:
1.Click a plane in the Display Planes button. Visible planes appear have dark colored previews.



Using Toolbars 20 12 #%:i ==V

Ray Dream’s toolbars can also be customized. By default Ray Dream displays the Standard, Rendering and Time
Controller toolbars horizontally and the Perspective toolbar vertically on the left side of the window. However, these
are not the only toolbars available in Ray Dream. There are several other toolbars you can use that contain tools for
zooming, previewing animations and accessing Internet sites.



Hiding and Displaying Toolbars XS Y Vi |

To display or hide toolbars:

1.Choose View>Toolbars.
The toolbars dialog appears.

1. Click the name of the toolbar you want to display.
Atoolbar is displayed when a checkmark appears next to its name.

2.Enable the Lock Toolbars checkbox, if you want all the toolbars to remain locked to the main window.
1.Enable Reset to default to display only the default toolbars.

Toolbars can remain part of the main window, or you can have them float as separate palettes.



Docking and Undocking Toolbars 22XV [ VNl

To undock a toolbar:

Click one of the edges of a tool and drag it towards the center of the window. A palette containing all the tools in the
toolbar appears.

To redock toolbars:

Drag the tool palette to the edge of the window. When the palette’s outline switches to a toolbar layout release the
mouse button.



Creating a New Scene

Before you can create a new 3D illustration, you have to create a new document in Ray Dream. A new document can
be a blank scene or a predesigned scene you add using the Scene Wizard.



Creating an Empty Scene

When you create an empty scene in Ray Dream, the Perspective window opens using your default workspace setup.
Your scene contains only one default light and a default camera.

To create an empty scene:

1.Choose File>New.
The New dialog appears.

1.Click Create Empty Scene.
An blank scene appears replacing any existing scene.



Using the Scene Wizard rowo =NV

The Scene Wizard is a picture-based assistant that guides you through the steps of creating scenes. There are two
ways to create scenes through the Scene Wizard, by using templates or by picking various components of your
scene, step-by-step.

There are three different categories of Scene Templates: Logo Templates, Indoor Templates and Outdoor Templates.
Each of these contains completed scenes in each of their categories. Once you’ve created the scene, you can edit
the scene, just as if you created it from scratch.

There are two categories of step-by-step wizards: Photo 3D and Indoor Step by Step. These categories create
scenes by stepping through a number of screens to select various components for your scene. The Photo 3D lets you
choose lighting effects, backdrops, and props. The Indoor step by step lets you choose wall and floor combinations,
and lighting effects.

The Scene Wizard can create new scenes or you can apply the Scene Wizard settings to an existing file. You can
have the Scene Wizard automatically appear whenever you launch Ray Dream.



Automatically Launching the Scene Wizard ZXETYEY frr Wl

To have the Scene Wizard automatically launch:
1.Choose File>Preferences.

1.Choose General from the pulldown menu.

1.Enable the Use Scene Wizard on New to have the wizard appear whenever you use the New command.



Creating a Scene with the Scene Wizard XY (Vi W4l

To create a new scene using the Scene Wizard:
1. Select New from the File menu.
In the dialog that appears, click the Use Scene Wizard button.

1.Follow the on-screen instructions.

2.Click Done when you’ve reached the final screen.



Adding to a file with the Scene Wizard 2SS [/l V|

To use the Scene Wizard to add to an existing file:
1.Choose File> Apply Scene Wizard.

1. Follow the instructions provided by the wizard.
The selections you make in the Scene Wizard will be applied to the current file.



Opening an Existing File
You can open any file you created in versions 3 or 4 of Ray Dream Designer, Animator or 3D.

To open an existing file:

1.Choose File>New.
The New dialog appears.

1. Click the Open Existing File button or Choose File>Open.
The Open dialog appears.

1.Locate the file using the dialog controls and click Open.



Using the Browser 2XSYEY i WMl

The Browser palette helps you store and reuse items and features you’ve created or customized. The Browser
palette has eight tabs—Shaders, Objects, Lights, Cameras, and Behaviors. Each tab category lets you organize
items you save into directories.

When you’ve customized an item in one of these tab categories, you can save it to the browser, where it will be easy
to retrieve and use again later. Most operations with the Browser are the same in all categories.

Note: Each item in the Browser is saved as a document (.BRW file). The Browser includes individual objects, groups
and full scenes.



Displaying the Browser XSSV fiir WW|

To display the Browser:

1. Choose Windows>Browser.
3D displays the Browser palette.

1. Click the tab for the category you want.
You may need to widen the window or click the tab scroll arrows to show the tab category you want.



Changing the Browser View and Column Width LXETYEY /W]

To change Browser view:
Choose Browser palette: View menu and select the display you want—Text, Small Icon, or Large Icon.

To change browser column width:

Drag the column divider to set the new column width.
If the number of columns exceeds the window width, use the scroll bar on the bottom to bring more items into view.



Setting Browser Preferences
1. Choose File>Preferences.

1.Choose Browser from the pulldown menu.

1. Enable Drop as Master Group if you want any camera, light or object dragged from the browser to be dropped into
the Perspective window as a Master Group.

2.Enable Auto Load Selected Shader In the Shader Editor to automatically launch the Shader Editor whenever you
click on a Shader in the Browser.
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Adding an Object, Camera, or Light to the Browser
To add an object, camera or light to the Browser:

1. Display the appropriate tab in the Browser.
1. Adjust the hierarchy to display the object, camera or light’s listing.

1.Drag the item’s listing from the hierarchy into the Browser palette.

You must drop it under one of the named directory columns. You may also add a group. To add the entire scene,
select all of the items and drag. 3D opens a dialog so that you can name the saved item.

1.Enter a name and click OK.
3D adds the item to the Browser in the directory column where you dropped it.
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Saving a Scene to the Browser
To save a scene to the Object Browser:

You may save a scene to the Browser palette: Objects tab in another way.
1.Choose File> Save As.
1. Click the Options button.
Enable the “Save icon preview” option.
You might want to disable the “Save cameras and lights” option.
Close the Save Options dialog.

1. Use the directory tools in the Save dialog to locate and open a folder/directory that’s loaded into the Browser
palette: Objects tab.

1. Save the scene file there.
2.Display the Browser palette: Objects tab.
3. Select the column listing for that directory.

4.Choose Browser palette: Update Selected Folder.
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Adding Items to the Browser

To add a shader or behavior, to the Browser:
1. Display the appropriate tab in the Browser.

1.Drag the item you want to add into the Browser palette.
You must drop it under one of the named directory columns.
If the item you want to add is in the Properties palette, you may drag it from there.
If the item you want to add is in a Browser document window, you may drag it from there.
You may also drag the preview from the Shader Editor.

1.3D opens a dialog so that you can name the item; enter a name and click OK.
3D adds the item to the browser in the directory column where you dropped it.
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Adding a List to the Browser

To add a list of behaviors to the Browser:

Behaviors are cumulative—you can apply several of them. You might create a list of behaviors that you’d like to save
and apply collectively. The Browser helps you do this.

1. Display the Properties palette: Behaviors tab.
1. Shift-click to select each behavior you want to include.

1.Drag the last item into the Browser palette.
You must drop it under one of the named directory columns.

1.3D opens a dialog so that you can name the list. Enter a name and click OK.

3D adds the item to the browser in the directory column where you dropped it.

overview ("W Topics



Retrieving from the Browser

To use an object, camera or light from the Browser:
1. Display the appropriate tab in the Browser.

1. Drag the item you want from the Browser into your scene.
You may drag it into the Perspective window or into the hierarchy.

Note: If you double-click an object, camera or light listing in the Browser, 3D will open it in a new scene.

When you introduce objects from the Browser into a new scene, the objects carry all of their shading and
arrangement characteristics with them. Scenes kept in the Browser are introduced into a new document as a group
class.

To use a shader or behavior from the Browser:

¢ Drag the item you want to use from the Browser onto the object where you want to apply it.
You may drag onto the object preview in the Perspective window or onto its listing in the hierarchy.

Note: You may also select the object, select the item in the Browser, then click Apply at the bottom of the Browser
palette.



Getting Info on Browser Items

Any item that appears in the Browser is saved as a separate document. All Browser items may be opened, edited and
saved.

To get info on a Browser item:
1. Display the appropriate tab in the Browser.

1. Select the item you want to find out about.
2.Choose Browser palette: File menu> Get Info.

3D displays a dialog providing information on the selected item.

You can use the Name field to change the name. Or add a comment as a reminder of how to use this particular
item.
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Editing Browser Items

Any item that appears in the Browser is saved as a separate document. All Browser items may be opened, edited and
saved.

To edit a Browser item:
1. Display the appropriate tab in the Browser.

1. Double-click the item you want to edit.
For an object, camera or light, 3D opens it in a scene. 3D opens all other items in a Browser document window,
which contains the tools appropriate to its type.

1. After making changes, choose Edit> Save.
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Creating Browser Items

Any item that appears in the Browser is saved as a separate document. All Browser items may be opened, edited and
saved.

To create a new Browser document:
1. Display the appropriate tab in the Browser.

1.Choose Browser palette: File menu> New Document.
1.3D opens a document window of the type you selected.

2. After making changes, choose Edit> Save.
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Duplicating Browser Items

Any item that appears in the Browser is saved as a separate document. All Browser items may be opened, edited and
saved.

To duplicate a Browser item:
1. Display the appropriate tab in the Browser.

1. Select the item you want to duplicate.
2.Choose Browser palette: File menu> Duplicate File.
3.3D creates a duplicate of the selected item.

4.You can now open the duplicate for editing.
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Creating a Browser Directory

To create a new directory in the Browser:
1. Display the appropriate tab in the Browser.

1.Choose Browser palette: File menu> Add Folder.
2.3D displays a dialog in which you can locate and open a new directory/folder.
3. Select the folder and click OK.

The folder appears as a new column in the that tab of the Browser.
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Removing a Browser Directory

To remove a directory from the Browser:
1. Display the Browser tab you want to work with.

1. Click on the folder/directory title you want to remove.
It will be highlighted.

2.Choose Browser palette: File menu> Remove Selected Folder.
3D removes the folder column from the Browser.

Closing a directory file does not delete files. It only removes them from display in the Browser.
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Updating a Browser Directory

To update listings in a Browser directory:
If you change the contents of a Browser directory, you may need to force 3D to build a new list of the contents.
1. Display the Browser tab you want to work with.

1. Click on the folder/directory title you want to update.
It will be highlighted.

1.Choose Browser palette: File menu> Update Selected Directory.
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Using the Time Line Window XXSTYEY frir Wul|

As you create your scene you’ll find that the Time Line window quickly becomes an invaluable tool for arranging and
animating objects in your scene. The Time Line window can be customized to display information specific to the type
of task you’re working on.

When you’re modeling or arranging objects you’ll need to see information on grouping and linking. For this task you
can use the Time Line window’ hierarchy mode. The hierarchy mode displays all objects, groups and scene elements
as icons. This mode has two views: vertical and horizontal.
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Displaying the Vertical/Horizontal Timeline View JYEYEYW [ |

To display the Vertical/Horizontal view of the Timeline:
1. Click the Time Line window.

1. Choose View>Horizontal or Vertical.

When you’re creating an animation you’ll need to see key events and tweeners. For this task you can use the Time
Line view of the window.
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Displaying the Timeline view of the Hierarchy 2XSr ¥ [/l Will|

To display the Timeline view of the Hierarchy:
1. Click the Hierarchy window.

1.Choose View>Timeline.
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Setting the Hierarchy Default Display Lrerview Ll

To set the default display of the Hierarchy:
1.Choose File>Preferences.

1. Choose Hierarchy from the pulldown menu.

2.Enable one of the display options.
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Navigating your Scene LXETYEY [ WMl|

As you create your 3D illustration your scene can quickly become rather large. You may not be able to see the entire
scene in the Perspective window, or you may want to enlarge areas to precisely edit objects. Ray Dream provides
several tools for moving around your scene, including the Hand tool, the Zoom tool, and the Zoom toolbar.



Moving an Area into the Perspective Window Yrervew fa .

To move an area of the scene into the Perspective window:
1. Click the Hand tool.

1.Drag the scene in the Perspective window in the direction you want to move it.

You can also select the Hand tool by holding down the spacebar.
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Zooming In and Out of an Area Vverview (a W

To zoom in to an area of your scene:
1. Click the Zoom tool.

1. Click on a point in your scene to enlarge it. You can also drag a marquee around an area to enlarge it.

To zoom out of an area:
1. Click the Zoom tool.

1.Hold down Alt and click an area or click the Zoom Out tool.
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Zooming to a Selection of Objects Lvervew (|

To zoom into a selection of objects:
1.If the Zoom toolbar is displayed choose View>Toolbars.

1. The Toolbar dialog click Zoom and then click OK
2. Select a number of objects.

3. Click the Zoom to selected tool.
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Viewing Objects in Actual Size Yrervew fa .

To view objects in actual size:
1. Display the Zoom toolbar using the Toolbars dialog.

1. Click the Zoom To Actual Size button.

MRelated Topics



Viewing All Objects 2XSTYEY [/l W]

To view all objects:
1. Display the Zoom toolbar using the Toolbars dialog.

1. Click the Zoom To All Objects button.
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Zooming to the Working Box LYSTYEW [ Y|

To zoom to the working box:
1. Display the Zoom toolbar using the Toolbars dialog.

1. Click the Zoom To Working Box button.
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Default View “XETYIET [/l Wl

The default view of your scene is through the default camera. The camera can be sent to a number of default
positions and oriented using the Camera tools.

You can also add additional camera to the scene, You can use the new camera to view your scene from different
angles.



Choosing a View YW [ vl

To choose a camera to view your scene:
1. Choose Windows>Camera Properties.

1. Choose the camera you want to use from the Camera pulldown menu.
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Viewing Your Scene from a Preset Position XS /il W]

To view your scene from a preset position:
Choose View>Preset Position> choose the position you want use.

When you have additional camera you can also view your scene from two different perspectives simultaneously.
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Viewing Your Scene from Two Perspectivesw

To view your scene from two views simultaneously:

1. Choose Windows>New Perspective.
A new window opens.

1.Enable Create New Camera to create a new default camera for this perspective window.
If you want to use the new perspective window to view your scene from two views simultaneously, you must have
at least two cameras.

1. Enter name for the camera and set its properties using the controls.
2.Choose View>Preset Position> the view you want use for this Perspective window.

You can also position the new camera manually.

Now, whenever you change anything in the first perspective window, the second window automatically updates to
reflect your changes.

Note: Each window is updated separately, so you will dramatically increase the redraw time of your scene by adding
more Perspective windows. Use this feature sparingly.
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Copying Items in the Perspective Window
You can cut, copy and paste any item in the Perspective window using the Edit commands.

To copy an item in the Perspective window:
1. Click the object, light or camera.

1.Press Citrl-C.
A copy of the item is placed on the clipboard.

1.Press Cirl-V to paste the item.

Overview (i . Related Topics



Cutting Items from the Perspective Window
You can cut, copy and paste any item in the Perspective window using the Edit commands.

To cut an item in the Perspective window:
1. Click the object, light or camera.

2.Press Ctrl-X. The item is removed from the scene and placed on the clipboard.

3. Press Ctrl-V to paste the item.
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Deleting Items from the Perspective Window
You can cut, copy and paste any item in the Perspective window using the Edit commands.

To delete items in the Perspective window:
1. Select the item.

1.Choose Edit>Delete.
The object is deleted from the scene.
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About Undoing Operationsw

You can reverse the effects of your last action by using the Undo command. Ray Dream has an multiple number of
Undo levels meaning that you can undo a series of operations by hitting undo several times. The maximum number
of undo levels is determined by the value you set in the Ray Dream Preferences.



Setting Undo Levels YSIYIEY fiir V|

To set Undo levels:
1.Choose File>Preferences.

1.Choose General from the menu at the top of the dialog.

2.Enter a value in the Multiple Undo box.
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Undoing Operationsw

To undo operations:

1.Choose Edit>Undo.
The last operation is undone.

1.To undo the next operation, choose Undo again.

There are some operations you cannot undo. In this case, the Undo command is replaced by Can’t Undo.
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Repeating Operationsw

To repeat an operation:
Choose Edit>Redo. The last operation is repeated.
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Saving a Scene

To save a your scene:
1.Choose File>Save.

1.Choose a location for your file.
2. Enter a name for the file in File name field.

3. Choose a file type from the Save as type pulldown menu and click Save.
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Saving Under a New Name

To save your file under a different name:
1.Choose File>Save As.

1.Choose a location for the file.
2. Enter a new name for the file in the File name field and click Save.

When you’re done editing a scene file you can close it.
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Closing a File

To close a file:
1.Choose File>Close.
If you have made any changes, a dialog box appears asking if you want to save your changes.

1.Click Yes to save your changes or No to discard them.
Note: If you click No, there is no way to recover your changes later.
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Modeling vs. Primitives 2XSTYEY frir WNl|

There are two ways of creating objects in Ray Dream 3D. You can create objects by combining a number of basic 3D
shapes, called primitives, or you can model unique shapes using the Ray Dream’s Free Form modeler. The method
you use will depend on the type of object you want to create.

The first thing you need to do when creating an object, is decide how you’re going to build it in 3D space. The easiest
way of doing this is to break the object down to its basic components.

e If those components turn out to be all geometric shapes, you use primitives to create it.
e If the object’s basic components are shapes that can’t be created using primitives, you use the modeler.

For example, when a sub is reduced to basic components, you can see that it’s made up of cylinders, cones and
cubes. Therefore you would use 3D primitives to create the object. Following the same example, if you reduce a
jellyfish to its basic components you’ll end up with objects that are not geometric shapes. In this case you’d have to
use the modeler to create this object.

Primitives are the most basic type of 3D object you can create in Ray Dream 3D. Geometric Primitives are 3D
geometric shapes such as cones, squares or cylinders.



Creating Geometric Primitives XSS [Pl Wl

Geometric Primitive objects are the building blocks of 3D objects. When you closely examine any complex 3D object
you’ll notice that it can be reduced to simple primitive geometric shapes. In fact, the easiest way of creating an object
is by combining a number of primitives.

When you create a Geometric Primitive object, it simply appears in your scene, where you can move and resize it if
you choose. Each type of object you can create has its own tool. The Geometric Primitive tools are located on a
single popup tool menu.

To create a Geometric Primitive object:
1. Select an object creation tool from the toolbar.

1.In the Perspective window, click a point in the Working box to create an object of default size, or drag to create an
object of a custom size.
You can also drag an object creation tool from the toolbar into the Hierarchy/Timeline window to create an object
of default size.

Objects dropped into the Perspective window are placed on the active plane of the Working Box, at the point where
you release the mouse. Objects dropped into the Hierarchy window are placed at the center of the Universe.

Another way is to choose Insert from the Edit menu, and select an object type from the submenu. The object is
created at a default size and placed in the center of the Universe.



Creating Environmental Primitives XSS (7l Vil|

Like Geometric primitives, Environmental primitives can be the building blocks of scenes. They can be used to quickly
add an environment to any scene.

The Cloud, Fog and Fire primitives are volumetric. They behave slightly different than other Ray Dream objects when
you change the size of the object. With other objects, changing the size causes the object itself to change scale.
Changing the size of a volumetric object changes the area that is included in the object but keeps the same scale.

For example, a small cloud made larger results in a larger area of cloud, but the swirls within the cloud stay the same
size. Afire object made taller results in higher flames. Making the fire object wider results in a larger area of fire
based on the parameters you have set.

The Environmental primitives have their own tools which are located on a popup tool menu.



Fountain Primitivew

The Fountain primitive is a particle primitive you can use to create objects like geysers or tornadoes. The Fountain
primitive attributes let you change its color, size and rate of animation.

To create a Fountain object:

1.

10.

Select the Fountain icon and drag it into the Perspective or Hierarchy window or choose Insert menu> Insert>
Fountain.

Double-click the new object.
The fire controls appear.

Adjust the value of the Completion of Fountain slider.
This slider controls the fountain’s animation. Set the slider to 0% at the beginning of the animation and 100% at
the end.

Adjust the value of the Start Speed slider.
This slider controls the force of the fountain. A low setting creates a fast spouting fountain while a high setting
creates a slow spouting fountain.

Adjust the value of the Maximum Angle From Up slider.
This slider controls the angle of the spray from the fountain. When the slider is set to 0 degrees the spray goes
straight up, at 180 degrees it goes out in a radius all the way around the fountain.

Adjust the value of the Gravity slider.
The Gravity slider controls the amount of gravity applied to the fountain. When the setting is low, gravity has little
effect on the fountain. When the setting is high, gravity pulls the particles down quickly.

Adjust the value of the Maximum Swirl Angle slider.
The Maximum Swirl Angle slider controls how much the particles rotate parallel to the ground plane as they fall. A
low setting causes very little rotation while a high setting causes a particle to rotate a great distance as it falls.

Adjust the value of the Number of Particles slider.
The Number of Particles slider controls the number of particles in your fountain.

Adjust the value of the Particle Size slider.
The Particle Size slider controls the size of the particles in your fountain.

Enable or disable the Use Particle life for mapping checkbox.
Enable this box to apply the shader to the entire object. Disable it to apply a shader to each individual particle.



Cloud Primitivew

The Cloud primitive creates a three dimensional, or volumetric, cloud. You can use this primitive to quickly add a sky
to any scene. There is no on-screen preview of the cloud except its bounding box that indicates the cloud's size and
location. You won’t be able to see the cloud until it’s rendered. You can place objects inside the Cloud or partially
within the cloud. Cloud attributes can also be animated.

Note: Changing the size of the cloud by dragging a larger or smaller bounding box does not change the scale of the
clouds. It only changes the area that is covered with clouds.
To create a Cloud object:

1. Select the Cloud icon and drag it into the Perspective or Hierarchy window or choose Insert menu> Insert>
Cloud.

2. Double-click the new object.
The cloud primitive controls appear.

3. Click the Color swatch and choose a color for the cloud.

4. Adjust the value of the Quantity of Clouds slider.
This slider controls the number of clouds that are included in the bounding box.

5. Adjust the value of the Cloud Size slider.
This slider controls the size of clouds that are included in the bounding box.

6. Adjust the value of the Density slider.
This slider controls the density of clouds. A low setting creates almost transparent clouds while a high setting
creates almost opaque clouds.

7. Adjust the value of the Density slider.
This Quality slider controls the quality of the clouds as they are rendered.

8. Click the Container menu and choose a container for your cloud.
The container determines the general shape of the cloud.

9. Adjust the value of the Edge Falloff Size slider.
The Edge Falloff Size slider controls the appearance of the edges of the clouds. A low setting results in a sudden
change or little falloff while a high setting results in gradual change or longer falloff.



Fog Primitive XS Y /i Wl

The Fog primitive creates a three dimensional, or volumetric, fog. You can use this primitive to create a layer of fog
surrounding your scene. There is no on-screen preview of the fog except its bounding box that indicates the fog's size
and location. You won’t be able to see the fog until it’s rendered.

You can place objects inside the fog or partially within the fog. You’ll probably want your fog object to be fairly large
S0 you can place a position of your scene inside it. Fog attributes can also be animated.

Note: Changing the size of the fog by dragging a larger or smaller bounding box does not change its scale. It only
changes the area that it covers.

To create a Fog object:
1. Select the Fog icon and drag it into the Perspective or Hierarchy window or choose Edit menu> Insert> Fog.

2. Double-click the new object.
The fog primitive controls appear.

3. Click the Color swatch and choose a color for the fog.

4. Adjust the value of the Patchiness slider.
This slider controls the regularity of the fog throughout the bounding box. A low setting creates uniform fog. A
high setting creates irregular fog.

5. Adjust the value of the Quantity of Patches slider.
This slider controls how many patches of fog are contained in the bounding box.

6. Adjust the value of the Density slider.
The Density slider controls the amount of light that penetrates the fog.

7. Adjust the value of the Quality slider.
The Quality slider controls the quality of the fog as it is rendered.

8. Click the Container menu and choose a container for your fog.
The container determines the general shape of the fog

9. Adjust the value of the Completion of Upward Effect slider.
The Completion of Upward Effect slider controls the animation of the fog. Set this value to 0% at the start of your
animation and 100% at the end.

10. Adjust the value of the Upward Speed slider.
The Upward Speed slider controls the rate at which the fog rises during an animation. Use a higher setting for
longer animations.

11. Adjust the value of the Swirls slider.
This slider controls how the fog swirls or rotates as it rises.

12. Adjust the value of the Swirl Size slider.
The Swirl Size slider controls the size of the swirls.

13. Adjust the value of the Chaos slider.
The Chaos slider controls the uniformity of the fog. A low setting creates uniform fog while a high settings create
random fog.

14. Adjust the value of the Edge Falloff Size slider.
This slider controls the appearance of the edges of the fog. A low setting results in a sudden change or little
falloff while a high setting results in gradual change or longer falloff.

15. Use the Shuffle button to randomly set fog attributes.



Fire Primitivew

The Fire primitive creates a three dimensional, or volumetric, fire. You use this primitive to set your scene aflame.
There is no on screen preview of the fire except its bounding box that indicates the fire's size and location. You won’t
be able to see the fire until it’s rendered. You can place objects inside the fire or partially within it. Fire attributes can
also be animated.

Note: Changing the size of the fire by dragging a larger or smaller bounding box does not change its scale. It only
changes the area that it covers.

To create a Fire object:

1. Select the Fire icon and drag it into the Perspective or Hierarchy window or choose Edit menu> Insert> Fire.

2. Double-click the new object.
The fire primitive controls appear.

3. Click the Tip Color swatch and choose a color for the tips of the flame.
4. Click the Base Color swatch and choose a color for the base of the flame.

5. Adjust the value of the Quantity of Flames slider.
This slider controls the quantity of flames that appear in your Fire object.

6. Adjust the value of the Pointiness of Flames slider.
The Pointiness slider controls the percentage of your Fire object that is points or tips of flames. A low setting
results in fewer, less tapered points while a high setting results in many more tapered points.

7. Adjust the value of the Detail slider.
This slider controls the degree of detail in the Fire object.

8. Adjust the value of the Density slider.
This slider controls the density of the fire. A low setting creates fire that is almost transparent. A high setting
creates fire that is almost opaque.

9. Adjust the value of the Quality slider.
The Quality slider controls the detail of the fire as it is rendered.

10. Click the Container menu and choose a container for your fire.
The container determines the general shape of the fire.

11. Adjust the value of the Edge Falloff Size slider.
This slider controls the appearance of the edges of the fire. A low setting results in a sudden change or little fall
off. A high setting results in gradual change or longer fall of

12. Adjust the value of the Completion of Burning Fire slider.
This slider controls the animation of your fire. Set this slider to 0% at the start of your animation, and at 100% at
the end.

13. Adjust the value of the Upward Speed slider.
The Upward Speed slider controls the speed at which the flames appear to shoot up during an animation.



Creating Infinite Planes

An infinite plane is a flat primitive whose sides extend out to infinity in all directions. This type of primitive is used to
create a surface for your scene such as a sky, ocean or ground.

To create an infinite plane:
1. Click the Infinite Plane tool and drag it into the Hierarchy to Perspective windows.

You can move the plane perpendicular to the ground plane to adjust the altitude of the plane, but moving the plane
parallel to the ground plane will have no effect.



Shading an infinite plane

Apply shaders to an infinite plane can be tricky since the texture or color you apply will extend out to infinity. This can
be a especially tricky when using texture maps or gradients. The plane’s tiling controls can help you adjust how
shaders are tiled on the plane.

To adjust shader tiling:
1. Double-click the infinite plane.

2. Enable the Tiling option if you want your shader to be tiled across the plane.

1. Enable either the Mirrored in X or Mirrored in Y option.
These options let you control the continuity of the pattern created by tiling shader.

2. Mirrored in X will mirror the tile in the X axis as it tiles it across the plane.

3. Mirrored in Y will mirror the tile in the Y axis as it tiles it across the plane.



Creating Text Objectsw

When you create a Text object, Ray Dream immediately opens it in the Text Modeling window, allowing you to enter
the text you want, specify its depth, and add bevels.

To create Text objects:
1. In the region at the bottom of the dialog, type the text you want.

2. Click the Font menu and choose a font for your text object.
Any TrueType and Type 1 fonts you have in your system are available for creating Text Objects.

3. Click the style menu and choose a font style.

4. Enter a value in the Font Size box.
Font size is measured in points. You can also use the scroll arrows to set a value.

5. Use the Depth controls to set an extension depth for the text.

6. Enable the Front Face checkbox to add a bevel on the front face of the text object.

7. Enter values in the Height and Depth fields to specify the slope or contour.

8. Enable the Back Face checkbox to add a bevel to the back of the text object.

9. Enter values in the Height and Depth fields to specify the slope or contour of the bevel on the back of the text.
10. Click on a bevel type in the Type controls.

11. Click Done or choose Jump Out from the Edit menu.
The Text window changes back to the Perspective window, and your text object is drawn.



Editing Text Objectsw

To edit a Text object:

Double-click a text object in the Perspective or Hierarchy window, or select a text object and choose Jump In from the
Edit menu.

Designer opens the text object in the Text window, where you can change its content, extrusion depth, bevels, or any
of the type specifications.



Text Objects 2SIV [l "

Text objects are controlled by your entries in the Text window. The size of a text object in the Universe depends on
the font size you choose in the Text window. You can determine how large a text object will be by dividing its font size
by two. This calculation gives you the approximate height (in inches) of a capital letter; lowercase letters are
proportionally smaller, of course.

For example, if you created a text object using 72-point type in the Text window, any capital letters in the text object
would be approximately 36 inches tall in the Universe. Knowing the height of the letters in your object, you can set a
value in the Extrusion Depth field to control the relationship between height and depth.



About Free Form Modeling

The Free Form modeler lets you create by converting 2D shapes into 3D objects. The modeler tools let you draw 2D
shapes called cross-sections and then convert them to 3D object by extruding them. Once you’ve created a 3D
object, you can refine its shape using an extrusion envelope.

The Free Form modeler is based on a concept called extrusion. You create an object by drawing a 2D shape, then
drawing a sweep path perpendicular to the shape. Ray Dream 3D sweeps the shape along the path to form a 3D
object.



Straight Extrusion

Straight extrusion is the most basic type of Free Form modeling. In a straight extrusion, a 2D shape is swept along a
straight sweep path, creating a sort of “cookie cutter” effect. The 2D shape doesn’t have to be a single outline—it can
consist of several distinct outlines. You can even extrude a compound path to create an object with a hole in it.



Scaling
Scaling creates objects by changing the scale of the 2D shape as it is extruded along the sweep path.

Simply changing the scale of a shape produces very basic shapes, but when combined with an extrusion or scaling
envelope, you can create a much wider variety of objects.



Lathing Technique

You can model many symmetrical objects using a technique called lathing. Lathed objects are created by extruding
the lath profile around a sweep path. You can think of the lathe profile as the outline of the object when it’s cut in half.



Cross Sections

Cross section are 2D shapes the act as the skeleton of your object. The Free Form modeler extrudes from each
cross section to the next, basing the contours of the object’s surface on the shapes in the cross sections.

This modeling technique is sometimes referred to as skinning—the Free Form modeler stretches a “skin” over the
various shapes in the cross sections.

Each cross section can have any number of 2D shape. However, the more shapes you add, the more unpredictable
you extrusion gets. The modeler’s shape numbering feature allows you to specify which shapes should be connected
from one cross section to the next. If a particular shape has no corresponding shape in the next cross section, it is
simply not extruded.



Complex Sweep Paths

The sweep path controls the general direction of the extruded object. A straight sweep path will create a straight
object while a more complex sweep path, creates objects with bends and curves.

The Free Form modeler allows you to draw a true 3D sweep path, meaning that it can be adjusted in x, y, and z axes.
You can also close the sweep path, to create a continuous object like a chainlink. Ray Dream also provides tools for
automatically creating complex sweep paths like spirals.



Choosing a modeling technique

The Free Form modelers offers you a number of ways of creating Free Form objects, but you’ll need to decide which
technique is best suited for your object before you begin modeling.

An easy way of determining which technique you’ll need is to take an imaginary knife and cut your object into several
slices. The types of slices you end up with will tell you which technique you should use.

If you get identical shapes, you can use straight extrusion.

If you get identical shapes that only differ in size, use the scaling technique.

If shapes vary dramatically in size and shape you may need to use a more complex modeling technique.
Use Lathing if the shapes are symmetrical.

If not, use the shape number and multiple cross sections technique.



The Free Form Modeling Window XYSTYEW i Tul|

The Free Form Modeling window is where you create new Free Form objects. When the Modeling window opens, it
temporarily replaces your scene’s Perspective window, new menus appear in the menu bar, and modeling tools
appear in the toolbar. Your view of the scene is replaced with a close-up view of the object.

The Time Line Window also automatically switches to the Masters tab, since changes you make in the Free Form
modeler affect Master objects, not individual copies of objects.

You can also open the Free Form modeler by jumping into an existing Free Form object. The Free Form modeler
opens showing you the components of the object.



Jumping into and out of an object 2SS [/l W]

To jump into an object:
Double-click the object in the Perspective or Hierarchy window, or select the object and choose Edit >Jump In.

When you’re finished modeling, you can jump out of the object and return to the Perspective view of your scene.

To jump out of an object:
Click the Done button at the bottom of the Modeling window, or choose Edit menu>Jump Out.



The Modeling Box

The Modeling Box is the primary feature of the Modeling Window. The box define s the drawing environment and
provides you with planes for drawing sweep paths, cross sections and extrusion envelopes.

You can only work on a single plane at a time. The plane you’re currently working on is called the Drawing Plane and
is highlighted in green.



Cross Section Planes

The cross section planes are the surfaces you use to create the basis of your object. These planes act like the paper
in a 2D drawing application. you can use the drawing tools to draw and edit shapes to create cross sections.

Every time you create a cross section, you create a new cross section plane. Since a cross section can contain any
number of 2D shapes, you may have more than on shape per cross section plane.

Cross section planes are oriented according to the shape of the sweep path. As the sweep path bends or twists, the
cross sections will reorient themselves to remain perpendicular to the sweep path.



The Sweep Path

The sweep path, also known as the "extrusion path, is the path along which cross section shapes are extruded. The
path is defined by two red lines which appear on the bottom and side walls of the modeling box.

You can think of these red path description lines as horizontal and vertical projections of the same sweep path. These
two lines let you edit the sweep path in both the x and y axis, meaning that you edit the sweep path in three
dimensions.

You can draw a sweep path of any shape or angle, including curved, straight or closed paths.



The Extrusion Envelope

The extrusion envelope lets you control the curvature in an object’s form. The envelope is not displayed when you
first open the modeling window. You need to add it to an object using the one Extrusion Envelope commands in the
Geometry menu.

The extrusion envelope is represented by four blue Bezier curves, two on each sweep path plane. By editing these
envelope description lines, you can scale an object’s cross sections as they’re extruded along the sweep path. You
can scale cross section shapes either symmetrically or asymmetrically.



Changing the Drawing Plane

The drawing plane is the plane you’re currently working on. It is used as a reference for viewing objects, such as the
View>Drawing plane command, and for positioning. When you’re using constrain keys, movement is restricted in
reference to the drawing plane. For example, when you’re using Alt/Option shapes move perpendicular to the
drawing plane.

To change the drawing plane:
1. Click on different plane in the modeling box. The plane you click becomes the drawing plane.



Changing Your View of an Object

Since you’re working with a 3D object, you can view it from any angle. You can change your view of an object using
either the View menu commands or the Virtual Trackball.

When you change your view of the object, your view of the modeling box changes as well. However, the object
maintains its spatial relationship to the modeling box at all times.

To select a different view:

1. Choose View>Preset Position> Reference (the default view), Drawing Plane, Top, Bottom, Left, Right, Front,
or Back.

The Drawing Plane view provides a direct view of the selected drawing plane. You should use this view when you’re

drawing detailed shapes.

To rotate the object:
1. Select the Virtual Trackball tool and drag the object in the direction you want to rotate it.

An object’s orientation in the modeler has no connection to its orientation in the scene. You may rotate the object
without worrying about its orientation in the scene.



Selecting an Object Preview Mode
There are four levels of object preview in the Free Form modeler. Listed from lowest to highest they are:

¢ No Preview

¢ Preview

e Shaded Preview
¢ Better Preview

Higher preview modes take longer to redraw. So it’s a good idea to use wireframe or preview mode when you’re
drawing.

To change the object preview:

Choose View>NoPreview, Preview, Shaded Preview or Better Preview.
The mode is enabled when a checkmark appears next to the command.

You can also click one of the preview buttons on the toolbar to change modes.



Selecting Modeling Box Display

By default, the modeling box appears displaying all three planes. If you find that the sweep path projections or cross

section previews are too distracting, you hide their planes. You can hide or display the modeling box planes using the
Display Plane tool.

To change the plane display:
1. Click on the plane you want to hide or show.



Setting Scale and Object Size

The Modeling window opens at a scale consistent with the proportions of objects in the scene. If you want to work
with an object at some other scale, you can reset the modeling box’s size.

To set modeling box and object size:
1. Choose View>Modeling Box Size.

2. Enter a dimension and select the units you want.

3. Enable the Scale object with Modeling Box check box if you want to resize the modeling box without resizing the
object.



Setting Surface Fidelity

When Ray Dream is rendering, it breaks each object down into hundreds of tiny polygons. This helps the renderer
understand the contents of the scene.

The number of polygons used for each object are based on the rendering resolution, the size of the object, and its
distance from the camera. This calculation usually results in a smooth object.

If a particular object does not render as smoothly as you’d like, however, you can force Designer to break it down into
a greater number of polygons. Designer allows you to set a value for each object’s surface fidelity.

To set surface fidelity:
1. Choose Geometry>Surface Fidelity.

2. Drag the slider to increase or decrease the object’s surface fidelity.
The default value is 100%.

The surface fidelity value is resolution-independent. That is, if a particular value yields good results for a given object
in a given scene at low resolution, it should yield good results at higher resolutions as well.



Working on the Drawing Plane

To create an object, you will need to draw cross section shapes and extrusion paths on the appropriate planes in the
Modeling window. Each plane in the modeling window is a separate 2D drawing environment with a grid. At any given
time, you will work on a single plane. The currently selected plane is called the drawing plane.

All 2D shapes and paths you draw in Ray Dream 3D are Bezier curves. A Bezier curve is an interpolated curve whose
shape is determined by the relative positions of its vertices and control points. Each segment of a Bezier curve
connects two vertices. The control points (handles) extending from each vertex determine the curvature of the path
segments.

Ray Dream 3D’s drawing tools are similar to those found in traditional Bezier-based 2D drawing applications. The
drawing tools enable you to create curves and shapes, and to edit and modify those shapes point-by-point. Don’t
confuse the drawing tools with the 3D Paint tools, which appear below the drawing tools in the toolbar.



About the Pen toolw

The Pen tool allows you to:
e Draw a new path.
¢ Add points to either end of an existing open path.

Drawing with the pen tool is like playing connect the dots. You draw a shape by adding one point at a time. As you
add points, Ray Dream connects them by drawing lines called segments.

Depending on the state of its handles, each point can be classified as a corner point or a curve point. A curve point’s
handles are bound together, creating a straight tangent for the path and resulting in a smooth curve.

A corner point’s handles can be moved independently of one another, or retracted completely, allowing you to create
abrupt changes in the direction of the path.



Adding a corner pointw

To add a corner point:
1. Click (but do not drag) at a point on the drawing plane.

1. Hold down Shift to constrain the position of a new point in relation to the previous point.
The angle between the two points is constrained to increments of 45 degrees.



Adding a curve pointw

To add a curve point:

Click and drag the pen tool at a point on the drawing plane.

As you drag, a pair of handles extends from the vertex. By default, each pair of handles is bound together creating a
curve point—the two handles remain parallel to one another.

e Hold down the Shift key while you drag, to constrain the angle of the handles to 45 degree increments.

e Hold down the Option/Alt key while you drag to break apart a pair of handles creating a corner point. You can
then move each handle independently. Continue to hold the Option/Alt key down as you drag. If you release the
key before releasing the mouse button, the handles snap back together.



Closing a path

To close a path:
1. Click on the first point you added.



Drawing a new pathw

To draw a new path:
1. Deselect all paths and points by clicking in an empty area of the drawing plane with the Selection tool.

2. Select the Pen tool.

1. Click anywhere on the drawing plane to start the new path with a corner point or, click and drag to start with a
curve point.

1. Click or click and drag to add each subsequent point.
As you add each point, the segments are drawn to connect the path.



Adding points to either end of an open pathw

To add points to a path:
1. Select one of the endpoints of an open path with the Selection tool.

2. Select the Pen tool.

3. Click or click and drag to add the next point.
A segment is draw to continue the path to the new point.

4. Continue adding points until you’re satisfied with the path.



About the Selection Toolw

In the Modeling window, the Selection tool allows you to:
¢ View the points on the path.
e Select, deselect, and move points.

e Drag handles.

The Selection tool is also used for scaling shapes.



Viewing points on a path

To view points on a path:

Click on a path.
All of the points on the curve become visible, but none are individually selected. A point appears white when it is
deselected, and black when it is selected.

¢ Hold down the Shift key and click on additional paths to view the points on multiple paths.
¢ Hold down the Shift key and click on a path whose points are visible to make them invisible.

¢ Click in an empty area of the drawing plane to make all points invisible.



Selecting points

To select points:

Click on a point to select it.
The point color changes from white to black and its handles, if it has any, become visible.

¢ Hold down the Shift key and click on additional points to increase your selection.
¢ Hold down the Option/Alt key and click on a path to select all of the points on the path.
¢ Hold down the Shift key and click on a selected point to deselect it.

¢ Click in an empty area of the drawing plane to deselect all points.



Moving points

To move points:

Drag a selected point to a new location.
All selected points move together. As you drag, the path segments that are affected by the move are redrawn.

¢ Hold down the Shift key while you drag to constrain the movement of the points in relation to their previous
positions. Their movement is restricted to angles of 45 degree increments.

e Select all of the points on a path and drag them to move the entire path.



Adjusting a curve

To adjust a curve:

Drag the point’s handles.
As you drag, the curve is redrawn. When you move a handle, the opposite handle moves to remain parallel to the one

you are moving.

¢ Hold down the Shift key while you drag to constrain the angle of a handle’s motion to 45 degree increments.

e Hold down the Alt key while you drag to break apart a pair of parallel handles. You can then move each handle
independently.



About the Convert Point Tool XS [FilF " W]

The Convert Point tool lets you:
e Convert a corner point to a curve point.

e Convert a curve point to a corner point.



Converting points to curves Vverview (a W

To convert a point to a curve:

Drag a corner point.
As you drag, a pair of handles extend from the point.

Converting a corner point to a curve point:

Drag one of a corner point’s handles.
When you click a corner handle the two handles extending from the point will move together.



Converting Curves to Points XS Vi V|

Converting a curve to a point:

Click on a curve point.
The point’s handles retract.

Converting a curve point to a corner point:

Drag one of a curve point’s handles.
When you click a curve handle, the handles extending from the point will move independently.



Deleting a point
The Delete Point tool allows you to:
e Delete a point.

e Delete a path segment.

To delete a point:

Click on a point.
When you delete a point in the middle of a path, the points on either side of the deleted point become connected by a
new segment, changing the shape of the path.

e When you delete the endpoint of an open path, the last path segment simply disappears, leaving a new endpoint.

e If you delete a point on the sweep path, any cross section associated with that point is deleted as well.



Deleting a segment

To delete a segment:
1.Click on a path segment.

Note: This feature applies to cross section shapes only—you cannot delete a segment from the sweep path or the
scaling envelope.

¢ Removing a path segment leaves adjacent path segments unchanged. When you delete a path segment from a
closed path, the path simply becomes an open path.

¢ When you delete a path segment from an open path, the path is split into two separate open paths.



About the Add Point Tool ZXEYEY fiis "

The Add Point tool lets you:

¢ Add a new point between two existing points on the same path.



Adding a pointw

To add points:

Click anywhere on an existing path.
Ray Dream determines whether to add a corner point or a curve point, depending on the shape of the path. The new
point is automatically selected so that it can be moved with the Selection tool.

When you add a point to the sweep path, you can simultaneously add a cross section at that point—just hold down
the Option/Alt key as you click.



About the 2D Primitive Tools ZZXSTYE¥ [Fis "Nl

The 2D Primitive tools allow you to easily create closed paths in a variety of shapes. These tools work only on the
cross section planes.

After creating a shape with one of the 2D Primitive tools, you will not immediately be able to edit its points—you will
need to ungroup it first.



Drawing a rectangular cross section i |

To draw a rectangular cross section:

Drag from one corner of the rectangle to the opposite corner.
Hold the Shift key down while dragging to create a square.



Drawing a rounded rectangular cross section i

To draw a rounded rectangular cross section:

1.
1.

Drag from one corner of the rectangle to the opposite corner.

Release the mouse button when the rectangle is the desired size.
Hold down Shift while dragging to create a square with rounded corners.

Set the curvature on the corners in the dialog.



Drawing an ellipse cross section i

To draw an ellipse cross section:

Drag to draw an ellipse.
Hold the Shift key down while dragging to create a circle.



Drawing a polygon cross section i

To draw a polygon cross section:

1.
1.

Drag the tool on the cross section plane.

Release the mouse button when the polygon is the desired size.
Hold down Shift while dragging to keep all angles equal.

Set the number of sides for the polygon in the dialog.
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The 2D Text tool allows you to create text on a cross section plane.



Drawing text on the cross section plane Sroiror (Al Wl

To draw text on a cross section:

1. Click to position the text.
The Text dialog appears.

2. Enter text and specify type settings.

Use this tool when you want to extrude text along a curved path. Use the Text modeler when you want to extrude text
along a straight path and add bevels.



About The Drawing Plane Grid XS i Y|

You can use the Drawing Plane grid to help you precisely position lines and points as you draw.

You can set the size of each grid increment, and specify whether a line should be drawn at every increment. As well

as enabling the Snap to feature. When this feature is enabled any object you drag along the plane will “jump” to the
nearest grid intersection.
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To set up the drawing plane grid:

1.

Choose View>Grid.
The Grid dialog appears.

Change the Spacing value to control the amount of spacing between grid lines in the box. You can also the value
using the scroll buttons.

Choose a unit of measure from the popup.
Change Draw a line every value to control how often grid lines are drawn.
Enable Snap to if you want objects to “jump” the nearest grid line as you drag them.

Disable Show if you want to hide the grid lines.
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The Properties palette displays the properties of the selected point, controls handle, group or compound cross
section.

e When a point is selected, the x and y coordinates are displayed.

¢ When a curve point is selected, the x, and y position of its handles are displayed. When these controls are active,
you can retract a control handle using the Retract button.

e When a group or compound cross section is selected, its top, and left coordinates are shown as well as the
shape’s height and width.

¢ No information is available for ungrouped shapes or multiple point selections.

By default, all values are shown in inches.



Changing the properties of a cross section Vverview (a W

To change the cross section properties:
1. If the properties palette is not visible, choose Windows>Properties.

2. Select a cross section group or point.
3. Adjust the position values.

e If you selected a closed cross section, you can enable the Keep Proportions checkbox to maintain the shapes
aspect ratio as you scale it.

e |f you selected a curve point, you can click the Retract button to retract the point’s handles. You can also click
the Corner Point button to convert the curve point to a corner point.



Rotating Freely or Numerically
You can use the 2D Rotation tool to rotate the cross section freely, or the Rotate dialog to rotate it numerically.

Note: You can only rotate cross sections, not the sweep path.

To free rotate a cross section:
1. Select the 2D Rotation tool.

2. Drag the cross section in a circular path.
A shape rotated with the 2D Rotation tool always rotates around its center.

If the Properties palette is open, the cross section’s position values will update as you rotate it.

To numerically rotate a cross section:
1. Select a shape, and choose Geometry>Rotate.

2. In the Rotate dialog, select the rotation center—the shape’s center, or the drawing plane’s center.

3. Enter a value for degree of rotation, select clockwise (CW) or counter-clockwise (CCW), and click OK.



Twisting An Object

When you rotate a cross section shape, you can specify that the rotation be applied to the surface of the object to
give it a twisted appearance.

To twist an object:

Hold down the Option/Alt key while rotating a cross section shape with the 2D Rotation tool.
For precise twisting, enable the Twist check box in the Rotation dialog. When Twist is enabled, Ray Dream twists the
surface the specified number of degrees.

Rotation values greater than 360 degrees make sense when twisting the object’s surface—you can use them to
specify multiple twists.



Grouping and Ungrouping Shapes

You can group one or more shapes using the Group command. Grouping two or more shapes lets you to manipulate
them all at once.

Note: Grouping is allowed only on the cross section planes.
To group shapes:

1. Select the shape(s) you want to group.

2. Choose Arrange>Group.

To ungroup:

1. Select the group you want to ungroup.

2. Choose Arrange>Ungroup.



Compounding Shapes

Compounding shapes is like grouping them, with one significant difference—any shape which is completely enclosed
by another shape in the same compound “cuts away” from the larger shape. When a compound is extruded, the
inner shapes create holes through the extrusion.

Note: Compound shapes are allowed only on cross section planes.

To compound shapes:
1. Select the shapes you want to compound.

2. Choose Arrange>Combine as Compound.

To break apart a compound:
1. Select the compound you want to release.

2. Choose Arrange>Break Apart Compound.



Scaling Shapes Numerically or by Dragging
You can scale shapes directly by dragging it’s bounding box, or numerically using the Scale dialog.

Note: Scaling is allowed only on cross section planes.

Scaling a cross section shape directly is not always necessary. The scaling can often accomplish the same results
more simply and powerfully.

To scale shapes:
1. Group the curves or shape you want to resize.

2. Drag a corner of the shapes bounding box with the Selection tool to resize it.
Drag towards the shape to reduce it’s scale, or away from it to increase it’s scale.

1. Hold down the Shift key to maintain proportions.
To scale shapes numerically:

1. Select the shape you want to resize.

2. Choose Geometry> Scale.

3. Inthe Scale dialog, enter horizontal and vertical scale factors, and click OK.



Importing Shapes
Ray Dream 3D lets you to import cross section shapes, sweep paths, and envelopes from 2D drawing programs that
support Bezier curves, like Adobe lllustrator or CorelDRAW!.

To import shapes to a cross section:

1. Click the cross section you want to work with.
You can also create a blank cross section using Sections>Create.

1. Choose File >Import.
The Import dialog appears.

2. In the dialog, select the file you want, then click Open.
Ray Dream 3D places the artwork on the drawing plane.
The file may include one or several two-dimensional shapes. You should, however, avoid unnecessary complexity.

Paint characteristics, like stroke and fill, are ignored. Compound paths are preserved. Text is automatically converted
to outlines.



Importing a path as a sweep path or envelope

1.

6.

Choose Geometry> Extrusion Envelope to turn on the extrusion envelope.

Note: Importing a sweep path or envelope replaces the current sweep path and envelope.
Click one of the path sweep path planes to make it the Drawing plane.

Choose File>Import.
The Import dialog appears.

In the dialog, select the file you want, then click Open.
If the file you choose contains more than one path, only the first path will be imported.

Another dialog will appear, allowing you to specify whether the path should be used as the sweep path or the
envelope.

Specify sweep path or envelope, and click OK.

Ray Dream 3D imports the sweep path or envelope.



Working with Cross Sections

A basic Free Form object, like a box, has one cross section at the start of the path. The shape on this first section is
swept to the end of the extrusion path. To create more complex forms, you can add any number of cross sections
along the length of the path. Since each cross section, in turn, can contain any number of shapes, you will be able to
model even very intricate objects.

The Free Form modeler automatically extrudes between each cross section and the next, basing the surface of the
object on the shapes contained in the cross sections.

As you begin to work with the Free Form modeler, you will find that the sweep path and cross sections are closely
tied.
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Modeling with multiple cross sections, lets you increase your control over the shape of the your object’s surface. If
you just use a few cross sections, Ray Dream automatically extrudes a surface between the cross sections creating a
flat surface.

With each section you add, you reduce the amount of surface areas that is automatically calculated. You can add
subtle variations in your object’s surface by placing more sections with different shapes in between cross sections.

Of course, the more cross sections you add the more complicated it becomes to work in the modeler. However, the
Free Form modeler has a number of features to help you model with multiple cross sections. The modeler lets you:

e Add or delete cross sections.
* Move between cross sections.
¢ Add shape numbering to sections to control the extrusion between section shapes.

¢ Control whether the surface is extruded from shape to shape or point to point.



Adding and Removing Cross Sections Lvervew o |

You can add as many cross sections as you like. Each cross section must correspond to a point on the sweep path. If
you want to add a cross section where there is no point, you have to add one.

Although modeling with multiple cross sections enables you to achieve otherwise impossible effects, be careful not to
add cross sections unnecessarily. Editing an object with too many cross sections can become difficult and tedious.
Often, you can accomplish similar results using the scaling envelope.



Creating a new cross section XEYEW i Y|

e If a sweep path point exists where you want the new cross section, choose Sections>Create.

¢ |f there is no point:
1. Select the Add Point tool.
1. Hold down the Option/Alt key and click on the sweep path at the point where you want to create the new

cross section.
Ray Dream 3D adds a point to the sweep path and creates a new cross section at that point.

e If you’re working on a cross section plane, choose Sections>Create.
Ray Dream adds a new cross section at the next vertex.



Generating intermediate cross sections 2YETYEY i V|

You can have Ray Dream create a specific number of cross sections between the current cross section and the next
one.

1. Click on a cross section plane.

2. Choose Sections>Create Multiple.
The Create Multiple Cross-Sections dialog appears.

3. Enter the number of sections you want, then click OK.

Ray Dream creates the intermediate cross sections, spacing them evenly between the current cross section and the
next one. A new point is added to the sweep path for each cross section created.

The shapes on the new cross sections are interpolated from the shapes on the existing cross sections. This process
is similar to blending between two shapes in a 2D illustration program—each shape on the new cross sections is like
one “step” in the blend.
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To remove a cross section:
1. Click the cross section you want to remove, or select the corresponding point on the sweep path.

2. Choose Sections> Remove.

To simultaneously remove a cross section and delete its corresponding sweep path vertex, use the Delete Point tool
to delete the point from the path.



Moving the Drawing Plane Between Sections 2XS ¥ [/l W4l|

If you have multiple cross sections, you can choose Next or Previous from the Sections menu to move the drawing
plane between adjacent cross sections.

To move between sections using the keyboard:

Hold down the Command/Control key and press the right or left arrow key to move to the next or previous cross
section, respectively.

To move to a specific section:
1. Choose Sections>Go to
2. Enter the number of the sections you want to go to and click OK.

Cross sections are numbered from left to right.



Correspondence and Shape Numbering_"“"""Enr"aﬂ"Ir i |

Normally, there is a direct correspondence between the number of shapes in adjacent cross sections. You can,
however, use a different number of shapes in adjacent sections, or change which shape sweeps to which. You control
multiple shape correspondence through shape numbering.

To control shape-to-shape correspondence:

1. Choose Sections > Show Shapes Numbers.
Ray Dream displays a number beside each shape in the drawing plane. A group or compound is assigned a
single shape number.

Each numbered shape is swept to the corresponding numbered shape in the next cross section.

1. Click on the number you want to change.
The Shape Number dialog appears.

2. Type in the number for the shape you want it to correspond to, then click OK.

e If you enter the number of another shape in this plane, the program swaps the correspondence number with
that shape.

e If you enter a unique number, make sure that you assign the same number to the appropriate shape in the
adjacent cross section(s).

Any shape that has no correspondence (i.e., its number does not match any shape number in an adjacent section) is
not extruded.



Cross Section Optionsw

The Cross Section Options dialog lets you specify whether the cross section should be “filled,” if it should be
connected to the next cross section, and what type of “skinning” should be used between it and the next cross
section.

To set cross section options:

1. Click on a cross section.
2. Choose Sections>Cross section Options.

1. Enable the Fill Cross Section checkbox if you want to fill the section.
For example, a cylinder with its first and last sections not filled would be a tube that you could look through. An
object’s first and last cross sections are often referred to as endcaps—you can turn endcaps “on” by filling them,
or “off” by leaving them unfilled.

1. Enable the Disconnect From Next Cross Section checkbox to turn off extrusion between this section and the next
one.
In this way, you could create an “intermittent” object.

2. Enable a Skinning option:

e  Skin Shape-to-Shape: This skinning method is especially well suited for creating smooth, organic surfaces
whose cross section shapes are significantly different from one another. In fact, if adjacent cross sections have
different numbers of vertices, shape-to-shape skinning is the only option available.

e  Skin Point-to-Point: Use point-to-point skinning when adjacent cross sections contain very similar shapes, and
you want each vertex in one cross section to be connected directly to the corresponding vertex in the next
cross section. This option is useful when you model an object which requires straight, sharp edges.



Centering a Cross Section Yrervew fa .

Often when you’re creating cross sections, you may end up with a number of off centered sections which can lead to
unexpected results when they’re extruded. It’s usually a good idea to center sections when you’re finished drawing
them.

To center a cross section on the sweep path:
1. Click the section you want to center.

2. Choose Sections>Center.
The shape(s) on the cross section will be centered around the sweep path.



Working with the Sweep Path

The key to working with the sweep path is understanding how the 2D path description lines define the 3D sweep
path. There are two red path description lines, one on each sweep path plane. Although the path description lines
appear to be two separate paths, they are actually just projections of the same path.

Each point on one path description line corresponds to a point on the other path description line. In fact, each pair of
points represents a single 3D point on the sweep path.

The sweep path on the ground plane describes the sweep path’s horizontal position wile the projection on the side
plane describes its vertical position. A sweep path that is curved on the side plane but straight on the ground plane
would create an object whose shape curves up and down but not side to side. .

A path that curves on both planes would create an object whose shape curves in 3D.



Drawing the Sweep Path in 3D

The best way to start drawing a sweep path is to consider how you want your object look both from the side an from
the top. An object that has a lot curves when viewed in profile, but look straight when viewed from the top, indicates
that the sweep path will remain straight on the ground plane and curved on the right plane.

.Unfortunately few objects are this simple. Most objects have some variation from both the top and the profile. you
can easily handle this type of sweep path by adjusting the point on the two sweep path projection.

In some cases, simple adjustment may not be enough. You may want to draw the sweep path continuously from the
first point to the last, switching back and forth between the two planes as you work.



Cross Sections and the Sweep Path

When you’re working with the sweep path it’s important to understand the relationship between cross sections and
the sweep path. You can think of the sweep path as an object’s spine. Whenever you move a point on the sweep
path, any cross section at that point will move as well.

The opposite is not true, however. When you move a cross section shape up or down, left or right along the cross
section plane, the sweep path is not affected. This allows you to create cross sections that are not centered around
the sweep path.



Translation vs. Pipeline

The Free Form modeler can extrude cross sections along the sweep path using one of two extrusion methods: the
Translation method or the Pipeline method.

With the Translation method, each cross section remains perpendicular to the ground plane of the modeling box,
regardless of the sweep path’s curvature.

With the Pipeline method, the orientation of each cross section depends on the direction of the sweep path at the
point where the cross section is located—all cross sections remain perpendicular to the sweep path, rather than to
the ground plane.



Choosing an extrusion method

To choose an extrusion method:
Choose Geometry> Extrusion Method>Translation or Pipeline.

You can switch extrusion methods at any time; however, changing methods may reset your sweep path and scaling
envelope. In general, you should try to determine which extrusion method is appropriate before you start work on an
object.



About Extrusion Presets Sroi ot il "l

Ray Dream 3D provides three extrusion presets, which automatically generate specific types of sweep paths. When
you apply an extrusion preset, the current sweep path and envelope are replaced with the preset path.



Straightening the sweep path Levew (W M|

To straighten a sweep path:
Choose Geometry>Extrusion Preset>Straight.

All of the points on the sweep path are moved into a straight line. Cross section shapes are unaffected.



Making a spiral extrusion XSSV fri WNl|

Note: When you use the Spiral extrusion preset, only the first cross section of your existing object is kept—the
remaining cross sections, sweep path, and envelope are all replaced.

To make spiral extrusions:

1.
2.

3.

Draw a 2D shape in the cross section plane.
Choose Geometry> Extrusion Preset>Spiral.
Enter the number of turns you want—one turn equals 360 degrees.

Enter the Length of the spiral sweep path.
The relationship between the number of turns and the length determines how “tightly” the coils of the spiral are
spaced.

Enter a value in the Distance to axis field.
This value determines the size of each coil by setting the distance between the cross section shape and the
spiral’s central axis.

Enter a percentage in the Cross Section Scaling field if you want to shrink or enlarge the cross section shape as
it sweeps along the spiral path.
Values less than 100% shrink the shape; values greater than 100% enlarge the shape.

Enter a percentage in the Spiral Scaling field if you want to decrease or increase the distance to the axis as the
cross section shape sweeps along the path.
Values less than 100% taper the spiral; values greater than 100% widen it.

Click OK to close the Spiral dialog.
Ray Dream creates the spiral sweep path you have specified, and automatically switches to Pipeline mode.
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The Torus extrusion preset automatically creates a perfect circular sweep path.



Using the Extrusion Envelope

To a large extent, the contours of a Free Form object are determined by the cross sections you place along the
sweep path. Wherever you change the size or shape of a cross section, the object’s surface changes accordingly.

To create some complex objects you may find that you‘ll need a finer degree of control than cross sections alone can
provide. The extrusion envelope lets you specify how an object’s surface should curve from one cross section to the
next, giving you precise control over the object’s form.

For the best results, you should model the object as completely as possible using the sweep path and cross sections,
then adjust the scaling envelope as a final step.



Understanding the Envelope Uvervew (w |

By default, the scaling envelope is not used—Ray Dream stretches the object’s surface over the cross sections as
simply as possible. When you turn the envelope on, it appears as four blue envelope description lines, two on each
sweep path plane.

Initially, the envelope conforms to the dimensions of the object’s cross sections, widening and narrowing only if the
cross sections vary in size.

The envelope description lines are Bezier curves. By editing these curves, you can alter an object’s contours. The
envelope has three modes:

e Symmetrical—all the envelope lines maintain symmetry
e Symmetrical in Plane—Ilets you edit the envelope description lines in pairs

e  Free—lets you edit each line individually. This allows you to model asymmetrical objects.



How the Envelope Relates to the Sweep Path

The envelope and the sweep path are closely related. In fact, each point on the extrusion envelope corresponds to a
point on the sweep path.

Moving an envelope point perpendicular to the sweep path controls the scaling of the object at that point on the path.
When you move an envelope point parallel to the sweep path, the corresponding point on the sweep path moves as
well—the points are “locked” together in the direction of the sweep path.

When you are using the Pipeline extrusion method, envelope points are constrained to move only perpendicular to
the sweep path.

To maintain the relationship between the sweep path and the envelope, when you add a point to the scaling
envelope, a point is also added to the sweep path. Likewise, when you delete a point from the envelope, the
corresponding point is deleted from the sweep path.



How the Envelope Relates to Cross Sections

Editing the extrusion envelope may also affect an object’s cross section shapes. If you edit the envelope at a point
where there is no cross section, only the surface between cross sections is affected. However, if you edit the
envelope at a point where a cross section exists, the shapes on the cross section are scaled accordingly. If you
delete a point from the envelope, you will also delete any cross section located at that point.

When using the extrusion envelope in conjunction with multiple-shape cross sections, note that the scaling reference
point is the sweep path—not the center of each shape. If you want a cross section’s individual shapes to scale
around their respective center points, you should resize each shape individually on the cross section plane, rather
than use the scaling envelope.



Enabling the envelope or changing its symmetry constraint ZXSTYEY i V|

1. Choose Extrusion Envelope from the Geometry menu and pull right to select a symmetry constraint setting:
Symmetrical, Symmetrical in Plane, or Free.

If the envelope was not already enabled, the four blue envelope description lines appear on the sweep path planes.

e Symmetrical—All four envelope description lines use the same curve. When you edit one line, the others update
automatically.

¢ Symmetrical in Plane—The two envelope description lines in either plane use the same curve; when you edit one
line, the other in its plane updates (as a mirror image) automatically.

e Free—Each line may have a unique curve.

To modify the extrusion envelope:
1. Use the drawing tools to edit the envelope description lines.

You can add and delete points, as well as adjust existing points and control handles. As you adjust one of the

envelope description lines, the other lines are updated in real time.

To reset the extrusion envelope:
Choose Geometry>Reset Envelope or, choose Geometry>Extrusion Envelope>None.
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Lathing lets you create many types of symmetrical objects by rotating a 2D profile around a straight axis. Rotation can
be circular or angular, around 360° or less.

Because your lathe object is actually a Free Form object, you can edit it in ways that traditional lathing tools do not
allow. For example, you can create a symmetrical lathe object, then deform it using the Free Form modeler’s other

tools.
Depending on the specific object you want to create, you can choose from two different lathing methods:
¢ using the Extrusion envelope

e using a circular sweep path
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You can create nearly any lathe object by extruding a circle or a regular polygon and using the extrusion envelope to
draw the object’s lathe profile.



Creating a lathe object with the extrusion envelope Yrervew fa .

To create a lathe object with the extrusion envelope:

1.

2.

1.

Click a cross section plane.

Draw a cross section using one of the drawing tools.

Draw your circle (or polygon) at an appropriate size for the object you are creating, since the initial diameter of
your object depends on the size of the cross section.

For example, the size of the first circular cross section determines the diameter of the glass’ base.

Hold down Shift to create circles or squares.

Choose Sections>Center to center the cross section on the sweep path.

Choose Geometry> Extrusion Method>Translation.

Choose Geometry> Symmetrical> Extrusion Envelope.

Don’t worry about trying to edit the envelope’s description lines—they disappear when you start drawing your
own lathe profile.

Click one of the sweep path planes to make it the Drawing plane.

Click an empty space on the plane, being careful not to select the sweep path or either of the envelope
description lines.

Choose View> Preset Position> Drawing Plane.
This allows you to draw in the plane of the screen.

Using the Pen tool, place the second point of the lathe profile.
You may need to drag the Pen tool to create a curve point.

Make sure you draw the lathe profile above the sweep path.
Continue drawing the lathe profile, placing additional points with the Pen tool.

You can also use the drawing tools to edit the points you have already placed. For the best results, be careful not
to cross over the sweep path as you draw the lathe profile.
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Some lathe objects are difficult to create with the scaling envelope. An object with a hole in the center can be
particularly difficult. To create this type of objects, you can draw the lathe profile in the cross section plane and sweep
it around a circular sweep path.

The Torus extrusion preset, available from the Geometry menu, creates a precise circular path.

To create a lathe object using a circular sweep path:
1. Draw your lathe profile in the cross section plane.

2. Choose Geometry> Extrusion Preset> Torus.
The Torus dialog appears.

1. Enter a value in the Distance to axis field, and click OK.
This value specifies the distance of the cross section from the torus’ central axis that is the radius of the object.

You may need to experiment with the radius of the torus to achieve the effect you want. Simply repeat steps 2 and 3,
and enter a different dimension—Ray Dream replaces the old torus with the new one you have specified.



About the Mesh Form Modeler

The Mesh Form modeler lets you sculpt three-dimensional objects by directly manipulating their surfaces. When you
use the Mesh Form modeler, you’re not limited to creating objects that can only be modeled as extrusions, you can
model objects by directly edit an object’s surface.

You can start with a predefined object, such as a sphere or cube, or use the polymesh modeling tools to generate
extrusions, sweeps, lathed objects, and lofted objects. Once you’ve created an object, you can reshape and refine it
by editing the points that define its surface.



Mesh Form Modeling Concepts

Three-dimensional objects can be described as sets of vertices, edges and polygons. A vertex defines a position in
three-dimensional space and an edge is the line that connects two vertices. For example, eight vertices and twelve
edges describe a cube. Each face of the cube is a filled polygon.

A polyline is a selected set of connected edges. A polyline that forms a closed loop is referred to as a “closed”
polyline. A closed polyline is not equivalent to a polygon—a closed polyline might encompass several polygons.
However, if you fill a closed polyline that doesn’t encompass any other edges or vertices, it becomes a polygon.

A collection of vertices, edges and the polygons that they form is called a polymesh. A polymesh can form a closed
volume, such as a cube, or an open object resembling a sheet of wire mesh.

Polymesh modeling is the process of creating three-dimensional objects by directly manipulating vertices, edges and
polygons. Instead of modeling all objects as extrusions, you can “sculpt” objects by changing the number and
location of their vertices, edges and polygons.

By combining the modeling techniques used in the Free Form modeler with the ability to directly edit vertices and
edges, the Mesh Form modeler makes it easy to create complex models. For example, you can use the Mesh Form
modeler to create a complex cross section and extrusion path, extrude an object, and then directly edit the object’s
vertices and edges to refine its appearance.



Extruding and Sweeping

When a cross section is extruded along a path, its orientation does not change—at every point along the path, the
extrusion’s cross section is parallel to the original cross section.

In contrast, when a cross section is swept along a path, its orientation changes so that the cross section of the sweep
is always perpendicular to the path..

With the Mesh Form modeler, you can:

e Extrude and sweep open and closed polylines selected from existing polymesh objects.
e Extrude and sweep 3-dimensional cross sections.

¢ Specify complex 3D extrusion and sweep paths using polylines.

¢ Use selected edges of existing polymesh objects as sweep paths.



About Lathing

When you lathe an object with the Mesh Form modeler, you specify both the lathe profile and the lathe axis. Unlike
the Free Form modeler, you do not specify a cross section; all lathed objects created with the Mesh Form modeler
have circular cross sections.

The Mesh Form modeler creates lathed objects by revolving the lathe profile around the specified lathe axis.
The Mesh Form modeler enables you to:

¢ Define 3-dimensional lathe profiles.

e Use closed polylines as lathe profiles.

¢ Use any edge in a polymesh object as the lathe axis.



Lofting
Lofting, also known as skinning, is the process of stretching a surface over several cross sections to construct a

complex object. In the Mesh Form modeler, you can easily:
¢ Create 3-dimensional cross sections.
¢ Use open and closed polylines selected from existing Polymesh objects as cross sections.

The Mesh Form modeler performs a straight extrusion from one cross section to the next. Unlike the Free Form
modeler, the Mesh Form modeler only supports one shape or object for each cross section.



The Mesh Form Modeling Window Vverview (a W

You work in the Mesh Form Modeling window whenever you edit a Polymesh model. You can also open imported
models and models created with other modelers in the Mesh Form modeler.

When you create a new Mesh Form model by dragging the Mesh Form Modeling tool to the scene window, the Mesh
Form Modeling window opens automatically. Your scene’s Perspective window is temporarily replaced by the Mesh
Form Modeling window, which displays a close-up view of the objects in the model.
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In the Scene window, double-click the model you want to edit.
The model is opened in the Mesh Form Modeling window.



Editing an Imported Model LXSTYIEW frir "ul|

1. Select the model you want to edit.

2.Choose Edit> Jump In Another Modeler.

3.In the Choose Another Modeler dialog, select Mesh Form modeler from the Available Modelers list.

4. Specify the fidelity for the conversion using the Fidelity slider.
The default, 100%, divides the object’s surface into the recommended number of polygons. A higher percentage
generates more polygons, providing more points of control. A lower percentage generates fewer polygons.

Regardless of the fidelity of the conversion, some data may be lost and the model distorted.

5. Click OK to convert the model and open it in the Mesh Form Modeling window.



Features of the Modeling Window

The Mesh Form Modeling window contains the Mesh Form model you’re editing. The window displays the objects in
the model, the drawing plane, and a tri-color axis-indicator.

When a model is opened in a different modeler than the one it was created in, the model is converted. This
conversion can distort the object’s appearance.

When the Mesh Form Modeling window is open, special commands are enabled in the menus and a new set of
modeling tools appears in the toolbar, replacing the object creation and camera manipulation tools.

The Hierarchy window automatically switches to the Masters tab when the Mesh Form Modeling window is open.
Changes you make in the Mesh Form modeler affect Master objects, not individual copies of objects.

By default, opening the Mesh Form Modeling window also opens the Properties palette. The tabs in the Properties
palette provide direct access to both object and tool properties, as well as action attributes you can use to alter the
effects of certain operations. For example, the Action Modifier tab allows you to change the number of sides in a
newly created cylinder.

The Properties palette is not automatically displayed if the Properties checkbox has been disabled in the Mesh Form
Modeler Preferences dialog.

When you’re done editing your model, you can return to the Scene window by choosing File> Jump Out or clicking
Done at the bottom of the modeling window. If you want to return to the Scene window without preserving your
changes, click Restore.



The Drawing Plane 22XV Y [l "

All drawing takes place on the two-dimensional drawing plane displayed in the modeling window. Like the Free Form
Modeling window, the planes of the modeling box can be displayed, but the objects’ profiles are not projected onto
the planes. By default, only the drawing plane is displayed.

A tri-color axis indicator is located in the center of the drawing plane when you open the Mesh Form Modeling
window. The x-axis is displayed in pink, the y-axis is displayed in red, and the z-axis is displayed in blue.

This indicator shows the orientation of the model’s x, y and z axes and identifies its origin. All x,y,z coordinates for the
model are relative to the origin of the axis indicator.

As you move the drawing plane and the objects in the model, the axis indicator helps you determine the orientation of
the objects and your point of view.

If you get confused about which way is up, you can always return to the initial view by choosing View menu> Preset
Position> Reference.



Setting Preferences for the Mesh Form Modeler

In the Mesh Form Modeler Preferences dialog, you can set preferences for the display of the Properties Palette, the
default welding tolerance, and the grid.

By default, the Properties palette is always displayed when the Mesh Form modeler is open and Studio automatically
switches to the appropriate tab for the current operation. You should normally leave these options enabled—the
Properties palette is integral to the operation of many polymesh modeling features.

The default tolerance value is used when you weld vertices and when vertices are welded as part of a Boolean
operation. Vertices are welded if the distance between them is less than or equal to the default tolerance.

By specifying grid settings in the Mesh Form Modeler Preferences dialog, you can set up the grid for the Mesh Form
modeler without affecting the grid settings used for the Scene window and other modelers.



Working in the Mesh Form Modeling Window

The Mesh Form modeler lets you freely move the drawing plane to any plane in the model. When you move the
drawing plane, you often need to change your viewpoint to get a better view of the objects you’re working with.

You can use the preset viewing positions in the View menu to change your viewpoint, like you can in the Free Form
modeler.

When you’re viewing and editing your model, you’ll also frequently want to change between the wireframe editing
mode and the preview modes. The Mesh Form modeler provides the same preview modes as the Free Form
modeler.

When editing your model, you can easily move and orient the drawing plane using the View menu and keyboard
shortcuts.



Moving the Drawing Plane to a Preset Position 2rorron [/ Wl

Choose View menu> Send Drawing Plane To> and select the position you want: Left, Right, Top, Bottom, Front or
Back.

1. These positions are relative to the drawing plane’s reference position, the position it is in when the Mesh Form
Modeling window is opened.



Aligning the Drawing Plane with a Selection Lvervew (|

1. Select the vertex, polygon, or group of vertices with which you want to align the drawing plane.

2. Choose View menu> Send Drawing Plane To> Selection.

1.1f the selection is a single vertex, Studio centers the drawing plane on that vertex without changing the plane’s
orientation.

2.If the selection is a group of vertices or a polygon, Studio moves the drawing plane to the plane shared by those
vertices. If the vertices t lie in different planes, the drawing plane is moved so that the selected points are as near
to the drawing plane as possible.



Moving the Drawing Plane to the Current Viewpointw

Choose View menu> Send Drawing Plane To> Screen.



Moving the Drawing Plane to a Particular Position 2SI €T Vi |

1. Choose View menu> Send Drawing Plane To> Position.

2. In the Move Drawing Plane dialog, specify the x,y,z coordinates to which you want to move the center of the
drawing plane.

1. Studio centers the drawing plane on that vertex without changing the plane’s orientation.



Rotating the Drawing Plane 2SS /il Wi

1.Choose View menu> Rotate Drawing Plane> and select the direction you want to rotate the drawing plane: Left,
Right, Front or Back.

2. The direction of rotation is specified in relation to the current view of the drawing plane.



Returning the Drawing Plane Back to its Original Position ZXETTEY [V V|

1.Choose View menu> Reset Drawing Plane.
The drawing plane is returned the position it’s in when the Mesh Form Modeling window is opened.

You can also move the drawing plane by Control-clicking when the Selection tool is active.
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1. Choose the Selection tool, Sphere of Attraction tool, Trackball Rotation tool or 2D Rotation tool.

1. Ctrl+click the polygon to which you want to move the drawing plane.
This moves the drawing plane to the plane that the polygon is on. If the polygon’s vertices aren’t all on the same
plane, the drawing plane is moved to the plane that best represents the polygon.



Moving the Drawing Plane to a Vertex SYSTYEW i "W

1. Choose the Selection tool, Sphere of Attraction tool, Trackball Rotation tool or 2D Rotation tool.

1. Control+click the vertex to which you want to move the drawing plane.
Studio centers the drawing plane on that vertex without changing the plane’s orientation. The current selection is
not affected.



Changing Your Point of View Vverview (a W

As you edit your model, you’ll frequently change your point of view. For example, when you move the drawing plane,
you often change your viewpoint so you’re looking at the drawing plane. (It can be easier to draw and rotate objects if
you’re looking directly at the drawing plane.)

Without changing your point of view to examine an object from all sides, it can be difficult to determine the object’s
position relative to other objects in the model. When you perform a Boolean operation such as subtraction, this is
particularly important—you need to be sure that the objects are actually overlapping for it to work.

To look directly at the drawing plane:

e Choose View> Preset Position> Drawing Plane (Control+5).

To return your viewpoint to its original position:

e Choose View> Preset Position> Reference (Control+0).

To move your viewpoint top, bottom, left, right, front or back:

e Choose View> Preset Position> and select the position you want: Top, Bottom, Left, Right, Front or Back.

* You can also move between these preset positions using keyboard shortcuts:
Top: Control+8
Bottom: Control+2
Left: Control+4
Right: Control+6
Front: Control+1
Back: Control+3

To return your viewpoint to the previous position:
e Choose View> Preset Position> Last.



Switching Preview Modes XS ™ vl VNl

By default, the Mesh Form modeler displays a wireframe view of the objects in the model. To view the effects of
operations such as emptying a polygon or sharpening edges, you must view the object in one of the preview modes.

To switch preview modes:

From View: Wireframe and View: Preview (fast) menu, choose a different preview mode: Preview, Shaded Preview,
Better Preview.



Using the Window Controls SXSTYISY i Wil

Three controls are provided at the bottom of the Mesh Form Modeling window:
¢ Done returns to the scene window, updating the model with your changes.
¢ Restore returns to the scene window without preserving any modifications to the model.

e Zoom level indicates the zoom factor at which the window contents are currently displayed. To change the zoom
level, choose a different scale factor from the pop-up.



Working on the Mesh Form Drawing Plane

To create objects with the Mesh Form modeler, you use the Polyline tool and the Polymesh primitive tools to draw
polymeshes, cross-sections, extrusion paths and lathe axes and profiles.

Like the Free Form modeler, you always work on a single drawing plane. However, you can freely move the drawing
plane to any location in the model.

In the Mesh Form modeler, all vertices are connected by straight lines. Unlike the Free Form modeler, you cannot
draw Bézier curves.



Mesh Form Modeler Arranging Tools

The arranging tools provided in the Mesh Form modeler are designed to make it easy to manipulate your polymesh
objects. In addition to the arranging tools available in the Scene window, the Mesh Form modeler provides a Marquee
Selection tool.



Selecting Vertices, Polygons, and Edges uYerYew g ol

Use the Selection tool to select and move vertices, edges, polygons and entire objects. You can also use the
Selection tool to select and resize objects.

Selected vertices and edges are highlighted in red. When you select an entire object, its bounding box is displayed
and all of its edges are highlighted.

You can select:
e Avertex or edge by clicking it.
¢ A polygon by clicking in the middle of it.

¢ An entire object by double-clicking any vertex or polygon in it or by triple-clicking any edge.

All the edges in the same direction by double-clicking one of the edges.
An adjoining edge is considered to lie in the same direction if the angle formed between the selected edge and
the adjoining edge is equal to or less than the Angle of Selection Propagation specified in the Properties palette:
Tool Options tab. If the adjoining edge lies in the same direction, it is selected and the angles formed between it
and any adjoining edges are evaluated. In this way, the selection propagates until there are no more adjoining
edges that meet the selection criteria.

e A group of objects, edges, or vertices by dragging until the marquee encloses the items you want to select. You
must begin the drag outside of the object—to select a group of edges and vertices within an object, use the
Marquee Selection tool.

To extend a selection, hold down the Shift key before selecting additional objects. To remove an object from the
selection, hold down the Shift key and reselect the object.



Marquee Selection Tool LYETYEY [ "N|

Use the Marquee Selection tool to select groups of objects. You must use the Marquee selection tool if you want to
select a group of vertices and edges within an object.

To use the Marquee Selection tool to select a group of objects:
¢ Drag until the marquee surrounds the objects, edges and vertices you want to select.

To extend the selection, hold down the Shift key before selecting additional vertices. To remove an object from the
selection, hold down the Alt key and reselect the object.



Camera Dolly Tool XYY [ V|

Use the Camera Dolly tool to move your viewpoint around the model. This allows you to determine the spatial
relationships between objects in the model.

You can also dolly the camera with the numeric keypad:

e 8 and 2 dolly the viewpoint up and down

e 4 and 2 dolly the viewpoint left and right

e 1 and 3 rotate the viewpoint around the drawing plane axis.
Note: Numlock must be on to dolly the camera with the keypad.

The View menu allows you to change your viewpoint to several preset positions.



Hand Tool 22T [ Wl

Use the Hand tool to adjust your view of the window contents. The Hand tool lets you scroll your view up, down, left
or right without using the scroll bars. Press the space bar to temporarily invoke the Hand tool when another tool is
active.

To use the Hand tool:
¢ Drag within the modeling window to move the window’s contents left, right, up, or down.
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Use the Zoom tool to magnify or reduce the window’s view. You can also zoom in and out with Control + + and
Control + —.

To switch to a particular magnification level, use the Zoom level pop-up at the bottom of the modeling window.

To use the Zoom tool:
¢ Click in the modeling window to zoom in.

e Alt+click in the modeling window to zoom out.

¢ Drag with the Zoom tool to zoom in on a particular item.
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Use the Plane Display tool to change the plane display in the Mesh Form Modeling window.

When you drag an object in the Mesh Form Modeling window, gray altitude lines show the object’s position relative to
the visible planes. Because of the potential complexity of Mesh Form models, 2D projections of the objects in the
model are not displayed on the visible planes.

To use the Plane Display tool
¢ Click on the representation of the plane you want to show or hide.

¢ Alt+click on the representation of a plane in the Plane Display tool to select it as the drawing plane.



Mesh Form Modeler Drawing Tools
The Mesh Form modeler provides several tools that you can use to create and edit objects in the modeling window:
¢ Polyline tool

e Sphere of Attraction tool
e Add Vertex tool

e Delete tool

¢ Polymesh Primitive tool
e Extrude tool

e Sweep tool

¢ Lathe tool

* Loft tool

¢ Increase Action Modifier

¢ Decrease Action Modifier
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Use the Polyline tool to draw two and three-dimensional polylines. The polylines can be open or closed. Polylines can
be used as cross sections, extrusion and sweep paths, and lathe profiles.

When drawing with the Polyline tool, you add one vertex at a time. Edges are automatically drawn between each
vertex.

The Polyline tool is not a Bézier drawing tool; points in a polyline or polygon are always connected by straight lines.
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Use the Sphere of Attraction tool to attract a group of vertices in an object. The Sphere of attraction tool behaves like
a magnet, pulling the vertices and edges within its sphere away from their original locations.

You can set properties for the Sphere of Attraction tool on the Properties Palette: Tool Options tab. The Tool
Properties allow you to control:

¢ The shape of the attraction curve.
¢ The radius of the sphere of attraction.

* Whether nearby edges and vertices are attracted or only the selected vertices and edges are attracted.



Add Vertex Tool ZXETYEW /i M|

Use the Add Vertex tool to add vertices to existing edges. This is useful when you need more control over the object
than is provided with the existing vertices.
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Use the Delete tool to remove vertices and edges from an existing object. You can also use the Delete tool to empty a
polygon.

e Removing a vertex also removes any edges connected to the vertex.

¢ Removing an edge does not affect the vertices that it linked.

e  Emptying a polygon doesn’t affect the vertices or edges surrounding the polygon. It simply converts the polygon
to a closed polyline by removing the polygon face.
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Use the Polymesh Primitive tools to quickly create standard objects of any size:
e Sphere tool—create a sphere.

e Cube tool—create a cube

e Cylinder tool—create a cylinder.

¢ Mesh tool—create an array of vertices.

¢ Rectangle tool—create a rectangle.

¢ Ellipse tool—create an ellipse.

You can set properties for the Sphere tool, Mesh tool, Cylinder tool, and Ellipse tool on the Properties Palette: Tool
Options tab. These properties affect all subsequent objects created with the tool.

¢ Mesh Tool Options allows you to specify the number of vertices in new meshes. The number of vertices doesn’t
affect the size of the mesh.

¢ Sphere Tool Options allows you to specify the number of polygons in new spheres. A greater number of polygons
creates a smoother sphere.

¢ Cylinder Tool Options allows you to specify the number of sides in new cylinders. The more sides that a cylinder
has, the smoother its surface.

¢ Ellipse Tool Options allows you to specify the number of edges in the ellipse. The more edges an ellipse has, the
smoother its circumference.

The actual number of polygons or sides in an object might differ from the value you specify in the Tool Options or
Action Modifiers tab. For example, if you specify 59 as the number of polygons in a sphere and create a sphere, that
sphere might actually contain 60 polygons. The Properties Palette: Numerical tab displays the actual values for a
particular object.

To change newly created objects, you can edit the options in the Action Modifiers tab



Extrude Toolw

Use the Extrude tool to create an extrusion from a profile and an extrusion path.
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Use the Sweep tool to create a sweep object from a profile and a sweep path.
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Use the Lathe tool to create a lathed object from a lathe profile and a lathe axis.
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Use the Loft tool to stretch a skin over a group of selected polylines.
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Use the Action Modifier Increase and Decrease tools to modify the result of the last action. These tools provide a
shortcut to the functions provided by the Properties Palette: Action Modifier tab. They have different effects depending
on what the last action was. The + and — keys have the same effect as the Action Modifier tools.

When an object is created with the Sphere, Cylinder, Mesh or Ellipse tool, the Action Modifiers can be used to smooth
or sharpen the object by increasing or decreasing the number of polygons, edges or vertices defining the object.

For example, when you create a cylinder, you can select the Increase Action Modifier to add more sides to the
cylinder. Similarly, you can use the Decrease Action Modifier to reduce the number of vertices in a newly created
mesh.

When you create objects with the Extrude, Sweep, and Lathe commands, the Action Modifiers can be used to change
which object is used as the cross section or profile.

When you use the Boolean Operations command, the operation defaults to the previous operation type (Union,
Intersection or Subtraction). You can use the Action Modifiers to change operation types.

The Action Modifiers can also be used in conjunction with the Sphere of Attraction tool: the Action modifiers increase
and decrease the radius of the sphere of attraction.



About Setting Up the Grid

You can use the grid to precisely position objects on the drawing plane. When Snap To is enabled, objects are
automatically snapped to the nearest grid intersection when they are dragged. By changing the grid, you can control
where objects are snapped.

You can control the grid used in the Mesh Form modeler independently of the grid used in the Scene window and
other modelers. To set up the grid for the Mesh Form modeler, you change the grid options in the Mesh Form Modeler
preferences. When you return to the Scene window, the grid settings revert to the settings last specified in the Grid
dialog.

To make global changes to the grid settings, you use the View menu> Grid command.



Setting the Grid for the Mesh Form Modeler Lrervew (.

1. Choose File menu> Preferences (Control+Shift+P).
Studio displays the Preferences dialog.

2. Choose Mesh Form Modeler from the pop-up.

1.1n the Grid Settings, specify the grid spacing increment and choose a unit from the pop-up.
The Spacing increment is also used for “nudging” (moving an object with an Arrow key).

2.Change the Draw a Line Every value to control how many grid lines are drawn.
This value sets the number of increments between grid lines. When set to 1, there is one increment for every grid
line and nudging an object moves it to the next grid line.

3. Change the Number of Steps to control the size of the grid.
The size of the grid is the number of steps multiplied by the spacing increment. For example, if you want to
multiply the grid frequency by 2, you need to double the number of steps and reduce the spacing increment by
half.

4. If you want to hide the grid lines, disable Show Grid.
The grid doesn’t have to be displayed for Snap to Grid to work.

1. Enable Snap to Grid if you want objects to “jump” to the nearest grid increment when you drag them.



Modifying the Last Action

When you’re creating new objects or performing complex actions such as Boolean Operations, you might not get the
results you want on the first try. To make it easier to modify the results, the Mesh Form modeler provides a special
feature for modifying the last action.

You can use the Action Modifier tools to step through changes, or you can enter values directly in the Properties
palette: Action Modifier tab. The action modifiers are not available for all operations, but do allow you to change:

¢ Newly created spheres, cylinders and meshes

¢ Newly created extrusions, sweeps, and lathed objects.
¢ Objects modified with the Sphere of Attraction tool.

¢ Objects created with the Boolean operations.

In most cases, the options that you can modify in the Action Modifier tab correspond to the drawing tool’s options.



Creating Polymesh Objects

A polymesh object is any polymesh created in the Mesh Form modeler, or created with another modeler and opened
in the Mesh Form modeler.

Instead of just being able to manipulate an object’s profile or cross section, you can manipulate any part of a
Polymesh object’s surface. You have complete control over all of the vertices and edges that describe the object.

This section describes how to create objects by drawing with the polyline tool, using the Polymesh Primitive tools,
and duplicating existing objects.

To create more complex objects, you can generate extrusions, sweeps, lathed objects lofted objects in the Mesh
Form modeler. The Mesh Form modeler also allows you to generate complex objects by performing Boolean
operations on existing objects.
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With the Polyline tool, you can open and closed polylines. The cursor changes to indicate when you have completed
a polyline by closing it or clicking twice on its end point.

To draw an open polyline:

1. Select the Polyline tool.

1. Click in the modeling window to add each vertex in the polyline.
Vertices are added to the current drawing plane. Hold down the Option/Alt key to draw vertices perpendicular to
the drawing plane. Edges are automatically drawn to connect the vertices. To constrain the polyline to 45°
angles, hold down the Shift key.

1. Click the last vertex again to finish the polyline.

To draw a closed polyline:

1. Select the Polyline tool:

2. Click in the modeling window to add each vertex in the polyline.
3. Close the polyline by clicking again on the first vertex.

To create polygons, you can fill closed polylines.
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You can use the Polymesh Primitive tools to create an object that you can “sculpt” with the editing tools. The cube,
sphere, or cylinder is like a block of clay that you can reshape into a finished object.

To draw an object:
1. Select a Polymesh Primitive tool: Sphere, Cube, Mesh, Rectangle, or Ellipse.

1. Click the drawing plane to add the object.
You can drag to create an object of a particular size.

Hold down the Shift key to constrain a new mesh or rectangle to a square, or to constrain a new ellipse to a
circle.
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You can duplicate an object with the Edit commands Duplicate and Duplicate with Symmetry.
e When you choose Duplicate, a second copy of the object is created at the same location as the original.

e When you choose Duplicate with Symmetry, the copy created mirrors the original object. In the Mesh Form
modeler, the drawing plane is used as the mirror plane. This allows you to control where the mirrored object is
placed by moving the drawing plane in relationship to the object you’re duplicating.

To duplicate an object:
1. Select the object you want to duplicate.

2. Choose Edit menu> Duplicate (Command-D/Control+D).

To duplicate an object with symmetry:

1. Adjust the drawing plane so that when used as the mirror plane, it will reflect the appropriate image.
For example, if you have modeled the fuselage of an airplane and one wing, you can duplicate the wing and
place it in the correct location if you move the drawing place so that it bisects the fuselage vertically.

1. Select the object you want to mirror.

2. Choose Edit menu> Duplicate With Symmetry (Command-Option-D/Control+Alt+ D).



Specifying Object Properties

The Properties Palette: Numerical Properties tab displays the properties of the selected object, vertices, edge or
polygon.

You can use the Numerical Properties tab to:

e Move selected vertices to particular X, y, z coordinates.

¢ Move selected objects to particular x, y, z coordinates.

When one vertex is selected, Numerical Properties displays the x, y and z coordinates of the vertex.

When two discontinuous vertices are selected, Numerical Properties displays the distance between the vertices and
the vertices’ x, y and z coordinates.

When an edge is selected, Numerical Properties displays the length of the edge and the x, y and z coordinates of the
edge’s vertices. In addition, the tab displays a set of radio buttons that indicates the edge’s current smooth setting.
Smooth indicates that the Smooth command has been applied to the edge, Automatic indicates that the smooth
setting is calculated from the crease angle, and Sharp indicates that the Sharpen command has been applied to the
edge.

When a polygon is selected, Numerical Properties displays the coordinates of the polygon’s center and the number of
vertices in the polygon.

When one polymesh object is selected, Numerical Properties displays the number of vertices and edges in the object;
the number of polygons or sides in the object, and the current crease angle.

When multiple objects are selected, Numerical Properties displays the number of selected vertices, edges, polygons
and polymeshes.



Specifying Object Properties in the Numerical Properties tab
1. Select the object whose properties you want to change.

2. Choose the Properties Palette: Numerical Properties tab.
1. Directly edit the displayed values.
By default, all values are specified in inches. To change units, select the units pop-up and choose ft, cm, m, mm,

or pts.

2. Click the Apply button.
If Auto is enabled, the changes are applied automatically.



Working with Selections

To make it easier to work with complex polymesh objects, the Mesh Form modeler allows you to save and restore
selections, invert selections, and hide selections.

When you’re working with complex objects, it’s often convenient to save selections of groups of objects so that you
can easily reselect them.

You can only have one saved selection at a time.
e Choose Selection menu> Save Selection to save the current selection.
e Choose Selection menu> Restore Selection to restore the last saved selection.

e Choose Selection menu> Invert to invert the current selection.
Inverting the selection selects only those items that are not part of the current selection.



Hiding Selections

When you’re editing a complex object, you might want to hide parts of the object to make it easier to view and select
the vertices and edges you want to work with.

To hide a selection:
1. Select the vertices and edges you want to hide.

2. Choose View menu> Hide Selection.
To reveal hidden vertices in an object:
1. Select the object.

2. Choose View menu> Reveal Vertices.



Working With Vertices

The real power of the Mesh Form modeler lies in the fact that you can directly edit polymesh objects. By moving
vertices and edges, adding vertices, removing selected vertices and edges, and joining separate objects, you can
model just about anything you can imagine.

Adding a vertex provides you with another point that you can manipulate to modify the object. You can add and
remove individual vertices with the Add and Remove Vertex tools. You can also remove selected items, including
vertices, by pressing the Delete key. Removing a vertex removes the vertex and any edges connected to that vertex.

To add a vertex:
1. Select the Add Vertex tool.

2. Click an edge where you want to add the vertex.
The new vertex is highlighted in red.

1.You can drag with the Add Vertex tool to add and immediately move a new vertex.
To remove a vertex:
1. Select the Delete tool.

2. Click the vertex you want to remove.
Removing a vertex also removes the edges that connected the vertex to other vertices.

Selected vertices can be removed with the Delete/Backspace key and the Edit menu> Delete command.

You can also remove edges with the Remove Vertex tool. Deleting an edge does not affect the vertices. The result is
the same as selecting the edge and choosing Selection menu> Unlink.



Linking and Unlinking Vertices

You can close or extend a polyline by linking two vertices. Linking vertices creates an edge between them. Unlinking
vertices removes the edge that connects them, but does not affect the vertices themselves.

Closing a polyline does not turn it into a polygon. If you want to create a polygon from a closed polyline, select it and
choose Selection> Fill Polygon.

To link vertices:
1. Select the vertices you want to link.

1.Choose Selection menu> Link.

An edge is created to connect the vertices. If the two vertices are part of the same polygon, the polygon is
divided into two smaller polygons.

To unlink vertices:
1. Select the vertices you want to unlink.

1.Choose Selection menu> Unlink.

The edge connecting the two vertices is removed. You can also unlink two vertices by clicking the edge with the
Delete tool.



Moving Vertices and Edges

The power of polymesh modeling lies in the ability to change an object by directly positioning its vertices and edges.
You can use the Object Selection tool to drag any selection to a new location. For example, you can move a polygon
by clicking in its center and dragging it.

When you drag a selection in the modeling window, the selection is moved in relationship to the current drawing
plane. Gray altitude lines show the object’s position relative to the visible planes.



Repositioning Vertices
In the Mesh Form modeler, you can precisely reposition vertices by:
¢ Offsetting a vertex from its current location with the Move command.

¢ Changing the coordinates of a vertex with the Properties Palette: Numerical tab.

To move vertices numerically:
1. Select the vertex or vertices you want to move.

2. Choose Selection menu> Move. Studio displays the Move dialog.

3. Enter the amounts you want to move the vertices in the x, y and z directions and click OK.

To move a vertex to an exact location:
1. Select the vertex you want to move.

2. Choose the Properties Palette: Numerical tab.

1. Specify the x, y, z coordinate for the vertex and click Apply.
If Auto is enabled in the Properties palette, the changes are automatically applied.



Moving Vertices with the Sphere of Attraction Tool

You can selectively move vertices in an object with the Sphere of Attraction tool. This tool behaves like a magnet,
attracting the vertices within its sphere of influence. The Properties Palette: Tool Options tab allows you to change the
shape of the attraction curve, adjust the radius of the tool’s sphere of influence, and specify an attraction mode.

You can set the attraction curve to one of four profiles: Cubic spline, Linear, Spiky, or Bumpy.
There are two attraction modes:

¢ Move selection, attract other vertices. Selected vertices are moved like they would be with the Selection tool, other
vertices within the sphere of attraction are moved towards the location of the selected vertices.

e Attract only selected vertices. Selected vertices are attracted with the Sphere of Attraction tool, other vertices are
not affected.

To move a group of vertices:
1. Select the Sphere of Attraction tool.

2. In the Properties Palette: Tool Options tab, select an attraction curve: Cubic spline, Linear, Spiky, or Bumpy.
3. Specify the radius of the sphere of attraction.

4. Select an attraction mode by enabling Move selection, attract other vertices or Attract only selected vertices.
5. With the sphere of attraction tool, select the vertices you want to move or attract.

1. Drag the attraction tool in the direction you want to move the vertices.

To constrain the move operation to the direction perpendicular to the drawing plane, hold down the Option/Alt
key.



Welding Vertices
You can join separate objects by welding the vertices where they meet.

Normally, if two vertices are within a specified distance from each other, they are welded when you use the Weld
command. However, if welding the vertices would cause a single edge to be shared by more than two polygons, the
vertices are not joined.

To weld vertices:
1. Select the vertices to be welded.

2. Choose Selection menu> Weld.
Studio displays the Weld dialog.

3. Indicate how close the vertices must be to be welded and click OK.

1. Use Default Tolerance welds the vertices if the distance between them is within the default tolerance specified in
the Mesh Form Modeler preferences.

2.Use Custom Tolerance allows you to specify the maximum distance vertices can be from each other and still be
welded.

3. Weld every selected vertex welds the selected vertices no matter how far apart they are.

4. Welded vertices are joined into a single vertex.
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The Mesh Form modeler provides a number of ways to manipulate an object’s surface without directly editing
individual vertices and edges. This section describes how you can:

¢ Adjust the position of vertices, edges, and polygons to align two objects.
¢ Add depth to an object’s surface to give it a visible shell.

¢ Create and fill holes in an object’s surface.

e Smooth or sharpen an object’s surface.

¢ Increase the number of polygons that describe an object’s surface, giving you more control over its shape and
appearance.
When an object such as a sphere is rendered, the individual polygons are shaded to appear smooth. In some
cases, you do not want smooth shading from one polygon to the next—the edge shared by the polygons might
represent a crease in the object’s surface.



Aligning Polymesh Objectsw

You can adjust the alignment of two objects by aligning part of one object with part of another. Using the Adjust
command, you can align vertices, edges, or polygons. For example, you could use Adjust to snap a lid on a can by
selecting one vertex on the lid and the corresponding vertex on the can.
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1. Select the two vertices you want to align.

2. Choose Polymesh menu> Adjust.
Studio displays the Adjust dialog.

3. Specify which vertex is the anchor, the one that should remain in its current position.

1.In the modeling window, the vertex highlighted in blue is the anchor. Click one of the blue anchor arrows in the
Adjust dialog to select the other vertex as the anchor.

1. When you’ve selected the anchor, click OK to align the vertices.



Aligning an Edge in One Object with the Edge in Another Vverview (a W

1. Select the two edges you want to align.

2. Choose Polymesh menu> Adjust.
Studio displays the Adjust dialog.

3. Use the blue Anchor arrows to specify which edge is the anchor, the one that should remain in its current
position.

1.In the modeling window, the edge highlighted in blue is the anchor. To select the other edge as the anchor, click
one of the blue anchor arrows.

2.When you’ve selected the anchor, click OK to align the edges.
The edge specified as the anchor isn’t moved. The other edge is aligned and centered along the anchor edge.



Aligning a Polygon in One Object with the Polygon in Another Lrervew (.

1. Select the two polygons you want to align.

2. Choose Polymesh menu> Adjust.
Studio displays the Adjust dialog.

3. Use the blue Anchor arrows to specify which polygon is the anchor, the one that should remain in its current
position.

1. In the modeling window, the polygon highlighted in blue is the anchor. To select the other polygon as the anchor,
click one of the blue anchor arrows.

2.When you’ve selected the anchor, click OK to align the polygons.
The polygon specified as the anchor isn’t moved. The other polygon is centered with the anchor polygon.



Adding Thickness to an Objectw

To add thickness to an object, you can perform a straight extrusion on all or part of its surface. To make this easy, the
Mesh Form modeler provides an Add Thickness command.

When you use this command, a straight extrusion with the specified depth is performed on each polygon in the
selection.

To add thickness to an object:
1. Select the part of the object you want to add thickness to.

2. Choose Selection menu> Add Thickness.
Studio displays the Add Thickness dialog.

3. Specify how thick you want the surface to be and then click OK.
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Polymesh objects do not have to be completely solid. You can cut holes in an object by emptying polygons on the
object’s surface.

You can also cut away parts of an object by using the Boolean Subtraction operation. For more information see Using
Boolean Operations to Create Complex Polymesh Objects.

To create a hole in an object:
1. Select the polygons you want to remove to create the hole.

2. Choose Selection menu> Empty Polygon.

You can also empty polygons with the Delete tool.

Filled and empty polygons appear the same in the wireframe view. To view the hole, switch to one of the preview
modes: Preview, Preview Shaded, or Better Preview.

To fill a hole in an object:
1. Select the closed polyline that you want to fill.

2. Choose Selection menu> Fill Polygon.
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Setting the crease angle allows you to control smoothing and sharpening for an entire object. Polygons on the
object’s surface that meet at an angle less than the crease angle are shaded smoothly; edges where polygons meet
at an angle greater than the crease angle are rendered as creases in the object’s surface.

To adjust the crease angle:
1. Select the object.

2. Choose Polymesh menu> Set Crease Angle.
Studio displays the Crease Angle dialog.

3. Enter a value in degrees for the crease angle.
4. Enable Override Edge Settings to override the effects of the Smooth Edges and Sharpen Edges commands.

1.Click OK to set the crease angle.
You can view the results in one of the preview modes.

overview ("W Topics



Smoothing Object Edgesw

To smooth edges in an object:
1. Select the edges you want to smooth.

1. Choose Polymesh menu> Smooth Edges.
You can view the results in one of the preview modes.

overview (i Wl 1aica Topics
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To sharpen edges in an object:
1. Select the edges you want to sharpen.

1. Choose Polymesh menu> Sharpen Edges.
You can view the results in one of the preview modes.

overview (i Wl 1aica Topics
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To determine an edge’s smooth state:
¢ Select the edge and check the Properties Palette: Numerical tab.

Overview (i~ . Related Topics



Controlling the Number of Vertices and Edges Used to Describe an Objectw

The Mesh Form modeler provides three commands that allow you to change the number of vertices and edges used
to describe an object: Triangulate, Subdivide, and Decimate.

e When a polygon is triangulated, edges are added to divide the polygon into smaller, triangular polygons.
Triangulating a polygon doesn’t affect the number of vertices in the polygon.

e When a polygon is subdivided, it’s triangulated and then vertices are added to divide each triangle into four
smaller triangles. Triangulating a three-sided polygon has no effect, but you can subdivide a triangle.

e Decimating an object reduces the number of vertices and edges in the object.

You can triangulate, subdivide, or decimate an entire object or just selected portions of the object.



Triangulating an Object

When you edit an object, you might create some large, odd-shaped polygons. When rendered, these polygons can
make the object look blocky. To create more natural looking transitions across the surface of the object, you can use
triangulate to add edges that you can adjust to create a smoother shape.

Triangulate can also be used in conjunction with the Decimate command to produce more satisfactory results.

To triangulate selected polygons:
1. Select the polygons you want to triangulate.

2. Choose Selection menu> Triangulate Polygon.



Subdividing an Object
Subdividing an object adds vertices and edges to give you finer-grain control over an object’s surface.

To subdivide selected polygons:
1. Select the polygons you want to subdivide.

2. Choose Selection menu> Subdivide.



Decimating an Object

Decimating an object is an easy way to simplify imported models that contain more detail than you need. In some
situations, though, decimating an object is counter-productive—you often want more control over an object’s surface,
not less.

To get the best results when you’re decimating an object, you might want to alternate decimating the object and
triangulating the object.

To decimate an object:
1. Select the object or portion of an object that you want to decimate.

2. Select Selection menu> Decimate.

1.In the Decimate dialog, use the Threshold slider to specify the percentage of vertices to be removed.
The higher the threshold, the more vertices will be removed.

2. Select the decimate technique to be used by enabling either Vertex Count or Decimate.
Vertex Count removes the percentage of vertices specified in the Threshold slider.
Decimate removes the vertices that meet the decimate criteria, up to the threshold percentage.

3. Select the decimate criteria by enabling either Distance or Angle.
Distance causes vertices to be removed based on their distance from the planes shared by their neighbors.
Angle causes vertices to be removed based on the angles formed by the polygons connecting the vertices to
their neighbors.

1. Click OK when you’ve finished specifying the Decimate options.
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The Mesh Form modeler provides a number of ways to move, scale and rotate polymesh objects or parts of
polymesh objects:

e  You can transform them interactively using the Selection tool, Trackball Rotation tool or 2D Rotation tool.
e You can also transform them numerically using the Rotate, Resize and Move commands.

e  For 3-dimensional objects, you can specify exact dimensions using the Resize command. Similarly, you can
specify the exact location of a vertex by editing its coordinates on the Properties Palette: Numerical tab.



Moving an Object or Selection 2XETYEY i Wl

You can move any selection simply by dragging it to a new location. For more precise positioning, use the Move
command or the Properties Palette: Numerical tab. You can also use the arrow keys to nudge objects.

If you hold down the Alt key, the object moves perpendicular to the drawing plane when it’s dragged or nudged.

The Mesh Form modeler also allows you to offset selected polygons from an object’s surface.

To move an object or selection numerically:
1. Select the object or portion of an object that you want to move.

2. Choose Selection menu> Move.
Studio displays the Move dialog.

1. Specify the amounts you want to move the object in the x, y and z directions and click OK.
Positive values increase the selection’s distance from the origin; negative values move the selection closer to its
origin. (The axis indicator identifies the origin for the model.) By default, the values are specified in inches. Use
the units pop-up to select a different unit of measure.

To offset the surface of an object:
1. Select the polygons that you want to offset from the object.

2. Choose Selection menu> Offset.
Studio displays the Offset dialog.

1. Specify the amount you want to move the selected polygons.
The surface is expanded like a balloon. Each selected polygon is moved outward, perpendicular to the plane
defined by the polygon.



Flattening Selections XS fri V|

In some cases, you might want to move the vertices in a polygon to the same plane. This is called flattening the
selection. The plane that the vertices are flattened to depends on the locations of the vertices in the selected polygon.

To flatten a polygon
1. Select the object you want to flatten.

2. Choose Selection menu> Flatten.



Moving Selections to the Drawing Plane ZXE0EY [Fil Wl

Instead of flattening selected vertices to an arbitrary plane, you might want to move them to all to the drawing plane.

To move a group of vertices, edges or polygons to the drawing plane:
1. Select the objects you want to move to the drawing plane.

2. Choose Selection menu> Move to Drawing Plane.



Scaling an Object or Selection XYY [ VNl

You can drag the corner of an object’s bounding box to scale it, scale the current selection by specifying x,y,z scale
factors with the Resize command, or change an object’s size by specifying new x,y,z dimensions with the Set Size
command.

To scale an object:
1. Select the polymesh you want to scale.

2. With the Selection tool, drag one of the object’s bounding-box corners.
Drag away from the object’s center to enlarge it; drag towards the object’s center to reduce it.

To constrain the scale operation to equal proportions, hold down the Shift key.
To constrain the scale operation to a direction perpendicular to the drawing plane hold down the Option/Alt key.

To move the drawing plane, hold down the Command/Control key.

To scale an object or selection numerically:
1. Select the object or portion of an object that you want to scale.

2.Choose Selection menu> Resize.
Studio displays the Resize dialog.

1. Enter the x, y and z scale factors and click OK.
The scale factors are specified in percentages. For example, to reduce an object to half its original size in all
dimensions, specify x, y and z scale factors of 50%.



Setting the Size of an Object XY™ [Fir "7l

To set the size of an object:

1. Select the object you whose size you want to set.

You can only set the size of 3-dimensional objects. To resize objects whose vertices all lie on the same plane,
use the Resize command.

1. Choose Polymesh menu> Set Size.
Studio displays the Set Polymesh Size dialog.

1. Enter the new x, y, and z dimensions for the object and click OK.
The object is resized so that its bounding box matches the dimensions you specify.



Rotating an Object or Selection 2T [ VNl

You can rotate an object freely in three dimensions, or in relationship to the drawing plane. With the Rotate
command, you can rotate an object a specific amount around the X, y, or z axis.

To free rotate an object in three dimensions:
1. Select the Trackball Rotation tool.

1. Drag to rotate the object to a new orientation.
The cursor must be over the object you want to rotate when you begin dragging. You can Shift-select other
objects to rotate them at the same time.

To free rotate an object relative to the drawing plane:

1.Choose View menu> Preset Position> Drawing Plane.
Objects are rotated with respect to the current drawing plane. It is easier to observe the effect of the rotation if
you are looking directly at the drawing plane.

1. Select the 2D Rotation tool.

1.Drag to rotate the object to a new orientation.
The cursor must be over the object you want to rotate when you begin dragging. You can Shift-select other
objects to rotate them at the same time. To constrain the rotation to 45° increments, hold down the Shift key
while you drag.

To rotate an object or selection numerically:
1. Select the object or portion of an object that you want to rotate.

2. Choose Selection menu> Rotate.
Studio displays the Rotate Selection dialog.

1. Select the axis of rotation.
The rotation is constrained to one axis of rotation.

2. Specify the angle of rotation and click OK.
The angle of rotation is specified in degrees. Positive values rotate the object clockwise around the axis of
rotation (looking away from the origin), negative values rotate the object counterclockwise.



Using Standard Modeling Techniques to Create Complex Polymesh Objects

You can use the standard modeling techniques introduced with the Free Form modeler to create complex objects in
the Mesh Form modeler. The Mesh Form modeler supports:

¢ Extrusions

e Sweeps

e Lathed objects

¢ |ofted objects

You should use the Mesh Form modeler to create these types of objects when you want to:
e Edit the surface of the resulting object.

e Create extrusions or sweeps with 3-dimensional cross sections or sweep paths.

¢ Use the resulting object to perform Boolean operations.

If the object you are modeling is easier to describe using Bézier curves, you can create the object in the Free Form
modeler and then edit it in the Mesh Form modeler.

You cannot extrude, sweep, loft, or lathe polygons with the Mesh Form modeler. If you want to use a polygon in an
existing polymesh object as a cross section, convert the polygon to a closed polyline by emptying it.



Extruding and Sweeping Polygon and Polyline Cross Sections

Extruding or sweeping a polygon creates an object similar to that created with the Free Form modeler. You can use
an open or closed polyline to define the cross section of an extrusion or sweep. Using an open polyline as a cross
section creates a shell with the shape of the polyline.

The cross section can be a separate polyline object, or a set of selected edges in a larger object.

The extrusion or sweep path is also defined by a polyline. The vertices of the extrusion path do not need to lie in the
same plane, allowing you to easily define complex, three-dimensional extrusion paths.

Like cross sections, the extrusion path can be defined by a separate polyline object or a set of selected edges in a
larger object.

When a cross section is extruded, the orientation of the cross section remains constant along the extrusion path.
When a cross section is swept along a path, the orientation of the cross section changes so that it always remains
perpendicular to the path.

To create a straight extrusion:
1. Create a cross section using the Polyline tool or select an existing polyline to use as the cross section.

2. With the cross section selected, choose Selection menu> Extrude.
Studio displays the Extrude Options dialog.

3. Specify the depth of the straight extrusion and click OK.

To create a complex extrusion:
1. Create a cross section using the Polyline tool or select an existing polyline to use as the cross section.

2. Draw the extrusion path with the Polyline tool or select an existing polyline to use as the path.

3. Select the cross section and extrusion path and choose Selection menu> Extrude.

1. Use the blue arrows in the Properties palette: Action Modifier tab to change which selection is used as the
extrusion path.
In the modeling window, the object selected as the extrusion path is highlighted in blue and the cross section is

highlighted in red. The starting vertex in the extrusion path is also highlighted in blue.

2.To change the object selected as the extrusion path, click one of the double arrows. To change the starting point on
the selected extrusion path, use the single arrows.

1.When the extrusion path is set, click Apply to generate the extrusion.

1.1f Auto is enabled in the Properties palette, the changes are automatically applied.

To create a sweep:

1. Create a cross section using the Polyline tool or select an existing polyline or polygon to use as the cross
section.

2. Draw the sweep path with the Polyline tool or select an existing polyline to use as the path.
3. Select the polygon and the polyline and choose Selection menu> Sweep.
1. Use the blue arrows in the Properties palette: Action Modifier tab to set the extrusion path.
In the modeling window, the object selected as the sweep path is highlighted in blue and the cross section is

highlighted in red. The starting vertex in the sweep path is also highlighted in blue.

2.To change the object selected as the sweep path, click one of the double arrows. To change the starting point on
the selected path, use the single arrows.

1. When the sweep path is set, click Apply to generate the extrusion.



1.1f Auto is enabled in the Properties palette, changes are automatically applied.



Modeling with Polygon and Polyline Cross Sections

Lofting enables you to stretch a surface over a series of cross sections. In the Mesh Form modeler, these cross
sections can be defined by open or closed polylines.

Like the cross sections used for extrusions and sweeps, these cross sections can be separate polyline objects or
selected edges in a larger object.

You can define as many cross sections as you need, but all of the cross sections for a single lofted object must be
either open polylines or closed polylines, you cannot mix them. To be lofted, the cross sections must lie on different
planes.

In certain situations, not all of the cross sections you define are used. This might happen if two of the cross sections
lie very close to the same plane—one of them is used and the other ignored.

To loft an object:
1. Create the cross sections with the Polyline tool or choose existing polylines to use as cross sections.

2. Select the cross sections.

3. Choose Selection menu> Loft.



Lathing with Polygon and Polyline Profiles

When you lathe objects in the Mesh Form modeler, you control both the lathe profile and the lathe axis. The lathed
object is created by revolving the profile around the specified axis. The cross section of a lathed Polymesh object is
always circular.

Both polylines and polygons can be used as lathe profiles. The lathe axis can by defined by any edge.

To lathe an object:
1. Create the lathe profile with the polyline tool, or select a set of connected edges to use as the lathe profile.

1. Create a lathe axis with the polyline tool or select an existing edge to use as the axis.
The lathe axis must be a line defined by two vertices.

2. Select the lathe profile and the lathe axis.
If you do not select a lathe axis, Studio will revolve the selected lathe profile around the axis formed by drawing a
line from the first vertex in the profile to the last vertex in the profile. In this case, the lathe profile must be an
open polyline.

1. Choose Selection menu> Lathe.

1. Use the blue arrows in the Properties palette: Action Modifier to set the lathe axis.
In the modeling window, the object selected as the lathe axis is highlighted in blue, and the lathe profile is
highlighted in red.

2.To change the object selected as the lathe axis, click one of the blue arrows in the Properties Palette: Action
Modifiers tab.

3. Specify the number of steps for the lathed object.
A greater number of steps produces a smoother object.

1. Click Apply to generate the extrusion.

1.1f Auto is enabled in the Properties palette, changes are automatically applied.



Using Boolean Operations to Create Complex Polymesh Objectsw

The Boolean operations Union, Subtraction and Intersection are used to produce a complex object from two simpler
objects. Boolean operations are performed on two overlapping volumes. Both volumes should be closed—holes in
the surface of a volume can prevent Boolean operations from producing the desired results.

The union of two objects is an object whose surface encompasses the visible surfaces of both objects. For example,
if you spray-paint two overlapping spheres, the painted surface represents the union of the two spheres.

If you take the intersection of two objects, the resulting object is the volume shared by both objects. For example, if
you take the intersection of two overlapping spheres, the resulting object resembles a flying saucer.

When you subtract object B from object A, the parts of object A that are encompassed by object B are removed. For
example, if you have two overlapping spheres and subtract one from the other, the resulting object resembles a
sphere with a large crater.

Boolean subtraction is similar to the concept of compounding shapes in the Free Form modeler. However,
compounding shapes only enables you to create holes through extruded objects. Boolean subtraction enables you to
work directly with 3D objects and remove overlapping volumes.

Note: When you perform a Boolean operation, you lose the uv coordinates of the original objects and surface
shading can become much more complex.

Using Boolean operations enables you to quickly produce certain types of complex models. For example, suppose
that you want to create a cylindrical hole through a sphere that originates on the top of the sphere and exits to the
sphere’s left side.

Using normal modeling techniques, this would be nearly impossible, but with Boolean subtraction it’s easy. You could:

1. Extrude a circle along a path defined by a polyline to form an object that looks like a bent pipe.
2. Align the sphere and the cylinder object.
3. Subtract the cylinder object from the sphere.

Before performing a Boolean operation, it is important to verify that the objects are aligned the way that you want
them. You should look at the objects from a variety of viewpoints to verify that their alignment will produce the
intended results. You might also want to check the Properties Palette: Numerical tab to verify the location of particular
vertices in an object.

When you use the Boolean Operation command, Studio automatically performs the last selected Boolean operation
on the selected objects. You use the Properties Palette: Action Modifiers tab to switch between the Union,
Intersection, and Subtraction operations.

If you enable Auto in the Properties palette, you’ll be able to see the results immediately when you switch between
operations.



Joining two objectsw

1. Align and select the objects you want to join.

1.Choose Polymesh menu> Boolean Operation.
Studio automatically performs the last selected Boolean operation.

1. On the Properties Palette: Action Modifiers tab, enable Union.

2. If Auto is not enabled in the Properties palette, click Apply to perform the union.



Creating an object that is the intersection of two objects Vverview (a W

1. Align and select the objects.

1.Choose Polymesh menu> Boolean Operations.
Studio automatically performs the last selected Boolean operation.

1. On the Properties Palette: Action Modifiers tab, enable Intersection.

2. If Auto is not enabled in the Properties palette, click Apply to perform the intersection.



Subtracting one object from another Uvervew (w |

1. Align and select the objects.

1.Choose Polymesh menu> Boolean Operations.
Studio automatically performs the last selected Boolean operation.

1. Enable Auto at the bottom of the Properties palette.
1.When Auto is enabled, you can immediately view the difference between the two subtraction operations.

1. On the Properties Palette: Action Modifiers tab, enable Subtract A from B or Subtract B from A.



Specifying an Object’s Mapping Mode

In some situations, you need to specify the mapping mode for a model to get the results you want. The Mesh Form
modeler provides additional control by allowing you to specify how shaders are mapped to individual objects in a
model.

In addition to the three projection mapping modes supported at the scene level, the Mesh Form modeler supports a
custom mode that allows you to specify uv coordinates for particular vertices.

If you specify mapping modes for individual objects in the Mesh Form modeler, and then specify a projection mapping
mode for the entire model at the scene level, the modes you specified in the Mesh Form modeler are overridden. To
use the settings specified in the Mesh Form modeler, use the Parametric Mapping mode at the scene level.

To change an object’s mapping mode:
1. Select the object.

2. In the Properties Palette: Mapping mode tab, select one of the Mapping Mode icons to choose a mapping mode:
Box/Face, Cylindrical, Spherical or Custom.

3. Specify the mapping options.
1. For box mapping, choose the face you want to map onto.
2.For cylindrical or spherical mapping, choose the orientation of the mapping primitive.

3.For custom mapping, specify the technique to be used to map the uv coordinates to the selected vertex or vertices.



Defining a Custom Mapping Mode for an Object

When you choose Custom mapping mode in the Properties Palette: Mapping mode tab you can specify how uv
coordinates from the shader should be applied to the selected vertex or group of vertices.

There are two options for applying uv coordinates to the selection:

¢ Interpolate sets the u or v value for the selected vertex or vertices using the uv values for the nearest vertices that
are specified.

e Keep Current Value locks the current specified u or v value.

When you enable Wrap, the shader is wrapped around the object from the specified u or v coordinate.

To view the uv coordinates that are set for a particular vertex:
1. Select the vertex and choose Polymesh menu> Shader Mapping.

1.1n the Properties Palette: Mapping mode tab, select Custom.
The current u and v values are displayed in the Specify fields.
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Deformers are a special set of tools that let you easily manipulate objects in ways that would normally require a large
number of arranging and remodeling operations. For example, using the Explode deformer, you can make an object
appear to explode by setting only a few parameters. Without the deformer, you would have to remodel the object
several time to achieve the same effect.

Deformers can also be animated. So you can create complicated animation effects like morphing and dissolves by
simply applying different deformers to your objects.



Applying Deformers 2XSTYEY [l W]

You can access all the Deformer available in Ray Dream from the Deformers tab on the Properties palette. Each
deformer has its own settings but they’re all applied in same way.

To apply a deformer:

1. Select the object or group you want to deform.
2.Open the Object Properties palette by choosing Windows>Properties.

3. Click the Deformers tab.
If the tab is not visible, use the scroll buttons at the top of the palette.

4. Click Select the deformer you wish to apply in the pop-up list of deformers.

5. Select the parameters desired by manipulating the appropriate sliders and checking the relevant radio buttons or
boxes.

6. Click Apply.
The deformation is applied automatically to your object.

Since only one deformer can be selected at any given time, if you want to combine the effects of multiple deformers
(a stretch and a twist for instance) to an object, you will need to stack them up using artificial group hierarchies.

To apply multiple deformers:
1. Applying the first deformer.

2.Put the object in a group by itself using the group button.

3. Apply the second deformer to the new group.
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The Direct Manipulation controls let you adjust the deformers attributes directly on the object. Direct manipulation
controls appear as a set of wires with “handles” at certain points. The handles represent attributes you can change

by dragging.
To display the Direct Manipulation controls on a Deformer:

1. Select an object.
2.Display the Properties:Deformers tab and apply a deformer to the object.
3. Click Auto.

4. Click the Direct Manipulation button.
The deformers control handles will appear in the Perspective window.

Note: Not all deformers have Direct Manipulation controls.



Atomize i S |

The Atomize deformer replaces the surface of the selected object with small balls which are then slightly scrambled
or wiggled.

To set Atomize attributes:

1. Adjust the value of the Completion of Wiggle Effect slider.
The Completion of Wiggle Effect slider controls the amount of movement the balls display as they move. When
animating this deformer, you would set the value of this slider to 0% at the first frame and 100% at the final
frame. A setting of 600% may result in the same position as a setting of 0%.

2. Adjust the value of the Particle Density slider.
This slider controls the number of balls created to cover the surface of the object.

3. Adjust the value of the Particle Size slider.
This slider controls the size of the balls on the object’s surface.



Bend and Twistw

The Bend and Twist deformer bend or twists the surface of an object. This deformer is particularly useful for fine
tuning complex models such as bent compound shapes that are otherwise tricky or impossible to achieve.

The bend and bend axis respectively control the amount and direction of the bend, while the twist, twist start and twist
size define the amount of twist and portion of the object on which the twist is applied.

To directly control the Bend and Twist deformer:

1. Click the Direct Manipulation button.
A bounding box with twelve points appears around the object.

2.Enable a Twist axis button.
These buttons let you select the axis to which the twist will be applied. When you select an axis the bend and
twist controls on the object’s bounding box move to the selected axis.

3.0n the Twist axis, drag one of the corner points clockwise, or counter-clockwise to twist the object.

4.0On the Twist axis, drag one of the middle point up or down to bend the object.
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The Black Hole deformer creates a vortex effect, similar to the way water swirls as it is being sucked down a drain. In
an animation the Black Hole deformer creates a whirling, circular motion that tends to form a cavity or vacuum at the
center of its action.

To set Black Hole attributes:

1. Adjust the value of the Completion of Hole Entrance slider.
The Completion of Hole Entrance slider controls how much an object is distorted as it moves towards the center
of the vacuum. Set this value to 0% at the beginning of an animation, and 100% at the end.

2. Adjust the value of the Winding slider.
This slider controls the rotation as the Black Hole deforms. A negative setting creates a counterclockwise
rotation.

3. Adjust the value of the Spin Speed slider.
The Spin Speed slider controls how fast the object turns as it goes down the vortex

4. Adjust the value of the Suck Down Point Below Object slider.
This slider controls how far below the object the center of gravity is placed. A low setting results in little gravity
pull while a high setting results in a stronger pull.
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The Dissolve deformer reduces the object to triangles or polygons then diminishes the object so that it gradually
fades away or disintegrates. You can use this deformer to create interesting sci-fi effects such as a transporter or a
mummy dissolving before your face in a horror movie.

To set Dissolve attributes:

1. Adjust the value of the Completion slider.
This slider controls how much the object has dissolved. In an animation, set this value to 0% in the first frame
and 100% in the last.

2. Adjust the value of the Size of Pieces slider.
This slider controls the size of the piece the object dissolves into.



Explode XYY /i Rl|

The Explode deformer causes the object to burst apart. Use this deformer to create images with exploding objects.
To set Explode attributes:

1. Adjust the value of the Completion of Explosion slider.
This slider controls how much the object has exploded. In an animation, set this value to 0% in the first frame
and 100% in the last. The pieces gradually fall to the ground as the explosion progresses.

2. Adjust the positions of the controls in the Size of Pieces slider.
This slider controls the range of sizes for the pieces created by the explosion. The slider contains two controls.
The right control sets the size of the largest pieces while the left control sets the size of the smallest pieces.

3. With the left control set to the far left (0%) and the right control set to the far right (100%) you will have the greatest
variety of sizes for the pieces. With the two controls set close together the difference between the largest and
smallest pieces will be less dramatic.

4. Adjust the positions of the controls in the Speed slider.
The Speed slider controls the speed of the pieces as they move away from the original position of the object. The
slider contains two controls. The left control sets the speed for the slowest moving particles while the right control
sets the speed for the fastest moving particles

5. With the left control set to the far left (0%) and the right control set to the far right (100%) you will have the greatest
variety of speed.

6. Adjust the value of the Gravity slider.
The Gravity slider controls how much gravity is applied to the pieces. The higher the setting, the faster the pieces
fall downward.

7. Adjust the value of the Slow Down at End slider.
This slider controls the rate at which the pieces slow down as they get farther from the center of explosion.

8. Adjust the positions of the controls in the Rotational Speed slider.
The Rotational Speed controls the speed at which the pieces rotate as they move away from the original position
of the object. The slider contains two controls. The left control sets the speed for the slowest moving pieces while
the right control sets the speed for the fastest moving pieces

9.Enable the Large Pieces Move Slower checkbox if you want larger pieces move more slowly during the explosion.

10. Enable the Pieces Stop At Bottom checkbox if you want all the pieces stop falling when they reach the bottom of
the original object’s bounding box.

11. Enable the Explode from Top Down checkbox if you want the object to explode starting from the top then working
down to the bottom.



About Formula Deformersw

The formula deformers uses mathematical equations to deform the selected object. You can use the Formula Editor
to input variables, operators and parameters. Formula deforming is a very technical process, for more information on
using formulas see the readme.
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The Punch deformer punches a dent into an object.
To directly control the Punch deformer:

1. Click the Direct Manipulation button.
A square with five points appears in front of the object.

2.Click the Orientation menu and choose an axis.
The punch controls move to the selected axis.

3. Enable the Punch Other Side checkbox to place the dent on the other side of the object.
4.Drag the center point on the square towards the object to increase the strength of the Punch, or away from it to
decrease the strength.

Dragging away from the object may create a bulge instead of a dent.

5. Drag one of the corner handles away from the center of the square to increase the Punch Radius, or towards the
center to decrease the radius.
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Shatter is a very simple, facet-based deformer you can use to simulate object explosions. Since the deformer only
works at the facet/patch level, it will work best on non patch-based, imported objects (DXF imports made of a large
number of polygons for instance).

When applied to objects made with Ray Dream’s Free Form modeler, the shatter will only separate the patches that
make up the surface of the object from each other. This results in a coarse grained shatter effect.

To directly control the Shatter deformer:

1. Click the Direct Manipulation button.
A bounding box with eight points appears around the object.

2.Drag a point on the box away from the object to increase the scale of the shatter, or drag towards the object to
decrease the shatter scale.



Spherical Morphw

The Spherical Morph deformer turns the selected object into a sphere.

To set Spherical Morph attributes:
Adjust the value of the Completion slider.

This slider controls the morphing of the object into a sphere. In an animation, set this value to 0% in the first frame
and 100% in the last frame.
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The Spike deformer adds needle-like pointed spikes to the selected object. Use the Spike deformer to add stubble to
a character’s chin or create a field of grass, blowing in the wind.

To set Spike attributes:

1. Adjust the value of the Spike Density slider.
This slider sets the number of spikes applied to an object.

2. Adjust the value of the Length slider.
The Length slider controls the length of the spikes.

3. Adjust the value of the Radius slider.
This slider lets you set the radius of the spikes.

4. Adjust the value of the Messiness slider.
The Messiness slider controls how wavy the spikes appear. A low setting results in fairly straight spikes while a
high setting results in very wavy spikes.

5. Adjust the value of the Flow slider.
The Flow slider works with Messiness and controls the wiggles of the spikes during animations. The higher the
value, the more the spikes will appear to move.

6. Adjust the value of the Gravity slider.
The Gravity slider controls the strength of gravity on the spikes. The higher the value, the more the spike will
bend downward.

7.Enable the Keep Original Object checkbox if you want to keep the original object while adding the spiked around it.
Disable it to replace the object will spikes.



Stretch ZISTTEW /vl |

The Stretch deformer is particularly suitable for simulating the exaggerated, cartoon-style effects of squash and
stretch motions. A squashed object will seem to bulge; a stretched one will elongate itself while thinning in its middle,
almost like chewing-gum!

The stretch axis indicates the axis along which the stretch/squash will occur. Any percentage value lower than 100%
will cause the object to be compressed and bulge; any value greater than 100% will elongate and thin the object or
group selected.

To directly control the Stretch deformer:

1. Click the Direct Manipulation button.
A bounding box with eight points appears around the object.

2.Select an axis to stretch along.

3.Drag a point on the box away from the object to stretch it, or drag towards the object to squish it.
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The Warp deformer takes the object’s surface points that are farthest from the center of the object and moves them
out farther. At the same time, surface points that are nearest the center of the object move in closer to the center.

Note: The Warp deformer has no effect on spheres.

To set Warp attributes:
Adjust the value of the Warp strength slider.

The Warp Strength slider controls the amount of distortion.

e Anegative setting moves surface points near the center away from the center and surface points far from
the center in toward the center.

e Anpositive setting moves surface points far from the center farther away from the center and points near the
center closer to the center.
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The Wave deformer distorts the object by pulling it along an imaginary wavy sweep path. Use this deformer to
simulate air or water currents.

To directly control the Wave deformer:

1. Click the Direct Manipulation button.
A bounding box with a number of control handles appears around the object.

2.Click the Orientation menu and choose an axis.
The height and phase controls move to the selected axis.

3. Adjust the value of the Number of Wave Cycles slider to set the number of waves applied to the object.

4. Click the Shape menu and choose a shape for your wave.
Planar A: Wave moves along the plane A.
Planar B: Wave moves along the plane B.
Radial: Wave moves from center point outward.
Cylindrical: Wave moves around the outside of the object as if it were in a cylinder.
The direction in which the wave is applied depends on the setting in the Orientation box.

5.Drag one of the corner handles to adjust the height of the wave.
Dragging away from the object increases the wave’s height.

6. Depending on the type wave you selected you can also adjust the phase of the waves in a number of ways:
For Planar A and B waves move the center handles left or right to adjust the phase.
For Radial waves you can move the handles towards or away from the objects center. As you move towards the
middle of the object, its center appears to sink, as you move away, its center bulges up.
For Conical waves you can move the center handles up or down to adjust the phase.



Applying Shaders

Shading is the process of assigning surface properties to your objects. By designing and applying shaders, you can
precisely control the color, texture, and finish on your objects.

3D’s drag and drop interface for applying shaders makes shading easy. You’ll keep a collection of shaders in the
Shaders Browser and simply drop them onto your objects in the Perspective or modeling window.

Using shading, you can assign a variety of surface characteristics to each object in your scene. When 3D renders
your final artwork, these characteristics determine whether an object appears rough or smooth, shiny or dull,
transparent or opaque. Shading allows you to describe which objects are glass and which are wood, metal, stone,
skin, painted or otherwise.



About Shadersw

A shader is a set of surface characteristics. Each shader may contain settings for one or more of the following
attributes: Color, Highlight, Shininess, Bump, Reflection, Transparency, Refraction, and Glow.

Each shader is saved as a document. 3D includes dozens of pre-defined shaders, which are ready to use right out of
the box. In time, you’ll build your own collection by editing existing shaders and creating new ones from scratch.

Note: As you learn how to build your own shaders, you’ll find the pre-defined shaders to be invaluable. Examine
them closely, for they demonstrate techniques you might not immediately discover through experimentation or
reading this chapter.
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Every object has a base shader called the primer, which covers the entire object. By applying a shader to an object’s
primer, you give the complete object its surface characteristics.

The default shader used for new objects is a simple red color.
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Many real-world objects have non-uniform surfaces. Variations on an object’s surface might be as simple as a
painted-on logo, or as complex as an intricate inlaid wood design.

To achieve effects such as these, you can use Ray Dream 3D’s 3D Paint tools. The 3D Paint tools allow you to apply
different shaders to various regions on the surface of an object. These regions, called paint shapes, may take the
form of geometric shapes, or of freely brushed designs.

Once created, paint shapes can be selected, moved along the surface of the object, modified (in shape, size, or
shader content), layered, or deleted.



The Browser Palettew

As you create shaders you want to keep, you’ll save them in the Browser palette: Shaders tab. You can select a

shader in the Browser and apply it to an object. You’ll also use the Browser to create, and open and edit shader
documents.
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The Shader Editor gives you complete control over the appearance of your shaders. You can use the Shader Editor
to edit shaders stored in the Shaders Browser or shaders you’ve applied to objects in your scene.

Each shader channel is on a different tab in the editor. The preview shows you how your shader will appear on the
surface of an object and provides you with immediate feedback when you change shading parameters.

MRelated Topics



Previewing Shadingw

Once you have created or edited a shader, you’ll want to see how it looks when applied to a particular object.

The level of detail you’re able to see in the Perspective window depends on the preview mode you have selected.
The Box and Wireframe modes provide no preview of the shaders in your scene. The standard Preview mode
displays only the average color of an object across its entire surface.



Shading an Entire Objectw

When you create a new object, 3D assigns it a default primer. To shade an entire object, you simply apply a shader to
the object’s primer. There are two ways to do this:

e the drag and drop technique
e the Apply button in the Shaders Browser
To apply a shader to an object’s primer (Drag and Drop):

e Drag a shader from the Shaders Browser onto an object in the Perspective window, or onto an object’s icon in
the Hierarchy window.

To apply a shader to an object’s primer (Apply button):

1. Select one or more objects in the Perspective or Hierarchy window.

2.Select a shader in the Shaders Browser, or use the Eyedropper tool to “grab” the shader from an object in the
Perspective window.

3. Click the Apply button in the Shaders Browser.
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An object’s primer always contains settings in all eight shader channels. Although you can replace some or all of
these settings by applying a shader, you can never completely remove settings from a primer channel.

A shader in the Shaders Browser, however, may have one or more empty channels. By default, Designer ignores
these empty channels when you apply a shader to an object’s primer. It applies only channels that contain settings.
Applying only non-empty channels allows you to selectively change certain shading attributes, while leaving others
intact.

Note: You might keep a catalog of frequently used colors or bump settings in the Shaders Browser, and apply them
to objects via the drag and drop technique.

Sometimes, however, you’d rather completely replace an object’s primer with the shader you’re applying. In this
case, you’ll need to apply all channels, rather than just those that contain settings. Since you want to replace the
primer completely, applying only non-empty channels would have left unwanted settings in the Bump, Reflection, and
Refraction channels. Applying all channels removes these unwanted settings and replaces them with the default
settings.

To replace an object’s primer (apply all channels):

1. Select one or more objects in the Perspective or Hierarchy window.

2.Select a shader in the Browser palette: Shaders tab.

3. You may also use the Eyedropper tool to “grab” the shader from an object in the Perspective window.
4. Pop-up the Apply button in the Browser palette and choose Apply All Channels.

This method applies also to the Apply button on the Current Shader Editor.

If you prefer, you can change the Default Apply Mode so that the Shader Editor applies all channels by default,
instead of non-empty channels only.

1.Choose File> Preferences.
2.Choose Current Shader Editor from the pop-up menu in the Preferences dialog.

3. Set your choice for the Default Apply Mode.



Using 3D Paint

When you want to apply a shader to a limited region on the surface of an object, you’ll use 3D’s 3D Paint tools. The
3D Paint tools allow you to create paint shapes directly on the surface of an object in the Perspective or Modeling
window. A paint shape may be rectangular, elliptical, polygonal, or freely brushed.

Because the 3D Paint tools work with the shaders in the Shaders Browser, you’re not limited to painting with color.
You can load your brush with gold, marble, or concrete and apply not only color, but bump, reflection, transparency,
and the other shading attributes as well.

Once you’ve created paint shapes, you can move them, resize them, layer them, and delete them. You may create
any number of paint shapes on the surface of an object.
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Designer’s 3D Paint tools allow you to paint directly on your 3D objects. Each tool provides visual feedback as you
paint to show you how your paint shape appears on the surface of your object.

The 3D Paint tools work best on objects created in 3D. You can paint on an object imported from another application,
but you may need to change the object’s mapping mode to achieve satisfactory results.

With the exception of the Brush tool, all of the 3D Paint tools work in both the Preview and Better Preview display
modes. In Preview mode, you’ll see only the outlines of your paint shapes, not the shaders they contain. The Brush
tool works only in Better Preview mode.



Using 3D Paint Tools
To use a 3D Paint tool:

1. Select the shader you want to use.

1. Click on a shader in the Shaders Browser, or use the Eyedropper tool to “grab” the shader from another object.

2.Select a 3D Paint tool.
The behavior of each tool is described below.

3. Paint on the surface of an object in the Perspective or Modeling window.

Note: It’s not necessary to select the object.



Rectangle Tool XEYEY [V VWl

Drag to create a rectangle. As you drag, a “rubber band” preview is drawn in real time to show you the boundaries of
the rectangle.

If you’re working in Better Preview mode, the paint shape is shaded when you release the mouse button.

When you draw with the Rectangle tool, your first mouse click positions one corner of your paint shape’s bounding
rectangle, then you drag to position the opposite corner. 3D normally uses the shortest path to connect these
opposite corners—that is, the paint shape will not wrap all the way around the object. If you want the shape to wrap
“the other way” around your object, hold down the Alt key as you drag.
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Drag to create an ellipse. As you drag, a “rubber band” preview is drawn in real time to show you the perimeter of the
ellipse.

When you draw with the Ellipse tool, your first mouse click positions one corner of your paint shape’s bounding
rectangle, then you drag to position the opposite corner. 3D normally uses the shortest path to connect these
opposite corners—that is, the paint shape will not wrap all the way around the object. If you want the shape to wrap
“the other way” around your object, hold down the Alt key as you drag.



About the Polygon Tool XYY [ V|

Click once to position each vertex of your polygonal paint shape. As you position vertices, the line segments
connecting the vertices are drawn. Double-click at the last vertex to automatically close the shape.

Although you can later resize or “stretch” a polygonal paint shape, you won’t be able to re-edit its vertices.



About the Brush Toolw

The Brush tool is the most versatile 3D Paint tool. It allows you to paint free form designs on the surface of an object.
Paint shapes you create with the Brush tool are called “brushed shapes.”

Like other paint shapes, a brushed shape may contain only one shader. If you choose a new shader while painting
with the Brush tool, 3D automatically creates a new brushed shape. You can create any number of brushed shapes
on an object.

Like the other 3D Paint tools, the Brush tool provides real time feedback as you work on the surface of an object.
When you position the Brush tool cursor over an object in the Perspective or Modeling window, a preview outline of
the size, angle and shape of the brush appears on the object.

Because 3D objects can be rendered at any resolution, you rarely need to concern yourself with the resolution of your
final output until it’s time to render your image. Because brushed shapes are pixel-based, however, they are of a
fixed resolution. You can think of the surface of your object as a blank image whose greater dimension (which may be
either its height or its width) has a default resolution of 1,024 pixels.

The resolution of an individual brushed shape depends on how much of the object’s surface it covers. If you plan to
render your final image at high resolution, you may wish to increase the default paint shape size. You can set this
value in the 3D Paint section of the Preferences dialog.
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When you choose the Brush tool, Designer opens the Brush Palette, where you can select a brush and set its
options.

The Paint Brush tool has three brush types:
e The Paint Brush allows you to paint new brushed shapes and add to existing brushed shapes.
e The Eraser modifies an existing brushed shape by “cutting away” from it.

e The Imported Shape Brush lets you import a 2D image to use as a brushed shape. This brush is described in a
separate section below.

To set brush options (Paint Brush or Eraser):

1. Click the icon for the brush type you want: Paint Brush or Eraser.
2.Drag the Size slider to make the brush smaller or larger.

3. Adjust the Advance slider to set the frequency at which the brush shape is drawn along the path of the moving
mouse.
A low Advance setting produces a continuous brush stroke. A high Advance setting produces a discontinuous
brush stroke, giving the impression that the brush has “skipped” across the surface being painted.

4.Drag the Hardness slider to adjust the edge of the brush stroke.
The hardest setting shades at 100% opacity all the way to the edge of the brush. Lighter settings fade out the
shader effect toward the edge of the brush.

5.Drag the Flatness slider to adjust the width of the brush.
Low Flatness produces a round brush. High Flatness produces a narrow brush.

6. Drag the Angle slider to adjust the angle of the Brush.
Note: Use Angle and Flatness together to create a calligraphic effect.
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To paint with the Brush tool:

1. Select the shader you want to use.

2. Select the Brush tool.
The Brush palette appears.

3.Choose a brush and set the brush options.
4. Hold down the mouse button and drag the brush cursor over the surface of an object to apply a brush stroke.

5. Drag again to apply additional brush strokes.
A brushed shape may contain any number of brush strokes, but only one shader.

You can also add to or subtract from an existing paint shape.



Adding to a Brushed Shape
To add to a brushed shape:

1. Use the Paint Shape Selection tool to select a brushed shape.

2.Use the Eyedropper tool to grab the shader from the selected brush shape, or select the same shader from the
Shaders Browser.
Note: When you add to a brushed shape, you must use the same shader.

3. Start your first stroke within the boundary of the selected brushed shape.

4. Continue in this fashion to add brush strokes.

To erase part of a brushed shape:

1. Use the Paint Shape Selection tool to select a brushed shape.
2. Select the Brush tool and choose the eraser from the Brush palette.
3. Drag the eraser across the portions of the brushed shape you wish to remove.

You can convert any other paint shape to a brushed shape, which you may then edit with the brush tool.



Importing a Brushed Shape

The Imported Shape brush allows you to import a 2D image file and use it as a brushed shape. The image you import
creates a brushed shape region that’s then filled with the current shader. When you import a brushed shape from a
2D image file, 3D ignores any color information in the file—only the brightness of each pixel is used to describe the
shape. Therefore, bitmap (1 bit black and white) and 8-bit grayscale images are best suited for use as imported
brushed shapes.

If the image you import is a bitmap, the black regions enable (turn on) the shader, and the white regions disable it. A
bitmap image is an easy way to create intricately patterned, irregular, or non-contiguous paint shapes.

If you use an 8-bit image, the brightness of each pixel determines how the shader in the brushed shape blends with
the primer or the shader of the paint shape below. For each black pixel in the image, the paint shape’s shader is
applied at 100% opacity to the corresponding point on the object. For each white pixel in the image, the shader is not
applied at all. Intermediate shades of gray blend the paint shape’s shader with the shader below.

To import a brushed shape:

1.Using a 2D art program, prepare the image you want to import.

2.Save the image in a convenient folder in one of the formats 3D supports.

3. Select a shader from the Browser.

4. Select the Brush tool.

5.In the Brush palette, select the Imported Shape brush.

6.Drag a marquee across the surface of your object to define the limits of your imported brushed shape.
7.Designer displays a dialog so you can select your 2D image file.

8. Use the file system tools to select and open your image.

3D closes the dialog and maps the image onto the object as a paint shape. Its proportions are determined by the
marquee you have drawn. 3D fills the shape with the current shader. If you’re not happy with the proportions of your
brushed shape, you can resize it to the proportions you desire.



Working With Paint Shapes
Once you’ve created paint shapes, you can move, resize, layer and delete them.

To select a paint shape:

1. Choose the Paint Shape Selection tool.
2. Click on the paint shape you want to edit.

3D shows the paint shape within a bounding rectangle. The rectangle has four handles, one at each corner.

To move a paint shape:
With the Paint Shape Selection tool, drag the shape along the surface of the object.

Note: You may also use the Properties palette: Shaders tab to reposition a paint shape.
To delete a paint shape:

1. Select the shape.
2.Choose Edit> Clear or press the Delete key.

Note: You may also use the Properties palette: Shaders tab to delete a paint shape.

To resize a paint shape:
With the Paint Shape Selection tool, drag one of the corner handles on the shape’s bounding rectangle. Drag toward
the center of the shape to shrink it. Drag outward to stretch it.

Note: You may also use the Properties palette: Shaders tab to resize a paint shape.

To crop a paint shape:
With the Paint Shape tool, drag a corner while holding down the Control key.



Layering

When you create a paint shape on the surface of an object, the paint shape’s shader overrides the shading
characteristics of the object’s primer. Likewise, when several paint shapes overlap, the topmost paint shape’s shader
overrides those below.

There is one important corollary to this rule, however. When a paint shape’s shader has one or more empty channels,
it inherits the settings for these channels from the paint shape immediately below it (or from the primer, if there is no
paint shape below).

For example, if you paint on an object with a bumpy primer, any paint shape you create will also be bumpy unless the
shader you’re painting with specifies different bump settings. To create a smooth paint shape on a bumpy object, you
would use a shader with a constant value in the Bump channel.

The Properties palette: Shading tab allows you to control the opacity of an object’s paint shapes. Unlike a shader’s
Transparency setting, paint shape opacity does not affect an object’s translucence; rather it controls how paint
shapes interact. If a paint shape’s opacity is less than 100%, its shader does not fully override the shaders of the
primer and paint shapes below; rather, the shaders effects are mixed.

To change the layering order of paint shapes:

1. Select one of the shapes you want to re-order.
2.Choose Arrange> Paint Shape Order and pull select To Front or To Back.

Note: You may also use the Properties palette: Shading tab to change layering.



Editing Shading in the Properties Palette

The Shading tab of the Object Properties dialog allows you to edit the position and size of an object’s 3D Paint
shapes with numerical precision. You can also add and delete paint shapes, change layering, specify a paint shape’s
opacity, convert a paint shape from one type to another, remove an object’s primer, and change an object’s mapping
mode.

To display the Properties palette: Shading tab:

1. Select an object.
2.Choose Windows> Properties from the Edit menu.

3. Click the Shading tab.
The Shading tab shows the primer and each applied paint shape (“element”).

To remove an object’s primer:
e Click the Remove button.
Note: If you have not changed an object’s primer since you created the object, this option is not available.

When you apply a primer to an object in the Perspective window, it is applied over the primer of the corresponding
Master object. Removing an object’s primer simply reveals the Master object’s primer.

To change the layering order of an object’s paint shapes:

e Drag the element listings into the order you want.
In a moment, the object preview updates to your changes.

To create a new paint shape:

e Click the Plus icon.
3D creates a new paint shape on the surface of the object. The new shape has the default size, position, and
shader—all of which you can change.

To delete a paint shape:

1. Select a paint shape from the list.

2.Click the Trash icon.



Setting Paint Shape Options
To set paint shape options:

1. Click the plus sign to display the controls for the paint shape element you wish to edit.

2. Adjust the Opacity slider to set a value between zero and 100%.
The opacity of a paint shape is not related to the transparency value you set in the Shader Editor. Whereas a
shader’s transparency setting determines the degree to which light passes through a surface, the opacity setting
simply determines the extent to which a particular paint shape hides or shows the paint shapes below it.

3. Edit the Position (h and v) values to move the shape on the object surface.
The Position values determine the position of the paint shape’s upper left corner on the surface of the object.
The numbers just to the right describe the range of possible values.

4.Edit the Size (Height and Width) values to move the shape on the object surface.
The Size values determine the size of the paint shape’s bounding rectangle. The numbers just to the right
describe the range of possible values

5.If you want to change the paint shape to a different type, choose the type you want from the Shape pop-up menu.

6. Click the Apply button.



3D Paint Preferences

The Preferences dialog includes a panel for 3D Paint options. Most of these let you choose between “higher quality
and “better efficiency.”
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1. Set your refresh option:
Wait for end of stroke to refresh
Refresh as stroke is drawn

2.Enable the Show Transparency/Reflection option if you want this information as you paint. (Not recommended on
slower systems.)

3. Adjust the slider for Paint Brush Shape resolution to set the number of pixels used in a brush shape.
Higher values offer better quality, but are more demanding on the system.

4.Enable the Beep on creation option if you want 3D to alert you when you create a new brush shape.
This might be important if you had intended to extend an existing shape, not create a new one.

5.1In the Advice box, enable the alert dialogs that you want to skip:
Preview mode—3D presents this alert when you try to use the 3D Paint Brush in any mode other than Better
Preview. When you “skip” this alert, 3D switches to Better Preview automatically.
Wrong Layer—3D will beep the first and second time you attempt to manipulate a master layer paint shape while
working on an object instance. The third time, 3D presents this alert, informing you why your attempt fails. When
you “skip” this alert, 3D beeps each time you attempt to manipulate a master layer paint shape while working on
an object instance.

6. Adjust the slider to set Rubber Band Fidelity.
Higher settings create smoother edges on oval paint shapes.
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Most shader content is two-dimensional. Texture maps, for example, are nothing more than 2D images. Many
procedural shader functions—including 3D’s checkers and wires—also produce two-dimensional image data. 3D
uses a process called mapping to apply this 2D shading information to the surface of a 3D object.

3D’s 3D Paint interface allows you to shade objects without worrying about the internal “nuts and bolts” of mapping.
Most of the time, you can simply paint on objects with the 3D Paint tools and let 3D take care of the details.
Occasionally, however, you may find that changing an object’s mapping mode makes it easier for you to achieve the
results you want.

When you change an object’s mapping mode, 3D changes the method it uses to map 2D shapes and images to the
object’s surface. As a result, the 3D Paint tools behave differently on the object. Depending on the shape of your
object and the mapping mode you choose, the difference may be subtle or quite dramatic.

About Parametric Mapping

3D’s default mapping mode is called parametric mapping. Parametric mapping is like applying a decal to an object’s
surface—each pixel in your image maps directly to a specific point on the surface of your object. This straightforward
approach minimizes distortion and loss of image quality. You’ll want to use parametric mapping for most objects you
create in 3D.

Note: Parametric mapping is called “implicit mapping” in Fractal Design Detailer.

About Other Mapping Modes

Because objects imported from other applications contain limited information, surface mapping generally cannot be
used on these objects. When you shade an imported object, you’ll need to choose one of 3D’s projection mapping
modes

e  box/face mapping
e spherical mapping
e cylindrical mapping

In the various projection mapping modes, 3D maps the image onto an invisible primitive—a box, a sphere, or a
cylinder which encloses the object. The image is then projected from the primitive onto the object itself. For the best
results, you should choose the primitive which best resembles the object you are mapping. For example, spherical
mapping would be appropriate for a basketball, and cylindrical mapping would be right for a soup can.

e When you choose box mapping, you can specify which face of the box primitive you want to map onto.

¢ When you choose cylindrical or spherical mapping, you can specify the orientation of the primitive in relation to
the object.
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To change an object’s mapping mode:

1. Select an object
2.Display the Properties palette.
3. Choose the Mapping Mode tab.

4.Use the pop-up to choose a mapping mode—Parametric, Box/Face, Cylindrical or Spherical.
3D displays the options appropriate for the selected mode. (Parametric mapping has no options.)

5. Set your options.
6. Apply your changes.

To set Box/Face options:

1. Click the icon for the mapping you want—Full Box or one of the Single Faces.
Full Box wraps the 2D image onto a box much like you’d wrap a package.
The face mappings project the image on one side of the object. The projection continues through to the other
side of the object.
By default, the image is aligned with the object’s bounding box axes.

2.If you need to, you can change the orientation of the image on the object.

Click the Orientation: Custom radio button.

Enter values in the Yaw, Pitch, Roll fields to change the orientation of the image.
3. Apply your changes.

To set Cylindrical or Spherical options:

1. Click the icon to choose the alignment you want—x, y, or z axis.
2.You may also design your own orientation:
Click the Custom alignment icon.
Enter values in the Yaw, Pitch, Roll fields to change the orientation of the image.

3. Apply your changes.
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If your scene contains several objects based on the same Master object, you can use the Master object to specify a
set of shading characteristics to be shared between all of these objects. You can also assign specific shading
characteristics to each individual object.

For example, you might create a bottle and shade it with a green glass shader in the Modeling window. You could
then duplicate the bottle, so that three copies appear in the scene, and use the 3D Paint tools to apply a unique label
to each copy. Suppose you decided later that you wanted marble, rather than glass bottles. You could reopen the
Master object in the Free Form Modeling window and apply a marble shader, affecting all three bottles while leaving
the individual labels intact.

When you create multiple copies of an object, each copy has two distinct shading layers:
e the Master layer
e the object layer

Any shading you apply to the Master layer affects all copies of the object in the scene. The shading on the object
layer, however, is unique to each copy. The two shading layers may each contain both a primer and paint shapes,
and the two layers need not share the same mapping mode.

Because the object layer is on top of the Master layer, paint shapes on the object layer always appear to be in front of
paint shapes on the Master layer. Moreover, if you apply a primer to the object layer, it obscures the entire Master
layer (both primer and paint shapes).

When you shade an object in the Perspective window, you’re working on its object layer. To work on the Master layer,
you simply shade the Master object in the Modeling window.
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To work on the Master shading layer:

1. Click the Masters tab in the Hierarchy window.
Alist of all the Master objects in the scene appears in the window.

2. Double-click the icon for the Master object you want to shade.
The object is opened for editing in the Modeling window.

3. Shade the Master object in the Modeling window.
You can edit the primer and/or work with the 3D Paint tools there.

4. Click the Done button to return to the Perspective window.
The shading you have applied appears on all copies of the Master object.

To edit the Master shading layer in the Properties palette:

1. Click the Masters tab in the Hierarchy window.
Alist of all the Master objects in the scene appears in the window.

2. Select the Master object whose shading you want to edit.
3. Display the Properties palette: Shading tab.

The Shading tab controls now let you work with the master object shading.



Managing Shaders

The particular shaders used on your objects are saved with the scene file. These shaders will not necessarily appear
in the Browser. The Browser displays only shaders that you’ve saved there.

Don’t overload the Browser with shaders. Each shader thumbnail requires some memory. Too many shaders loaded
into the Browser may impact your performance. It’s a good idea to limit the directories listed at any given time.

You might want to organize your shader directories as logical categories. For example, a list of directories might read
“Wood, Rocks, Plastic, Glass, Marble.”

About External Texture Maps:

If any of the shaders in your shader files contain Texture Map components that reference external image files, you
need to maintain the relative path from the shader files to the image files.

If either the shader files or the image files are moved to a different directory, 3D will prompt you to locate the missing
image files when it loads the shader files into the Browser.



Why Create a Shader?

Shaders can be a powerful way of bringing your 3D objects to life. You can use Ray Dream’s extensive libraries of
shaders to add life to your objects, but there is since there is no limit to the types of objects you can create, you may
need to build a unique shader to suit the objects you create.

Ray Dream’s shader structure makes it possible to create your own custom shaders. Much like mixing, you open
colors on a painter’s easel, the Shader Tree structure of each shader makes lets you create an infinite number of
different textures, colors and surfaces.



The Shader Tree

A shader is a set of surface properties that you can assign to an object or to a paint shape on the surface of an
object. 3D features a modular structure for defining shaders: the shader tree. The shader tree’s modular nature
allows for great flexibility in shader content.

A shader tree contains all of the settings for a single shader. The shader itself is at the root of the tree. Immediately
beneath the root, the tree has eight branches, one for each of the shader channels: Color, Highlight, Shininess,
Bump, Reflection, Transparency, Refraction, and Glow.

To specify shader settings, you add components to the shader tree in one or more of the channels. The components
beneath a particular channel represent that channel’s settings.

Depending on the components you use, the settings in each channel may be simple or complex. The Color channel
might specify either a plain color or a multi-color pattern. Likewise, the Reflection channel might specify uniform or
varying levels of reflectiveness across the surface of an object.

A shader need not contain settings in all eight channels. If you don’t want to define a particular shading attribute, you
can simply leave that channel empty.



Shader Components

There are three types of components: basic components, operators, and functions. Basic components are the
fundamental building blocks of shaders. Colors, values, and texture maps are examples of basic components.

To create more complex and varied shading effects, you can use operators to combine the effects of two basic
components within a shader channel.

e The arithmetic operators (Add, Subtract, and Multiply) combine components mathematically.
e  The versatile Mix operator uses functions to combine components in a variety of ways.

By choosing which function to use, you control how the mix operator combines a pair of components. Ray Dream 3D
ships with several functions, including Cellular, Checkers, Wires, Wood, Spots, Gradient, Psychedelic and Marble.
You can also define your own function with a formula.

When a component such as the Mix operator has branches extending below it, the component and all of the
branches below are referred to as a subshader. Subshaders allow you to create truly complex effects—anywhere you
can place a component on the shader tree, you can place a subshader instead.



Composite Shaders vs. Global Mix Shaders

The shaders in all of the preceding examples are called Composite shaders, because they are simply collections of
individual channel settings. The settings within the different channels combine to determine the shader’s overall
appearance, but settings in one channel have no effect on the settings in the other channels.

Suppose you wanted to create a shader which mixed attributes in all of the shader channels at once. For example,
you might want to create a checkerboard pattern with alternating squares of shiny, reflective gold and rough granite.
To accomplish this with a Composite shader, you would need to apply the same mix function to each channel.
Fortunately, Ray Dream 3D provides another type of tree structure, the Global Mix, which makes it easier to achieve
effects like this.

The top level of a Global Mix shader tree has only one branch, which affects all eight shader channels. The Global
Mix operator always appears on that branch. The Global Mix operator functions identically to the Mix operator, except
that it mixes complete shaders rather than individual shader components. These complete shaders may be
Composite shaders, as in the example above, or other Global Mix shaders. You can achieve some very complex
shading effects by nesting Global Mix shaders.



About Shader Components

You may have received other shader components, in addition to those described here. 3D’s open architecture allows
developers to program their own shader components in the form of plug-ins. These third-party extensions join

seamlessly with 3D’s built-in shading tools. Information on how to develop extensions for 3D is included in Ray
Dream 3D’s Extensions Portfolio.



Color Componentw

The Color component allows you to specify any color. Although you can place the Color component anywhere on the
shader tree, it’s best suited for use in the Color, Highlight, Reflection, Transparency, and Glow channels, which are
designed for color input.

¢ In the Bump channel, the Color component produces no effect because it gives a constant value across the surface
of an object. To create the illusion of bumpiness, the Bump channel requires variation across an object’s surface.

¢ |n a non-color channel—Shininess or Refraction—colors are converted to values. Dark colors convert to low
values, light colors to high values.

When you place the Color component on the shader tree, it appears as a color swatch.
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To set the color:

1. Double-click a color swatch to edit the color.
3D opens the color picker.

2.You can switch between the RGB and CMYK color models using the Model pop-up.

3.Drag the RGB or CMYK sliders to set the color you want.
You can also enter specific values into the text boxes. The valid range for RGB values is from zero to 255. The
valid range for CMYK values is from zero to 100%.

Your choice of a color model is for your convenience only—it has no effect on the content of your final rendered
image. Like other rendering applications, 3D always renders RGB images. You can use an image processing
application to convert rendered images to CMYK for separation.

To use the system color picker:
¢ Click the color wheel in the upper right corner of the RBB/CMYK color picker.

Note: You can use the system color picker as the default. Choose File> Preferences. Choose Shader Editor from the
pop-up. Enable the “Use system color picker” option.



Value Componentw

The Value component allows you to set a value between zero and 100%. You’ll use the Value component frequently
in every channel but the Color channel.

e If you use it by itself, it specifies a constant level for a particular attribute across the surface of an object or paint
shape.

For example, a 30% value in the Transparency channel means that the shader will make an object 30%
transparent.

¢ If you place it beneath the Color channel, its value is converted to a shade of gray. Zero converts to black, 100 to
white.

When you place the Value component on the shader tree, it appears as a slider.



Setting a Value ST [ vl

To set the value:

e Drag the pointer along the Value slider.
The far left side of the slider represents zero, the far right 100. The number to the right of the slider displays the
current value.



Texture Map Component

The Texture Map component allows you to use a 2D image, such as a scanned photograph or paint-type illustration,
in your shader. Used effectively, texture maps can lend your shaders unparalleled realism. Many complex real-world
surfaces are nearly impossible to simulate through other means.

To assist you in creating texture maps, Fractal Design has developed Detailer—a dedicated program for preparing
texture map images. Detailer and 3D work together and help you achieve superior results.



Using Color Images as Texture Maps

Texture maps using color images are extremely useful in the Color channel. You might import an actual product logo
as a texture map and apply it like a decal to a 3D package model. Or to mimic an extremely detailed natural surface,
you could import a small photographic sample of the surface and tile it—duplicate it a specified number of times—to
cover your entire object.

Color texture maps are also appropriate in the Highlight, Reflection, Transparency, and Glow channels. If you use a
color image in a non-color channel, 3D internally converts it to grayscale.

You can use an image of any color depth as a texture map. In most cases, an 8-bit (256 color) image with a custom
color palette provides excellent results, while requiring substantially less memory and disk space than a 32-bit image.
3D cannot use CMYK images as texture maps. If you want to use a CMYK image, you must convert it to RGB before
importing it.



Black & White and Grayscale Images as Texture Maps

You can use a black and white or grayscale texture map in any channel (besides Color) to specify varying levels of a
particular shading attribute. The shade of each pixel in the image determines the level of the attribute for the
corresponding point on the object or paint shape.

If you use a black and white image, each black pixel turns the attribute on—sets it to 100%—while each white pixel
turns the attribute off. An 8-bit grayscale image allows subtler effects, with 256 possible shades for each pixel. For
example, a grayscale blend from white to black in the Transparency channel would make an object or paint shape
fade smoothly from opaque to transparent.

You can also use a black and white or grayscale texture map with the Mix operator, in place of a function.



Storing Maps Internally vs. Externally

By default, 3D saves copies of all texture maps internally. You can also have 3D save only a reference to an external
file.

There are advantages and disadvantages to each option.

e  Storing maps internally avoids organizational hassles, since you don’t need to keep track of any external files.
¢ Internally saved maps greatly increase the size of a file, which can result in slower loading and saving.

e With an external map, you can modify it with another program, and you don’t need to reload the map.

In general, you can store maps internally unless your file contains particularly large texture maps (or many smaller

maps). If you move an externally referenced image on your hard drive, 3D will prompt you to locate the image file the
next time you open your scene file or shader Browser document.



Choosing an Image

When you place a Texture map component on the shader tree, 3D displays the standard Open dialog, prompting you
to choose an image.

To choose an image:
1. Select an image file from the file list in the Open dialog.

2. To specify whether you want a copy of the image saved within your 3D file:
Click the Options button in the Open dialog.
The Texture Map Options dialog will appear.

3.Choose Internal or External.
4.Click OK to close the Options dialog.

5. Click the Open button in the Open dialog, or press Return/Enter.
The texture map controls will appear, showing the image you have chosen.

Depending on the current display setting in the Shader Editor and the location of your Texture map component on the
shader tree, you may not be prompted immediately to choose an image—in this case, a preview sphere appears in
place of the texture map controls. To open the controls and choose an image, simply double-click on the preview
sphere.

A thumbnail preview of the image appears in the upper right corner of the Texture map controls. Immediately to the
left of the preview, 3D displays the image’s dimensions in pixels, and its color depth.



Flipping or Rotating an Image

To flip or rotate images:
e Click the appropriate button to the left of the preview.



Tiling an Image

To tile images:

1. Click the Tile check box to turn tiling on.
3D enables the tiling sliders.

2.Use the sliders to set the number of repetitions in each direction.

3.1f you want 3D to rotate and flip neighboring tiles to maximize continuity, click the Seamlessly check box.
If your image is specifically designed for seamless tiling, you don’t need to enable this option.



Filtering an Image

To filter images:

1. Click the disk icon in the Texture Map controls, and choose Filter... from the pulldown menu which appears.
A dialog listing available Adobe Photoshop™-compatible filters appears.

2.Choose a filter from the dialog and click the OK button, or simply double-click the filter’s name.

If you have Adobe Photoshop-compatible filters on your hard drive, but none appear in the Filters dialog, you need to
use the Preferences dialog to set the location of your third-party plug-ins.



Replacing an Image

To replace images, do one of the following:

e  Click the disk icon in the Texture Map controls, and choose Open from the pulldown menu. The Open dialog
appears, allowing you to choose a different image.

e  Click the disk icon in the Texture Map controls, and choose Import... from the pulldown menu.
A dialog appears, allowing you to choose from any Adobe Photoshop-compatible plug-ins you may have
available. If you have the appropriate plug-in, you can acquire an image from a scanner or a PhotoCD, for
example.

The White Is Invisible check box allows you to achieve a type of masking effect by instructing 3D to ignore any purely
white pixels in the image. For example, you could use this option to place a logo with an irregular shape on the
surface of an object. Simply create a map with a white background and place it in the Color channel; then apply it to
an object using the 3D Paint rectangle tool. Wherever there is a white pixel in the map, the paint shape or primer
below shows through.



Movie Component

If you have installed Ray Dream 3D, you’ll also find a Movie component among your choices. The Movie component
allows you to use any AVI movie within a shader, in the same way that you use a still bitmap image.



About Operators

Operators allow you to create complex shading effects by combining two components or subshaders within a single
shader channel.



The Mix Operator

The Mix operator is 3D’s most versatile shading tool. It can produce a wide variety of results, depending on which
function you choose to mix the two components.

When you place a Mix operator on the shader tree, it appears as a node with three branches below it. The left and
right branches are placeholders for the two components you want to mix. The mixing operator goes on the middle
branch.

For each point on an object or paint shape, the operator generates a value between zero and 100. The Mix operator
uses this value to combine the components on the left and right branches. When the value is closer to zero, more of
the left component is used. When the value is closer to 100, more of the right component is used.

Some functions, like Checkers and Wires, generate a value of zero or 100 for each point. These functions result in
clear divisions between the two components. Other functions, like Wood and Spots, generate a range of values
between zero and 100. These functions result in gradual blends between the components.



The Add (+) Operator

The Add operator sums the values of two components. When you place the Add operator on the shader tree, it
appears as a node with two branches extending below.

The two branches are placeholders for the components you want to combine. For each point on a paint shape or
object, the Add operator sums the values of the two components.



The Subtract (-) Operator
The Subtract operator subtracts the value of the right component from the value of the left component.
You can use the Subtract operator to invert the value of another component. Just place the component you want to

invert in the right branch and a Value component set to 100 in the left branch. Try this technique on a Texture Map if
you need to invert all the colors in an image.



The Multiply (*) Operator

The Multiply operator multiplies the values of the left and right components. The Multiply Operator can be used to tint
a grayscale bitmap by multiplying the bitmap shader by a color shader.



About Functionsw

Functions are used almost exclusively with the Mix operator. They can, however, be used by themselves. A function
generates a value between zero and 100 for each point on an object or paint shape.

e When you place a function on the middle branch of the Mix operator, the operator uses the values generated by
the function to mix the components on the left and right branches. Where the value equals zero, the left
component is used; where the value equals 100, the right component is used. Intermediate values produce a
blending of the two components.

e When you place a function in a channel by itself, it assigns a value directly to each point on the object or paint
shape. In a non-color channel, each value is used “as is.” In any of the channels designed for color input (Color,
Highlight, Reflection, Transparency, or Glow), each value is converted to a shade of gray, with zero translating to
white and 100 to black.
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The Cellular function creates a surface that looks like a network of cells. It can be used effectively in the Color and
Bump channels. You can experiment with it in the other channels for other effects. Cellular is a 3D function

To set Cellular options:
1.Use the Shape menu to select the basic shape of the cells.

2.Drag the Intensity slider to adjust the contrast between the two colors.
The slider ranges from -100% to 100%. Negative settings invert the image.

3.Drag the Scale slider to change the size of the cell shape.
The slider ranges from 1% to 200%.

4.Drag the markers on the Upper and Lower Limits slider to controls the range of values created by the function.
The range determines the balance between the two (light and dark) components. The left marker controls the
lower limit. The right marker controls the upper limit.

5.Enable the Fractal Version option to use fractals instead of more regular shapes for the cells.
Using the Fractal Version can significantly increase the time required to redraw and to render your image.
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The Spots function produces a random pattern of spots. The spots are irregular, more like leopard spots than polka
dots.

Unlike Checkers and Wires, which produce 2D image data, Spots is a 3D function. Applying a 2D function like
Checkers or Wires to an object gives the impression that a 2D image has been wrapped around the object. Applying
a 3D function like Spots creates the illusion that the object has been carved from a solid block of material.

To set Spots options:
1. Adjust the Size slider to control the size of the spots

2. Adjust the Blending slider to control how the spots blend together.
When Blending is set to 0%, the function produces equal numbers of zero-value and 100-value spots, with
gradual blending.
When Blending is set to 50%, the function produces equal numbers of zero-value and 100-value spots, with
abrupt transitions.

3. Click the Shuffle button to randomize the spot pattern.



The Wood Functionw

The Wood function produces a wood grain pattern. It assigns a value of 100 to the veins and a value of zero to the
spaces between the veins. Like Spots, Wood is a 3D function.

To set Wood options:
1. Adjust the Global Scale slider to set the size of the wood grain pattern in relation to the object.

2. Adjust the Vein count slider to set vein spacing.
High values produce dense vein patterns, while low values produce sparse vein patterns.

3. Adjust the Perturbation to control the size of the “waves” in the veins.
4. Adjust the Undulation slider to control the frequency of the waves in the grain.

5. Adjust the Vein Blending slider to determine whether the transitions between veins and spaces are abrupt or
gradual.

6. Use the Direction pop-up menu to set the orientation of the wood grain pattern in relation to the object.
7.Use the Center pull-down menu to set whether the wood grain pattern is taken from the center of the tree, where
the curvature of the veins is quite pronounced, or from a point further from the center, where the curvature is

more gradual. There are three settings to choose from.

8. Click the Shuffle button to randomize the wood grain pattern.



The Marble Functionw

The Marble function produces a marble pattern. It assigns a value of 100 to the veins and a value of zero to the
spaces between the veins. Like Spots and Wood, Marble is a 3D function.

To set Marble options:
1. Adjust the Global Scale slider to set the size of the marble pattern in relation to the object.

2. Adjust the Vein count slider to set vein spacing.
High values produce dense vein patterns, while low values produce sparse vein patterns.

3. Adjust the Perturbation to control the size of the “waves” in the veins.
4. Adjust the Undulation slider to control the frequency of the waves in the pattern.

5. Adjust the Vein Blending slider to determine whether the transitions between veins and spaces are abrupt or
gradual.

6. Use the Direction pop-up menu to set the orientation of the marble pattern in relation to the object.

7.Click the Shuffle button to randomize marble pattern.

Objects shaded with 3D functions like Spots, Wood, and Marble appear to be carved or sculpted from solid blocks of
material, but this appearance is only skin-deep—Ilike all of the objects you create in 3D, these objects are still
“hollow.” To illustrate this point, if you make a marble object partially transparent, you won’t see veins running
through the inside of the object.
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The Checkers function produces a checkerboard pattern. Every point is assigned a value of exactly zero or 100, so
no blending occurs.

To set Checkers options:
1.Drag the “Squares horizontally” slider to set the number of horizontal squares.

2.Drag the “Squares vertically” slider to set the number of vertical squares.
By setting one of the sliders to zero, you get stripes—either horizontal or vertical, depending on which slider is at
zero.



The Wires Functionw

The Wires function produces a grid of lines. Like the Checkers function, Wires assigns a value of either zero or 100 to
each point on an object or paint shape. Specifically, it assigns a value of 100 to the lines of the grid, and a value of
zero to the spaces.

To set Wires options:
1. Drag the “Horizontal count” slider to set the number of lateral wires.

2.Drag the Height slider to set the size of the lateral wires.
The thickness of the horizontal/vertical wires is expressed as a percentage of the height/width of the entire object
or paint shape. You can determine the thickness of a single wire by dividing the percentage by the number of
wires. For example, if ten horizontal wires represent 50% of a paint shape’s height, the thickness of each wire is
5% of the height.

3. Drag the “Vertical count” slider to set the number of longitudinal wires.
4.Drag the Width slider to set the size of the longitudinal wires.

5.Enable the Gray Scale option if you want to smooth the transitions between the spaces and the wires.
This option is especially useful in the Bump channel, where gradual transitions produce more striking results.
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The Psychedelic shader function creates unusual textures, including swirls of color reminiscent of the psychedelic
Pop Art of the 1960s. Psychedelic is a 3D function.

To set Psychedelic options:

1. Adjust the three Interference sliders to control the amount of interference applied to each plane.
The sliders range from -1.00 to 1.00. Each slider controls the stripes applied on the specific plane. A setting of 0
results in no interference on that plane. Using all three planes you can create more interesting design elements.

2.Enable the Use Global Coordinates checkbox to use the Global Coordinates for the Psychedelic function.
By default the function uses the individual Object's coordinate system. The shading is constant as you move and
rotate the object. When Global Coordinates is enabled, the shading remains static in global space when the
object moves. The object behaves as a “window” on the shading. This is like moving your hand through the
dappled shadows under a tree. Instead of shadows, though, the psychedelic shading passes across the moving
object.

3. Drag the Scaling slider to control the size of the design elements.

4. Adjust the Number of Stripes slider to control the number of stripes in each element.

5. Adjust the Density slider to control the density of the pattern.

6. Adjust the Phase slider to set the current position in the psychedelic cycle.
The Phase slider ranges from 0.00 to 1.00. The two extreme settings display the cycle at the same point.

7.Use the Flat preview to see how the shader changes when you adjust the Phase.

Note: Phase settings are particularly useful in animations. Set key events to animate the Phase from zero to one
using the Oscillate: Saw/Loop tweener.



The Gradient Functionw

The Gradient function produces a gradual blend from one color to another. Gradient is useful in the Color and
Transparency channels.

To set Gradient options:
1. Choose Horizontal or Vertical from the Direction menu to set the direction of the blend.

2. Adjust the Turbulence slider to mix up the colors as they change.
A low setting results in a uniform blend. A high setting increases irregularity in the blend.



The Formula Functionw

The Formula function lets you design a mixing function with a mathematical formula.



Using Other Components as Functions

You can actually use any component as a function in the Mix operator. This allows you to mix components in ways
not supported by 3D’s basic functions. When you use a component as a function, 3D automatically converts its
output to values so that the Mix operator can use it to mix the components on the left and right branches.

Value and Texture map components are especially useful in place of functions.

¢ You can use a Value component to blend the components on the left and right branches of the Mix operator in a
given ratio. A value of 50 blends the two components evenly. Lower values favor the left component, while higher
values favor the right component.

¢ You can use a black and white or grayscale texture map to mix the left and right components in a custom pattern.

For each white pixel in the image, the Mix operator uses the left component. For each black pixel, the Mix
operator uses the right component. Intermediate shades produce a blending of the two components.



The Color Shader Channel

No shader channel has a more obvious effect on the appearance of an object or paint shape than the Color channel.
Depending on the components you place beneath the Color channel, you can specify anything from a plain color to a
complex, multi-color pattern.

¢ To specify a plain color, simply place a Color component.

¢ To specify a multi-color pattern, use a Texture Map component or combine colors with the Mix operator.

If you find that your single-color objects look unrealistic, try using the Mix operator with the Spots function to create
minute color variations. Simply mix two slightly different hues in a pattern of tiny spots, with Blending set to zero for
smooth blends. When viewed from a distance, these subtle color variations can give an object a more realistic
appearance.

The default content of the Color channel is a Color component, set to a shade of red. 3D assigns the default content
of each channel, as part of the default primer, to each new object you create. The default content is also used to
calculate the preview of a shader in the Shader Editor, when a particular channel is empty.



Highlight and Shininess

Most objects in the real world show highlights when illuminated. These bright spots or streaks are direct reflections of
light sources, like the sun glinting off a chrome bumper. Metallic objects have small, bright highlights. Plastics have
dim, but large highlights. And stones usually have no highlights, unless polished. You can control the color, intensity
and size of an object’s highlights by placing shader components beneath the Highlight and Shininess channels.

e The Highlight channel controls highlight intensity.
In the Highlight channel, a high value produces bright highlights, while a low value produces dim highlights.

e  The Shininess channel controls highlight size.
In the Shininess channel, a high value produces small highlights, while a low value produces large highlights.

Note: Typically, highlights that are extremely bright are very small, while those that are softer spread larger.

By default, highlights are white. You can specify color highlights by placing a Color component (or any component
that produces color information) in the Highlight channel. Color has no effect on the Shininess channel; any color
information in the Shininess channel is internally converted to values.

The default content of both the Highlight channel and the Shininess channel is a Value component, set to a value of
50. If you want varying levels of highlight or shininess across the surface of an object or paint shape, you can use a
texture map or a function.



Bump

Bumpy and rough surfaces are difficult to model geometrically. Imagine modeling the irregularities of the skin of an
orange, point after point—the task would quickly become a nightmare. Fortunately, 3D allows you to use a shader to
simulate variations on the surface of an object.

By placing shader components in the Bump channel, you can “perturb” a smooth surface to produce irregularities.
This technique is known as bump mapping. Bump mapping can produce subtle effects like the bumps and pits on the
surface of an orange, or more pronounced effects like the seams on a baseball.

Bump mapping does not change the actual topography of an object—no points are displaced. Rather, it changes the
angle at which light rays reflect off the surface at certain points. This technique tricks the eye into perceiving texture.
Because the bumpiness is just an illusion created by the renderer, the edge of the object remains smooth. In most
cases, this is not a problem. However, if you require true surface variations to appear on the silhouette of your object,
you’ll need to create them in the modeler.

To simulate bumps, the components you place beneath the Bump channel must specify some variation in the colors
or values of adjacent pixels. Consequently, placing a simple color or value in the Bump channel does not produce
bumping.

Texture maps and functions produce the best results in the bump channel. Like the other non-color channels, the
Bump channel always converts color information to grayscale.

When you use a grayscale image in the Bump channel, lighter areas appear to be raised, while darker areas appear
to be lowered. When you use a function that produces values, areas with higher values appear to be raised, while
areas with lower values appear to be lowered.

¢ For the most convincing results, you should create a smooth blend between extreme values like black and white or
zero and 100.

If a grayscale image with hard edges between black and white does not produce a satisfactory bump effect, try
applying a blur effect to the image in an image-editing application.

¢ The relative height or “steepness” of the bumps depends on how rapidly you blend between extreme values. A
blend that occurs over the range of many pixels produces shallow, gradual bumping. A blend that occurs over the
range of a few pixels produces steeper, more sudden bumping.

The default content of the Bump channel is a Value component, set to a value of zero. This produces no bumping,
since there is no variation from pixel to pixel.



Reflection

Many real-world surfaces are at least somewhat reflective. Most types of metal and glass are partially reflective. A
mirror is so reflective that it takes nearly all of its color from the environment around it. 3D allows you to specify
reflectiveness by placing shader components beneath the Reflection channel.

Although a Value component works fine in the Reflection channel, both subtler and more fantastic effects can be
achieved by using a Color component instead. To make a highly reflective object appear more vivid (less washed
out), use a variation of the same color you have in the Color channel (if the object’s color is particularly bright, you
may want to use a darker tint of the same color). To give reflections an unusual tint, try using a color that is markedly
different from the one in the Color channel.

¢ When you use color data (a Color component, a Texture Map component, or a complex subshader) in the
Reflection channel, its hue affects the tint of the reflection and its brightness determines the amount of reflection.
Darker colors produce less reflection; brighter colors produce more.

¢ Using values in the Reflection channel produces the same effect as using shades of gray. Only the amount of
reflection is affected.

Of course, if you want varying levels and tints of reflection across the surface of an object or paint shape, you can use
a texture map or a function.

The default content of the Reflection channel is a Value component, set to a value of zero.



Transparency

When light strikes an opaque surface, it simply bounces off. When it strikes a semi-transparent surface, some light
bounces off, but some passes through. As a result, you can see through a semi-transparent object. Glass, water, and
clear plastic are examples of semi-transparent materials.

You can specify transparency by placing shader components beneath the Transparency channel. While a Value
component is perfectly appropriate in the Transparency channel, a Color component provides a much broader range
of possible effects. Objects made of colored glass tend to look more realistic if you use a similar color in both the
Color and Transparency channels (if the object’s color is bright, you may want to use a darker tint in the
Transparency channel).

Try using a function or a black and white texture map in the Transparency channel to create a shader which makes
transparent “holes” in an object. For example, placing the Wires function in the Transparency channel creates a
wireframe effect.

¢ When you use color data (a Color component, a Texture Map component, or a complex subshader) in the
Transparency channel, its hue affects the appearance of colors viewed through the transparent shader. Its
brightness determines how transparent the shader is. Darker colors produce less transparency; brighter colors
produce more.

¢ Using values in the Transparency channel produces the same effect as using shades of gray. Only the amount of
transparency is affected.

¢ A 100% transparent surface may not be completely invisible—depending on the settings in the other channels, it
may still refract and show highlights.

The default content of the Transparency channel is a Value component, set to a value of zero.



Refraction

When light rays pass through a semi-transparent object, their trajectories are deflected. This phenomenon is known
as refraction. Glass, fluids, and other translucent materials refract light to some degree. This results in a distorted
view of objects behind the refractive surface.

Note: The setting in the Refraction channel only affects a shader with some degree of transparency. Light must pass
through in order to be refracted.

e  Shaders simulating glass should have Refraction values around 20.
e  Shaders simulating water or ice should have values that are somewhat lower.

Try experimenting with different values until you achieve the effect you want. The default content of the Refraction
channel is a Value component, set to a value of zero. A single Value component is generally all you’ll need to place in
the Refraction channel.

Color has no effect on the Refraction channel. Any color information in the Refraction channel is internally converted
to values.



Glow

The settings in a shader’s Glow channel determine the shader’s luminance. An object whose shader has a high
degree of luminance will appear bright, even if it is not lit by ambient light or external light sources. Objects with
glowing shaders do not cast light on other objects in the scene.

Glowing shaders can be used to simulate things like neon tubing, lit windows in a cityscape at night, or the LED
display of a digital clock. They can also be used for the subtler purpose of brightening a particular object in a dimly lit
scene. This allows you to emphasize an object without affecting the lighting and mood of your entire scene.

Although a Value component can be used in the Glow channel, a Color or Texture Map component is more
appropriate. For realistic results, try using similar colors in the Color and Glow channels.

To create unusual effects, you can place markedly different colors in these two channels. For example, you might
create a shader which appears green when well lit, but glows red when covered in shadow.

When you use color data (a Color component, a Texture Map, or a complex subshader) in the Glow channel, its hue
determines the color of the glow, and its brightness determines the intensity.
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Most of the work in building and modifying a shader takes place in the Current Shader Editor. The Browser palette:
Shaders tab and shader document windows are also useful.

The Current Shader Editor is a palette that provides all of the tools for customizing a shader. You can use the Current
Shader Editor to design a new shader, modify a shader you’ve stored in the Shaders Browser, or edit a shader
you’ve applied to an object or paint shape.



Displaying the Current Shader Editor 22X ™ (Vi Nl

To display the current shader editor:

e Choose Windows> Current Shader Editor.
The contents of the Shader Editor depend on what type of shader you’re editing: a Composite shader or a Global
Mix shader.

Because a Composite shader’s tree can be quite complex, the Shader Editor does not display the entire tree at once.
At any given time, you’ll work with only the portion of the tree beneath a single shader channel. You can use the eight
channel tabs to move from one channel to another.

The preview in the upper left corner of the Shader Editor shows you what the shader you are editing looks like. Each
time you change the shader tree, 3D updates the preview to show how your change affects the shader.

You can choose a spherical preview, which shows you how your shader will look on the surface of an object, or a flat
preview, which gives you an undistorted view of 2D image data like texture maps.

To switch between spherical and flat preview:

e  Choose Current Shader Editor: View menu> Sphere Preview or Flat Preview.
This change affects only the preview of the shader you are currently editing.

To switch between shader channels:

e Click the channel tab for the channel you want to edit.
The Shader Editor displays the branch of the tree beneath the channel you have chosen.

Note: The top level of a Global Mix shader’s tree is fixed—it always contains a Global Mix component with three
branches. The middle branch contains the mixing function, and the left and right branches contain the subshaders
being mixed. Because all eight channels of the subshaders are mixed with the same function, no channel tabs appear
in the Shader Editor when you are editing the top level of a Global Mix shader.



Designing a New Shader Vverview (a W

To design a shader:
1.Choose Windows> Current Shader Editor.

2.Use the Shader Editor tools and features to design the shader.
3.Choose a tab, select a place holder, and add a component from the Insert menu.
You may also drag a shader from the browser into an appropriate place holder in the Shader Editor, where it

becomes a subshader. You may also open a shader document from the Browser and drag its components or
subshaders into the Shader Editor.

Note: If you drop a shader or subshader onto a place holder where its type is inappropriate, 3D will alert you. For
example, you can’t put a Global Mix shader where a simple component is required.

4.When you’re finished designing, either apply your new shader to an object or add it to the Browser.



Adding the Current Shader to the Browser 2SI EY i V|

To add a shader to the Browser:

1. Drag the shader preview from the Current Shader Editor to the Browser palette.
You must drop the shader under a directory column. 3D prompts you to name the new shader.

2.Enter a name and click OK.
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In the Browser, shaders are saved as documents.

To open a shader:

1. Double-click on the shader you want to edit.
3D opens it in a shader document window.

Note: If you don’t see the shader document window right away, it might be hidden under one of the floating
palettes—the Current Shader Editor or Browser palette.

2.Edit the shader by adjusting sliders and other settings.
You may also drag and drop components or subshaders from the Current Shader Editor or other open shader
documents.

3. You can apply the modified shader to a selected object by clicking the Apply button.

4.You can move the contents of the document to the Current Shader editor by clicking the Use button.

To save the modifications to the shader:
1.Make sure the shader document is the active window.
2.Choose File: Save.

3D saves the changes into the Browser document file.

To save the shader under a different name:
1. Drag the preview into the Browser.

2.Enter a new name.

3. Close the shader document window when you’re done.



Editing an Object’s Primer or a Paint Shape’s Shader Vverview (a W

To edit a shader:
1. Choose the Paint Shape Selection tool.

2.Display the Current Shader Editor palette.
3. Click an object to edit its primer—make sure you click an area where there are no paint shapes.

4. Click on a paint shape to edit its shader.
If the Shader Editor isn’t already open, double-click an object or paint shape to open the shader in the editor.

5. Edit the shader tree by adding, removing, and modifying shader components.

6. When you are satisfied with the changes you’ve made, click the Apply button in the Shader Editor.



Navigating the Shader Tree LYSTYISW fiir "NN|

A complex shader tree has many levels. Each time the tree branches, a new level is added. When you are working
with a Composite shader, you can choose to view just one level at a time, or you can expand the tree to show all of
the levels beneath a particular channel.

Viewing all levels requires more space on your screen, but eliminates the need to jump from one level to another to
edit components.



Choosing a display mode SXETYEY Vi V|

To choose a display mode:
Choose Current Shader Editor palette: View menu> One level or All levels.

The All levels display option does not apply to Global Mix shaders. If you want to edit the subshaders on the left and
right branches, you need to “jump into” them. When you jump into the left or right subshader of a Global Mix shader,
the channel tabs appear, giving you access to the settings in each of the subshader’s channels.



Jumping Into and Out of a Subshader XS EY (/i 7Nl

To jump into a subshader:
¢ Double-click the preview of the subshader.

¢ Click on the preview to select it, then choose Current Shader Editor palette: View menu> Next Level.

To jump out of a subshader:
e Choose Current Shader Editor palette: View menu> Previous Level.

¢ The tiny arrow in the lower right corner of the Shader Editor’s main preview indicates a pop-up. Press on it and
choose any higher level.



Editing the Shader Tree

You’ll build a shader by placing components and subshaders on the branches of the shader tree. To edit a shader
tree, you simply add, remove, and replace shader components.

3D’s drag and drop interface pertains not only to applying shaders, but also to building them. You can drag a
component or subshader from one branch of the shader tree to another. You can also drop a shader from the
Shaders Browser onto a branch of the shader tree, or drag a subshader from the tree into the Browser for storage.



Specifying a Shader Type

To specify a shader type:

e Choose Composite or Global Mix from the Shader Editor’s Component menu.
This replaces the current contents of the Editor with an empty Composite or Global Mix shader tree.

To place a shader component or subshader on the shader tree:

1. Display the shader channel tab where you want to work.

2.Click on the branch (component or place holder) you want to select.
3D outlines the selected branch in gray. The root of the channel is automatically selected.
If the component you select is the root of a subshader, the entire subshader is selected.

3. Choose the component you want to add from the Current Shader Editor palette: Components menu.

Note: When you add a simple component to the left or right subshader branch of a Global Mix shader, it is placed in
the Color channel of the subshader. To edit its settings, you need to jump into the subshader.



Moving Components by Dragging
Drag a subshaders or component onto the branch of the shader tree where you want it.
¢ You can drag a shader from the Browser.

¢ You can drag a component or subshader from an open shader Browser document. This has the advantage of
bringing all of its parameters with it.

3D copies the component or subshader you drag onto the branch where you drop it, replacing any contents that may
have been there before.

When you drop a shader onto any branch of a Composite shader, only the contents of the applicable channel are
placed on the branch. If the shader you’re dropping has no components in the applicable channel, 3D will notify you,
and nothing will be added to the branch.

Note: When you drop a shader onto the left or right branch of a Global Mix shader, the entire shader you’re dropping
(all eight channels) is placed on the tree.



Removing the Contents of a Branch

To remove a branch or its contents:
1. Select a component or subshader.

2.Choose Clear from the Edit menu, or press the Delete key.
If the component you remove is the root of a subshader, 3D removes the entire subshader.



Copying a Component to Another Channel

e Drag a component from its branch and drop it onto any channel tab.
3D replaces the entire contents of the channel with the component you drop.



Copying a Subshader to Another Channel

e Drag a subshader from its branch and drop it onto any channel tab.
3D replaces the entire contents of the channel with the subshader you drop.



About the Workspace (The Universe)
Ray Dream Studio 5’s three-dimensional workspace is called the universe. The universe is where all objects are

displayed, assembled and manipulated. By default, Ray Dream Studio opens new scenes with one light and one
camera in the universe. This camera provides the view of the scene universe shown in the Perspective window.

Ray Dream Studio uses a coordinate system called the Cartesian coordinate system to reference positions in the
universe. A triplet of unique coordinates (x, y, z) is associated with each individual position in the universe.

The maximum volume of the universe is a 3.32 kilometer cube. On the other end of the scale, the minimum
dimension of an object is 0.006 millimeters. You can specify your object sizes in the measurement unit of your choice
as long as they stay within that range. In a practical sense, only the region of the universe where objects exist is part
of your scene.

The grids displayed in the Perspective window describe faces of a cube called the working box. The working box is
a visual reference of the global universe and a tool to help you manipulate objects.



Selecting an Arranging Tool

The Arranging tools let you perform every basic operation (alignment, orientation, positioning) by dragging in the
Perspective window. These tools are located in the upper or left-most part of the toolbar.

To select a tool:

To select a tool, click its icon or use press its keyboard shortcut.
The mouse pointer takes on a distinctive cursor shape that depends upon the tool chosen.

e  Selection Tool (Shift-T)—Use the Selection tool to select, move or resize 3D objects, 2D projections and groups
of objects. Double-click on an object to open it in the modeling window. Double-click on a group to jump into it.

e Virtual Trackball Tool (Shift-V)}—Use the Virtual Trackball tool to orient selected objects in 3D space.

¢ Rotation Tool (Shift-Q)—Use the Rotation tool to rotate an object in 2D along one of the working box planes.



Using the Viewing Tools
The viewing tools let you change scale and navigate the display, which helps when arranging objects.

Magnifying Glass
Use the Magnifying Glass to magnify the view in the Perspective window.

1.You can press Ctrl+Spacebar to temporarily choose the Magnifying Glass.

2.When you release the keys, the previous tool returns.

Note: The Magnifying Glass and Zoom pop-up only enlarge the view displayed in the Perspective window. They do
not move the camera that provides the view of the scene.

To zoom in and out:
1. Click once to magnify the window’s view by a factor of two.

2.Hold down the Alt key and click to zoom back out.

To magnify a specific area of the scene:

e Drag a marquee around it. Ray Dream Studio magnifies the selected area to the closest corresponding zoom
level.

To set a specific magnification:
e Use the Zoom Level pop-up, located in the bottom left corner of the window, to choose a magnification level.

Hand Tool
Use the Hand tool to pan around the window. Drag the area you want into view.

1.You can press the Spacebar to temporarily choose the Hand tool.
2.When you release the Spacebar, the previous tool returns.

Alternatively, you may use the window scroll bars to pan the view.

The Working Box

The working box appears in the Perspective window as three intersecting grids, like three sides of a box. These grids
are a visual reference for the dimensions of the universe.

When you open a new scene, the “floor” might be the only plane visible. You can change display of the working box
to show none, one, two or all three of its grid planes.

The working box planes show projections (like shadows) for the objects in the scene. These projections help you see
which objects are “farther away,” “higher” or “tilted,” and help you move the objects into the positions and orientation
you want.

By default, the working box is centered on the origin (0, 0, O of the universe) and aligned with the axes of the
universe. The lines where the grid planes meet show the x, y and z dimensions of the universe. The working box is
moveable, though, so you can set it at different angles and move it away from the origin. A number of useful
operations require you to move the working box into position first.

If you like, you can think of the working box as a three-dimensional ruler that helps you bring objects together more
easily and accurately.



Changing Display of the Grid Planes
By default, only one of the grid planes is visible when you first launch the program. You can customize the display of
the working box to display any, all, or none of the grid planes for all sessions by setting the Plane Display button.

The Plane Display button is the only tool in the Planes toolbar. It has four active areas: the three planes and the
object preview.

To display or hide a working box plane:
e Click on the plane you want to show or hide to toggle it on or off.
Shaded planes are displayed; white ones aren’t.

The object preview, represented by the cube at the center of the Plane Display button, allows you to toggle display of
the object preview.



About the Active Plane

The active plane is the plane of reference used when dragging objects in the Perspective window and for other
positioning operations. The working box shows the active plane in a different color from the other two. The Plane
Display button identifies the active plane by displaying it in blue.

You can set the active plane to control your next series of operations.

To change the active plane:
¢ Hold down the Alt key and click on the plane you want active in the Plane Display button.



Changing Grid Options and Color XYSIYIEW [/ V|

The working box’s grid can be used for estimating real world size, or positioning objects.

To set grid options:

1.Choose View menu> Grid, or press Ctrl+J.
The Grid Settings dialog appears.

2.Enter a Spacing amount to set the grid increment.
You can type in a value or click the increment/decrement buttons. You can also drag the increment button up or
drag the decrement button down to move quickly to a new value. The Spacing increment is used for “nudging”
(moving an object with an Arrow key).

3.Choose a unit from the pop-up.
The unit you choose should make sense for the scene you are building. For example, if you’re creating a
building, one foot or meter should provide enough accuracy for most operations.

4.Change the Draw Line Every value to control how many grid lines are drawn.
The value sets the number of increments between grid lines. When the setting is 1, the increment and displayed
grid correspond directly.

5.Set the Draw a Line Every option to a value >1 if you want fine control over the Snap to Grid function but do not
want many grid lines visible.

6. If you want to hide the grid lines, disable Show Grid.
When Show Grid is disabled, only the edges of the planes are shown.

Note: Even if the Show Grid option is not selected, object hot points will snap to the grid if Snap to Grid is
selected.

7.Enable Snap to Grid if you want objects to “jump” to the nearest grid increment when you drag them.

Note: The hot point of the object, not the edge of the projection, snaps to the grid.
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To change Working Box properties:
1. Choose the Selection tool.

2.Choose Windows menu> Properties.
The Properties palette appears.

3. Hold down the Ctrl key and click on the working box grid.
The Properties palette updates to show the working box properties. The General tab contains controls for the
plane display colors and grid options. The Transform tab contains controls for working box size, orientation, and
position in the universe.

You can set your preference for the size and colors of the working box in new documents in the File menu>
Preferences dialog: Perspective and Colors panels.



Using the Working Box LYSTYEW [ "W|

It is possible to move and orient an object anywhere in the universe without making any adjustment to the working
box. However, using the working box can simplify many types of arrangement operations.

You can set the attitude of the working box for a particular arrangement operation, or set of operations. For example,
to make orienting objects on an angle easier, you can reset the angle of the working box, then “slide” an object down
the slope of the active plane. This is just one example. You’ll find a number of ways to take advantage of the working
box.

After each operation, you’ll need to move or re-orient the working box for the next task.



Moving the Working Box LYSTYEW [ "W|

There are several ways to orient the working box:
e Rotate it with the Virtual Trackball
e Send it to another coordinate system

e Setits attitude numerically

Note: Changing the working box does not affect your existing objects. The orientation of the working box applies only
to subsequent arrangement operations.

To move the Working Box:

1. Choose the Selection tool.

2.Hold down the Ctrl key and drag the working box.



Resizing the Working Box Vverview (a W

To resize the Working Box:
1. Choose the Selection tool.

2.Hold down the Ctrl key and drag a corner of one of the grid planes.



Orienting the Working Box with the Virtual Trackball X200 i TNl

To orient the Working Box:
1. Choose the Virtual Trackball tool.

2.Hold down the Ctrl key and drag on the working box grid.
The working box revolves about its center as you drag.
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To position the Working Box:
1. Choose the Selection tool.

2.Hold down the Ctrl key and click the working box to select it.
“Handles” appear at the working box corners when it is selected.

3. Choose Windows menu> Properties.

4.Choose Properties palette: Transform tab.
The transform properties include Position, Orientation and Size controls.

5. Choose the coordinate system you want from the System pop-up.
In most cases, you’ll move the working box in relation to the global universe.

6. Use the Position controls to set the Center x, y, z position values for the center of the working box.
7.Use the Orientation controls to set the yaw, pitch, and roll values to orient the working box.
8.Use the Size (Scaling) controls to change the dimensions of the working box.

9. Click Apply to make the changes.
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To align the Working Box:
1. Select an object or group.

2.Choose Arrange menu> Align Working Box.

Ray Dream Studio sets the working box planes parallel to the sides of the selected object or group bounding box .
The coordinate systems of the working box and object (or group) are now aligned.

The bounding box is the smallest box that encloses an object or group of objects. Bounding boxes appear around
objects that are selected.
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To align the Working Box:
1.Hold down the Ctrl key and click the working box to select it.

2.Choose Arrange menu> Align> On Gravity.
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You can send the Working Box to a particular position. The position may be determined by the Global Universe or an
Object/Group bounding box.

To send the Working Box to a particular position:
1. 1f you want to send the working box to an object or group, select that object or group.

2.Choose Arrange menu> Send Working Box To> and select the position you want: Global Universe, Local Universe,
or Selection—if you have one.

e  Global Universe—The Working Box moves to align its origin with the origin of the global universe.

e Local Universe—This option is available only when “Jumped Into” a group. The Working Box moves to align
its origin with the center of the group bounding box.

e  Selection—This option is available only when an object or group is selected. The Working Box moves to
align its origin with the center of the object or group bounding box.

In all cases, the working box is resized to a scale appropriate to the new position.
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Objects are shown in the Perspective window by a preview. The display is called a preview because the level of detail
is below that of the final rendering.

In all preview modes, objects create projections on the working box planes. And selected objects display their
bounding boxes.



Setting Preview Detail for the Perspective Window Lrervew (.

Choose View menu> and select the preview mode you want.
You may also click on the standard toolbar icon for the preview quality you want.

* No Preview does not show the objects themselves; however, their bounding box projections still appear on the
working box planes. There is no toolbar icon for No Preview.

e Bounding Box displays only the bounding boxes for the objects.
e  Wireframe displays objects as a mesh of wires.

e Preview displays objects with colored surfaces. Only the outlines of painted shapes are shown. The lighting is
arbitrary.

e Shaded Preview displays objects using scene lighting to shade it and show its 3D shape. This display mode uses
lower resolution textures and a faster shading method than Better preview. Shaded Preview is the only display
mode that uses QuickDraw 3D or Direct3D acceleration.

e  Better Preview displays objects using ambient light and your specific light sources to show color, highlights, gel
effects, and depth shading. Displays shading, texture maps, and paint regions, in detail. Provides better details of
the shape and color of objects.

Using Better Preview increases the time required to calculate and draw or redraw the Perspective window. To
increase the efficiency of the application, work in Wireframe, Preview or Bounding Box mode at the outset of a
project, then switch to Better Preview mode only as specific shading detail becomes more important. Use the Render
Area tool whenever possible instead of switching to Better Preview.



Hiding an Object

To hide objects:
1. Select the object.

2.Choose View menu> Object Visible/Object Invisible.



About Bounding Boxes and Projections

The bounding box is the smallest box that encloses an object or group of objects. Bounding boxes appear around
objects that are selected.

The bounding boxes of all objects, including cameras and spot lights, cast 2D profiles, called projections, on the
planes of the working box. These projections show the object’s position and orientation in relation to each of the three
planes. You can drag the projection to manipulate the object with respect to that plane.

Objects may be collected to form a group. All of the positioning, scale and orientation features available for objects
apply equally to groups.



Naming Objects

New objects are named by default Type n, where Type is the object description (Free Form, Sphere, Text, etc...) and
n is the number of similar objects in the order created—Free Form 1, Free Form 2 and so forth.

You can change the name of objects and groups. Giving objects and groups descriptive names can make them
easier to locate and select.

To change the name of an object or group:
1. Select the object or group.

2.Choose Windows menu> Properties.
The Properties palette appears.

3. Click the General tab.

4.Enter a new, descriptive name.

Note: You may also select an object’s listing in the hierarchy and press Return/Enter to change the name.
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You’ll select one or more objects before choosing a command.

A selected object displays its bounding box, the 2D projections have handles at the corners, and its item in the
hierarchy is highlighted.

Ray Dream Studio 5 provides several ways to select objects:

¢ By using the Selection tool in the Perspective window to click on the object preview or one of the projections.
e By clicking an item or dragging a marquee over one or several items in the hierarchy.

¢ With the Find command.



Selecting Objects with the Selection Tool LYETYEW [ "N|

To select objects:
1. Click the Selection tool.

2.In the Perspective window, click on the preview or on one of the projections for the object you want to select.

3. Hold down the Shift key and click other objects to add to the selection.
Shift-click an object that’s already selected to subtract it from the selection.

4.1f a number of objects overlap, position the cursor over the object (preview or projection) and hold the mouse
button down.
A pop-up appears, listing all of the objects beneath the cursor at that point. Select the object you want.

5. Choose the object name followed by XY, ZX or YZ for a 2D projection or 3D, for a 3D object.

6. To select the object’s Hot Point, choose the item containing the object’s name followed by HP.



Selecting Objects in the Hierarchy Lvervew w |

To select objects:
e Click the object’s icon in the hierarchy.

e You may also drag a marquee around the objects, if you want to select several.

Hold down the Shift key and click other objects (or drag another marquee) to add to the selection. Shift-drag over
items that are already selected to subtract them from the selection.



Finding and Selecting an Objectw

To find and select objects:

1.Choose Edit menu> Find.
The Find dialog appears.

2. Enter the name of the object to locate.
You may enter a portion of the name.

3. Click the radio button for the appropriate matching method—Is, Contains, Starts with, or Ends with.

4. Click Find to begin the search.
Ray Dream Studio selects the first object that matches the search criteria.

5. Click Find again to select the next object that matches the search criteria.



Arranging Objects

Arranging is the process of positioning and orienting objects. The most significant part of an object’s arrangement is
its spatial relationship to other objects. In most cases, the absolute arrangement (in relation to the Global Universe) is
relevant only to the extent of what seems “upright” to you. For example, you’d probably find it confusing to work in an
upside-down scene, and a glass of wine placed at any attitude other than upright would seem to defy gravity if the
wine did not spill.

If you like, you can create a tilted or upside down world simply by changing the attitude of your camera. This is far
easier than working in a skewed universe.

Arranging one object in relation to another may require a series of positioning, orientation, and alignment operations.
Many of these commands operate under the constraints of the working box. Setting the working box appropriately
before starting an operation greatly simplifies the procedure. Because the relationship of objects to one another is the
most important part of arrangement, resizing may also be necessary.

Except where noted, all of the positioning, orienting, aligning, and resizing commands work with either simple or
grouped objects.



About the Hot Pointw

The hot point is the single point of an object or group that identifies its center of rotation. The hot point of selected
objects and groups appears in the Perspective window as a small 3D sphere, which also casts 2D projections.

By default, an object or group’s hot point is at the center of its bounding box. You can move the hot point to any point
in, on the surface, or some distance from the object.

Where you put the hot point depends on the type of arrangement operation you are planning. Different operations
suggest different placements of the hot point. For example, with the hot point at the center of an object, a rotate
command spins the object in place. However, with the hot point placed some distance away, the object will rotate
around its hot point, like a planet orbiting around its sun.



Moving a Hot Point by Dragging 2XSr €™ (Vi "l

To move a hot point:
1. Choose the Selection tool.

2. Select the object or group whose hot point you want to move.
3.Drag the hot point in 3D or drag one of its 2D projections.
¢ Hold down Alt to drag the hot point perpendicular to the active plane.

e If you turn on Caps Lock on your keyboard, you can lock the object to its hot point. In this case, if you drag
the hot point, the object moves with it.

e If youdrag in 3D with the Ctrl key down, the hot point snaps to the surface of the object beneath it.

By putting on Caps Lock and holding down Ctrl while dragging, you can drag an object by its hot point across a
contoured surface. The object you drag maintains its distance from the surface across any contour.
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To center a hot point:
1. Select the object or group in the Perspective window.

2.Choose the Arrange menu> Center Hot Point, or press Ctrl+Alt+H.
Ray Dream Studio moves the hot point to the center of the object or group bounding box.

You may also use the “Send to” arrow (points up) on the Properties palette: Transform tab: Position controls to
send the hot point to the center.



Moving a Hot Point Numericallyw

To move a hot point:
1. Select the object or group.

2.Choose Windows menu> Properties.
The Properties palette appears.

3.Choose the Transform tab.
The Properties palette: Transform tab: Position controls display the position of the hot point (x,y,z coordinates).

4.Use the System pop-up to select the coordinate system you want to use.
Global lets you specify the hot point location in the universe.
Working Box lets you specify the hot point location in relation to the working box. This will be useful if you’ve
moved the working box to a particular, significant location and attitude.
Local lets you specify the hot point location with respect to the center of the object or group bounding box. This
is useful if you want to move the hot point (out from the center) on a particular axis.
Raw Data lets you use Studio’s internal transform data to control the object.

5.1f you are using Global or Working Box and you want the object to move with its hot point, click the Lock icon.
The hot point is locked in relation to the object when the Lock icon “connects” the Center and Hot Point fields.
Click the Lock again to disconnect the references and allow them to move independently.

6. Enter new position values for the hot point.

7.Click Apply to move the hot point to that location.

8. You can enable Auto (Apply) if you want the hot point to move to the positions you enter automatically.
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To place th hot point back in the object’s center:
1. Select the object or group.

2.Display the Properties palette: Transform tab: Position controls.

3. Click the “Send to” arrow (points up between Hot Point and Center) to send the hot point to the center of the object
or group bounding box.



Positioning Objects

You’ll position objects to move them to particular locations in your scene. In most cases, the most important part of
an object’s position is its location relative to other objects. Often, to create the desired relationships, you will use the
positioning tools in conjunction with the orientation and alignment tools. Positioning applies to objects and groups, as
well as lights and cameras. In this section, the term “object” also refers to cameras and lights.

Remember that the appearance of your scene is determined not only by the position of objects, but by your point of
view—the location of the camera you’re looking through. With two objects in your scene, you can switch their relative
positions, left-to-right, by simply placing the camera on the other side of the scene.

Note: Most artists build the scene around the center of the universe (0, 0, 0). This offers the advantage that an
objects global position describes its position from the center of the scene.

Ray Dream Studio 5 provides several ways to position objects:

e Dragging

e Nudging

e Numerical Positioning



Dragging Objectsw

The easiest way to move an object through space is to drag it with the Selection tool. These dragging operations use
the working box planes as the dimensional reference. Remember that you can orient the working box to a particular
attitude before dragging an object.

Remember that the planes of the working box extend throughout the universe. The visible grid is merely a reference
of the orientation of those planes and does not restrict you to the visible space.



Moving an Object Parallel to the Active Plane XS [V vl

To move an object:
1. Choose the Selection tool.

2.Drag the object’s preview where you want it.
Hold down the Shift key to constrain the drag angle to an increment of 45°.
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To move an object.
1. Choose the Selection tool.

2.Hold down the Alt key and drag the object preview.



Moving an Object Along a Specific Plane LeTEY i W

To move an object:
1. Choose the Selection tool.

2.Drag the object’s projection in that plane.
Hold down the Shift key to constrain the drag angle to an increment of 45°.
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Nudging lets you move an object by pressing one of the Arrow keys on your keyboard. Nudging uses the working box
active plane as the reference. The grid lines on the active plane indicate the directions that the Arrow keys move the
object.

Remember that you can orient the working box to a particular attitude and change which of the three is the active
plane before nudging an object.



Nudging an Objectw

To nudge an object:
1. Select one or more objects

2.Press one of the Arrow keys.
The selected objects move parallel to the active plane one increment of the grid increment setting.

3. Hold down the Shift key when nudging to increase the nudge distance (grid increment) by a factor of 5.



Nudging Perpendicular to the Active Plane WYY (i

To nudge perpendicular:
1.Hold down the Alt key and use the Up or Down Arrow key.

2.Hold down the Shift key when nudging to increase the nudge distance (grid increment) by a factor of 5.



Numerically Positioning Objects
Numerical positioning lets you enter X, y, z coordinate values to locate the object.

To position an object or group numerically:
1. Select the object or group.

2.Display the Properties palette: Transform tab: Position controls.

3. Use the System pop-up to select the coordinate system you want to use.
Global lets you specify the object location in the universe.
Working Box lets you specify the object location in relation to the working box. This will be useful if you’ve
moved the working box to a particular, significant location and attitude.
Local lets you specify the object location with respect to the center of the group bounding box. This is useful if
you’ve jumped into a group and want to specify the location with respect to the center of the group’s bounding
box (local origin).
Raw Data lets you use Studio’s internal transform data to control the object.

4.Choose the preferred units, if necessary.

5.If you want to maintain the relationship between the object center and hot point, click the Lock icon.
The hot point is locked in relation to the object when the Lock icon “connects” the Center and Hot Point fields.

Note: If you want to move the object, but leave the hot point where it is: Disable the Lock and use the Center
fields to move the object.

When the hot point and center are locked, you may use either the bounding box Center or the Hot Point as the
reference on the object or group.

6.Enter x, y, z values position values for either the object Center or the Hot Point.
You can type in a value or use the scroll arrows.

7.Click Apply to move the object to that location.

8. Enable Auto (Apply) if you want the object to move to the positions you enter automatically.



Centering an Object on the Hot Point XYSTYIEW frir Wul|

To center an object:
1. Select the object or group.

2.Display the Properties palette: Transform tab: Position controls.

3. Click the Send to arrow (points down between Center and Hot Point) to move the center of the object or group
bounding box to the hot point.



Measuring and Setting the Distance of Objects
Ray Dream Studio lets you measure the distance between any two objects. You may enter a distance value to move

one of the objects into position. This is particularly useful when the objects are aligned with one another and you want
to move one of them closer to or farther from the other.

To measure and set distance:

1. Select two objects.
This feature does not work if more than or less than two objects are selected.

2.Choose Windows menu> Properties.
The Properties palette appears.
With two objects selected, Distance is the only tab available. The Distance field shows the distance between the
object centers.

3. Choose the units you’d like to use from the pop-up.

4.From the Lock pop-up, choose which object you want to keep its position.
The other object will move.

5. Enter a new distance value.
You can type in a value or use the scroll arrows.

6. Click Apply to move the “unlocked” object to the specified distance from the other.
Setting distance is particularly useful when positioning a camera. For example: The camera points directly at an

object, but it’s just too far away and the object looks small. Select both the camera and the object. Lock the object,
and set the distance lower to move the camera closer.



Resizing Objectsw

When you create an object, you model it at a particular size. Once in the scene, you can scale the object to new
dimensions. The most important aspect of an object’s size is its relationship to other objects. For example, if the cork
is larger than the wine bottle, one of them has the wrong scale.

Because Ray Dream Studio allows you to work with real world units (inches feet, centimeters, meters, etc.), many
artists scale objects equivalent to their size in the real world. For example, a soft drink can is 4.75 inches tall and 2.5
inches in diameter, so it makes sense to scale a can object to these dimensions. When you put a pencil object (0.62
inches in diameter and 7.4 inches long, unsharpened) next to the can, the two objects have the correct size
relationship.

Note: Scaling in the scene does not change the size of the original (master) object.

Ray Dream Studio allows you to resize an object or group in one of two ways: by dragging its bounding box or 2D
projection handles (free resizing), or by using the Properties palette: Transform tab: Size & Scaling controls. In both
cases, you can resize an object proportionally or disproportionally.

The size you create objects has little relationship to the size they appear in the final rendered image. The size of
objects in the rendered image is determined not only by their dimensions, but more importantly by their distance from
the point of view. This is just like in the real world: a car right in front of you appears larger than when it’s parked
down the block. In Ray Dream Studio 5, the point of view is the camera, so if you want to make objects appear larger
in the rendering, either move the camera closer, or increase its focal length.



Free Resizingw

Free sizing lets you scale an object or group by dragging a corner of its bounding box or projection.

To resize an object or group:

1. Select an object or group.
You may select several objects, then resize one of them to apply the same scaling factor to all.

2. With the Selection tool, drag one of the corners of the object’s bounding box.
You may also drag the corner of a projection to scale in the dimensions of that plane.

3. With no keys down, you’ll scale the object disproportionally in the axes parallel to the active plane.
When using modifier keys, start dragging, hold down the modifier key, release the mouse, then release the key.
The reference—which remains anchored in place—is the opposite corner (from the one you drag).
Note: Groups cannot be resized disproportionally. They are always scaled equally in all three dimensions.

The following modifier keys give you control resizing:

Shift: Maintain proportions. Resize equally in all three dimensions.

Alt: Resize only in the dimension perpendicular to the active plane.

Ctrl: Resize using the hot point as the reference. The hot point stays in place, and all eight corners of the
bounding box move to resize the object.

4.When you are satisfied with the object’s new size, release the mouse.

The object bounding box and working box may not be aligned. In this case, the scaling dimensions are described by
the bounding box axes that are closest to being parallel with the active plane. Or with the Alt key down, the scaling
axis is the box axis that’s closest to being perpendicular to the active plane.

Resizing may change the relative positions of two objects. For instance, a glass on a table, if enlarged, may go
through the table, and if shrunk, may seem to float over it. You can prevent this by using the plane at the bottom of
the glass as the reference for resizing—that is, by dragging a corner at the top of the bounding box, not at its bottom.
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Numerical resizing allows you to enter size values or scaling percentages to resize the object in any or all
dimensions.

To resize numerically:
1. Select an object or group.

2.Display the Properties palette: Transform tab: Size & Scaling controls.
You can choose the units from the Units pop-up.

3. Enable the Keep Proportions option to maintain the ratio between an object’s height, width, and depth.

4.Enter values in any Size or Scaling field to describe the size or relative scale in that dimension.
You can type in a value or use the scroll arrows. The values in the Size fields give the dimensions (height, width,
and depth) of the object’s bounding box. The Scaling fields give the scaling percentages in each dimension.
When all three are at 100% the object is at the scale it was created.

5. Click Apply to move the object to that location.

6. Enable Auto (Apply) if you want the object to scale to the values you enter automatically.



Orienting Objectsw

Most real-world objects have a logical “upright” and some have a logical “front.” For example, airplanes and
automobiles have both. In simple terms, you can think of an object’s orientation as “the direction it faces.” Ray
Dream Studio 5 determines the native upright and front of objects by the way they were modeled.

Orientation applies to objects and groups, as well as lights and cameras. In this section, the term “object” also refers
to cameras and lights.

If you are building a complex object, you will orient the parts as you assemble them. Then, group the complex object
SO you can orient it as a single object. Of course, you can still “*Jump Into the group” and change the relative
orientations of the objects.

The technical terms that describe orientation movements in an object’s own local coordinate system or frame of
reference are taken from aviation.

e Yaw (blue axis) is the degree of rotation about the upright axis.

e Pitch (pink axis) is the degree of front-to-back rotation.

¢ Roll (red axis) is the degree of side-to-side rotation.

e  Sometimes the term attitude is used to describe the combined effect of yaw, pitch, and roll.

Ray Dream Studio 5 allows you to change an object’s orientation in several ways: with the Virtual Trackball, with the
Rotate tool and numerically.



About Free Rotatingw

The Virtual Trackball allows you to orient an object by dragging its 3D preview.

With the Virtual Trackball, the object rotates around its hot point. You might want to position the hot point before
proceeding.



Orienting an Object with the Virtual Trackball ZXEYEY fFi Wl

To orient an object:
1. Choose the Virtual Trackball tool.

2. Click the object or group you want to orient.
You may select more than one object. Shift-click to add objects to the selection. Shift-click to remove selected
objects.

A set of rings appears around the object hot point. The rings describe the axes of rotation. (If you have a multi-
object selection, only one set of rings appears.)

3.Drag in the perspective window to change the object orientation. The following descriptions will help you control the
orientation change:

e Drag outside of the circle to rotate in relation to the monitor screen.

e Drag within the rings to roll the object in three dimensions.

e Hold down the Shift key and drag one of the rings to rotate the object only on the corresponding axis. Hold
down the Alt key while you drag to constrain rotation to increments of the Rotation Angle constraint.

Note: The point of rotation is at the hot point. If you have a multiple selection, each object rotates about its own hot
point. To rotate several objects around a single point, you must first group them.



Constraining Rotation to a Plane 22X [/l "N

To constrain rotation:

1.If necessary, orient the working box and position the object hot point.
Setting these allows you to control the plane and axis of rotation.

2.Choose the 2D Rotation tool.
The Rotation tool shares a space on the toolbar with the Virtual Trackball. You can “pop-up” the Virtual Trackball
icon to choose the Rotation tool.

3.Drag inside one of the three projections to rotate the object parallel to that plane.
Drag the projection in a circular path.

4.Hold down the Shift key while you drag to constrain rotation to increments of the Rotation Angle constraint.
You can change the setting in File menu> Preferences: Perspective.
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The Properties palette lets you orient an object numerically. Numerical orientation uses the center of an object as the
reference point.

To orient an object or group numerically:
1. Select the object or group.

2.Display the Properties palette: Transform tab: Orientation controls.

3. Use the System pop-up to select the coordinate system you want to use.
Global lets you specify the object orientation with respect to the universe.
Working Box lets you specify the object orientation with respect to the working box. This will be useful if you’ve
moved the working box to a particular, significant location and attitude.
Local lets you specify the object orientation with respect to its own coordinate system. This is useful when,
regardless of the object’s current rotation, you want to rotate it a set number of degrees.
Raw Data lets you use Studio’s internal transform data to control the object.
Note: Local Yaw, Pitch and Roll values revert to zero after you apply changes.

4.Enter new values in the Yaw, Pitch and Roll fields.
You can type in a value or use the scroll arrows

5. Click Apply to update your changes to the selected object or group.

6. When Auto is enabled, the object’s orientation automatically updates when you click in another field.



Using the Axis Indicators XS frir V|

Ray Dream Studio offers a set of axis indicators for the object’s hot point. The indicators are a visual reminder of the
object’s original x, y, z orientation.

To display the axis indicators:

1.Choose File menu> Preferences.
The Preferences dialog appears.

2.Choose Perspective from the pop-up.
3. Enable the Show Axis Information option.

The colors of the X (purple), Y (red) and Z (blue) axes match the colors of the Pitch, Roll and Yaw key in the
Orientation controls.



Mirroring an Object’s Orientation XXSIY Y i W]

You can automatically “mirror” an object’s orientation across an imaginary plane. The mirror plane is parallel with the
bottom plane of the working box and passes through the object’s hot point.

To mirror an object or group’s orientation:
1. Orient the working box to describe the angle you want for the mirror plane.

2. Select an object or group.
3.If necessary, position the hot point to describe the location you want for the mirror plane.
4.1n the Properties palette: Transform tab: Orientation controls, enable the Mirror option.

5. Click Apply to update your changes to the selected object or group.
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You can align objects with the working box, with the universe, or with gravity.

When the working box is in its “home” orientation (aligned with the universe), there is no difference between aligning
with the working box and with the Local Universe.



Aligning Objects with the Working Box XETYEW [ Y|

To align an object:
1. Select one or more objects.

2.Choose Arrange menu> Align> On Working Box (or press Ctrl+Shift+K).
Ray Dream Studio rotates the objects the minimum amount to put the sides of the object’s bounding box parallel
to the planes of the working box.



Aligning an Object with the Universe 2XSTYEY /il V|

To align on object:
1. Select an object.

2.Choose Arrange menu> Align> On Universe (or press Ctrl+Alt+K).
Ray Dream Studio places the object upright and sets its bounding box parallel to the axes of the universe.



Aligning on Gravityw

To align on gravity:
1. Select an object.

2.Choose Arrange menu> Align> On Gravity or press Ctrl+Shift+G.
Ray Dream Studio sets the Roll of the selected object to zero without affecting its Pitch or Yaw.

This feature is particularly useful for correcting the attitude of a camera. For example, if you were looking through a
camera and the horizon slanted diagonally across the frame, Align with Gravity would adjust the roll of the camera to
level the horizon.



Resetting Orientation 2XSIYEY i V|

To reset the orientation:
1. Select the object.

2.Choose Arrange menu> Align> Reset Orientation or press Ctrl+Alt+Shift+K.

Ray Dream Studio returns the object to its native orientation in terms of the local universe.



Aiming Cameras and Lights
All of the positioning and orientation commands work on cameras and lights as well as simple objects.

Note: Because the current camera is not visible as an object, manipulation by dragging isn’t possible.

The Point At command directs the light beam or camera view toward an object you specify.



Pointing a Camera or Light at an Object

To point a camera or light:

1. Select the camera or light and the object you want to point at.
You may select multiple cameras and lights, but only one object or group. If you don’t select a camera or light,
Ray Dream Studio 5 points the current camera.

2.Choose Arrange menu> Point At or press Ctrl+M.
The light or camera points at the hot point of the selected object or group.



Aligning Objects Relative to One Another

Ray Dream Studio 5’s relative alignment feature lets you arrange several objects with respect to each other. This can
be quite useful.

Aligning works with respect to the Working Box. For example, if you were building a bicycle wheel, you would use
relative alignment to arrange the axle, hub, spokes, rim, and tire to be concentric and co-planar.

When aligning many objects, you might want to start by aligning only two of them. Once you have aligned the two
objects, group them. Then align a third object to the group. Continue to group and align objects until all objects are
aligned.

To align objects:
1. Orient the Working Box to set the axes of constraint you want to use.

2. Select two or more objects.
The first selected object becomes the anchor object.

3.Choose Arrange menu> Align Objects.
The Alignment dialog appears. You’ll align your objects in each dimension (x, y, and z) separately. The selected
dimension is called the axis of constraint.

4. Select the axis of constraint from the Axis pop-up.

5.1If you’d prefer to see each axis of constraint at once, click the Key icon at the bottom of the Alignment palette to
expand it.

6. Select the alignment command you want for this axis: None, Align, Space, Distribute and Contact.
Note: You’ll often use a different command on each axis.

e None leaves the objects at their original position. along the axis of constraint.

e Align sets the reference point of each object co-linear with the reference point of the anchor object along the
axis of constraint.

e  Space puts the specified distance between the reference points of each object along the axis of constraint.

e  For Space, enter a spacing value and use the pop-up to set the units.

e Distribute places the reference point of each object, evenly spaced between the two anchor objects, along
the axis of constraint. The reference objects do not move in distribution. Therefore, Distribute requires a

selection of at least three objects.

e  Contact brings the BoxMax of each object into contact with the BoxMin of the next object along the axis of
constraint.

1.Using the red Anchor arrows, select the object to be used as the anchor.
The anchor object keeps its current position. All of the other objects move in relation to this object. Alternatively,
the Tab key advances the selection, and Shift-Tab retreats it. The 2D projection of the selected anchor object is
shown in red.

2.For the Distribute command, click the blue Arrow buttons to select the second anchor. Select two anchor objects.
The 2D projection of the second anchor object is shown in blue.

3. Select the reference point on the objects.
Note: Object reference points that are grayed out are unavailable for that alignment command.

e Hot point specifies each object’s hot point.

e BoxMin specifies the side or edge of each object’s bounding box with the lower coordinate value along the
axis of constraint.

e  Center specifies the center of each object’s bounding box.



e BoxMax specifies the side or edge of each object’s bounding box with the higher coordinate value along the
axis of constraint.

e Sides specifies the sides of the object’s bounding box.

1. Click Apply.
Note: The Undo command restores the objects to their original orientation after the last alignment operation until
you change the axis of constraint, or leave the Alignment window, deselect the objects, and attempt another
operation.

2.When you have achieved the alignment you want in one constraint axis, move on to the next one. (Return to step
3.)

Depending on your design for this set of objects, you may use relative alignment in one, two, or all three axes of
constraint.



Duplicating an Object

Duplication is a handy method of automatically repeating a series of position, orientation, and resize operations on a
duplicate object. Duplication is an efficient way of working and has a number of practical applications. Duplicated
objects are multiple instances of a single master object.

For example, you could use this feature to build a spiral staircase. Create the first stair and set its hot point to the axis
of spiral. Then, duplicate the stair, raise the duplicate to the level for the next step, and rotate it an appropriate
amount. Choose duplicate again and again until you have built the staircase.

To duplicate:
1. Select one object.

2.Choose Edit menu> Duplicate or press Ctrl+D.
Note: When created, the duplicate occupies the same space as the original.

3. Perform any number of position, orientation, and resize operations without deselecting the object.
4. Choose Duplicate again.

Each time you duplicate, the new copy receives the same set of positioning, orientation, and resizing operations
relative to the last duplicated object.



About Object Symmetww

Many real-world objects exhibit symmetry. Airplanes, automobiles, and the human body are a few examples. To help
you build complex symmetrical objects, Ray Dream Studio 5 provides two commands—Flip and Duplicate with
Symmetry.

Both symmetry commands use an imaginary plane parallel to the bottom plane, passing through the center of the left
and right planes of the working box (working box z=0). This plane acts as a mirror across which the objects are
reflected, or flipped.

The attitude of the working box and the object’s z coordinate value (in the working box system) are important for a
successful Flip or Duplicate with Symmetry operation.

¢ If you want to flip the object in place, the center of the object should be at z=0.

¢ To Duplicate with Symmetry and have the mirrored duplicate lie precisely alongside the original, duplicate the
object with symmetry, then use the Alignment palette to align the duplicated objects correctly.



Flipping an Objectw

To flip an object:
1. Orient and position the working box to put the plane of symmetry where you want it.

2. Select the object you want to flip.
3.Choose Arrange menu> Flip.

Ray Dream Studio flips the object across the plane of symmetry.



Duplicating with Symmetry ZTSTYSY [/l W]

To duplicate:
1. Orient and position the working box to put the plane of symmetry where you want it.

2. Select the object.
3. Choose Edit menu> Duplicate with Symmetry or press Ctrl+Alt+D.

Ray Dream Studio duplicates the object across the plane of symmetry.



Shadow Casting

By default, all objects that are not transparent cast shadows. There might be a case where you don’t want a
particular object to cast shadows. Studio allows you to turn Shadow Casting on and off for individual objects.

To set shadow casting for one or more objects:
1. Select one or more objects.

2.Choose Arrange> No Shadow Casting to turn off shadow casting for the selected objects.

3. Choose Arrange> Shadow Casting to turn on shadow casting for the selected objects.

Note: For a single object, you can set whether or not it casts shadows in the Properties palette: General tab.



Using the Counter

The Counter is a utility that tracks the complexity of the geometry in the scene. The Counter maintains the following
data:

¢ The number of objects in the scene

e The number of modeled patches

¢ The number of modeled facets

e The number of triangles that would be created in an exported version of this file

This technical information may be useful to some artists who intend to export the scene for use in another program.
The number of triangles has a direct correlation to file size in the exported document.

To use the Counter:
1.Choose Arrange> Counter.

2.When you’re done viewing the information, click OK.
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The contents of a scene can be built by adding, deleting and replacing objects. You can also modify any object that
you have created.

You can add existing objects to your scene (from other scenes or from clip art folders) in several ways: using the
Objects Browser, by dragging between windows and with the Copy and Paste commands. You may even add an
entire scene. In this case, the scene you add becomes a group in the new scene. The Ray Dream 3D Scene Wizard
is one special way you can add an entire scene to your existing one.

When you load an existing object, its shading, position, orientation and size characteristics are brought with it. You
can, of course, change any of these to fit the new scene.
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To add an object:
1. Open both scene files.

2.Drag the icon representing the object you want from the source Hierarchy window to the destination Perspective or
Hierarchy window.

When you drag into the hierarchy, you can drag directly onto a group or an object. If you drag an object onto
another object, the hot points are aligned, and the object you dragged is linked to the other object.



Deleting an Objectw

To delete an object:
1. Select the object in the Perspective or Hierarchy window.

2.Choose Edit menu> Delete.
When you select a parent object within a group, you automatically select all of its child objects. If you delete the

parent, the children or the group contents are deleted as well. If you want to delete an object, but not its children,
change the structure of the hierarchy to place the child or contents at some other level before proceeding.
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When you replace an object, the replacement takes on the positioning, alignment and size characteristics of its
predecessor.

To replace an object:
1. Select the object you want to use.

2.Choose Edit menu> Copy.(or press Ctrl+C)

3. Select the object you want to replace.

4. Choose Edit menu> Paste.(or press Ctrl+V)

5.1f you are pasting an object (not a group), a dialog gives you a scaling option. Make your choice and click OK.
e Fitin Box scales the replacement to fit within the same bounding box.

e Keep Scaling keeps the replacement at its original scale.



Jumping into Objects 2XSY Y [l "l

At any time, you can select an object and “jump into” it. When you jump in, Ray Dream 3D opens the object in a
modeler where you can modify it.

To jump into an object:
1. Select the object.

2.Choose Edit menu> Jump In.

You can also double-click the object preview in the Perspective window or its listing in the hierarchy.

Note: If you try to jump into an instance of a class, Ray Dream 3D alerts you with a dialog. You may choose to modify
the master for this class or create a new master object.

e When you jump into a Free Form object, Ray Dream 3D opens it in the Free Form modeler.
e When you jump into a Mesh Form object, Ray Dream 3D opens it in the Mesh Form modeler.

e When you jump into a volumetric primitive, like Fountain, Fire, Fog or clouds, Ray Dream 3D opens the
appropriate control panel.

e [fit’s an imported or primitive object, like the cone or sphere, Ray Dream 3D opens it in the Minimum Modeler
window. You cannot modify the geometry of the object but you can apply shaders and paint shapes.



Jumping into an Object in a Separate Window Lvervew (|

To jump into an object:
1. Select the object.

2.Choose Edit menu> Jump In New Window.
You may have to adjust the size and position of the windows so that both are visible on your screen.

Because your modifications are updated to the object first, and then updated to the Perspective window, performance
may lag slightly when you use Jump In New Window. For this reason, Jump In New Window is not recommended for
systems with limited RAM.



Jumping into an Object in a Different Modeler XYY i V|

Normally, jumping in opens the object in the modeler where it was created or the Minimum modeler for primitives and
imported objects. You might prefer to open the object in a different modeler.

Working with an object in a different modeler changes its type. This may limit your options for future editing. For
example, you can’t edit a Free Form object in the Mesh Form modeler, then take it back into the Free Form modeler.

To jump into the object in a different modeler:
1. Select the object.

2.Choose Edit menu> Jump In Another Modeler.
3.Ray Dream 3D opens a dialog that shows your modeler options.

4. Select the modeler you want.
Note: Some modification options might not be available under other modelers.
Ray Dream 3D constructs 3D surfaces using facets and patches. Facets are triangular. Patches are polygons
derived from Beziér curves. Some objects may be entirely facets, others may be a mixed set of facets and
patches. When you open a primitive or Free Form modeler object in the Mesh Form modeler, all patches are
converted to facets.

5.1f you select the Vertex modeler, drag the slider or enter a value to set a fidelity level for creating facets from
patches.
More facets creates smoother surfaces, but increases the file size and memory required for the model.

6. When you have set your options, click OK.
Ray Dream 3D opens the object in the selected modeler.



Building a Hierarchical Structure 2SS /il Wl

The structure of a scene organizes the elements of a scene according to spatial or logical relationships. Structure
simplifies arrangement operations and can save you time and trouble.

Working primarily in the hierarchy, you can structure a scene by grouping and linking objects. The term “object” refers
also to lights, cameras, and closed groups. You’ll find it’s far easier to keep track of objects that you’ve specifically
named than it is to manage generically named objects.

Every object in your scene appears in the hierarchy. The hierarchy is shown as a tree of elements, each represented
by a listing or named icon. The hierarchy of a scene changes as you introduce objects, group them, and create links.

Elements may be objects, groups, cameras, or light sources. The highest level of the hierarchy is the root. It is
represented by an icon entitled “Universe.” It encompasses your entire scene. Beneath the universe, you may have
any number of branches and sub-branches.
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You can view the hierarchy in the Time Line window, vertically or horizontally. You may choose the display that’s
suitable for your working style and screen space.

Time Line view lists the contents of the hierarchy in outline form rather than with icons. This is especially useful for
complex scenes or if you want to see as much of your hierarchy as possible.

To change hierarchy display:
1.Make sure the Time Line window is displayed.

2.To display the window, choose Windows menu> Hierarchy of [filename] or Time Line of [filename].
3.If necessary, click in the Time Line window to bring it to the front.

4.Choose View menu> Vertical, Horizontal or Time Line.
Ray Dream 3D sets the display to your choice.



Navigating the Hierarchyw

You can expand and collapse the items in the hierarchy to view more or fewer elements in your scene. You may need
to open a series of groups to find a particular object deep in the hierarchy. To return to the outer view, close the group
box at each level until only the main branch, beneath the universe root, is displayed.

Usually, the root is the Universe. However, if you “Jump Into” a group box, the hierarchy displays the group box as
the current root and the contents of that group as the only elements of the hierarchy.

A small icon appears to the left of every group. The icon is a plus sign when the group is closed and a minus sign
when opened.



Opening or Closing a Groupw

To open a group:
e  Click the plus/minus sign beside the group.
Once a group is opened, the plus sign becomes a minus sign.

To collapse the outline and close a group:
¢ Click on the minus sign.

If you are in the Time Line view, a second set of plus/minus signs appears next to groups and objects. These icons
located closest to the object are used to expand the hierarchical structure of the animation attributes. Use the icons to
the left of these to expand and collapse the scene hierarchy.



Changing the Hierarchy Structure
You can combine multiple elements of your hierarchy in two ways: grouping and linking.

e You can nest groups within other groups or create a chain with multiple links.

e You can reorganize your groups and links by dragging them from one location in the hierarchy to another. Don’t
worry about making a mistake in changing the hierarchy. You can drag an element to another level at any time.

e You can drag objects individually or select several and drag them at once. To select multiple items, drag a
marquee around them or hold down the Shift key and click on additional items.

To remove a single object from a multiple selection, hold down the Shift key and click it.

Drawing a marquee is an easy way to select a set of objects. However, you may not select a group exclusive of its
contents or a parent exclusive of its children.

Selecting elements in the hierarchy applies not only to the selected object, but, in the case of a closed group box, to
its contents, and in the case of a parent object, to its children.



Groups and Links

Groups and links are similar — both let you combine multiple objects in your scene so that you can manipulate them
as a single unit, but their usage is quite different.

Grouping is a way of creating collections of objects that make structuring and navigating through your scene more
manageable. Groups are static, in that they don’t change the relationship between the objects in the groups, they
only contain them. This is similar to the group function in 2D illustration and drawing programs.

Links on the other hand, let you define an active relationship between the “parent” object and the “child” object. By
applying various types of links you can “tie” them together so that moving the parent effects the child, but moving the
child does not effect the parent. The exception to this is when applying the Inverse Kinematics behavior to a child
object in a linked chain.



Grouping Objectsw

As you build up your scene, you’ll want to group related objects. Grouping allows you to control a set of objects as a
single unit.

You can arrange a group just as you do a single object. During any positioning or orientation operation, the objects in
a group retain their spatial relationship to one another.

How you organize your groups is up to you.

e You’ll often create groups based on the logical context of a set of objects—for example, the “hub, axle, spokes,
rim and tire.” When arranged properly and grouped, the set of objects becomes a single object you could name
“bicycle wheel.”

e You can also create groups based on the proximity of a set of objects—for example, “all objects on the
bookshelf.”

e You can nest one group within another to as many levels as you like. As you build a complex scene, you’ll find
nesting groups helps manage the multitude of elements.

Don’t worry about perfecting the shape of an object before putting it in a group. You can always open the group, then
open the object for editing.



Creating a New Groupw

To create a new group:

1. Select the objects you want to group.
You may select the objects in either the Perspective or Hierarchy window.

2.Choose Arrange menu> Group.
You may also click the Group/Ungroup icon in the Standard toolbar. A box icon (or group listing, in Time Line
window) appears in the Hierarchy window under the current root.

By default, group boxes are named Group x, where x is a sequential number (1, 2, 3...).



Changing the Name of a Groupw

To change the group name:

1. Click on the name of the group in the Hierarchy window.
If you’re using the Time Line window, don’t click, but hold down the mouse button for a second or two. Ray
Dream 3D opens the Edit Name dialog.

2. Enter the new name and click OK.

Note: You may also change a group’s name in the Properties palette: General tab.

You can have Ray Dream 3D automatically prompt you to name groups you create. Choose File menu> Preferences:
Hierarchy Tab and enable Ask for name.



Adding Objects to a Groupw

To add objects:
e Drag the icons of the objects you wish to add onto the group box icon.

Note: You can bring an object into the scene and immediately place it in a group. Drag the object from its source
(Browser palette or other scene hierarchy) and drop it directly onto a group box icon.



Removing Objects from a Group_"“""'r"'w""":""Ir . |

To remove objects:

e Simply drag the selected objects to another point in the hierarchy.
For example, you can drag onto the universe icon. This places the objects on the main branch of the hierarchy.



Opening and Closing Groupsw

You can open and close groups while you work. When the group is closed, you can manipulate the entire group as a
single object. When a group is open, it maintains its structure in the hierarchy, but you can select and move each
component object independently.

This is a great time saver and gives you maximum flexibility. You can easily adjust the objects in your groups, but
maintain their structure in the hierarchy.

To open a group:

e  Click the plus/minus sign beside the group listing in the hierarchy.
A group box is the root of its contents. While the group box is open, indicated by the open box icon, its contents
are displayed on a subbranch.

Note: Ungrouping is different from opening a group. Ungrouping gets rid of the group; the contents appear at that
level of the hierarchy.

To close a group:

e  Click on the minus sign.
The icons of the group’s components collapse into the box, and the display returns to the next higher level of the
hierarchy.



Group Bounding Boxes SXSIYIEW i WM

In the Perspective window, the elements of a group are enclosed in a single bounding box, which is visible when the
group box is closed. When you create a group, the group bounding box is set parallel to the planes of the working
box.

The group bounding box is defined as “the smallest box, with the same orientation as the working box, that encloses
all bounding boxes of the group’s contents.” If you add or remove objects from the group, the dimensions of the
group bounding box may change. The orientation of the group bounding box, however, does not change as you add
or remove elements.

After reorienting a group, the group bounding box will no longer be parallel to the working box.

To re-calculate the group bounding box:
1. Select the group you want to recalculate.

2.Choose Arrange menu> Ungroup or press Ctrl-U.

3. Choose Arrange menu> Group or press Ctrl-G.



Jumping In and Out of Groups LYOvew fie

You can jump into a group to modify the relative positions and attitudes of the objects it contains.

Within a group, a Local Universe, also called the Object/Group Universe, is used. This coordinate system’s axes are
parallel with the walls of the group’s bounding box, with its origin at the center.

The Local Universe maintains the relative positions of the objects when you move or rotate the group as a whole.
That is, regardless of how you manipulate the group bounding box, the content objects have the same positions in
terms of the Local Universe.

To jump into a group:
1. Select the group.

2.Choose Edit menu> Jump In.

You can also double-click the group box icon in the hierarchy to jump in right away.

Note: To open the group in a separate window (while keeping the Perspective window visible), use Edit menu> Jump
In New Window.

¢ When you jump into a group, the Hierarchy window displays the group box as the current root and its contents as
the only elements of the hierarchy. Simultaneously, the Perspective window redraws to display only the contents
of this group.

e When you jump into a group, the working box is oriented parallel with the group’s bounding box. This enables
you to work in terms of the group’s Local Root Universe. If this is not what you want, you can align the working
box with the Global Universe.

To jump out of a group:
e  Choose Edit menu> Jump Out.

You can also double-click the group box icon in the hierarchy or click the Done button at the bottom of the
Perspective window.

When you jump out, the Hierarchy and Perspective windows returns to displaying the universe.



About Linking Objectsw

Linking creates a “physical connection” between objects. In a linked pair, one object is the “parent” and the other is
the “child.” When you change the position or orientation of the parent, the child moves with it. However, you can still
more or rotate the child independently of the parent.

Linking is used to create articulated structures, like an arm. The hand is linked to the forearm, which is linked to the
upper arm, which is linked to the shoulder.



Linking an Object to Another Lrervew (e e

To link objects:
¢ In the Hierarchy window, drag the object or group’s item (icon or listing) onto the item of the desired parent.
The link icon appears prior to the parent object.

Note: If you duplicate a parent object, you’ll also be duplicating all of its child objects.

To attach an object to a parent that is off screen in the Hierarchy window, drag the new element with the Alt key held
down. This automatically scrolls the window’s contents to reveal additional elements.



Breaking a Link SXETYRW far o
To break links:
¢ Select the child object’s item and drag it to another point in the hierarchy.

You cannot link a child object to a simple group. To do this, you must first promote the group to a master object. Then
you can link the object (child) to the group (parent).



Applying Link Propeniesw

Linked objects have properties that constrain the child’s movement relative to the parent. An excellent real world
example of this is the human hand. The hand is linked to the forearm. Its range of motion (relative to the forearm) is
limited—you can’t bend it forward or back more than 90° or side-to-side more than 45°—anything more would break
the wrist. These are just the kind of limits you can impose with link properties.

Links become a more powerful tool for creating spatial relationships between objects when you apply a Link Property.
This is especially true when setting up your scene for animation. Not only can you use links to constrain the
movement of objects, but by applying the Inverse Kinematics behavior, you can create kinematic chains that allow
you to manipulate the parent by moving the child.

To apply a link property:

1. Position the child object where you want it in relation to the parent.
2. Position the child object’s hot point where you want it.

3. Select the child object or group.

4.Choose Windows menu> Properties.
The Properties palette appears.

5. Click the Links tab.

6. Choose the type of link you want to apply from the pop-up— None, 2D Plane, Axis, Ball Joint, Custom, Shaft, Lock
and Slider.

7.Choose your options for the specific Link Property.
8.When you are ready to apply your changes, click Apply at the bottom of the Properties palette.

9. You may enable the Auto option to have your changes updated automatically.



Types of Links
There are eight link types available: None, 2D Plane, Axis, Ball Joint, Custom, Shaft, Lock and Slider.

None
None is the default link property. You are free to position the child object anywhere in your scene.

2D Plane

The 2D Plane link restricts the movement of your object to a specific plane. This plane is relative to the child object’s
axis, not the global universe. For example, if you rotate the object, the plane that it moves on will ilt.

Click a radio button to select the plane you want: XY, ZY or ZX.

Axis
In the Axis link, a child object can be rotated around its hot point on one of the three axes. The rotation can be locked,
limited, or free.

¢ |f the rotation is locked, no movement occurs.
¢ |f the rotation is free, the rotation is an unlimited 360° on that axis.

¢ If the rotation is limited, you can constrain the rotation between two points.

Ball Joint

The Ball Joint link allows you to rotate the child object 360 degrees around its own hot point. Like the 2D Plane link,
the Ball Joint link is not related to the parent object, except when moving the parent. There are no constraints on any
axis.

There are no options for the Ball Joint.

Custom
The Custom link allows you to build your own combination of constraints using sliders and axis rotation controls.

Shaft

In the Shaft link, the child object can both rotate around one of its axes, while it slides up and down the same axis.
Perhaps the best way to think of a shaft link is to visualize a firehouse pole. The firefighters can slide down the pole
while also rotating around it.

Choose the main axis of rotation and set both rotation and slider controls.

Lock

A Lock link means that the child object is locked to the parent object. You cannot select the child object and move it,
but it will move in relation to the parent when the parent is moved.

There are no options for the Lock property.

Slider

A Slider link sets constraints for the child object’s movement along its X, Y, and Z axes. Movement on each axis can
be Locked, Limited, or Free.

¢ Locked prevents any movement on that axis. This is the default setting.
¢ Limited allows you to place limitations on movement in both directions.
¢ Free lets the object move anywhere along that axis.

Set your options using slider controls.



Setting a Link Slider Control
To set link slider controls:

1.1n the Preferences palette: Link tab, choose the type of constraint from the pop-up—Locked, Limited or Free.
Ray Dream 3D displays the controls for the chosen constraint.

2.Drag the slider markers to set position limits and a new position.

In Free mode, the slider has one marker. You can drag the marker to move the object along that axis. You can
double-click the slider to set the current position numerically.
In Limited mode, the slider has three markers.

The marker on the left sets the outer constraint in the negative direction away from the object’s hot point.
Drag the marker to change the limit.

The marker in the middle sets the current position of the object. Drag the marker to move the object along
that axis between the limits.

The marker on the right sets the outer constraint in the positive direction away from the object’s hot point.
Drag it to set a new limit.
The text field to the right displays the position of the currently selected marker.

3.If the slider range is too large to give you precise control, click the plus magnifying glass icon to the right.
Click it as many times as necessary to decrease the slider scale.

4.If the slider range is not large enough to let you set the constraint limit where you want, click on the minus
magnifying glass icon.
Click it as many times as necessary to increase the slider scale.



Setting Axis Rotation Controls
To set axis rotation controls:

1.1n the Preferences palette: Link tab, choose the type of constraint from the pop-up—Locked, Limited or Free.
Ray Dream 3D displays the controls for the chosen constraint.

2.Drag the markers to set position limits and a new position.
In Free mode, your object can rotate 360° around the chosen axis. Drag the marker to rotate the object.
In Limited mode, the angle ring displays three markers.

e The top marker defines the outer constraints of the rotation on the positive side of the axis. Drag the
marker to change the limit.

e  The middle marker sets the current position of the object. Drag the marker to rotate the object between
the limits.

e  The lower marker defines them for the negative side of the axis. Drag the marker to change the limit.



About Controlling Links Directly

The Direct Manipulation option for Link properties provides an onscreen description and control of the object’s motion
and rotation range. You can drag handles on the wires to control these properties.



Using Direct Manipulation Controls for Link Properties
To use direct manipulation:

1. Follow the instructions to apply a Link property to an object and set link controls on it.

2. After you’ve chosen the constraint type, click the Direct Manipulation button to display the controls on the object.
The controls appear as a set of wires with “handles” at certain points. The appearance of the wires depends on
the type of link and type of constraint.

¢ You won’t see the control wires when the constraint type is Locked.

e  The Direct Manipulation controls require Auto Apply enabled.

. For slider controls, you’ll see a straight wire. When the constraint is “Limited,” the handles at the ends
determine the limit for sliding on that axis.

Note: If you don’t see the wire, it’s probably inside the object. Use the slider in the Properties palette: Link tab to
extend the range.



Setting Slider Options Directly
To set slider options:

¢ Drag the handle at the end of the wire to change the limit in that direction.]

¢ Drag the object to change its position along the wire.
The object’s hot point slides along the wire until it reaches the end.

For rotation controls, you’ll see a wire arc that describes the object’s angular rotation range. The line within the arc
describes the current rotation.



Setting Rotation Controls
To set rotation controls:

¢ Drag the handle at the end of the arc to change the rotation limit.

¢ Drag the handle on the line within the arc to rotate the object within the range.



Building Chains of Links

The parent-child link enables you to easily manipulate multiple objects from a number of reference points by creating
chains of linked objects. This feature is useful in creating articulations, especially when used in conjunction with the
Inverse Kinematics feature.

For example, if you wanted to create a fully articulated arm— one that could bend at the shoulder, elbow, wrist, and
each of the five finger joints—you should arrange the objects to construct the arm, then link them into a chain with the
fingers at the deepest level of the hierarchy and the shoulder at the root.



About the Links Browser
The Browser palette: Links tab lets you save link settings that you can later apply to your objects.

The methods for saving to the Browser palette and using saved settings are common to the several browser
categories.



Working with Master Objects Yrervew fa .

Most scenes use one or more duplicates of some particular object. Each duplicate is not an independent object but
an Instance of the original Master object. For example, if you create a chair using four duplicate chair legs, the four
legs of a chair are object instances of a master object called, “chair leg.”

The position, orientation, size, hot point location, and shading of each object instance may be unique. The shape,
however, must be common.

Shading of instances may be unique or common. A good example of common shading would be a dozen bottles on a
shelf, all having the same label. Working at the master object level, you could change the labels on all twelve bottles
in one operation. Working at the instance level, you could put a stain on one of the labels. Later, you could change all
of the labels by modifying the master object without affecting the stain.

The following list describes the priority of shading layers.
First: Instance Paint Shape

Second: Master Paint Shape

Third: Instance Primer

Fourth: Master Primer



Objects and Masters Tabs in the Hierarchy Lrevew fae |

The Hierarchy window contains three tabs that change your view of the objects displayed in the hierarchy. The
Objects tab displays all the objects and object instances in your scene. The Masters tab displays only the master
objects. The Effects tab displays any Rendering effects you may have applied to your scene.

Unlike the Objects tab, the Masters and Effects tabs do not let you structure or group objects.

To display Master objects:
¢ Click the Master tab in the Hierarchy window.

You create a new master object each time you add a new object to the scene.



Jumping into an Instance XS [ V|

When you jump into an instance object, Ray Dream 3D displays a dialog alerting you. In the dialog, you may choose
to modify the master object of this class or create a new master from this instance.

You may have multiple instances with the same name, but you may not have two master objects with the same
name. When you create a new master object by modifying an object instance, Ray Dream 3D names the new class
object by appending a number to the old name.

If you modify an instance when you had intended to modify the master object, you can easily get back on track by
replacing the master with your modified instance.

You can create new instances of the master object by duplicating an existing instance, copying and pasting, or by
dragging the object from the Master tab into the scene.



Modifying a Master Objectw

When you modify a master object, all object instances are automatically updated to the new form. Their individual
position, orientation, scale, symmetry, and region shading remain unchanged.

To modify master objects:

1.1n the Time Line window, click on the Masters tab to display all master objects.

2. Select the master object you wish to modify.

3. Choose Edit menu> Jump In to open it for editing.
You can Jump In New Window if you want to modify the object in one window while viewing the scene in another.
You may also double-click its listing in the Master tab to open it for editing

4.Use the modeling or shader tools to modify the object.

5. Click Done to jump out of the object and apply your changes.



Replacing a Master Objectw

To replace master objects:

1. Select and copy the object that will replace the existing master object.
2.In the Time Line window: Masters tab, select the master object you want to replace.
3.Choose Edit menu> Paste or press Ctrl-V.

When you replace a master object, every instance of the class is replaced by the new object. Each object instance of
the replacement uses the positioning, alignment, scale, and symmetry characteristics of its predecessor.



Using a Group as a Master Objectw

To use a group as a master object:
1. Select the group in the hierarchy.
2. Drag the group over the Masters tab, then down to drop it where you want it.
A master group operates under the same rules as a master object. If you jump into one instance of the master

group and modify its contents in any way—the number of elements, their relative positions or orientations—you
separate this group instance from its master, thus creating a new master group.



The Objects Browser
The Browser palette: Object tab lets you save objects, groups and full scenes that you can use later.

The methods for saving to the Browser palette and using saved settings are common to the several Browser
categories.



About Lighting
The appearance of objects in the Ray Dream 3D universe is determined greatly by the light in which they are viewed.

A good set of lighting conditions is an important step toward creating high quality artwork. The same scene rendered
under different light can provide strikingly different results. For example, rendering with all lighting at zero brightness
is like taking a photograph—uwithout a flash—in the bottom of a coal mine. Conversely, too much lighting washes out
subtle effects.



Where Lighting Effects Are Visible

In the default Preview Quality Display mode, lighting effects specific to your scene are not visible. Instead, the
appearance of objects is determined by an arbitrary, fixed light source not visible in the Perspective window. This
ensures that you’ll see the objects you manipulate clearly—even if you are working on a dark scene. This also helps
make the Preview Quality Display mode significantly faster than the Better Preview mode.

The Better Preview mode uses ambient light and your scene’s specific light sources to show color, highlights, gel
effects and depth shading. No other lighting effects (shadows or reflections) appear. If ambient light is your only
source of light, you won’t see the depth shading effect on objects.

When modeling in the Free Form modeler view, the Better Preview uses an arbitrary, fixed light source. This allows
you to see details of the object’s textures and geometry clearly, regardless of the scene’s actual light settings.

When you render your scene using the Production Z-Buffer or the Ray Tracer, that rendering will show color, shading,
and all of the lighting effects selected in the renderer.

Before launching the rendering process, use the Render Preview tool in the Perspective toolbar to preview lighting
and shading effects.



About Cameras

Cameras provide viewpoints for the Perspective window and for renderings. As you build your scene, the cameras
can be positioned to get the best view for working. You can place several cameras and switch among them to get
alternate perspectives of your scene. You can even create a second Perspective window to view your scene from two
different angles at once.

When you are ready to render, you can select one camera as the viewpoint. The camera position and settings
combine with the production frame position and rendering format to determine the scale and framing of the scene.

Ray Dream 3D also lets you create camera effects, like lens flare and depth of field. These effects help you achieve
results you’d expect from photography.



Setting Lights XS0 [fi "

Ray Dream 3D supports two categories of lighting—ambient and specific. There is one ambient light setting, but there
are several types of specific light sources.

The lighting you set up in your scene has a big effect on the look of your rendered illustration. All the different lighting
controls combine to result in dramatically different effects. Experiment with different light settings to create the effects
that you want in your 3D illustration.



Setting Ambient Lightw

Ambient light is uniform through the scene. It has no specific origin and casts no shadows. It is the equivalent of
daylight in a real world scene. It radiates in every direction, has no position and no origin point.

1. To set ambient light:

2.Choose Windows menu> Scene Settings.
The Scene Settings palette [palette or dialog?] appears.

3. Click the Effects tab.

4. Click the Ambient Light color chip and use the color picker to set the color for the ambient light.
Use the Brightness slider to set the amount of ambient light.
For deeper shadows and high contrast with lit areas, use a lower ambient light setting.
As you increase the brightness of ambient light, the intensity of shadows and other effects generated by your
other lights decreases. This “flattens” the image.
To rely exclusively on your other lights, set ambient light at zero. For example, to create the dramatic effect of a
spotlight on a theatre stage, use no ambient light.

5. To view your changes, choose View menu> Better Preview or use the Better Preview tool in the Standard toolbar.



Creating New Light Source

You may create several types of specific lights. The standard lights are distant, bulb, and spot. You may add as many
lights as you like, but as the number increases, so does the time it takes to render your final 3D illustration. Most
scenes can be lit with one, two, or at most three well placed lights.

By default spot light and bulb light previews are displayed in red. If you want, you may change the color of light
objects in the Perspective window. Choose File menu> Preferences: Color and set your preference.

To create a new light source:

e Drag the Create Light tool from the Tools toolbar into the Perspective or Hierarchy window.

e You can also choose Edit menu> Insert> Light to add a light at the center of the Universe (0,0,0).

If you want to create a light with the same settings as an existing light, you can select the existing light then Copy and
Paste, or use the Duplicate command.

After creating a light, you can change its properties.



Setting Light Properties

Once you have created a new light, specify which type it is (distant, bulb, or spot) then, set its options on the
Properties palette: Light tab. You can use these controls at any time and adjust the settings of a selected light.

To set light properties:
1. Select the light.

2.Display the Properties palette: Light tab.
3. Choose the type of light you want from the pop-up: Bulb Light, Distant Light or Spot Light.

e ADistant Light is outside of the scene universe [new term?]. The light rays from a distant source are parallel
as they enter your scene. An example of this is the way the sun lights the earth.

e ABulb Light radiates light in all directions.

e A Spot Light casts light in a specific direction. The light rays of a spot light diverge based on parameters that
you set, such as the Half Angle and Distance Fall Off.

When you change light type, the tab displays the parameters appropriate to that type.



Setting Common Light Characteristics

The characteristics of color, brightness, and shadow control are common to distant, bulb, and spot lights. You adjust
these settings in the Properties palette: Light tab.

To set the color:
e Click the color chip and use the color picker to choose a color.

To set the brightness:
e Drag the slider to set the brightness.

To control shadow strength:

e By default, all lights (except ambient) cast shadows. If you want to minimize the shadows from a particular light,
drag the Shadows slider to a lower setting.

Use Better Preview mode or render to view the changes.



Setting the Direction of a Distant Light Source

The direction of a distant light source is set indirectly—by moving the highlight on the surface of the sphere in the
distant light’s Properties palette: Light tab.

To set the direction:
To set the position of the light, imagine the distance light sphere as a glass ball surrounding your scene. The highlight
shows where the distant light shines through the glass, toward the center of your scene.

1. Drag the highlight on the surface of the sphere to position the light source.
2.To shine the light from behind, click the Back radio button.

The Front of the scene refers to the direction shown in the following figure when the working box is in its initial
position, the Reference view.

As with ambient light, you can use a distant light to soften the shadows cast by your other light source. Position a
distant light above your scene, then experiment with light settings to diffuse the shadows from your other lights.



Setting Bulb Light Characteristics

Bulb lights appear in the Perspective window. You can move them anywhere in the 3D workspace with any of the
positioning features, including the Selection tool, Virtual Trackball, and Properties palette: Transform tab: Position and
Orientation controls.

Because bulb lights shine equally in all directions, you do not need to aim them.
To set the range of a light source:

1.Enter a value.
2.Use the pop-up to select your units.

The range is the distance from the light itself to the point where the light has no effect.
To set the distance fall-off:
e Drag the Distance Fall-off slider.

The distance fall-off setting determines how the brightness of the light diminishes toward the edge of its range. A fall
off of 10% means that the light has full intensity from the source through 90% of its range, then decreases linearly to
the end of the range.



About Spot Light Characteristics
Your brightness, half angle, and angular fall off settings are previewed in real time in the diagram to the right.

To set the half angle of a cone light:

The half angle is the angle of the radius of the cone. A narrow angle creates a beam like that of a spotlight. A wide
angle creates a beam like that of a flood light. (See the following diagram.)

e Drag the Half Angle slider.
You may also use the Direct Manipulation controls to set this feature.

To set the angular fall-off:

Fall-off is how the brightness of the light diminishes toward the edge of the light cone. A fall off of 10% means that the
light has full intensity from the center to 90% of the radius of the light cone, then decreases linearly to the edge of the
cone.

e Drag the Angular Fall-off slider. You may also use the Direct Manipulation controls to set this feature.

To set the range of the light source:
The range is the distance from the light itself to the point where the light has no effect.

e Enter a value. Use the pop-up to select your units.

To set the distance fall-off:

The distance fall-off setting determines how the brightness of the light diminishes toward the edge of its range. A fall
off of 10% means that the light has full intensity from the source through 90% of its range, then decreases linearly to
the end of the range.

e Drag the Distance Fall-off slider.
The spot light parameters interact with each other. For example, using a light colored light with a low brightness

setting may generate a similar result as a darker colored light with a higher brightness setting. Experiment with
various settings until you achieve the lighting you want.



Positioning and Aiming Spot Lights

Spot lights appear in the Perspective window. You can move them anywhere in the 3D workspace and change their
direction with any of the positioning and orientation features, including the Selection tool, Virtual Trackball, and the
Properties palette: Transform tab controls.

Ray Dream 3D offers several other methods of aiming lights, including the Point At command, the Point At behavior,
and the Direct Manipulation controls.



Pointing a Light at an Object
The Point At command lets you point a light directly at an object.

To point a spot light at an object:

1.Hold down Shift and select the light and the object you want to point it at.
You may select multiple lights, but only one object.

2.Choose Arrange menu> Point At, or press Ctrl-M.
Ray Dream 3D reorients the light to point at the hot point of the selected object.

The Point At command does not link the light to the object selected. That is, if you move either element, the light no
longer points at the object. If you want to maintain the relationship between a light and the object it points at, place
them together in a group. If you want the light to follow the object, apply the Point At behavior.

To direct a light to a particular area in your scene, you can create a temporary object for the light to point at, then
delete the object. Remember that the light points at the hot point of the object selected.
You can check where the light is cast by actually viewing your scene through the light. Use the Position pop-up in the

Camera Properties dialog to select the light source from which you will view the scene.

The Point At behavior sets a light to aim at an object. If the object moves, the light automatically reorients itself to
point at the object in its new position.



Following an Object with a Light

To follow an object with a light:
1. Select the spot light you want to use.

2.Display the Properties palette: Behavior tab.

3. Click the Plus sign icon.

4. Select Point At from the dialog and click OK.

5. Enter the name of the target object—the one you want the light to follow.

6. Leave the axis option as it is. The axis option sets which axis of the object should point at the target. For a light,
you only want to use the axis that emits the light.

7.Click Apply to send your changes to the light.

From now on, whenever you move the target object, this light reorients to point at it.



Controlling a Spot Light Directly

The Direct Manipulation controls for a light provides an on-screen description of the light’s aim and properties. You
can drag a light’s control handles to change light properties.

To display the Direct Manipulation controls on a spotlight:
1. Select a spot light.

2.Make sure this light is visible in the Perspective window.
For best results, you’ll want all planes visible so you can work with the projections.

3. Display the Properties palette: Light tab.
4. Click the Direct Manipulation button to display the control handles on the selected light.

The controls appear as a set of wires with “handles” at certain points. Each handle represents a control you can
drag to set properties.

Note: The Direct Manipulation controls require Auto Apply enabled.



Aiming a Light

To aim a light:

e Drag the control handle in front of the light cone.
The handle will move parallel to the active plane. Hold down the key to drag the handle perpendicular to the
active plane.

You can drag it out, extending the wire all the way to the point you want to aim at. The wire shows the angle of
the light beam.

¢ You may also aim the light with respect to a given plane by dragging the corresponding handle on one of the light’s
projections.

The light rotates to aim where you place the handle.



Moving a Light

To move a light:
e Drag the handle behind the light cone.

¢ You may also move the light with respect to a given plane by dragging the corresponding handle on one of the
light’s projections

The light moves to the new position and orients itself to point at the target.



Checking the Light Cone Diameter at a Given Point

To check the light cone diameter:
e Drag the handle that’s on the direction wire, centered in the ring.

The ring around the direction wire describes the cone diameter at that point. Notice that as you drag the handle closer
to the target, the ring expands.



Changing the Light Cone Half Angle

To change the light cone half angle:
¢ Drag the handle on the ring perimeter to change the light’s half angle.

Note: If you have the Properties palette: Light tab displayed, you can see the effect of your changes in the preview
and settings.



Changing a Light’s Angular Fall-off

To change a light’s fall-off:

1.Drag in (toward the center of the ring) on the ring handle to separate the angular fall off ring from the half angle
ring. (The fall off ring is always on the inside.)

2.Drag the fall-off ring handle to set the fall off you want.
The gap between the two rings describes the fall-off.

Note: If you have the Properties palette: Light tab displayed, you can see the effect of your changes in the preview
and settings.



Changing a Light’s Brightness

To change a light’s brightness:
e Drag the handle on the wire that extends from the light perpendicular to the direction wire.

¢ Drag away from the light to increase the brightness, or towards the light to decrease brightness.

Note: If you have the Properties palette: Light tab displayed, you can see the effect of your changes in the preview
and settings.

On a bulb light, brightness is the only control available with Direct Manipulation.



Setting Shadow Options for a Light

Objects block light and, therefore, cast shadows on other surfaces. For each light, you can choose between two
shadow types—Hard Shadows and Soft Shadows.

To set shadow options:
1. Select the light you want to set.

2.Display the Properties palette: Shadows tab.
3. Use the pop-up to choose the type of shadow you want for this light.

e Hard Shadows is the default. The edges of hard shadows end abruptly. The transition from complete
shadow to full light is immediate.

e Soft Shadows let you create a penumbra at the shadow edge. The shadow has a soft transition between
complete shadow and full light.

Note: Distant Lights are restricted to Hard shadows.



Setting Soft Shadow Options

To set soft shadow options:

1.Enter a value in the Diameter field to set the size of the light source.
A larger light source creates a wider penumbra. The penumbra width depends on the diameter of the light source
and the proximity of the source, object and shadow surface. The behavior follows what you’ll experience in the
real world, so you can experiment with a light source (lamp), object (your hand) and surface (wall or desk) to see
the penumbra-umbra transition in action.

2.Drag the Quality slider to set the number of samples.
The range is from 16 to 128. Higher values improve shadow quality, but increase render time. Each sample
represents a point on the light source that is used as the origin for ray tracing rays. The points are spaced evenly
around the perimeter and across the surface of the light.

3.Enable the Optimize option if you want to speed up a rendering.

When Optimize is disabled, the system will check every sample of the Quality setting.

When Optimize is enabled, Ray Dream 3D checks the condition of the first seven samples.

e If all seven samples are “in the umbra,” Ray Dream 3D assumes that the remainder (up to the Quality setting)
are also and skips them.

e If all seven samples are “in full light,” the system assumes that the remainder (up to the Quality setting) are also
and skips them to save time.

e If the first seven samples have any combination of umbra and light, Ray Dream 3D recognizes that this pixel is in
the penumbra and finishes checking all samples of the Quality setting to ensure shadow quality.

Note: Using the Optimize option may produce erroneous results with a light source of large diameter and objects that
are small and relatively close to either the light or the shadow surface.



About Using Gels XYY i V|

You may place an image as a mask or transparency in front of a light to project complex patterns and images on your
scene. The image you place in front of the light is called a gel.

If the gel is a 1-bit image, it becomes a mask. White regions of the mask transmit the light and black regions block it.
Bitmap gels can create intricate effects, such as the shadow of a chain-link fence, or the dappled shade under a tree.

Grayscale or color images create transparencies when used as a gel. Their image is projected into your scene, just
as a slide projector sends an image across the room. With a color image, you can achieve many effects, like sunlight
filtering through a stained glass window. An 8-bit gel will probably provide all the color you need.

Two gels types—Blinds and Gradient—are built-in gels. You may also load a texture map or movie to use as a gel. As
you adjust the settings for these gels, a preview displays to the right.



Placing a Gel on a Lightw

To place a gel on a light:

1. Select a light.
Gels are generally used on distant or spot lights. Your choice depends on the effect you want.

2.Display the Properties palette: Gel tab.
3. Choose the type of gel from the pop-up.
e None is the default. The light has no gel.
e Blinds creates horizontal or vertical stripes—venetian blinds, prison bars, etc.
e Gradient uses a blend of two colors as a gel. A gradient gel can be vertical or circular.

e Map uses a bit-mapped image file as the gel. This is the best choice when you want specific imagery in the
gel.

e Formula uses a mathematical formula to create colors and patterns in the gel. You can devise your own
formula to create a new pattern.

e Movie uses a sequence of images in the gel. This option only makes sense when you are creating an
animation.



Gel Blinds Controls 2SI Y i "

To set blinds options:
1. Select a light.

2.Choose Windows menu> Properties palette: Gel tab.

3. Choose Blinds from the pop-up.
The blind controls appear in the Gel tab.

4.Drag the Vertical number slider to set the number of vertical slats.

5.Drag the Vertical width slider to set the width of the vertical slats.
The width is expressed as a percentage of the gel frame.

6. Drag the Horizontal number slider to set the number of horizontal slats.

7.Drag the Horizontal width slider to set the width of the horizontal slats.
The width is expressed as a percentage of the gel frame.

8. Click Apply to apply the selections.



Gel Formula Controls fi e |

To select a formula for the gel:
1. Select a light.

2.Choose Windows menu> Properties palette: Gel tab.

3.Choose Formula from the pop-up.
The formula controls appear in the Gel tab.

4.1f the current formula uses the Parameter sliders, you can adjust them to change the formula result.

5.To load a new formula, click the Disk icon and choose Open from the pop-up.
Use the Open dialog to locate and open an appropriate formula. Look in the Ray Dream 3D CD: Samples:
Formulas directory for some samples to get you started.

6. Use the Open dialog to locate and open an appropriate formula.

7.1f you want to edit the formula or create your own, click More to open the Formula Editor.

Ray Dream 3D uses the Formula Editor in several places. Use of the editor is common, but the type of formula
you’re creating determines the valid input and output variables.

Note: Formula editing becomes technical quickly. You can learn a lot by loading the sample files.
8. When you’re done with the Formula Editor, click OK.
9. To save a formula, click the Disk icon and choose Save As from the pop-up.
10. Use the Save dialog to name the file and select a disk location.

11. Click Apply to apply the selections.



Gel Gradient Controls 2XSY =¥ fii "W

To set gradient options:
1. Select a light.

2.Choose Windows menu> Properties palette: Gel tab.

3. Choose Gradient from the pop-up.
The gradient controls appear in the Gel tab.

4. Select a Vertical or Circular gradient pattern.
5. Click the Start color chip and select a color from the color picker.
6. Click the End color chip and select a color from the color picker.

7.Click Apply to apply the selections.



Map Controls
The Map option lets you load an image to use as a gel.

To create a map image:

1.Use any 2D art program to create an image for the gel.
You might scan a photograph and use filters to accentuate or minimize some aspects of the image.

The gel does not need to be high resolution. If you intend to use this gel on a bulb light, create the image at an
aspect ratio of 2:1. If you are going to use this gel on a spot or distant light, use an aspect ratio of 1:1.

2.Save the image file in a format that Ray Dream 3D supports and in a convenient folder.



Loading a Map Image as a Gel

To load a map image as a gel:
1.Select a light.

2.Choose Windows menu> Properties palette: Gel tab.

3. Choose Map from the pop-up.
The map controls appear in the Gel tab.

4. Click the Disk icon and choose Open from the pop-up.

5. Use the Open dialog to locate and open the map image you saved.



Setting Map Controls

To set map controls:
1. Click the directional buttons next to the Disk icon to change the image’s orientation.

2.Drag the Brightness slider to adjust the image’s brightness.

3. Enable the Better (but slower) sampling option to view a more precise preview.
4.Enable the Invert Color option if you want to invert the image’s colors.

5.If you want the image to repeat, enable the Tile option.

6. Use the Horizontally and Vertically sliders to set the number of tiles in each direction.
7.Enable the Seamlessly option to smooth the transitions between tiles.

8. Click Apply to apply the selections.



Movie Controls fi e |

Movies create sophisticated gels for your animations. For example, you might capture some video of a tree blowing in
the wind. With a little preparation, you can load it as a gel to create a moving shadows in your scene.

A gel movie frame for a bulb light should have an aspect ratio of 2:1. A gel movie frame for a spot or distant light
should have an aspect ratio of 1:1.



Selecting a Movie for a Gel LYSTYIEW [ "N|

To choose a movie for a gel:
1. Select a light.

2.Choose Windows menu> Properties palette: Gel tab.

3. Choose Movie from the pop-up.
The movie controls appear in the Gel tab.

4. Click the Disk icon. Ray Dream 3D displays the Open dialog.

5.Locate and open a movie file.

6. When you’ve opened a movie, a preview player appears.

7.Click the directional buttons next to the Disk icon to change the movie’s orientation.
8.Drag the Brightness slider to adjust the movie’s brightness.

9. Enable the Better (but slower) sampling option to view a more precise preview.

10. Enable the Invert Color option if you want to invert the movie’s colors.

e If you want the frame to repeat, enable the Tile option. The tiled movie appears in the right preview.
e Use the Horizontally and Vertically sliders to set the number of tiles in each direction.

e Enable the Seamlessly option to smooth the transitions between tiles.

¢ You can get more information on this movie by clicking More.

1.When you’re done with the Movie Time Selection window, click OK.



Previewing a Movie in the Gel Tab 2151 /il "Wl

To preview a movie:
1. Click the Play button at the bottom of the dialog.

2. Click the Stop button when you want to stop the movie.

You can also click the Loop button to have the movie play continuously.



Using Cameras XSV i WMl

Just as a photographer strategically places cameras for different views, you will set up various cameras for viewing
your scene. After the scene is finished, you can frame the view of your scene that you want to render. Framing a
scene is similar to looking through a camera’s viewfinder.

The position and orientation of a camera is called a viewpoint. When you select a preset view, such as a top view of
your scene, your active camera (the current camera) is moved directly to that viewpoint: over your scene and pointed
downward in the case of a top view.

You may create multiple cameras, positioned anywhere in your scene, and shift the view to any of them. Using
multiple viewpoints can be quite useful.

What you see in the Perspective window is the projection of the scene through the lens of the current camera. At any
given time, only one camera is selected as the viewpoint for the Perspective window. If you open more than one
Perspective window, each has its own current camera.



The Camera’s Field of View

A camera’s settings and position determine its field of view. The field of view of the current camera does not
necessarily equal what you see in the Perspective window. The display in the Perspective window is also determined
by the size of the window and its level of magnification. You can use the scroll bars or hand tool to adjust the region of
the field of view that the Perspective window currently displays.

The camera’s field of view is not affected by zooming (the Magnifying Glass tool) or panning (with the Hand tool or
the scroll bars).

The portion of the camera’s field of view that is used for the rendering is identified by the Production Frame. The
Production Frame is similar to a real-world camera’s viewfinder. By default, the production frame appears as a green
rectangle on top of your perspective view.



Creating a New Camera STV Vi vl

To create a new camera:

e Drag the Create Camera tool from the Tools toolbar to the area of the Perspective window where you want it
placed.

e You may also drag it into the Hierarchy window to add the camera at the center of the Universe.
e You may also choose Edit menu> Insert> Camera to add the camera at the center of the Universe.

Note: If you choose Windows menu> New Perspective to create another view of your scene, Ray Dream 3D gives
you the option of creating a new camera to provide that view.

The new camera appears in your scene as a blue 35 mm camera that faces downward. The camera is an object that
has projections. You can move the camera as you would any other object.

If you want, you may change the color of camera objects in the Perspective window. Choose File menu>
Preferences: Color and set your preference. In the Hierarchy, cameras are represented by numbered camera icons.

Note: The current camera is not visible in the Perspective window. Because you are viewing the scene through it, it is
not visible within the scene.

If you set up several cameras, you might want to name them according to their viewpoints. This makes it easy to
select the view you want.



Setting the Camera Lens LYSIYEEW /i WM

You can change the properties of the current camera using the controls on the Camera Properties palette.

To change a camera’s lens:
1. Select the camera you want to change.

2.Choose Windows menu> Camera Properties.
The Camera Properties palette appears.
For convenience, the camera lens controls are also provided on the Properties palette: Camera tab.

3. Use the Type menu to select the camera you want: Conical, Isometric or IVRM Spherical.

e  The Conical camera has four settings: Normal, Wide, Telephoto and Zoom.
If you select Zoom, the slider lets you set a focal length between 6 and 500 mm.

e The Isometric camera provides a view in which object size is not related to distance from the camera (that is,
there is no vanishing point.) With an isometric camera, use a Backdrop not a Background.

e The IVRM Spherical camera creates a spherical rendering to be used with a virtual reality viewer, like the
RealSpace Traveler.



Positioning and Aiming Cameras in the Scene Lvervew (w M|

Cameras (other than the current camera) appear in the Perspective window as an object.

You can move them anywhere in the 3D workspace and change their angle with any of the standard positioning and
orientation features.



Pointing a Camera at an Objectw

The Point At command is usually the easiest way to aim a camera in the general direction of an object. Then, you can
make precise adjustments to the camera’s position and aim using the navigating tools.

To point a camera at an object:

1.1f you want to aim the current camera, select the object you want to point at.
You’ll probably find it is easiest to select it in the Hierarchy window.

If you want to aim a camera other than the current one, select the camera and the object you want to aim it at.

Note: You cannot point a camera at a light.

2.Choose Arrange menu> Point At.
The Point At command does not link the camera to the object selected. That is, if you move either element, the
camera no longer points at the object.

To direct a camera to a particular area in your scene, you can create a temporary object for the camera to point at,
then delete the object. Remember that the camera points at the hot point of the object.

If you want the camera to follow an object, apply the Point At behavior.



Following an Object with a Camera Yrervew fa .

The Point At behavior sets a camera to aim at an object. If the object moves, the camera automatically reorients itself
to point at the object in its new position.

To follow an object:
1. Select the camera you want to use.

2.Display the Properties palette: Behavior tab.

3. Click the Plus sign icon.

4. Select Point At from the dialog and click OK.

5. Enter the name of the target object—the one you want the light to follow.

6.Leave the axis option as it is.
The axis option sets which axis of the object should point at the target. For a camera, you only want to use the
axis with the viewing lens.

7.Click Apply to send your changes to the camera.

From now on, whenever you move the target object, this camera reorients to point at it.



Controlling a Camera Directly Lervew i |

The Direct Manipulation controls for a camera provides an on-screen description of the camera’s aim. You can drag
control handles to change the camera’s properties.

Note: These features are not available for the current camera. You must view the camera as an object to control it
directly.



Displaying Direct Manipulation Controls on a Camera Lrervew e .

To display direct manipulation controls:
1.Select a camera.

2.Make sure this camera is visible in the Perspective window.
For more control, you’ll want all working box planes visible so you can work with the projections.

3. Display the Properties palette: Camera tab.
4. Click the Direct Manipulation button to display the controls on the selected camera.

The controls appear as a set of wires with “handles” at certain points. Each handle represents a control you can
drag to set properties.

Note: The Direct Manipulation controls require Auto Apply enabled.

Tip: You might want to aim the camera with the Direct Manipulation controls while simultaneously seeing the result in
that camera’s view. You can do this by opening a second Perspective window and arranging them side-by-side.



Aiming a Camera ST [ vl

To aim a camera:

e Drag the handle in front of the camera.
The target handle will move parallel to the active plane. Hold down the key to drag the target perpendicular to
the active plane.

e You can drag it out, extending the wire all the way to the point you want to aim at. The wire shows the angle of
the camera’s aim.

¢ You can also aim the camera with respect to a given plane by dragging the corresponding handle on one of the
camera’s projections.

The camera rotates to aim where you place the handle.



Moving a Camera i |

To move a camera:
e Drag the handle behind the camera preview.

e You may also move the camera with respect to a given plane by dragging the corresponding handle on one of
the camera’s projections.

The camera moves to the new position and orients itself to point at the target.

To change the zoom:
e Drag a corner of the rectangle in front of the camera to change the zoom. Drag toward the target object to zoom
in.

The Rectangle in front of the camera represents the Production Frame.

Note: You can change the zoom level for the Conical or Isometric cameras.



Changing Your Perspective on the Scene Yrervew fa .

You may choose to work with one camera or several. If you are working with one, you can move it to another position
whenever you want a different viewpoint on your scene.

If you’re working with several cameras, you can simply switch the viewpoint of the Perspective window to a different
camera by selecting from your available cameras using the Camera Properties dialog.



Moving the Current Camera to a Preset Position XYY Vi Wl

You can choose View menu> Preset to change the current camera’s view to the top, bottom, left, right, front or back.
To return to the original view of your Perspective window, select the original camera or position.

To choose a preset position:
e Choose View menu> Preset Position> and select the position you want.

e You can also use the Camera Properties palette: Position pop-up.

Whenever the camera position and orientation is not at one of the presets, the Camera Properties palette: Position
pop-up displays Custom.

When you Jump Into an object or group using any of the default preset positions, the camera goes with you—that is,
it establishes the preset position and orientation relative to the local universe you’ve jumped into. A custom position,
on the other hand, is kept “as is” when you Jump In. This could result in an empty window when you Jump Into a
group. Choose a default preset or select an object and Point At it to see the contents of the group.



Navigating the Current Camera Lvervew (|

Ray Dream 3D allows you to directly manipulate the current camera using the Dolly, Pan, and Track tools and with
the Navigation panel on the Camera Properties palette.

Note: You may also select the current camera in the hierarchy and use the Properties palette: Transform tab:
Position and Orientation controls to move and aim the camera numerically.

The navigation tool icons share a space on the Tools toolbar.

e Press on whichever one is visible to “pop-up” the others and choose the one you want.

Whenever one of these navigation tools is selected, a green rectangle, the production frame, automatically appears in
the Perspective window.

The production frame acts as a viewfinder to help you frame your scene properly. It automatically disappears once
you switch back to any non-navigation tool. If the production frame is not visible at first sight, reduce your
magnification level in the Perspective window to the standard (1:1) ratio.
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To rotate the camera:

1. Select the object you want to rotate around.
If you deselect all objects, the current camera will rotate around the origin of the Universe.

2.Click the Dolly tool.
The Dolly tool moves the camera while keeping it pointed at the same spot in the scene.
The camera changes position and orientation.

3.Drag in the Perspective window to dolly the camera.

The behavior is similar to the Virtual Trackball, except in this case, it’s the camera that moves.



Panning the Camera STV [ |

To pan the camera:

1. Click the Pan tool.
The Pan tool rotates the camera on its own axis.

2.Drag in the Perspective window to pan the camera.
Hold down the Shift key to constrain panning to the vertical or horizontal.
The camera changes orientation only.

To visualize panning, imagine standing in place and looking through your camera’s viewfinder. Turn side-to-side and
tilt up and down.

Note: If you pan the camera, then decide you want to level its view, you can use Arrange menu> Align on Gravity.



Tracking the Camera ST Vil VNl

To track the camera:

e  Click the Track tool.
The Track tool moves the camera up, down, left, or right in the plane parallel to the monitor screen.

The camera changes position only.

The tracking directions are in relation to the camera’s active attitude—not to the axes of the Global Universe or
working box

To track in or out:
e When using any of the three navigation tools, hold down the Ctrl key and drag upward to move the camera forward.

¢ Hold down the Ctrl key and drag downward to move the camera back from your subject.

The camera changes position only.

Unlike zooming using the Magnifying glass, tracking in and out actually moves the camera toward or away from your
subject, effectively changing your field of view and perspective if you are using a non- isometric camera.



Using the Navigational Panel LYSTYEY [ VM|

The Camera Properties palette: Navigation panel lets you click buttons to incrementally dolly, pan, and track the
camera.

To use the Camera Properties palette’s Navigation panel:

1. Choose Windows menu> Camera Properties.
The Camera Properties palette appears.

2.1f necessary, click the Key icon to expand the palette and show the Navigation panel.
3. Click the buttons to move or rotate the camera incrementally.

4.If you like, you can change the distance or rotation amount for each click.

5. Click the Scale icon to open the Increments dialog.

6.In the dialog, set the amount and units for position controls.

7. Set the degrees for rotation controls.



Saving Position Presets ZYSTYEY i W]

If you set a camera position that you particularly like, you may add it to the presets. Your saved position will be
available on the View menu> Preset Position sub-menu in all of your scene files.

To save a position as a preset:
1. Select the camera with the position and orientation you like.

2.Display the Camera Properties palette.

3. Choose Position pop-up> Save Position.

4. Select whether to save just the Position and Orientation, the Type and Parameters or All aspects of this camera.
5. Type a name for this camera position and click OK.

To remove a preset camera position:

1. Choose Position pop-up> Delete Position.

2. Select the position you wish to remove, and click OK.



Working with Multiple Cameras

Multiple cameras can help you arrange your objects by providing different views of your scene that you can switch
between or use simultaneously. When you are ready to create a rendering, you’ll select one of the cameras as the
viewpoint to render from.

To switch the view between cameras:
e Choose View menu> Camera and select the camera you want to use.

To view from two cameras at once:
1.Open a second Perspective window.

2.Choose Windows menu> New Perspective.
The New Perspective Window dialog appears.

3. Select the camera you want or create a new one.
Each Perspective window you open increases demand on your computer, its RAM, and the hard disk—especially
when the level of display detail is high (that is, in Preview or Better Preview mode). This might slow you down.
For better efficiency, use fewer windows or switch several of them to fast preview modes (bounding box or
wireframe).

4. Click OK.



Using the RealSpace Spherical Camera

The IVRM spherical camera produces a rendering that includes every viewpoint radiating from its position—a
“spherical image.” The image is actually rectangular, but a special viewer program will wrap it onto the inside of a
sphere, where you can look at it and turn to see every angle of your scene.

The RealSpace Traveler viewer is provided with Ray Dream 3D, so you can create and view these virtual reality
views of your Ray Dream 3D scenes.

To use the IVRM Spherical camera:

1. Create a scene, centered at the origin of the Universe. Don’t forget to account for lighting in all directions.
For best results, you should create objects on all sides, above and below.

2.Drag the Create Camera tool into the Hierarchy window to add a camera at the origin (0, 0, 0) of the Universe.

3.Choose Windows menu> Camera Properties or press Ctri+E.
The Camera Properties palette appears.

4. Choose Type pop-up> IVRM Spherical.

You’re now ready to set rendering options.



Setting IVRM Spherical Camera Rendering Output Options
To set IVRM options:

1.Choose Windows menu> Scene Settings.
The Scene Settings palette appears.

2. Click the Output tab.

3. Click the triangle next to Image Size.
The image size controls appear.

4. Define the aspect ratio.
The aspect ratio of the rendering must be 2:1, but you may use whatever resolution you like—for example, 1000
pixels wide by 500 high. Although a higher resolution rendering may produce better results, it will also require
more RAM to view successfully.

5. Click the triangle next to Camera.
The camera controls appear.

6.Choose IVRM Spherical as the rendering camera.

7.Click the triangle next to File Format.
The File Format controls appear.

8.Choose JPEG as the file format from the pop-up.
9. Click the Options button and use the dialog to set your choice for JPEG compression quality.

10. Save the scene file and close the document.



Rendering with the IVRM Spherical Camera
To render:

1.Choose Render menu> Batch Queue.
Ray Dream 3D displays the Batch Queue window.

2.Click Add.

3. Use the dialog to locate and select the scene you want to render.
4.Click Open to add it to the queue.

5. Click Done to close the dialog.

6. In the Batch Queue window, click Launch.

When Ray Dream 3D finishes rendering, you’ll find two new files in the folder with your scene: a JPEG file and a
VRML file. Use the VRML file with the Traveler viewer.



About Key Event Animation XSV Vi VNl

In Studio, you create an animation by moving to different points in time and making changes in the scene to define
the state of the action at that moment. These changes are called key events. Studio automatically fills in the
transitions between key events to create the illusion of motion.

Most features in a Studio scene can be animated in this way:
¢ The motion of objects, lights, and the camera

¢ Object size, shape, and shading attributes

e Camera and light parameters

¢ Ambient lighting, background, backdrop, and atmospheric effects



About Time-Based Animation

In Ray Dream Studio 5, key events are tied to real-world time increments—minutes and seconds—rather than to
individual animation frames. This means you can create key events at specific points in time without worrying about
the number of frames in your final rendered animation.

You might work at a low frame rate (6 frames per second is the default) to preview your animation on screen. Then
increase the frame rate to render your final animation.

Once you have defined a key event, you can remove it, copy it, or move it along the time line to fine-tune the timing of
your animation.



Animatable Properties

Each characteristic of an object or effect that can be animated is called a property. A typical object or effect has many
animatable properties. Some properties, like those that define position and orientation, are common to all objects.
Other properties are specific to certain types of objects.

e Lights have special properties like brightness, fall-off and sometimes gels.

The properties of an individual object depend on several factors, including what type of object it is, and what types of
components are used in its shader.



About Properties in the Hierarchy

So that you can keep track of all of a scene’s animatable properties, the hierarchy can be expanded to show all of the
properties you can animate.

You can also control the hierarchy to limit which properties are displayed.



Changing the Property Display in the Time Line Window

To change the property display:
1.Bring the Time Line window to the front.
You can either click in it or choose Windows> Time Line of [filename].

2.Choose View> Preset Views> and select the view option you want:

e  Hide still properties—Sets the hierarchy to display only animatable properties that have key events. (This
excludes animatable properties that are constant throughout the animation.)

e Hide non-transformation properties—Limits the hierarchy to display only transformation properties.

e Hide non-existent properties—Sets the hierarchy to exclude animatable properties that have not been
applied to the object.

e Hide empty property groups—Sets the hierarchy to exclude properties that cannot be animated.



About the Fixed Animation Hierarchy

Ray Dream Animator uses the hierarchy to manage an animation internally. For this reason, the hierarchy is fixed-it
cannot change during the course of an animation. You cannot add or remove objects at specific points in time, nor
can you change groups or links. You can Cloak (hide) or Uncloak (show) an object at any point during the animation.
This allows an object to “exit” or “enter” during the course of the animation without changing the hierarchy.

The values of the properties may change over time, but the properties themselves must be constant. For example, a
spot light cannot become a distant light over time; a bitmap background cannot become a bi-gradient. Most of the
effects you might hope to achieve by changing the hierarchy over time can be achieved using other techniques.



The Hierarchy/Time Line Window
The Time Line window is the heart of the animation interface that provides tools for several basic tasks:

¢ Viewing the animation hierarchy
¢ Changing the current time
e Setting the frame rate

The Time Line window provides a visual representation of the key events that make up an animation. It allows you to
manipulate key events and move then to different points in time. The Time Line window consists of three areas:

The Hierarchy area located on the left side of the window displays the scene’s hierarchical structure.

The Time Line area to the right of the hierarchy area displays a time track for each item (object, effect, or property)
currently shown in the hierarchy area. Key event markers on these tracks represent key events in the animation.

The Time Axis extending across the bottom of the window acts as a time ruler, with marks indicating time increments
(minutes, seconds, and frames).

Note: All of the grouping, linking and organization tools of the Hierarchy are the same for producing a 3D illustration
or an animation.



Hierarchy Area Objects, Masters, and Effects Tabs

The contents of the hierarchy area (and therefore the tracks shown in the time line area) change depending on which

tab is displayed.

¢ Click the Objects tab to show a hierarchical outline representation of all of the objects, lights, and cameras in the
scene, with the Universe at the root.

¢ Click the Masters tab to show a list of the scene’s master objects.

Because the modelers operate on master objects, key events modifying an object’s shape appear on the time
track of the corresponding master object. The Masters tab is useful for viewing these key events.

¢ Click the Effects tab to show a hierarchical representation of the scene’s render effects. The general category
Render Effects is at the root.



Expanding and Collapsing Property Hierarchies

Expanding and collapsing the hierarchy allows you to control which time tracks appear in the Time Line window. This
is useful when you are editing key events on the time line.

You can expand individual objects, master objects, and effects to view their animatable properties.

To view the animatable properties of an item:
e Click a green plus/minus sign immediately to the left of its name.

A time track appears for each property. This allows you to edit the key events modifying individual properties. By
expanding and collapsing the hierarchy, you can work with as little or as much detail as you like in the Time Line
window.

Within the property hierarchy, related properties are grouped logically into categories, some of which may also
include sub-categories. For example, Transformation is a category of properties that includes the sub-category
Position and the individual properties Hot Point, Scaling, and Orientation. The Position sub-category has three
individual properties: X, Y, and Z, which together define the object’s position in 3D space.

You can expand and collapse the categories and sub-categories within the property hierarchy by clicking their
respective plus/minus signs. Individual properties are represented by small green squares rather than plus/minus
signs, indicating that they cannot be expanded any further.

Some items in the property hierarchy have no iconic representation, and no associated time track. This indicates
that the item is not a property of the parent object or effect. In the figure above, the Cube has no Link property
because no link has been assigned to it.



Scrolling and Resizing the Hierarchy Area

When you expand the hierarchy to show several levels, there may not be enough space horizontally to display all of
the names. You can either scroll the view or widen the hierarchy portion of the window.

To scroll the hierarchy area:
¢ Use the horizontal scroll bar to scroll the view of the hierarchy area.

To change the size of the hierarchy area in relation to the time line area:

1. Position the cursor over the dividing line between the hierarchy area and the time line area. The cursor changes to
indicate that you are over the divider.

2.Drag the divider to widen or shrink the hierarchy area.

3.Release the mouse button when the size is right.



About the Time Line Area

The time line area of the Time Line window displays a time track for each element (group, object, effect, property
category, or individual property) currently shown in the hierarchy.

An animation’s key events are represented by key event markers on the tracks of the time line. A marker may
represent a single key event or several coincident key events, each relating to different properties of the same object.

The key event marker appears on the track for the object or effect to which it relates. The location of a key event
marker along its track indicates the time at which the key even occurs.



About Key Event Markers on Collapsed Time Line Tracks

The term key event refers to the modification of a single property. Key event markers higher in the hierarchy—on the
tracks of groups, objects, effects, and property categories—actually represent key events that modify the individual
properties at the bottom of the hierarchy.

Whenever two or more coincident key events modify properties of the same object or effect, they are represented on
higher levels by a single key event marker. So, when you move, copy, or delete a key event marker that represents
several coincident key events, all of the key events beneath it are affected.

To manipulate the key events separately you need to expand the hierarchy to the individual property level, where the
two key events are represented by different key event markers on separate tracks.



About Overlapping Key Event Markers

Sometimes two or more key event markers appear on the same time track at nearly, but not exactly, the same time.
In other words, they may represent key events modifying the same property, or key events modifying different
properties of the same object or effect.

Depending on the current time scale (how closely you have zoomed in on the view of the time line area), these
markers may overlap. In this case, the tiny vertical mark on the top key event changes to a plus sign, indicating that
there are two or more closely spaced key event markers present.

Zooming in usually makes it easier to distinguish between overlapping key events. You can zoom in with the
Magnifying Glass tool, or click the Time Scale button and change the settings in the Set Time Axis dialog.



The Time Axis ZXETY ¥ il |

The Time Axis extends across the bottom of the window. It serves as a time ruler, with marks indicating time
increments (minutes, seconds, and frames).

The Time Axis and its related interface items—the Current Time Bar, the Time Edit Controller, the Render Range, and
the Time Scale Button—serve several important purposes:

¢ The Time Axis provides a temporal reference for the key event markers in the time line area.

¢ The Render Range (the white area of the Time Axis) indicates the beginning and end of the animation for the
purposes of previewing and rendering.

¢ The Time Scale Button allows you to change an animation’s frame rate and the size of the time increments on the
Time Axis.

e The Current Time Bar and the Time Edit Controller indicate the current time—the point in the animation currently
displayed and edited in the Perspective window.



About Time Scale and Frame Rate

The time scale describes the amount of time between each mark on the Time Axis. You can change the scale of the
Time Axis to see more time in a shorter distance, or vice versa.

The frame rate describes the number of frames displayed in each second. This applies to previews and renderings.
You can set both these options in Set Time Axis dialog.

Note: The frame rate also determines the number of tics between major time divisions on the Time Axis.



Changing the Time Axis Scale XSYEW [ Y|

To change the time axis scale:

1. Click the Time Scale button.
The Set Time Axis dialog appears.

2.Choose time scale from the Division menu.
Time scales range from 1/3 second to 2 minutes.



Setting the Animation Frame Rate ZXSTE™ /il W4l

To set the frame rate:

1. Click the Time Scale button.

2.Choose one of the frame rates from the Frame Rate menu.
The options range between 1 and 60 frames per second (fps). Typical frame rates are 15 or 18 fps for multimedia
(CD-ROM), 24 fps for film, and 30 fps for NTSC video.

You’ll probably want to use a lower frame rate for previewing, then increase the rate for final rendering.

Note: The frame rate menu in the Set Axis dialog is synchronized with the frame rate menus in the Time Controller
toolbar and the Render Settings dialog.



Snapping To Frame Boundaries

With Snapping is turned on, the Current Time Bar and key event markers will snap to individual frame boundaries
when you drag them.

To set snapping:
1. Click the Time Scale button.

2.Enable the Snap option.



Using the Current Time Bar

The Current Time Bar is a vertical red slider with an arrow that points to the current time on the Time Axis. The
content of the Perspective window reflects the state of the scene at the current time. The title bar of the Perspective
window also indicates the current time.

By default, when you drag the Current Time Bar it snaps to each tick (frame boundary) along the Time Axis. This
allows you to set the current time precisely. You can turn snapping off by clicking the Time Scale button and disabling
the Snap option in the Set Time Axis dialog.

To use the Current Time Bar:

e Drag the Current Time Bar to a different point along the Time Axis.
You can also click a point on the Time Axis.

If you drag the Current Time Bar slowly, the contents of the Perspective Window update interactively as you drag.



Using the Time Edit Controller

The Time Edit Controller, located to the left of the Time Axis and beneath the hierarchy area, displays the current time
numerically in minutes, seconds, and frames (mm:ss:ff). For example, a reading of 00:08:23 refers to the moment
that is eight seconds, 23 frames into the animation.

Note: The Time Edit Controller is synchronized with the Current Time Bar and the Time Controller toolbar.

To use the Time Edit Controller:
1. Select the minute, second, or frame field.

2.Type a new value, or use the arrows to scroll the current value.



Displaying the Time Controller Toolbar ~XSir et fril "Wl

The Time Controller toolbar contains VCR-like buttons for previewing and moving through your animation within the
Perspective window, moving forward or back one frame, and moving to the beginning or end of the render range.

The render range is the white area of the Time Axis, which determines the starting and ending points for previewing
or rendering an animation.

To display the Time Controller toolbar:
1.Choose View> Toolbars.

2.In the dialog, click the Time Controller item to enable its display.
When the item has a check beside it, Studio displays that toolbar.

Note: Like all of Ray Dream Studio’s toolbars, you can use the Time Controller as a floating palette or dock it on any
side of the screen.



Previewing an Animation i

You can use the Time Controller toolbar to preview your animation at any time. The animation will play in the
Perspective window at the current display quality. Better Preview quality is not recommended for previewing
animations.

When you preview an animation in a Perspective window, Ray Dream won’t skip any frames. If it can’t maintain the
current frame rate, the preview will take longer to play.

Reducing the frame rate will produce a choppier, but faster preview. Lowering the current display quality to wireframe
or box will speed up the preview without sacrificing smoothness of motion.

The Time Controller can also be used to change the current time. You can advance or back up one frame, or move to
the beginning or end of the render range. You can also change the frame rate. In some cases, you may want to
render a low-resolution animation for preview purposes, rather than preview the animation in the Perspective window.



Changing the Frame Rate Using the Time Controller XSS ffir Wul|

To change frame rate:

e Choose a frame rate from the Frame Rate popup.
Values range from 1 to 60 frames per second.

Note: You can also set the frame rate using the Set Time Axis dialog or the Scene Settings window: Output tab: File
Format controls.

If you are working with limited screen space, you can close the Time Line window and use the Time Controller toolbar
to change the current time as you define key events. However, you won’t be able to see the list of animatable
properties, manipulate key event markers, or apply tweeners with the Time Line window closed.



Enabling and Disabling Interactive Mode Yrervew fa .

Studio’s Interactive Mode lets you see the objects move when you preview animations using Shaded or Better
preview. When Interactive Mode is off, only projections (and bounding boxes for selected objects) move when you
preview animations in Shaded or Better preview.

To enable or disable the interactive mode:
1.If necessary, display the Rendering toolbar.

2.In the Rendering toolbar, click the Interactive Mode button.
Interactive Mode is on when the button is darkened.



Showing and Hiding an Object’s Motion Path 2ZST € /7 "l

To help you visualize the movements of your animated objects, you can choose to display motion paths. A motion
path is a line curving through space that describes where an object is located throughout the animation. Motion paths
are 3D and cast projections.

The knobs on the path describe the relative spacing of transition frames. When you change the tweener, the spacing
of the knobs changes to describe the new transition.

Note: The motion path is a visualization tool. You cannot change an object’s trajectory by editing the path directly.
Motion paths apply to objects individually, so you can show or hide them for any particular object. The control for
viewing motion paths is on the Time Controller Toolbar.

To show or hide the motion path:
1. Select the object whose path you want to show or hide.

2. Click the Motion Path icon on the Time Controller toolbar.
Studio toggles display of the object’s motion path.

Note: Remember that motion paths are available for objects individually. You must select an object before clicking
the icon to change its motion path display state.
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Key events are changes to the properties of objects and effects in your scene at specific points in time. You’ll define
key events to set the changes that create your animation. Studio automatically calculates the transitional states
between key events.

After creating key events, you may want to modify the rule (tweener) Studio uses to calculate the transitional states
between keys.

The physical force behaviors have special considerations. Their physical behaviors take precedence over arbitrary
settings. Therefore, you cannot set key events for position or orientation on any object that has physics applied.

Typically, you’ll create a key event at the beginning and end of a particular action.
To define a key event:

1. Set the current time to a time where you want to add one or more key events.
You can drag the Current Time Bar, click a point on the Time Axis, or enter a time in the Time Edit Controller to
set the time.

2.Use the standard Ray Dream Studio tools, editors, palettes, and dialogs to modify the properties of any object or
effect you want animated.
Studio places a key event marker on the appropriate track in the time line.

3. Continue creating key events for the several elements at various points along the Time Axis.

You can also add a key event directly to a time track in the Time Line window, using the Add Key Event tool. This
doesn’t change the existing action. It adds a key event at that point which you can then edit to change the timing of
the animation.

Note: Notice that every element has a key event in frame one. That’s because everything must have an initial state.



Editing the Time Line
After you’ve created several key events, you may want to change the timing of your entire animation, or synchronize
individual events within the animation.

You can edit the time line to adjust the timing and content of your animation. You can add key event markers, delete
them, or move them along the Time Axis. You can also copy and paste events between time tracks.



Selecting Key Event Markers SYSTYEY /i V|

To select a key event marker:
1. Choose the Selection tool.

2.Click on the key event marker you want to select.

e Hold down the Shift key and click additional markers you want to select.

e  You may also drag a marquee around one or several markers to select them.



Adding Key Events XYW ffir Wul|

To add a key event:
1.Choose the Add Key Event tool.

2.Click on the time track at the point where you want to add the event.

3.You can select the new key event marker and move it to change the timing.

Note: The transitions before and after the new key event use the tweener options for the previous key event.



Removing Key Events 2YSTYEW frir "ul|

To remove a key event:
1. Select one or more key event markers.

2.Press the Delete key.
You may also choose Edit> Delete.



Changing the Timing of Key Events Lervew i |

To change the timing of key events, you simply move key event markers horizontally along the time tracks to different
points along the Time Axis.

To change the time of a key event:
1.Drag the key event marker along the Time Axis to the point where you want it.

2.If you’ve selected several markers, drag one of them and they all will move.
The time intervals between the selected key events remain the same.

Ray Dream lets you to move a key event marker past neighboring key event markers on the same time track. If you
want to restrict a key event marker to stay between the previous and next key event markers, hold down the Shift key
as you drag the key event marker.
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You can duplicate a key event to another location on the same time track by holding down a modifier key while you
drag a key event marker. This is useful when you want to return an object or effect to the same state at several points
during an animation.

To duplicate key events while dragging:
¢ Hold down the Alt key and drag one or more key event markers along their time track(s).

To nudge selected key event markers:
1. Select one or more key event markers.

2.Press the left or right arrow key to move the marker one screen pixel to the left or right.

3. Hold the Shift key down and press the arrow keys to move one frame at a time.

When you duplicate an object (Ctrl+D), or Copy and Paste an object, you duplicate all of its animatable properties.
Likewise, when you copy and paste objects into other scenes, they carry their key events.
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You can stretch a series of key events over time, while maintaining the proportional timing between the events. This is

useful when you’re satisfied with the relative animation of a particular sequence, but you want the entire sequence to
be sped up or slowed down.

To compress or expand the timing between a series of key events:
1. Select three or more key event markers.

2.Hold down the Ctrl key and drag one of the selected key event markers.

The entire series of key events will be stretched or compressed, retaining the proportional timing between the
key events.
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You can copy key events from one time track to another. The key events you are copying must modify properties that
pertain to the destination track. For example, you can paste key events modifying an object’s position to another
object’s track, but not to a render effect’s track—render effects don’t have positions.

When you paste key events, they keep both the timing and the property state.

To copy key events:

¢ Select one or more key event markers.
Choose Edit> Copy.

To paste key events:

1.1n the hierarchy area, select the name of the object, group, effect, or property whose time track you want to paste
onto.

2.Choose Edit> Paste.
The key events (from the clipboard) are added to the destination track. If some of the key events copied do not
pertain to the destination track, they cannot be pasted.



Choosing XYZ Key Event Mode
Studio offers two “recording” modes for when you create a key event by translating an object (change its position):

e Mark XYZ Together
In this mode, Studio creates a key event on each of the separate X, Y, Z position tracks—even if you’ve changed
the position in only one dimension. For example, if you raise the object (change Z position), Studio places a key
event marker on the object’s Transformation: Position: X, Y and Z time tracks. Mark XYZ Together is the default
mode.

e  Only Mark Changed
In this mode, Studio creates a key event only on the necessary X, Y, Z position tracks. For example, if you raise
the object, Studio places a key event marker on the object’s Transformation: Position: Z time track. Because you
didn’t change X orYY, there’s no event on these tracks.

The two modes produce different results when you create and play the animation. You’ll need to set the mode you
want to use before translating the object to create key events.

To set the mode:

e Choose Arrange> XYZ Key Event Mode> and select the mode you want—Mark XYZ Together or Only Mark
Changed.



Using a Key Event Action ZXETYEY i vl

Studio provides some special features for duplicating and modifying a series of key events. You can reverse, repeat
or mirror a key event sequence. You can also adjust the positioning of the events so that they coincide with the start
of the next frame.

1. Choose the Selection tool.
2.In the Time Line window, adjust the display to show the sequence of key events you want to work with.
3.You may need to change the time scale or expand the properties of an object.

4. Select each marker in the sequence.
You may drag a marquee or Shift-click.

5.Choose Arrange> Key Event Action> and select the action you want:

e Reverse—Studio flips the order of the events so that the last becomes first and vice versa.

e Repeat Sequence—Studio duplicates the sequence and places the duplicate immediately after the selected
sequence.

e Mirror Sequence—Studio duplicates the sequence, reverses the duplicate, and places it immediately after
the selected sequence.

e Snap to time—Studio adjusts the positioning of the selected events so that they coincide with the start of
the next frame



About Tweenersw

Tweeners make it easy to create more interesting and subtle changes in the transitions between key events.
Tweeners will save you time by automatically creating movements and changes that would be extremely difficult with
key events alone. Tweeners make your animation motions and other changes more natural and sophisticated.

The time period between any two key events is considered a transition. In the Time Line, you’ll see the transition as
the “gap” between key event markers. Studio uses a formula (the “tweener”) to create the transitional states so that
the object or effect changes smoothly between the two key events.

You won’t always want a smooth, linear transition. Sometimes you’ll want an abrupt change of state. Other times
you’ll want a transition that starts slowly and accelerates to finish in a rush. You might even want a transition that
quickly alternates between the before and after states, like a florescent light flickering on.

All of these transitions are possible by setting your options for the tweener used between each pair of key frames. A
tweener requires a beginning and an ending key event, although you can place the ending key event far out in time.

Note: The term tweener is derived from “in-between.”



Applying Tweeners o € (Vi Wl

Every “gap” between key events on the time track must have a tweener. The default tweener is Linear, which
produces an even rate of change between the two states. You can achieve a different sort of transition by applying a
different tweener.

To apply a Tweener:
1. Set up beginning and ending key events.

2.Double-click the time track segment between the two key event markers.
The Transition Options dialog appears.

3. Select a tweener type from the menu.

4. Set the appropriate controls for the tweener.
As you move the handles on a slider, the graph reflects the new settings.

5. Click OK to close the dialog.

Note: Notice the small graphic on each segment of the time track. This graphic indicates the kind of tweener that is
applied.
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The linear tweener creates smooth transitions. When the graph line is straight, from the bottom left to the top right
corner, the transition proceeds at an even rate from start to finish. This is the default, but you can change it.

To set Linear Tweener options:

The two handles on the Ease-In/Ease-Out slider on the Linear tweener modify the rate of change at the beginning
and end of the transition.

e Drag the left handle to the right to start slowly.
e Drag the right handle to the left to finish slowly.



Setting Discrete Tweener Options Urervew W M|

The Discrete tweener maintains the values from the key event that begins the transition until a specific time in the
transition is reached. Then the values abruptly change to those of the key event that ends the transition. Use the
Discrete tweener when you want a property to change immediately, like switching on a light.

To set Discrete Tweener options:
¢ Adjust the Threshold slider to specify the exact point during the transition where you want the change to occur.

The threshold value is a percentage of the transition’s entire duration. For example, if you want the discrete
change to occur halfway between the key events, set the threshold to 50%. If you want the change to occur at
the time of the first or last key event, set the threshold to 0% or 100%, respectively.
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The Bézier tweener is designed especially for creating smooth motion paths.

The Bézier tweener has two controls that you can adjust—Ease-In/Out and Tighten-In/Out.

To set Bézier Tweener options:

1. The two handles on the Ease-In/Ease-Out slider on the Linear tweener to modify the rate of change at the
beginning and end of the transition.

2.Do one of the following:
e Drag the left handle to the right to start slowly.
e Drag the right handle to the left to finish slowly.

The Tighten In/Out slider allows you to adjust the trajectory of the transition—the “path” the values take as they
change from one key event to the next.

Do one of the following:
e Drag the left handle to change the initial trajectory.
e Drag the right handle to change the finishing trajectory.
Values near the extremes (0% and 100%) result in tighter trajectories (closer to linear). Values near 50% result in

looser (less direct) trajectories. The default settings (33% in and 67% out) are optimized for natural, smooth
motion.
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The Oscillate Tweener switches back and forth between the start and end values several times during the transition
You can choose between several wave forms to describe the alternation.

To set Oscillate Tweener options:

1. Click the radio button to choose the wave shape you want.
The graph of the wave shape shows how the switch occurs between up and down phases.
The Sine wave uses a sine curve to alternate the before and after values.
The Square wave alternate back and forth between the first and last key events with no interpolation.
One way to make a light blink at one second intervals is to turn the light on and off by setting key events every
second on the light’s time track. A more efficient way is to turn a light on at Event A and then turn it off, perhaps
ten seconds later, at Event B. Afterwards, apply the Oscillate Tweener, and specify ten oscillations (using the
Square wave so that the switches are abrupt). The Oscillate tweener will switch the light on and off ten times
during the ten-second interval, using only two key events and a single tweener.
The Saw/Loop wave interpolates linearly from its beginning value to its ending value, then snaps back abruptly to
the beginning value in each oscillation.

You can use this option to replicate an action, such as hitting a gong. The character’s arm is first placed in a
drawn back position, moves to strike the gong, and then snaps back. You can also use Saw/Loop to play a movie
from start to end in a loop.

The Triangular wave shape causes the transition to alternate back and forth more abruptly between the
beginning and ending values than does the Bounce wave form.

2. Adjust the Number of Oscillations slider to set the number of times the values should alternate.

3. Adjust the Damping slider to progressively diminish the amplitude of the oscillations.
After each oscillation, the amplitude diminishes by the damping factor percentage.

4. Adjust the Up Phase slider to control how much of each oscillation is dedicated to the “up phase.”

For example, if you set the Up Phase value to 90%, the object spends 90% of the oscillation changing from A to B
and only 10% changing from B to A.



Animating Object Shape
You can change the shape of an object over time. This is as easy as jumping into the object and changing its shape
to create a key event. 3D creates the transitions necessary to “tween” the original into the modified shape.

The type of object determines which modeler you’ll use when you jump in and, therefore, what modifications you can
make. For example, with the Free Form Modeler, you can edit the cross sections, sweep path and scaling envelope.
But with the volumetric primitives, like Fire and Cloud, you’ll use sliders to change the character of the object.



Free Form Modeler_Ml

Ray Dream 3D allows you to change the shape of a free form object during animation using the Free Form Modeler.

There are some limitations in the kinds of changes you can make in your models, but generally you can edit all
existing cross sections and points on an extrusion path or scaling envelope.

You cannot add or delete cross sections or points, or change the basic structure of the object.



Creating Free Form Models Whose Shapes You Want to Animate 2SN frir T|

To create free form models to animate:

1. Create all of the control points for the extrusion path.
You cannot add or delete points during the animation, so you must create all you’ll need at the outset.

2.Create all of the cross sections, with all of the control points.

Start with the most complex shape your object will have during the entire animation. You can pull the control
points close together at first, and then pull them apart as the object changes shape.



Animating a Free Form Shapew

To animate a free form shape:
1. Set the current time bar to the point where you want the key event to occur.

2. Display the hierarchy Masters tab.
3.In the Master’s tab, double-click the name of the object whose shape you are animating.
4.You may also select it, then choose Edit> Jump In.

5.1In the Free Form Modeler, adjust the points and curves of any cross section, extrusion path or envelope line.
You may not add or delete points or add a cross section shape.

6. When you are finished changing the object shape, click Done.

You can now change the tweener between this event marker and the previous one to set the transition method.



Animating a Primitive Shape

To animate a primitive shape:
1. Create the primitive and adjust its attributes at the start of the animation.

2.The “Completion of ...” slider sets the current moment of the animation.
In most cases, the slider should be at zero at the start of the animation.

Note: Fogrises, Fire burns and the Fountain spews. The Cloud, however, is static. Therefore, the Cloud
modeling dialog does not have a Completion slider.

3. When you’re finished setting the attributes, click Done to close the volume modeler.
4. Set the current time bar to the point where you want the key event to occur.
5. Display the hierarchy Masters tab.

6. In the Master’s tab, double-click the name of the object.
You may also select it, then choose Edit> Jump In.

7.In the Attribute Dialog, adjust the “Completion of ...” slider to the percentage that describes how much of the
object’s animation should be accomplished at this point.
Assuming that this is the end of the animation, set it to 100%.

8. You can adjust other attributes to change the characteristics of the object.
For example, you might want the Fire to change the quantity of flames or its upward speed.

9. When you are finished changing the object shape, click Done.

You can now change the tweener between this event marker and the previous one to set the transition method. For
example, to get flickering flames, you can use the Oscillate tweener.



About Animating Motion

Complex motion is generally animated by moving (translating) an object to various positions along the desired motion
path and creating key events at each position.

The Bézier tweener can then be applied to smooth the motion. When animating along simple, curved paths, however,
it is often easier to offset an object’s hot point and animate its motion using rotation rather than translation.

An object always rotates around its hot point. By default, an object or group’s hot point is at the center of its bounding
box; however, you can move the hot point anywhere, even some distance from the object.

For example, you can point a camera at an object and move the camera’s hot point to the center of the object. You
could then rotate the camera around its own hot point to animate a “fly-around” of the object. This approach generally
requires fewer key events than creating a similar motion path in the usual way, and produces equal or better results.



About Duplicating Relative Motion with Groups

Duplicating an object or effect also duplicates its animation data (its key events and tweeners). When key events are
duplicated in this fashion, the values of the original object’s properties are copied exactly to the duplicate. In the case
of motion, this does not always produce the desired results.

When an object is animated within a group, its position is animated relative to the group, not relative to the global
coordinate system. Therefore, when the group is duplicated and offset, the animated object in the duplicate group
moves along its own motion path, within the group.



About Cloaking an Objectw

When you want to have an object enter or exit (appear or disappear) during the course of your animation, you’ll use a
technique called cloaking. Cloaked objects are visible and can be manipulated in the Perspective window; they simply
are not included in the rendering of your animation.

You can take advantage of cloaking to switch one version of an object for another version of the same object. This is
advantageous when the two versions have contradictory properties, which you need at different times of the
animation. As long as the two objects look the same, occupy the same space, and cloak and uncloak in the same
frame, the exchange from the one to the other will be seamless.



Cloaking or Uncloaking an Object at a Specific Time LYSTYEW frir "ul|

To cloak or uncloak an object:
1. Select the object.

2.Display the Properties palette: General tab.

3.Enable or disable the Cloak check box.



About Rotoscoping

Rotoscoping is a general term that describes using video or selectively inside another movie. You can add live action
or moving textures to your scene by rotoscoping with animations or digitized videos (movies) in your animation.
Rotoscoping adds realism and visual excitement to your animations.

You can use any Microsoft Video (AVI) file for rotoscoping. You can use movies in any of the following places:

e texture map or paint shape on an object—including in non-color channels, like Bump.

e Background or backdrop.

e Light gel.

A movie is saved as a separate file. Its pathname is relative to the animation file it’s used in. When you move a file
with rotoscoping, be sure to maintain the relative path to the movie file.

Rotoscoping is visible on objects in Better Preview mode, but is not displayed on backgrounds, backdrops and in gels
until you render the animation.



About Synchronizing Movie Frames STV [l Wl

When you apply a movie, 3D creates two key events—one at the start and one at the end of the movie.

The ending event marker is placed according to the duration of the movie—not the number of frames it has. This
means that the frame rate of the movie should be compatible with the rate of the animation.

It isn’t necessary that the movie begin at frame 1. You can start at a later frame by synchronizing the movie to the
animation.



Synchronizing a Movie with an Animation 2250 <¥ (7l "

To synchronize a movie with an animation:
1. Set the current time bar to the moment (frame) where you want to synchronize the animation.

2. Select the object or light that has the movie rotoscoped onto it.
(This isn’t necessary for a background or backdrop.)

3. Display the tab or window containing the rotoscope movie controls.
For a texture map, display the Current Shader Editor.
For a light, display the Properties palette: Gel tab.
For the background or backdrop, display the Scene Settings window: Effects tab: Background or Backdrop
controls.

4. Use the preview controls to advance to the movie frame you want synchronized with the current frame of the
animation.

5. Apply the change.



Looping a Movie XYY i |

To loop a movie:
1. Apply the movie at the start of the animation.

2.Drag the end-of-movie key event marker out as far as you want the movie to continue.
3. Double-click between the two movie key event markers.

4.Choose the Oscillate tweener

5. Choose the Saw/Loop Wave Shape.

6. Set the Up Phase slider to 100%.
This rewinds the movie instantly after each cycle.

7. Adjust the Number of Oscillations slider to set the number of times the movie should repeat.
Each up slope in the graph represents one time playing the movie.

8. Close the Transition Options dialog.

For precise work, you’ll want to calculate the correct number of oscillations based on the number of frames in the
movie and the duration of the animation. You can adjust the end-of-movie marker, if necessary.



About Animating Shaders

Animating shaders opens a wide range of possibilities. You can animate virtually any type of change to a shader that
you can imagine, from a simple color change to a shifting geometric pattern. You can even make an object appear to
change from bricks to glass, or from marble to metal.

The only limitation is that you cannot replace one shader component with another during the course of an animation.
You cannot, for example, replace a Wood function with a Spots function at a particular point along the time line.
Thanks to the flexible, modular nature of the Shader Editor, this turns out to be only a minor limitation.

Animating simple changes to shaders is straightforward. You just use the Shader Editor to adjust the parameters of
individual shader components at specific points along the time line. Examples of parameters you can adjust include:

e Colors
¢ Values for attributes like transparency, shininess, etc.

e Procedural function parameters, like the number of squares in a checker pattern, or the undulation of the veins in a
wood pattern



Animating Shaders with the Global Mix and Mix Components

The Global Mix option in the Shader Editor allows you to animate more drastic changes to an object’s shader. In the
following example, a Global Mix is used to create a shader which animates gradually from bumpy, opaque wood to
smooth, transparent glass.

To build this animatable shader, a wood shader and a glass shader were first created separately and stored in the
Shaders Browser. A new shader was then created.

¢ The Global Mix option was chosen from the Components menu in the Shader Editor. A Global Mix mixes all shader
channels at once, so the individual channel tabs disappear when Global Mix is selected.

¢ The original wood and marble shaders were dropped into the left and right branches of the tree, respectively.
¢ A Value component was placed in the lower branch, to be used as the mix function.

The value set in this Value component determines the contribution of each original shader to the mix. When the value
is zero, the wood shader contributes 100%. When the value is 100, the marble shader contributes 100%. When the
value is 50, the two shaders are mixed equally.

To animate this shader, only the value component needs to be altered over time. To animate gradually from wood to
glass, you would set the value to zero at one key event and to 100 at the next.

The same technique can be used to animate between different types of components within a single shader channel,
except that you would use a Mix component instead of a Global Mix. This technique also allows you to animate a
cross-fade between two bitmapped images or movies. Just put the two bitmaps or movies in the left and right
branches of the Mix.



Rotoscoping in Non-Color Shader Channels

The most common use of rotoscoping is in a shader’s Color channel, where it allows a movie to be played on the
surface of an object. However, rotoscoping can also be used in other shader channels to create stunning visual
effects.



About Renderingw

Rendering is the process of capturing a view of your three-dimensional scene and saving it as a 2D image. An image
has to be rendered before you can print it or open it in an image editing or page-layout program.

Rendering is analogous to taking a photograph of your scene. The result is photorealistic because the final rendering
procedure considers all of the objects in a scene simultaneously and calculates not just forms, color, and texture, but
the interaction of lights and surfaces within the scene.

Since your scene exists in three dimensional space you can take any number of renderings of it—from different
angles and even with different lighting conditions. If you created an object in a 2D drawing program and wanted to
look at it from another side, you would have to redraw the object. In Ray Dream 3D, you simply move the camera to
another view and re-render the scene.

Arendering is a separate file and is stored on disk in a different format. Ray Dream lets you save renderings in many
popular image formats: PICT and EPS (Macintosh only), Windows Bitmap (BMP), TIFF, Adobe PhotoShop, and
others. You can print your renderings, open them in an image-editing program, or place them into virtually any
application.



The Rendering Procedure XS it V|

When you’ve built a scene, set lights, and chosen a viewpoint, you are ready for rendering. You’ll probably render
your scene several times—the first couple of renderings will be low resolution proofs, so you can check your work.

You can also use the Render Preview tool to marquee an area of your scene and ray trace it directly in the
Perspective window. (The ray tracing prepared by the Render Preview tool will not show your Reflected
Background/Backdrop.)

At each proof stage, you may want to change your Rendering Settings, depending on the image aspects you want to
check. For example, if you just want to look at the objects, you might use the Production Z-Buffer. Or if you’re
concerned only with shading and shadows, you might turn off the other ray-tracing options, like reflections and
transparency, which add to rendering time. Then, after correcting anything that didn’t turn out as expected, you can
generate the final, high resolution rendering.



Overview of Rendering Steps Lrervew (.

Ray Dream offers a number of options and settings for controlling rendering. To get the rendering results you want,
you’ll need to make several choices and adjustments.

Your choices will be based on your expectations—whether you’re creating a draft rendering to check the objects,
rendering final artwork, or rendering an animation.

Before you render:

1. Arrange the objects in the scene.
Apply shaders to give the objects interesting surfaces.

2.In the Perspective window, add lights to illuminate the scene.

3. Set your rendering options using the tabs in Scene Settings window.
Options include rendered image size, file format, and post-render filters for special effects.

4. Display the production frame and adjust the position and settings of the camera to frame the view of the scene you
want rendered.

5. Adjust Ambient Light, Background, and Atmospheric settings.

6. Once you have verified that all settings are correct, you can start the rendering with one of the Render commands.



Setting Rendering Preferences for Individual Objectsw

Each object has two preferences that instruct the ray tracer (and Adaptive renderer) how to deal with it. These
preferences concern reflection and refraction, and you’ll only need to change them if you want the renderer to deal
with a particular object differently.

To set an object’s rendering preferences:
1. Select an object.

2.Display the Properties palette: Rendering tab.

3. Use the Reflection Feature pop-up to set whether or not this object is reflective—No Reflections or Ray-traced
Reflections.

4.If this object does show reflections, set the Reflection Feature controls: Maximum depth value to limit the number of
ray reflections.
If two reflective surfaces face each other, the rays would bounce back and forth between them indefinitely. The
Maximum depth value sets the number of bounces before the renderer stops.

5. Use the Refraction Feature pop-up to set whether or not this object is refractive—No Refractions or Ray-traced
Refractions.
If this object does refract, set the Refraction Feature controls: Maximum depth value to limit the number of
refractions.
If multiple refractive objects align, the rays would bend from one to the next, through all objects. This would take
an exceedingly long time to render and wouldn’t contribute to image quality. The Maximum depth value sets the
number of refractions before the renderer stops.



Setting Default Rendering Preferences Lvervew (w |

You can choose certain rendering options as defaults so they will be set in every new scene.
To set rendering default preferences:
1.Choose File> Preferences.

2.Choose Render Features from the main pop-up.

3. Use the pop-ups to choose default settings for Shadows, Reflections and Transparency.



Setting Scene Rendering Options Lrervew i .

The Scene Settings window provides four tabs for controlling rendering: Renderer, Effects, Filters and Output.
To set rendering options:

1.Choose your selections in the Scene Settings dialog.
2.Click OK to save these settings with your scene.
3. Click Load to have the new settings appear in the Render command.

To display the Scene settings window:
e Choose Windows> Scene Settings for filename.



The Scene Settings Renderer Tab LYETYEY [ W

3D offers four rendering engines to choose from: Adaptive, Draft Z-Buffer, Ray Tracer, and Natural Media. Each has
an advantage when you’re looking for a particular result.

¢ The Adaptive renderer adapts the rendering method for different regions of the scene. It uses ray tracing where it’s
required for bump maps, reflections, shadows, etc. And it switches to an accelerated A-Buffer renderer for other
regions. The Adaptive renderer produces anti-aliased edges on objects.

e The Draft Z-Buffer is an excellent choice for fast proofing. The quality it produces is similar to that of Better Preview
mode in the Perspective window.

e The Ray Tracer calculates the effects of light rays from your light sources as they encounter the objects in your
scene. Ray tracing shows most of the “real world” lighting effects, including transparency, shadow, reflection,
and bump maps.

e The Natural Media renderer produces interesting, stylistic renderings of the scene.

To choose the renderer you want to use:
1. Display the Scene Settings window: Renderer tab.

2.Choose the renderer you want from the pop-up menu.
The panel updates to show the options for this rendering engine.
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To set adaptive renderer options:
1.Enable the Shadows option to render shadows.

2.Enable the Reflections option to render reflections on reflective surfaces.

3.Enable the Bump option to render bump effects on objects.

4.Enable the Transparency option to render transparent objects.

5.Enable the Refracted transparency option to render refraction effects through transparent objects.
6. Enable the Light through transparency option to render lighting effects through transparent objects.
7.Click a radio button to choose the level of Anti-aliasing you want—None, Edges or Better.

8. Adjust the Silhouette Quality slider to set the accuracy for the edges of objects.
Note: Increasing Silhouette Quality increases rendering time and RAM requirements.

9. Adjust the Maximum Ray Depth slider to set a limit on the number of interactions allowed for rays that reflect or
refract.

Note: You can limit ray depth for individual objects.



Setting Draft Z-Buffer Options 2SS (Vi Wl

To set Draft Z-Buffer options:

1. Click on the Reflected color swatch to select the reflection color.
The reflected color appears in all areas that would show reflections in ray tracing.

2.Click on the Transparent color swatch to select a transparency color.
The Transparent color appears in all areas that would show transparency in ray tracing.

3. Enable the No shaders option if you want to see the objects without their applied shaders.



Setting Ray Tracer Options Yrervew fa .

To set ray tracer options:
1.Enable the Shadows option to render shadows.

2.Enable the Reflections option to render reflections on reflective surfaces.

3.Enable the Bump option to render bump effects on objects.

4.Enable the Transparency option to render transparent objects.

5.Enable the Refracted transparency option to render refraction effects through transparent objects.
Reflectiveness, transparency, refraction and bump are shader characteristics. You’ll apply shaders to develop
these effects on particular objects.

6. Enable the Light through transparency option to render lighting effects through transparent objects.

7.Click a radio button to choose the level of Adaptive Oversampling you want—None, Fast or Better.
Adaptive oversampling renders at a higher resolution, then resamples the picture to produce a smoother, anti-

aliased image.

8. Adjust the Silhouette Quality slider to set the accuracy for the edges of objects.
Note: Increasing Silhouette Quality increases rendering time and RAM requirements.

9. Adjust the Maximum Ray Depth slider to set a limit on the number of interactions allowed for rays that reflect or
refract.

Note: You can limit ray depth for individual objects.
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To set natural media renderer options:
1. Use the pop-up to choose the rendering style you want.

2. Adjust the sliders and set your other options to control the effect.

3.When you’ve changed object position or geometry in the scene, click the “Update Geometry” button.
3D rebuilds the preview with the new scene data.

Note: There may be more information on Natural Media rendering in the Read Me documentation.
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Ray Dream 3D provides some environment options to help complete the appearance of your scene in renderings.
These options include:

e Ambient Light
e Atmospheres
e  Backgrounds

e  Backdrops

Atmosphere
Ray Dream 3D offers two types of fog effects: Distance Fog and Cloudy Fog.

¢ Distance Fog produces an effect like a haze, which is more apparent across greater distances. This fog has
uniform density.

¢ Cloudy Fog produces an effect that simulates the irregular “clumping” of clouds.

Atmospheric effects are only visible in the final rendered image.



Using Distance Fogw

Distance Fog produces an effect like a haze, which is more apparent across greater distances. This fog has uniform
density.

To use distance fog:

1. Display the Scene Settings window.
Choose Windows menu> Scene Settings for filename.

2.Display the Scene Settings: Effects tab.

3. From the Atmosphere pop-up, choose Distance Fog.
3D displays the Distance Fog controls.

4. Click the Fog Color swatch to set its color.
3D opens the system color picker so you can choose a color.

5.Enter the Fog Starts distance.
This is the distance from the camera where the fog begins.

6. Enter the visibility distance.
This is the distance beyond the start of the fog where it becomes so thick that visibility becomes zero.

The results of these settings will be visible in the final rendering. You may return to these settings, make changes,
and render again.



Using Cloudy Fogw

Cloudy Fog produces an effect that simulates the irregular “clumping” of clouds.
To use cloudy fog:

1. Display the Scene Settings window.
Choose Windows menu> Scene Settings for filename.

2.Display the Scene Settings: Effects tab.
3. From the Atmosphere pop-up, choose Cloudy Fog.

4. Click the Fog Color swatch to set its color.
3D opens the system color picker so you can choose a color.

5. Enter values for Top and Bottom.
These values define the range, above the ground plane, where fog appears.

6. Set the Density slider.
Density determines fog thickness.

7.Set the Lumpiness slider.
Lumpiness determines how much the fog clumps together.

8. Set the Global Scale slider.
Global Scale determines the spacing between the wisps of fog are.

The results of these settings will be visible in the final rendering. You may return to these settings, make changes,
and render again.



Backgrounds and Backdrops Lrervew (.

When you render your scene, regions where there are no objects are considered background areas. By default, these
areas appear white in the renderings. 3D offers two features for filling in the space between objects—Background
and Backdrop.

Background

The Background gives you control over the scene environment. The Background is sometimes called an environment
map. During rendering, the background is projected on the inside surface of a giant sphere that surrounds your
scene. Any region of a rendering not occupied by an object will show the background. The background is also the
environment reflected by reflective objects.

You may choose the type of background you want: Image, movie, color, or bi-gradient. The background is only visible
in your final ray-traced image.

Note: An isometric camera cannot record a Background. If you are using an isometric camera for your final
rendering, you must use a Backdrop instead.

Backdrop
The Backdrop is a colored screen placed behind your scene. The Backdrop appears in regions of the rendering
where there are no objects. The Backdrop does not appear in reflections or interact with the lighting.

You might want to use both a Backdrop and a Background. In this case, 3D uses the Background for the reflection
environment and places the Backdrop behind the objects.
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To use a reflected background:

1. Display the Scene Settings window.
Choose Windows menu> Scene Settings for filename.

2.Display the Scene Settings: Effects tab.

3. From the Background pop-up, choose the type you want.

None creates no Background in the scene. The background areas appear white in the final rendered image.
Bi-Gradient creates a paired gradation for the Background. This is an easy way to create a sky and horizon.

Map uses a bit-mapped image file as the Background. This is the best choice when you want specific
imagery in reflections.

Color sets a solid color as the Background. Open the controls and click the color swatch to choose a color.
Formula creates a color pattern from a formula. You can devise your own formula to create a new pattern.

Movie uses a sequence of images in the background. This option only makes sense when you are creating
an animation.



Using a Backdropw

To use backdrop:

1. Display the Scene Settings window.
Choose Windows menu> Scene Settings for filename.

2.Display the Scene Settings: Effects tab.
3. From the Backdrop pop-up, choose the type you want.

e None creates no Backdrop in the scene.
e Bi-Gradient creates a paired gradation for the Backdrop.

e Map uses a bit-mapped image file as the Backdrop. This is the best choice when you want specific imagery
behind your objects.

e Color sets a solid color as the Backdrop. Open the controls and click the color swatch to choose a color.
e  Formula creates a color pattern from a formula. You can devise your own formula to create a new pattern.

e Movie uses a sequence of images in the Backdrop. This option only makes sense when you are creating an
animation.



Using a Bi-Gradient for a Background or Backdropw

To use a bi-gradient:

1. Choose Bi-Gradient from the pop-up where you want to use it—Background or Backdrop.
2. Click the plus/arrow icon to display the Bi-Gradient controls.

3. Choose colors for the Top (“Sky”) and Bottom (“Sea/Ground”) Start and Stop colors.

4. Click the color swatch and use the system color picker to choose a color.

5. Adjust the “Limit between top and bottom slider” to control the height of the horizon.
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To choose a formula:

1.Choose Formula from the pop-up where you want to use it—Background or Backdrop.

2. Click the plus/arrow icon to display the Formula controls.

3.If the current formula uses the Parameter sliders, you can adjust them to change the formula result.

4.To load a new formula, click the disk icon.

5. Use the Open dialog to locate and open an appropriate formula.
The formulas for a Background or Backdrop differ. Remember the Background is projected onto a sphere, so it
uses a 3D system. The Backdrop is rectangular, so it uses a 2D system.

6. If you want to edit the formula or create your own, click More to open the Formula Editor.
Ray Dream 3D uses the Formula Editor in several places. Use of the editor is common, but the type of formula
you’re creating determines the valid input and output variables. Formula editing becomes technical quickly. You
can learn a lot by loading the sample files.

7.When you’re done with the Formula Editor, click OK.

8.To save a formula, press on the disk icon and choose Save As from the pop-up.

9. Use the Save dialog to name the file and choose a disk location.



Map Controls
The tools and methods for using a map are the same for the Background or Backdrop.

Ideally, images for the Background should have an aspect ratio of 2:1 (twice as wide as they are tall).

Images for the Backdrop should have the same aspect ratio as the final rendering and be equal or greater in

L]
resolution. You can set the final rendering image size in the Scene Settings window: Output tab: Image Size

control.
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To select a map:

1.Choose Map from the pop-up where you want to use it—Background or Backdrop.
2. Click the plus/arrow icon to display the Map controls.

3. Click the disk icon.
3D displays the Open dialog.

4.Locate and open a bitmapped image file.

5.When you’ve opened an image, a preview appears in the left panel.

6. You can click the directional buttons to change the image’s orientation.
7.You can reduce the image’s brightness with the Brightness slider.
8.Enable the Better (but slower) sampling to view a more precise preview.
9. Enable the Invert Color option if you want to invert the image’s colors.

10. If you want the image to repeat, enable the Tile option.
The tiled image appears in the right preview.

11. Use the Horizontally and Vertically sliders to set the number of tiles in each direction.

12. Enable the Seamlessly option to smooth the transitions between tiles.
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To select a movie:

1.Choose Map from the pop-up where you want to use it—Background or Backdrop.
2. Click the plus/arrow icon to display the Movie controls.

3. Click the disk icon.
3D displays the Open dialog.

4.Locate and open a movie file.

5.When you’ve opened a movie, a preview appears in the left panel, and a preview player appears in the right.
6. You can click the directional buttons to change the movie’s orientation.

7.You can reduce the image’s brightness with the Brightness slider.

8.Enable the Better (but slower) sampling to view a more precise preview.

9.Enable the Invert Color option if you want to invert the movie’s colors.

10. If you want the frame to repeat, enable the Tile option.
The tiled movie appears in the right preview.

11. Use the Horizontally and Vertically sliders to set the number of tiles in each direction.
12. Enable the Seamlessly option to smooth the transitions between tiles.

13. You can get more information on this movie by clicking More.
3D opens a window that provides technical information and a movie preview player.
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The render filters create special effects in the image after it has been rendered. Actually, they’re post-render filters.

The filters include lens effects that simulate the results obtained from photographic cameras and special lighting
effects.
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All of the filters have settings that you can change to create key events. The results of animating filters can be
dramatic. For example, by animating the Depth of Field filter, you can have the camera focus on the foreground, then
gradually move its focus to a background object over the course of the animation.

To do this, you need to set the Depth of Field focus (on the foreground) in the first frame, then move later in time and
set the Depth of Field focus (on the background) to create a key event. You can change the tweener to modify the
focus transition—have it accelerate, for example.

All of the effects can be animated in this way. Most of them have several settings you can animate.
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To apply a render filter:

1. Display the Windows> Scene Settings window: Filters tab.

2. Click the Plus button.
3D opens a dialog with a list of the available post-render filters.

3. Choose the filter you want to apply. Click OK.

4.1n the Filters tab, set the options for the filter.
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The Depth Of Field filter simulates the lens of a real life camera. The Depth Of Field filter post-processes the
rendered picture by blurring the objects according to their distance from the rendering camera. Depth of Field is a
post-render filter. It does not change the rendering camera itself. You can also choose or design your own lens to
change the depth of field range from macrophoto to telephoto.

Note: Normally, every object appears in focus regardless of its distance from the camera.

To set depth of field options:

1. Click one of the radio buttons to chose the preview quality:
x1—high quality (slower)
x2—normal quality
x4—Ilow quality (faster)

2. Click the Preview button to generate a preview of your scene.
This takes a few moments.

3. Click the red cross button to select the tool for setting the plane of focus.

4.Click in the preview on the object that you want to be in focus.
3D puts a red cross on the point where you click and sets this distance as the plane of focus.

5. Set the range for the depth of field.
You have three options to do this:
e By using the blue and green crosses and clicking in the preview.
e By dragging sliders on the blue and green Distance sliders on the graph.
e By choosing a preset.

To use the click tools:
1. Click the green cross button to select the tool for setting the foreground out-of-focus plane.

2.Click in the preview on the foreground object that you want to be 50% out-of-focus.
You cannot select a foreground object that is behind the in-focus object.
3D puts a green cross on the point where you click, sets this distance as the plane of 50% out-of-focus, and
updates the Depth Of Field curve.

3. Click the blue cross button to select the tool for setting the background out-of-focus plane.

4.Click in the preview on the background object that you want to be 50% out-of-focus.
Note: You cannot select a background object that is in front of the in-focus object.
3D puts a blue cross on the point where you click, sets this distance as the plane of 50% out-of-focus, and
updates the Depth Of Field curve.

To use the Distance sliders:
You must set the plane of focus with the red cross when using the sliders.

1.Drag the blue slider on the Distance bar to set the distance of the 50% out-of-focus background plane.
If you want background objects to stay in focus, move the blue slider all the way to the right.

2.Drag the green slider on the Distance bar to set the distance of the 50% out-of-focus foreground plane.
If you want foreground objects to stay in focus, move the green slider all the way to the left.

To use a Depth of Field preset:
You must set the plane of focus with the red cross when using a preset curve.

1. On the right side of the panel, click the graph describing the Depth of Field you want.

2. Use the scroll bar to view more choices.
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In natural photography, depth of field is closely connected to film resolution and size. The smaller the film the more
the out-of-focus objects are blurred. The Depth Of Field filter works the same way: if you increase the size of the
rendered picture the depth of field effect will appear weaker. Keep this in mind when working with your small
previews.

To prevent this, the Depth Of Field filter uses the DPI settings as the film resolution. When increasing DPI the picture
size and film resolution are increased, hence the depth of field effect remains the same.

You can get a stronger depth of field effect by increasing the dpi and decreasing the picture size by the same amount.
For example, if you want an effect that is twice your current effect, halve the picture width and height and double the
dpi.



Setting Lens Flare Options

Lens flares are reflections of a strong light source on the various components of the lens. Flare color and size depend
on the kind of glass and shape of each lens component. The Lens Flare filter adds lens flare to every visible light
source in your final rendered image according to its position, color and intensity.

To get a lens flare effect, a light source must be visible to the rendering camera The light source must be within the
production frame and not hidden behind or inside another object—even if it is a transparent object. A spot light must
be aiming toward the rendering camera to produce a lens flare. (The camera must be within the light cone.)

You have two options for previewing the lens flare effect. To switch between preview modes, click the radio button for
the mode you want.

* “Display selected lens flare” shows an arbitrary light source on a black background to create the lens flare.

You can drag in the preview to change the relationship between the light source and lens. This doesn’t effect your
final lens flare effect.

® ” Show preview” uses a rendered preview of your scene. You must first generate a preview to use this option.

Note: If you’re rendering with a white background, you won’t see the result of the lens fare effect. Choose a dark
color for the background.

To generate a preview of your scene:

1. Click one of the radio buttons to chose the preview quality:
x1—high quality (slower)
x2—normal quality
x4—Ilow quality (faster)

2.Click the Preview button to generate a preview of your scene.
This takes a few moments.

3. On the right side of the panel, click the image describing the lens flare you want.

4.Drag the Intensity slider to change lens flare strength.
The Lens Flare effect uses three parameters to render the effect: Light source color, Light source intensity and
Lens Flare intensity. To get brighter Lens Flares use brighter light sources. It also helps to lower the ambient light
and use darker backdrops.



Setting Glow Options

Glow simulates a photographic filter by adding a glow around every visible light source. The effect of the glow
depends on the light’s position, color and intensity.

The light source must be visible from the camera to produce a glow. It must be within the production frame and not
hidden behind or inside an object.

To set glow options:

1. Adjust the Glow Size slider to change the diameter of the glow.

2. Adjust the Glow Intensity slider to change the strength of the glow.



Setting Nebula Options
The Nebula filter adds multicolored streaks around every visible light source.

The light source must be visible from the camera to produce a nebula effect. It must be within the production frame
and not hidden behind or inside an object.

To set nebula options:

1.Drag the 1st radius to set the streak’s starting radius.

2.Drag the 2nd radius to set the streak’s ending radius.

3. Drag the Angle slider to rotate the streaks around the light source center.
4.Use the Branch number pop-up to choose the number of streaks.

5. Enable the Thick option to makes the streaks thicker.

6. Drag the Intensity slider to set the streak intensity.

Note: You’ll need to render on a dark background to see the effect.



Setting Pulsator Options
Pulsator adds dotted streaks around every visible light source.

The light source must be visible from the camera to produce a pulsator effect. It must be within the production frame
and not hidden behind or inside an object.

To set pulsator options:

1.Drag the Thickness slider to set the streak thicker.
2.Drag the Size slider to set the streak radius.
3. Drag the Angle slider to rotate the streaks around the light source center.

4.Drag the Intensity slider to set the streak intensity.

Note: You’ll need to render on a dark background to see the effect.



Setting Stars Options

Stars adds a star around every visible light source. The light source must be visible from the camera to produce a
stars effect. It must be within the production frame and not hidden behind or inside an object.

To set stars options:

1. Drag the Thickness slider to set the star thicker.

2.Drag the Size slider to set the star radius.

3. Drag the Angle slider to rotate the stars around the light source center.
4.Use the Branch number pop-up to choose the number of rays.

5. Enable the Diffraction option to split the stars into rainbow colors.

6.Drag the Intensity slider to set the star intensity.

Note: You’ll need to render on a dark background to see the effect.



Setting VarioCross Options
The VarioCross filter adds two streaks around every visible light source.

The light source must be visible from the camera to produce a variocross effect. It must be within the production
frame and not hidden behind or inside an object.

To set variocross options:

1.Drag the Thickness slider to set the streak thicker.

2.Drag the Size slider to set the streak radius.

3.Drag the 1st Angle slider to rotate the first streak around the light source center.
4.Drag the 2nd Angle slider to rotate the second streak around the light source center.
5. Enable the Diffraction option to split the streaks into rainbow colors.

6. Drag the Intensity slider to set the streak intensity.

Note: You’ll need to render on a dark background to see the effect.



Setting CrossScreen Options
The CrossScreen filter adds a glow and large branches to every visible light source.

The light source must be visible from the camera to produce an effect. It must be within the production frame and not
hidden behind or inside an object.

To set crosscreen options:

1. Adjust the Glow Size slider to change the diameter of the glow.
2.Drag the Star Size slider to set the star radius.

3. Drag the Angle slider to rotate the stars around the light source center.
4.Drag the Branch number slider to set the number of rays.

5.Drag the Intensity slider to set the effect intensity.
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The 3D Light Cone simulates the interaction between light from a Spot light and smoke, fog, and dust. The 3D Light
Cone effect post-processes the rendered picture to adding visible light beams from Spot lights. The visible light
beams accurately describe the half angle of each Spot light in the scene.

Note: In the natural world, light rays are visible when the atmosphere contains small particles of dust or vapor which
diffuse light.

About Warnings:

Some of the 3D Light Cone options lead require more memory and extend rendering time.

e The warning box at the bottom left of the panel tells you when the current settings demand a large amount of
memory and require more rendering time.

e The bottom right box indicates the amount of RAM required to render the scene with the current settings.
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To set the light cone options:

1. To change the color of the fog, click on the color swatch at the left of the Fog panel.
3D opens the system color picker so you can choose a color.

Note: The color of the visible light cone results from the interaction of the light’s color and the fog color. Yellow
light in a white fog produces a yellowish light cone. In a blue fog, yellow light produces a green cone.

2.Drag the intensity slider to change the strength of the light cone effect.
The range is from 25% to 200%.

3.Enter a value in the Range field to set the length of the light cones.
The Range describes the number of inches before the light cone fades out.

4.Enable the “Use gel” option if you want to use any gel on the lights in the light cone effect.
Use this option only if you’ve applied gels to your Spot lights.

5.Drag the Gel Buffer Size slider to set the quality of the gel effect in the light cone.

6. Move the slider to the right to increase quality of the gel in the light cone.

Caution: To render textured light rays, the filter pre-processes and stores buffers for each Spot light in your
scene. High buffer values produce better results, but can be costly in rendering time and memory requirements.
Don’t try values higher than 200 unless you have a powerful computer and are working on high resolution
pictures. Always start with a small value.

7.Enable the Add Turbulence option if you want swirls in the fog medium.

8.Drag the Turbulence size slider to set the mean size, in inches, of the wreath of smoke.
This slider ranges from 0.01 inches to 489 inches.

9. Drag the Turbulence lumpiness slider to set the contrast level in the wreath of smoke.
10. Drag the Turbulence sampling slider to set the number of samples per pixel.
The typical value is 10. Don’t change this value unless you are working on high resolution pictures (over 1024 x

1024). High sampling values significantly slow down the rendering.

11. Enable the Animated option if you want the fog medium to move (change over time).
This option slows down the rendering. Use it only when doing animations.

12. Enable the 3D Shadow option if you want objects in the light cone to cast shadows in the fog.

13. Drag the Shadow Buffer Size slider to set the quality of the 3D shadow effect in the light cone.

Caution: 3D Shadows is a powerful but costly effect. The filter must pre-process and store buffers for each Spot light
in your scene. High values can are costly in rendering time and memory requirements. Do not try values higher than

200 unless you have a powerful computer and you are working on high resolution pictures. Always start with a small
value.

Note: You’ll need to render on a dark background to see the visible light cones.



Setting 3D Light Sphere Options

The 3D Light Sphere simulates the interaction between light from a Bulb light and smoke, fog, and dust. 3D Light
Sphere filter post-processes the rendered picture by adding a light sphere around each Bulb light.

Some of the 3D Light Sphere options lead require more memory and extend rendering time.

e The warning box at the bottom left of the panel tells you when the current settings demand a large amount of
memory and require more rendering time.

e The bottom right box indicates the amount of RAM required to render the scene with the current settings.
To set the light sphere options:

1. To change the color of the fog, click on the color chip at the left of the Fog panel.
3D opens the system color picker so you can choose a color.

Note: The color of the visible light sphere results from the interaction of the light’s color and the fog color. Yellow
light in a white fog produces a yellowish light sphere. In a blue fog, yellow light produces a green sphere.

2.Drag the intensity slider to change the strength of the light sphere effect. The range is from 25% to 200%.

3.Enter a value in the Range field to set the radius of the light sphere.
The Range describes the number of inches before the light sphere fades out.

4.Enable the Add Turbulence option if you want swirls in the fog medium.

5. Drag the Turbulence size slider to set the mean size, in inches, of the wreath of smoke.
This slider ranges from 0.01 inches to 489 inches.

6. Drag the Turbulence lumpiness slider to set the contrast level in the wreath of smoke.

7.Drag the Turbulence sampling slider to set the number of samples per pixel.
The typical value is 10. Don’t change this value unless you are working on high resolution pictures (over 1024 x
1024). High sampling values significantly slow down the rendering.

8.Enable the Animated option if you want the fog medium to move (change over time).
This option slows down the rendering. Use it only when doing animations.
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Aura let you render true glowing objects with an outside aura. The light emitted from the glowing objects can interact
with fog or turbulent smoke. Aura automatically detects which objects have a glow shader, letting you create
impressive effects like laser beams, neon signs and LEDs.

Aura uses the shader glow channel to know which object are glowing and which are not. Only objects that have some
degree of luminance in the glow channel receive an aura.

To set the aura for objects:

1. Select an object that should have an aura.
2.Display the Current Shader Editor palette: Glow tab.

3. Set the glow color.
Higher luminance values result in a brighter glow and, therefore, a stronger aura.

4.Repeat steps 1 through 3 for each object that should have an aura.
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To set the aura options:

1. To change the color of the aura, click on the color chip at the left of the Aura panel.
3D opens the system color picker so you can choose a color.

Note: The color of the final aura effect results from the interaction of the object’s glow color and the aura color.

2.Enable the Test Z option if you want 3D to check the depth of the different objects in the scene before applying the
aura effect.
When Test Z is off, the Aura might produce an unexpected result when the aura object is partially obscured by a
non-aura object. For example, you set up two spheres—one in the foreground without glow and the second with
glow behind the first. With Test Z off, the Aura around the background sphere may cover a part of the foreground
sphere. With Test Z on, the Aura filter knows which object is in front, and the foreground sphere will correctly
obscure the background aura.

3.Drag the intensity slider to change the strength of the aura effect.

4.Drag the Range slider to set the radius of the aura.
The Range describes the number of inches before the aura fades out.

5. Enable the Add Turbulence option if you want swirls in the aura medium (smoke wreaths).

6. Drag the Turbulence size slider to set the mean size, in inches, of the wreath of smoke.
This slider ranges from 0.01 inches to 489 inches.

7.Drag the Turbulence lumpiness slider to set the contrast level in the wreath of smoke.
8. Drag the Turbulence sampling slider to set the number of samples per pixel.
Leave this value at the default unless you are working on high resolution pictures (over 1024 x 1024). High

sampling values significantly slow down the rendering.

9. Enable the Animated option if you want the medium to move (change over time).
This option slows down the rendering. Use it only when doing animations.



The Scene Settings Output tab
The Scene Settings window: Output tab provides a set of controls for the images the renderer creates.

Image Size Controls

The Image Size controls lets you describe the dimensions and resolution of the image to be rendered. The resolution
of a device, such as a monitor, printer, scanner, or image setter, is described as the number of pixels it can create for
each inch of image area: pixels (or dots) per inch (ppi or dpi).

For example, the screen of an Apple color monitor has 72 dots per inch (dpi). Each dot is a pixel, so an image that is
72 x 72 pixels would be one inch square on the screen of that monitor. VGA monitors have slightly higher resolutions.
Many color printers are capable of 300 dpi, and some image setters can produce more than 2500 dpi.

This discrepancy in device resolution creates a slight problem—pixels are different sizes on different devices, so an
image displays or prints at a different size on devices of different resolution. For example, the 72 x 72 image that
appears one inch square on the screen would be less than one-quarter inch when printed on a 300 dpi printer. (72
pixels drawn at 300 dots per inch: 72/300=0.24 inches.)

The solution is to set the rendering parameters according to the size of the image you want from a particular output
device.



Setting Image Size and Resolution
To set the image size and resolution:

1.1n the Width and Height fields of the Rendering Settings dialog, enter the dimensions you want for the picture.
Set the size according to your final output. You can use the pop-ups to the right to choose the units.

2.In the Resolution field, enter the resolution (dots per inch) of the expected output device.
A six-inch square image at 600 dpi may occupy as much as 100 MB on disk! (The size varies depending on file
format and image content.)

3.Enable the Keep Proportions if you want to keep the same aspect ratio (ratio of width-to-height) when you change
either the width or height.

4.To check how long rendering will take, click the Estimate button.
In a moment, the Render time display shows approximately how long rendering will take at the current settings.



Limiting Rendering Time

If time is more important than quality, you can give 3D a time limit and ask for the best rendering in that time frame.
This would be a good choice, for example, if you wanted the rendering done by the time you got back from lunch.
To set a time for rendering:

1.1n the Render time fields, enter the amount of time you want 3D to work on the rendering.
2. Click the Estimate button.

In a moment, the Resolution (and number of pixels in each dimension) changes to the best resolution possible in
the time allotted settings. You can now start the rendering to get this result.
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The image dimensions are closely related to the production frame, which specifies the area of the scene (as seen by
the camera) that’s rendered in the final artwork. You can think of the production frame as the camera’s view finder.

After setting the image size in the Image Size panel of the Render Settings dialog, turn on the Production Frame
display and check the framing of your scene.
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To set the aura options:

Choose View> Production Frame
e  The production frame appears as a colored rectangle (green, by default) in the Perspective window.
e The rectangle’s dimensions are determined by the width and height settings in the Image Size panel.

e The area of the scene the frame encloses represents the area of your rendering. You can think of the
rectangle as “defining the print area” of your scene.
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To move the production frame:

1. Choose the Selection tool.

2.Click on the outer rectangle to select it.
You’ll notice “handles” appear on each corner and side.

3. Move the cursor inside the frame and drag it where you want it.

Note: To change the viewpoint of your scene, you’ll need to work with the camera.
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To resize the production frame:

1. Choose the Selection tool.

2.Click on the outer rectangle to select it.
You’ll notice “handles” appear on each corner and side.

3.Drag a corner handle to resize in two dimensions.
Hold down the Shift key while you drag to constrain proportions (maintain the aspect ratio).

4.Drag a side handle to resize in one dimension.
When you resize the production frame, 3D updates the height and width values in the Scene Settings window:
Image Size controls. The resolution (dpi) stays the same.

Note: The camera position does not change when you move or adjust the Production Frame. What you are doing is
cropping the camera’s view.

The Magnifying Glass tool and the scroll bars change the display in the Perspective window—not the camera view. If
you can’t see all of the production frame, use the scroll bars and/or Magnifier tool (to zoom out) until you do.



Selecting the Camera to Render From

If you use one of the Render commands, by default you’ll be rendering from the current camera. To render from some
other camera or if you are going to use the Batch Queue, you can identify which camera to use.

To choose the camera:

1. Display the Scene Settings window: Output tab: Camera controls.

2.Use the Rendering Camera pop-up to choose the camera you want to render from.
The pop-up lists all cameras in your scene.

3. Save your scene.

Note: If you want to render one scene several times from different cameras, use the Batch Queue.



Using File Name Controls
The File Name controls let you set the name and disk location for rendered files.

To set a file name for rendering a scene:
1. Display the Scene Settings window: Output tab: File Name controls.

2. Click the In Named File radio button.

3. Click Set.
3D displays a dialog that lets you enter a name for renderings from this scene and choose a disk location.

4. When you’ve finished with the dialog, click Save.
3D displays the disk location and name to the right of the Set button.



Using File Format Controls

The File Format controls let you choose the type of file saved to disk and set options for it. The File Format controls
also let you specify the frame range and rate for rendering animations.

To set file format options for rendering the current frame:
1. Display the Scene Settings window: Output tab: File Format controls.

2.If necessary, click the radio button for Current Frame (still image).
Movies have additional settings and considerations.

3. Choose the file format you want from the pop-up.
Windows Bitmap, PICT (Macintosh), TIFF, EPSF, GIF, JPEG, Painter RIFF, Targa (Windows), Corel Photo Paint,
and Adobe PhotoShop. You may have other formats added as PhotoShop compatible plug-ins.

4. Click the Options button.
Ray Dream opens a dialog that lets you set features for this file format.

5.When you’re finished setting options, close the options dialog.



Choosing a Movie File Format
To choose the format for a movie file:
1. Click the radio button for Movie (animation).

2.Choose the movie file format you want from the pop-up.
Movie formats include QuickTime Movie, AVI Movie, Sequenced Corel Photo Paint, Sequenced GIF, Sequenced
JPEG, Sequenced PICT, Sequenced PhotoShop, Sequenced TIFF, Sequenced Targa, Sequenced Painter RIFF.
The “Movie” formats (QuickTime and AVI) generate a single file that includes all of the frames.
The “sequenced” formats generate a single file for each frame. The files are numbered 000, 001, 002, and so
forth, to keep them in sequence. Sequenced files are often used for transferring the animation to other programs,
such as Adobe Premiere™.

3. Set the start and end points of the render range.
4.Choose a frame rate from the Rate pop-up.

5. Click the Options button.
3D opens a dialog that lets you set features for this file format.
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Rendering animation requires significant amount of hard disk space. If you have disk space limitations, you will want
to compress the movie that you render. If you have plenty of disk space, you may want to render without
compression. This way you won’t invest rendering time only to find out that you used too much compression. You can
then re-open the movie file in Ray Dream 3D and save it with compression.

The software compression and decompression algorithms (called codecs) that you can select in the Compression
Settings dialog are provided with QuickTime (Macintosh) or AVI (Windows). Codecs compress data when you render
an animation and decompress the data when you play the movie. Any Macintosh or Windows system with QuickTime
or AVI software can play back a compressed movie.

If you are using hardware for MPEG compression, see the instructions that accompanied your board for a description
of available compression options.

To set the movie compression option:

1. Click the Options button in the Scene Settings window: Output tab: File Format controls.
The Compression Settings dialog appears

2. Select one of the compressor options from the Compressor pop-up menu.
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Microsoft Video 1. This codec compresses each frame of a clip (and is used for analog video (8 and 16-bit). Some
data is discarded (the codec is lossy).

Full Frames (Uncompressed). This option is best for capturing full frames of analog video. No compression is
applied, so use of this codec requires lots of disk space.

Cinepak Codec (Radius™). This is a cross-platform codec for QuickTime and AVI. Movies take a long time to
compress, but decompress quickly at playback. Cinepak is optimized for 16- and 24-bit animations. Cinepak has
a better compression ratio, image quality, and playback than the Microsoft Video 1 codec.

Intel Indeo Video R3.2. This codec uses higher compression ratios, and results in better image quality and faster
playback than Microsoft Video 1.

Microsoft RLE. Use this option for compressing animation and computer-synthesized 8-bit images.

Intel Indeo Video Raw. Use this compression method for capturing uncompressed video. You will obtain superior
image quality because no compression is applied.

Compression tip: For optimal compression, use the right frame size: 160 x 120 for Apple Video compressor and 240 x
180 for Cinepak. When using Cinepak, frame dimensions need to be multiples of four for best performance.
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To set the compressor options:

1.Choose a color depth from the Color pop-up.
The depths available depend on the selected codec.

1. Use the Quality slider to set the level of compression.
The compression ratio is inversely proportional to image quality. The Quality slider allows you to set an optimum
between the amount of compression and image quality.

2. For a codec that uses key framing, enter a Key Frame rate.
The key frame is used in temporal compression methods. Each key frame is stored in its entirety. The next set of
frames—up to the next key—are saved only as changes.

3. For a codec that supports the feature, you can use the Limit Data Rate option.
This allows you to set a maximum size for any frame. QuickTime automatically adapts the compression quality to
maintain this rate. This feature is available for only a few codecs.
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Ray Dream 3D can calculate and save more than a dozen separate channels of geometric and lighting information in
addition to your full color rendered image.

These additional channels appear as grayscale images, where the gray values represent information. The data in
each of these channels describes the point in your 3D scene that each pixel in the image represents. For example, if
the scene shows a drinking glass on a wooden table, each pixel in the rendered image corresponds to a point—on
the glass or on the table—in your 3D scene.

Not all file formats are capable of storing all of the channels possible. Because Painter 5 RIFF and Adobe PhotoShop
2.5 and higher support multiple channels, rendered images saved in these format can contain all G-Buffer channels.

There are many versions of the TIFF format. The TIFF format used in the Windows version of Ray Dream 3D can
also contain all G-Buffer channels.
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To set G-Buffer channels:
1. Display the Scene Settings window: Output tab: G-Buffer controls.

2.Enable the check box or each feature you want.

3. Do not enable channels that you don’t need.
Each channel adds to the file size considerably.

e  Pixel color: The pixel color is determined by shading and lighting effects. For example, looking through a drinking
glass, you can see the wooden table behind. The color of a specific pixel in the glass appears as the color of the
wood after it has filtered through the translucent glass. Pixel color occupies channels 1, 2 and 3 for red, green
and blue.

e Mask: Amask is a “shadow” image of your scene. It describes where objects are, versus where they are not.
The mask is used as a selection of your image when you paste onto a background in an image-editing program.
Pasting a foreground image onto a background is called compositing.

Refer to your image-editing application’s documentation for instructions on selections, masks and compositing.

Ray Dream 3D puts the mask data in channel 4, the Alpha channel, which is where masks are usually kept in
applications like Painter and Adobe PhotoShop.

e Distance: The distance channel describes the distance of each point from the camera, or viewpoint. Lighter
pixels are closest to the camera, while dark colors represent areas of the rendering that are farthest from the
camera. You can use the distance channel information in Painter 5 with the Focus> Depth of Field effect to blur
areas that are farther from the camera.

e Object index: The object index relates each pixel in the image to the object its corresponding point belongs to.
With an object index loaded in Adobe PhotoShop, you can easily select individual objects with the Magic Wand,
regardless of color. This works as long as the objects do not overlap.

e  Normal vector: The normal vector creates three channels describing the direction that each surface of the object
faces. This information can be used after rendering to simulate additional light sources. For example, it’s
possible to add directional lighting or glows in PhotoShop by loading the normal channel to select all the surfaces
that face in a given direction, complete with information about how those facings fall off.

e  Position: The position describes the coordinate of each point in the image. 3D position uses three channels, one
for the x value, one for the y value, and one for z. An example of how you could use this information is to position
low hanging clouds, making use of the Z, or height, channel.

e Surface coordinate: The surface coordinate describes the location of the point on the object in relation to the
object’s surface coordinate system. This is two-dimensional information which allows adding, replacing, or
repositioning texture maps on 3D objects in an image editing program.
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Ray Dream 3D allows you to save frequently used render settings. Your saved settings will appear as presets on the
Render menu, where you can use them directly

To create a new render preset:

1. Set all rendering options to your liking.
The presets include the controls in the Scene Settings: Render tab and Output tab.

2.Choose Render> Save Current Settings.
3D opens a dialog that lets you name the preset, add a comment and set two other options.

3.Enable the Save Camera option if you wan to include the choice of rendering camera.
4.Enable Save Punch In and Punch Out if you want to include the rendering range.

5. Click OK to close the dialog and create the preset on the Render menu.



Removing Preset Render Settings Lrervew el

To remove preset render settings:

1.Choose Render> Remove Settings.
3D opens the Remove Render Settings dialog appears.

2. Select the render setting to be removed in the left window.

3.Click OK.



Starting a Rendering Job

When you have set your options and framed your scene, you can start a rendering.

To start rendering using the current settings:

e Choose Render> Using Current Settings. You may also use the key shortcut Command-R/Ctrl+R.

An Image window opens and rendering begins. The progress bar advances as rendering proceeds.

To render with a preset:
e  Choose Render> Preset Name.

Rendering is computationally intensive, and depending on the render settings, jobs may take several hours to
complete. Rendering can run in the background. You can go on working with 3D and even launch other applications
—if memory permits.

Because rendering is time consuming, Designer provides a feature that helps you fit heavy rendering jobs into your
schedule: the Batch Queue.

When using applications such as word processors or 2D drawing programs, the CPU is not using maximum capability
and spends a lot of time idling. Ray Dream 3D takes advantage of this by taking control of the CPU and performing its
calculations in the background. The computational load between Designer’s ray tracer and other programs has been
set up so that you can type in your favorite word processor without perceptible slowdown.



Using the Batch Queuew

Ray Dream 3D allows you to batch several rendering jobs in a queue for deferred, unsupervised processing. By
default, batched files are rendered automatically using the render settings saved in the file. However, batch queue
rendering parameters can be set to use specific settings for the entire batch or to use particular settings for each file
in the batch queue.

During rendering, Ray Dream 3D displays and processes all scenes one at a time. You can add to or remove files
from the batch queue at any time.



Adding Files to the Batch Queuew

To add files to the Batch Queue:

1. Set up each scene you wish to include in the batch:
Remember to set the render settings, the production format, the framing, and the default camera.

2.Save and close these files.
3.Choose Render> Batch Queue.
4. Click Add.
3D opens a dialog so you can locate and add one or more scene files. Readable files (scenes) in the current

directory are on the left. Files you’re adding appear on the right.

5. Select a file, then click Add.
You may also double-click a file to add it.

6. To include all files in the current directory, click Add All.

7.1f you want to remove a file from the queue, select it and click Delete (Windows) or Remove (Macintosh).
8. Repeat step 4 until you’ve added all files you want in this batch.

9. Click Close (Macintosh) or Done (Windows).

10. At this point, you can launch the batch process or check and change the settings for any particular file.
11. To use this same list of files in the batch queue at a later date, click Save List.

3D opens a dialog so you can name the list and choose a disk location. Later, when you want these same files in
the batch queue again, click Load List. Use the dialog to locate and open the saved batch queue list.



Changing Settings for a File in the Batch Queue JYEYEW W |

To change settings:
1.1n the Batch Queue list, select the file or set of files you wish to change.

2.Click the Settings button.
3D displays the Render Settings dialog, where you can view and change the image size, file format and other
options.

3. You can page to the different tabs and change settings individually.

4.You can use the Load button to choose one of the saved presets.

5.You can use the Save button to add the current settings to the presets.

Note: Changing the settings for a file in the batch queue only affects this batch process. The settings saved in
the file itself are unchanged.

6. When you’re finished with the Render Settings dialog, click OK.



Starting a Batch Process 2YSTYIEW i "Nl|

To start a batch process:

1. To start batch processing, click Launch.
While the batch is running, you can click Abort to stop it.
You can click Pause to temporarily halt the process. Click Resume to start the process again.
You can use the Rendering Progress and Scene Statistics items in the top panel to get information on the scene
currently being rendered or on a scene you select in the lower panel. Use the Information pop-up to choose
which.

2.1f you want to save the information, click Save Text. Use the dialog to name the file and choose a disk location.



Rendering a Scene More Than Once From Different Cameras XYW fri "Nl|

To render a scene from different cameras or different camera positions, copy the scene for every camera or camera
position to render.

To render a scene from different cameras:
1. Choose the rendering camera from the Scene Settings dialog: Output tab.

2.Choose File> Save As and save the file with a different name.
This creates a copy of the scene.

3. Repeat steps 1-2 until you’ve created a copy of the scene for each camera and position you want to use.

4.1n the Batch Queue, add the scenes created in steps 1-3 and follow the Batch Queue instructions for rendering.

Note: Animation offers a different approach to rendering one scene from different viewpoints. Simply animate the
camera to “visit” each viewpoint on the scene. Then render a movie, using a frame rate that coincides with each
camera location.



Speeding Up Renderingw

There are several techniques that you can use to reduce your rendering time. These techniques are especially useful
when rendering animations that may have hundreds, or even thousands, of individual images to be rendered.

e Use an image editing program to reduce your texture maps to 8-bit depth. Very few images actually use millions
of colors, and many image editing programs discard insignificant information while maintaining the quality of the
image. (Some textures even look good in 4-bit depth, or 16 colors.)

e Reduce all texture maps to be used in non-color channels like the bump channel to 8-bit and grayscale before
importing them. The color file wastes space and time while Designer converts it to gray.

e If an object is distant from the camera, open it in the Free Form Modeler and lower its surface fidelity to the
minimum. This results in the minimum amount of RAM being used for its geometry.

e When an object leaves the frame, and isn’t reflected in any surface that you can see in the rendering, activate its
Cloak property. This won’t save memory, but it does save rendering time. Objects that pass behind solid objects
can be cloaked to save time, too. Be careful that you do not lose a cast shadow where one is needed.

You can speed up rendering by applying these techniques:
¢ Use the Production Z-Buffer instead of the Ray Tracer or Adaptive renderer.

e Use the Draft Z-Buffer to preview your object positions and movement. Unless you need reflection or refraction to
show in your animation, choose the Production Z-Buffer for a higher quality fast rendering.

e Work with smaller image (frame) sizes. The standard for CD-ROM-based QuickTime movies is half-screen size, or
320 by 240 pixels, although satisfying results can be achieved at 240 by 180. (You can then scale up to full-
screen size for VHS output, although pixelation may be apparent when you scale up.)

¢ Limit the number of frames per second to 15, which is adequate for QuickTime movies. (Video uses 30 fps and film
24 fps.)

¢ Simplify objects and reduce the number of objects in the animation.

e Limit the number of lights.

¢ For the Ray Tracer or Adaptive renderer, disable the Reflection, Transparency, and Refraction options.

e Keep objects near the background simple. (A complex bitmapped background does not affect rendering speed.)
e Limit the size of texture maps.

¢ Use 8-bit texture maps instead of 24 bit.

e Limit the number of reflective and transparent objects.

¢ Divide animations into smaller files and eliminate objects that won’t be seen on-screen.

¢ Turn off anti-aliasing when previewing rendered animation.



Computer System Optimization

Ray Dream 3D’s performance is affected by available RAM and disk space. You can never have a fast enough
computer, enough RAM or disk space, a large enough monitor, or a fast enough computer. With that in mind, here are
some things you can do to get the best performance out of your system.

If you have a scene that uses more RAM than you have, 3D uses its own virtual memory system to keep things
running, spooling data back and forth to the hard disk. The greater the disparity between RAM needs and what is
available, the more speed it costs you. If the scene ends up dipping into the operating system’s virtual memory as
well, performance can be very poor. In this case, adding RAM can improve speed, although this makes the computer
run more efficiently, not any faster.

The fastest rendering takes place on a fast processor with plenty of RAM. Systems used in professional animation
may 128 MB RAM or more. Because all rendering involves some spooling to disk, you need a large hard disk with
plenty of free space.

e To keep your hard disk running efficiently, use disk utilities to scan for disk errors, and defragment your hard disk
prior to starting a project or even a long rendering session.

e Don’t run other programs in the background. Some screen savers use as much CPU time as Ray Dream 3D.



Viewing Rendered Images

When you render using Render menu commands, the image is displayed in a window when rendering is done. If you
want to keep this rendering, you should save the file.

Renderings generated from the Batch Queue are automatically saved to disk. You can open these files in Ray Dream
3D by double-clicking on the file icon. Or, you can open and view them in another graphics application.



About the Image Window

When you open a rendered image, it’s displayed in the image window. The program tries to load the image into RAM.
If there is not enough available RAM, 3D spools the image from the scratch disk. For example, Ray Dream 3D’s
spooling enables you to display a 20MB image on your system with only 16MB of RAM. The penalty of spooling is
slower access time. Each time you adjust the image, the computer must read/write to the disk.

The zoom ratio (scaling) appears in the top left. The ratio is “screen pixels-to-image pixels.” When the ratio is 1:1,
one screen dot represents one image pixel. When the ratio is 1:2, one screen dot represents two image pixels. The
ratio changes as you zoom in or out with the magnifying glass tool.

The image resolution, color depth, and size of the image (in “K,” for kilobytes, or “MB,” for Megabytes) appear at the
top.

Note: Images produced by 3D using the Render> Use Current Settings command and Render> High Resolution are
rendered and stored on disk in 24-bit (millions of colors) format.



About the Movie Window
When you open a rendered animation that’s saved as a QuickTime or AVI movie, 3D displays it in the movie window.

The movie window adds the duration and frame rate to the other statistics at the top of the window.
¢ Click the Play button to play the movie. During play, click the Pause button to stop.

¢ Click the Frame Forward or Frame Back buttons to step through one frame at a time.

¢ Click the Loop button to enable looping. Then click Play.

e Drag the slider to “scrub” through the movie.



Post-Production Overview

Rendering produces a 2D, bitmapped image of your scene. Anything you do with that image is considered post-
production. Post-production might include compositing, filtering, cropping, and retouching the image in an image-
editing application.

Rendering an animation produces a movie—either a single file that contains all frames (AVI) or a sequence of files.
Post-production on a movie might include any of the still-image operations, like compositing and filtering. It might also
include more advanced work, like editing clips together and adding sound effects.



Post-Production Applications

Ray Dream 3D is a 3D illustration tool. It does not provide comprehensive post-production features. You may use an
image editing or paint application such as Fractal Design Painter®, Micrografx Picture Publisher®, Corel Photo-
Paint®, or Adobe PhotoShop for the best in post-production results. In some cases, you might want to use your
imaging application to adjust colors or contrast, apply an effect or image filter, or paint directly onto the image.

3D saves renderings in file formats that are compatible with virtually any pre-press or layout application.



Compositingw

Compositing is the process of pasting one image onto another. For example, if you built a car in Ray Dream 3D, you
could paste it onto a scanned photo of a highway. If you’re careful, the car can appear as though it was on the road
when the original photograph was taken.

Usually, the foreground image (what you paste) is not a rectangle, but an irregularly shaped selection of the rendered
objects. This selection should be created from an auto-generated mask. (The mask is created when you request a
rendering.) This ensures precise outlines on the objects you paste.

Note: You can set the background color or imagery in the Scene Settings window: Effects tab: Background or
Backdrop controls.

Objects in photographs have their own perspective. If the modeled object you composite does not match the
perspective of the background, it will seem unnatural and out of place. After rendering, you can’t change the
perspective of the objects you create. Before rendering, however, it’s easy.



Setting Up a Scene to Render with a Mask
To set up a scene to render:

1.When you’re ready to render your scene, display the Scene Settings window: Output tab: File Format controls.

2.Make sure the selected file format supports saving multiple channels.
Painter (RIF), Adobe PhotoShop, and TIFF are good choices.

3. Display the Scene Settings window: Output tab: Output tab: G-Buffer controls.

4.Enable the Mask check box.



Compositing using Fractal Design Painter XS frir Wl

This procedure uses Painter as the post-production application. The steps in Adobe PhotoShop would be nearly
identical.

To composite using Painter:

1.Render the scene—either directly or through the Batch Queue.

2.1f you rendered directly, save the image to a convenient location.
Verify the file format before saving.

3. Open the rendered image in Painter (or another image-editing application).
The mask generated during the rendering appears in the Mask List palette.

4. From the Select menu, choose Load Selection.
5.In the dialog, make sure the mask is selected in the pop-up.

6. Click OK.
Painter selects the objects of your rendering.

7.Choose Edit> Copy.
You’re now done with this file.

8. Open the background image.
(The image you are pasting onto.)

9.Choose Edit> Paste.
The pasted selection comes into the image as an image floater.

10. Drag the floater where you want it.

Refer to the documentation that came with your image-editing application for additional information about working
with masks and channels.



Filtering Images

You may have image filters for Adobe PhotoShop, either from Adobe Systems or from a third-party. You may use
these filters directly from Ray Dream 3D.

Most plug-in filters are compatible with Ray Dream 3D; however, filters that specifically require Adobe PhotoShop are
not.

To use filters you must first identify the directory containing your plug-in modules (filters). If you plan to share plug-ins
between applications, make sure you move all your plug-ins into a single directory so that Ray Dream 3D can find all
of them.

To identify the directory containing your plug-in modules (filters):
1.Choose File> Preferences.

2.Choose “Imaging, Scratch Disk” from the pop-up.
3. Click the Set Directory button.

4.Use the dialog to locate and select the directory containing the plug-in modules.

If you add additional filters to your plug-in directory, you will need to re-identify the directory before you can use the
filters.

When you have identified the plug-ins for Ray Dream 3D, you can use them on an image in the Image window, in the
Shader Editor on texture maps, in render effects or on Backgrounds and Backdrops.

To use filters on the Background or Backdrop (before rendering):
1. Display the Scene Settings window: Effects tab: Background or Backdrop controls.

2.Pop-up the disk icon and choose Filter from the menu.
3.3D displays the list of available filters appears.
4.Select one of the filters.

To use a filter in the Shader Editor:
1. Display the Current Shader Editor.

2. Select the channel containing the texture map you want to filter.
3. Pop-up the disk icon and choose Filter from the menu.
4.3D displays the list of available filters appears.

5. Select one of the filters.



Animation Post-Production

For some post-production work on animations, you’ll want to use Painter. Painter opens either movie files or
sequenced files, so you may render your 3D animation to either format. For the best quality, use uncompressed,
sequenced files.

* You can use Painter to composite animations with background stills, video or other animations. To do this, you’ll
want to make sure to include a mask when you render the animation.

¢ You can apply image effects to an animation and add special effects with floaters.

¢ You can paint directly onto an animation using any of Painter’s fabulous brushes.

¢ You can use cloning to convert the imagery to a Natural-Media style—watercolors, for example.

You’ll find detailed instructions for these and other techniques in the documentation that came with Painter.

You might want to use Adobe After Effects for some animation post-production tasks. You’ll need a movie-editing
application, like Adobe Premiere, to edit animation clips together and synchronize sound effects.



Printing Images

You can print your rendered images directly from Ray Dream 3D. If you require color separations, you’ll have to work
with your image in a pre-press application.

To print an image from Ray Dream 3D:

e  With the Image window active, choose Print from the File menu.
3D displays the standard Print Dialog.

Refer to your operating system and printer documentation for more information.



2D (two-dimensional): A shape, path, or plane that exists in the dimensions of width and height only.



3D (three-dimensional): An object or volume that exists in the dimensions of width, height and depth.



Absolute Position: The X, Y, Z coordinates of an object’s hot point in the Global Universe.



Alpha Channel: The top byte of a 32-bit pixel that is used for data other than color. The channel may hold mask or
transparency data. Commonly used for compositing Ray Dream 3D illustrations in Adobe Photoshop.



Ambient Light: That light responsible for the overall, diffuse lighting of a 3D scene. Similar to daylight in the real world.



Anti-aliasing: The procedure of filtering an image to remove jagged edges from shapes. Anti-aliasing fills in the jagged
pixels with intermediate colors (or shades of gray). This makes transitions between colors smoother.



Aspect Ratio: The ratio of the width of an image to its height (x:y). For example, the aspect ratio of an image 640 x
480 pixels is 4:3.



Atmospheric Effects: Atmospheric conditions or phenomena that affect the clarity or mood of a scene. Fog and smoke
are examples of atmospheric effects.



Axis: A hypothetical linear path. The X, Y, and Z axes (width, height, and depth, respectively) define the directions of
the 3D universe. The axis along which an object is rotated is the axis of rotation. An object’s axes are parallel to the
corresponding walls of its bounding box.



Backdrop: A picture that is automatically composited behind a 3D scene to provide additional details that would be
difficult to model or slow to render. The matte paintings used in traditional movie making are examples of backdrops.



Bézier Curve: A path defined by the position of four control points (at the ends of the tangents of the vertices). The
length and angle of the tangents describe the deviation from a linear path that the curve follows between vertices.



Bit Depth: The number of bits used to define the shade or color of each pixel in an image. A 1-bit image is black and
white. An 8-bit grayscale image provides 256 shades of gray (2 to the 8th power is 256). An 8-bit color image
provides 256 colors. A 24-bit image provides over 16 million colors: 8 bits are used for red, 8 are for blue, and 8 for
green. This yields 256 levels for each of the color channels.



Bitmap: An image in which each pixel is represented by a “bit” of memory. Because a bit is either “on” or “off,” each
pixel may be black or white.



Bounding Box: A hypothetical box drawn around an object or group of objects. A bounding box is the smallest
rectangular box in which the object (or group of objects) fits completely. The bounding box is parallel to the axes of
the object. The bounding box is shown (around the preview of selected objects and groups) in the Perspective
window, and it is the bounding box—not the object itself—that “casts™ the projections onto the working box grid.



Child: An object linked to another object (its parent) in the hierarchy. When the parent is moved, the child and all
“grandchildren” go with it. The parent-child link is used to enable articulation of complex objects.



CMYK Color: The subtractive color model used in printing. Colors are created by assembling different densities of
cyan, magenta, yellow, and black pigments on a surface. When white light strikes the surface, only specific hues are
reflected—depending on the density of the specific pigments. The reflected hues create the perceived color. The
CMYK model is called the subtractive model because the pigments subtract (by absorption) the portions of white light
that do not contribute to the specified color.



Co-planar: Occurring in the same plane.



Complex Object: An object constructed of several simple objects that are linked or grouped. For example, a
telephone—comprised of the grouped simple objects “cord,” “handset,” and “cradle”—would be considered a
complex object.



Concentric: Having the same center.



Constrain: To restrict object movement to a particular plane, axis, or angle. The working box is the primary tool for
constraining an object.



Control Points: The “knobs” at the ends of Bezier tangents used to adjust a Bezier curve.



Cross Section: One of the planes on which two-dimensional shapes are drawn to create the form of a three-
dimensional object. Objects have two or more cross sections.



Deformers: Properties that can be applied to any object (or group of objects) to deform its geometry. Asymmetric
scaling, bend, twist and shatter operations are examples of deformers.



Dithering: The process of approximating colors by using adjacent pixels of colors that together perceptually represent
the original color. For example, dithering yellow and blue pixels is perceived as green. Dithering is most often used
when reducing the color depth of an image. Dithering can improve transitions between colors when reducing a 24-bit

image to 8-bit format.



Dolly, Pan and Track: The computer equivalents of the real world camera movement commands. With Dolly, the
camera moves around in 3D space as if gliding on the surface of a sphere that has the object of interest as its center.
Inversely, using Pan, the camera acts as the “center of the sphere” and rotates at a fixed position in space to track an
object or view a scene, much like a movie camera can rotate on a tripod to follow a moving object. Finally, Track
moves the camera in a plane perpendicular to the direction in which the camera is pointing.



Drag: To position the mouse pointer on an item (an object or an icon), depress and hold the mouse button, move the
mouse (usually moving the pointer into a specific region), and release the mouse button.



DXF: A standard 3D file format originally developed by Autodesk, makers of AutoCAD, for the purpose of exchanging
CAD data between various 3D software applications. Widely used as a “lowest common denominator” exchange file
format, DXF only offers support for basic geometric information (no textures).



Face: The back (first cross section shape) or front (last shape) of an extruded object.



Free Form Modeler: A modeler that allows for the creation of freeformed objects with a more organic and less-
mechanical appearance. Typically, it uses higher-level curve representation such as NURBS or Bézier patches.



G-Buffer (Geometry Buffer): A type of information carried on optional channels of an image rendered in Ray Dream
Studio. The G-Buffer carries an aspect of three dimensionality with the 2D rendering. This can assist 2D filters and
paint tools during retouching. The G-Buffer is not available in Ray Dream 3D.



Global Mixer: A new kind of shader editor component that allows the simultaneous mixing of all the channels of two
shaders as opposed to the traditional mix component which only allows for the mixing of two shaders in one single
channel.



Global Universe: The Global Universe is a Cartesian coordinate system with the origin of the X, Y, and Z axes (0, O,
0) at the center of the universe. The Global Universe is fixed and is not affected by changes made to the working box.



Glow Channel: A shading channel in which information about an object’s luminescence or “glow” can be stored.



Grayscale: An image in which the pixels are defined with 8 bits, which provides 256 levels of gray.



Group: A set of collected objects. Grouping enables a set of objects to behave as one.



Hierarchy: The tree structure in the Hierarchy window that shows the logical relationships of linked and grouped
objects. The Hierarchy can be restructured within the Hierarchy window.



Highlights: Regions on an object where light reflects directly into the viewpoint. Highlights appear as bright spots on
smooth/shiny objects and are almost nonexistent on rough/dull objects.



Hot Point: A special active point inside, on the surface of, or near an object or group. The hot point is used for precise
positioning and alignment operations, including numerical positioning.



Icon: A pictorial representation of a tool, object, file, or other program item. An item is selected by clicking its icon
once. Some items require double-clicking.



Jaggies: The appearance of “stair-step” jagged edges in a bitmapped image. Jaggies can be reduced with anti-
aliasing.



Leading: Leading determines the vertical space between lines of text. The default leading value is 120% of the font’s
point size. Decreasing the percentage makes vertical spacing more compact, while increasing the percentage
expands it.



Letter Spacing: Letter Spacing adjusts the horizontal spacing between characters in an entire word, line, or text block.
A negative value decreases spacing, while a positive value increases it.



Links: A variety of child/parent relationships and constraints on relative motion to simulate traditional, real world
mechanical links. Shafts, gliders, and ball joints are all good examples of links implemented in Ray Dream 3D.



Marquee: When selecting a set of elements or region of an image by dragging the mouse diagonally, the rectangle
created between the start point (mouse down) and the end point (mouse up) of the drag is called the marquee.



Mask: The mask is an “inverted shadow” that is used to occlude areas of an image that are not part of the desired
foreground object. The mask enables you to paste just the object itself onto a background (a process called
compositing).



Object Scaling: The percentage an object is resized.



Object/Group Coordinate System: Groups and individual objects have their own local coordinate systems. The origin
of a group or object’s coordinate system is at its hot point. The axes are parallel to the sides of the bounding box.



Object: Any 3D volume or other item that appears in the universe, including cameras and lights. When objects are
grouped, their group is also described as an object.



Operator: An operator is a shader shell that combines other shaders to form a sub-shader.



Orientation: The direction an object “faces” as defined by the compound effect of the object’s pitch, yaw, and roll.
Usually, the most important aspect of an object’s orientation is its relation to other objects. An object’s relation to the
viewpoint can be changed by moving the current camera.



Oversampling: A widely used computer graphics technique for getting rid of computer generated artifacts such as
jaggedness. Smoother looking results are obtained by taking more samples (hence the name) from the 3D world and
averaging them when rendering a picture.



Path: The curve or line along which shapes are extruded when modeling. Called the sweep or extrusion path, the
path is defined by one line on the bottom plane and one line on the back plane in the Modeling window. The
compound curvature of these two lines define the path itself.



Pipeline: An extrusion in which the cross section is always perpendicular to the sweep path.



Pitch: The aspect of an object’s attitude that describes its angular deviation along its vertical (top-to-bottom) axis.



Pixel (picture element): One dot in a 2D image. Computer images are created as an array of such dots, each having
a specific color. See also Resolution and Bit Depth.



Pixmap: An image formed as an array of pixels.



Plane: A hypothetical two-dimensional construct that may exist at any attitude in space. A plane can be envisioned as
a flat sheet of invisible paper that stretches infinitely in two dimensions. In Ray Dream Designer 4, planes are used to
constrain the direction of translation of an object. The working box shows the angle at which the constraint planes are
set. By default, the planes of the working box are set parallel to the axes of the current local universe.



Point of View (also viewpoint): The position and angle from which you view a scene. The point of view (POV) is
always through a camera. You may add several cameras, positioned and angled differently, and switch the Universe
window POV between them. When you render an image, you choose the POV from which the image should be

taken.



Point: As a unit of measure, a point is 1/72 of an inch. Point also refers to Bézier vertex and control points.



Pop-up (Fly-out) Tools: A pop-up menu of tool icons that automatically reveals itself when clicked upon with the
mouse.



Preview: The display of an object in the Perspective or Modeling window or the swatch of a shader in the Shaders
Browser. Also refers to a rendering with a low resolution setting.



Production Frame: The computer equivalent of the viewfinder in a real-world camera. The production frame can be
thought off as delimiting the area of the 3D scene that will be rendered into an image.



Projection: The silhouette of an object’s bounding box on one of the three visible planes of the grid. Used for
translations.



Ray Tracing: A procedure for generating a rendering. The ray tracer sends hypothetical rays of light from the sources
in the scene and calculates the visual effects, for each pixel in the rendering, as the rays encounter and reflect from
the objects in the scene.



Reference: A fixed point or plane used as the starting point for some operation. The hot point, the center of the
bounding box, and the corners of the bounding box are common reference points.



Reflected Background: Also known in computer graphics as Environment Maps, reflected backgrounds permit the use
of photographic or hand painted images as stand-ins for the typical subtleties of real world environments that have
not been depicted in the 3D scene itself. Reflected backgrounds will show up on reflective surfaces (metal, glass,
etc.), increasing the apparent realism of such surfaces.



Reflection: The phenomenon of light “bouncing off” objects.



Refraction: The phenomenon of light deflecting as it passes through a translucent object, like glass or fluid.



Relative Alignment: Setting two or more objects to some meaningful spatial relationship, such as centering them or
distributing them evenly along a line.



Relative Position: The placement of an object in relation to another object. For example, a book might be on top of a
table.



Render: The process of capturing a 2D image from a 3D scene.



Resolution: For devices, like a printer or the monitor screen, resolution is given in dots per inch (dpi) or dots per
centimeter.



RGB Color: The additive color model, used in computer monitors. Colors are created by adding varying degrees of
red, green, and blue light. For information on the “varying degrees,” refer to Bit Depth.



Roll: The aspect of an object’s attitude that describes its angular deviation along its lateral (side-to-side) axis.



Root: The root describes the highest level of the hierarchy, the universe. When you are “Jumped Into” a group, the
group box is the highest level of the hierarchy, and therefore, the local root.



Shader Component: An elementary building block of a shader tree.



Shader Family: A category of shader variants. In a Family, the settings in certain channels are often similar.



Shape: A 2D path that may be open, a line, or closed, such as an oval or a polygon. Shapes are used in cross
sections when modeling. In shading, paint shapes are used to specify regions for shading.



Text Alignment: Text alignment affects text objects of more than one line. The lines of text may be aligned to their left
edge, their center, or to their right edge.



Text Scaling: Scaling changes the width of characters without affecting their height. A value below 100% results in
characters that are narrower than usual, while a value above 100% results in characters wider than usual.



Texture Map: A 2D image used as a shader.



TIFF (Tagged Image File Format): An image file format often used for transfer between applications or platforms. Ray
Dream 3D opens TIFF images in RGB format, but not in CMYK format.



Tiling: The technique of repeating a small image across a larger surface to cover it.



Toolbar (dockable): An array of tool icons that can be “docked” or attached on a side of the computer screen.



Translation: Any manipulation of the position or attitude of an object. Also, an extrusion in which the cross section
remains at one angle, regardless of the curvature of the sweep path.



Translucence: The characteristic of an object that allows light to pass through it.



Universe: The 3D workspace, shown in the Perspective window, where you place and position objects.



Vertex: A control point on a path. Paths begin, change angle, and end at vertices.



Wizards: Visual step-by-step pictorials used to simplify a typically complex multi-stage process. Ray Dream 3D’s
modeling wizards allow the quick creation of 3D objects, and the scene wizards the rapid set-up of a scene complete
with lighting and props. Wizards are great learn-by-example resources that embed the know-how of experts in the
field of 3D graphics.



Word Spacing: Word Spacing adjusts the horizontal spacing between words. A negative value decreases spacing,
while a positive value increases it.



Working Box System: The working box has its own coordinate system. The attitude of its axes and the position of its
origin (at the center of the working box) change as you move and re-orient the working box.



Working Box: The three visible grid planes in the Perspective window. It is called the working box because you move
it as you work to constrain operations to certain planes.



Yaw: The aspect of an object’s attitude that describes its angular deviation along its linear (front-to-back) axis.



Open Import

Import Options

File Name

Select or type the name of the document you want to open. This box lists documents with the filename extension
selected in the List Files Of Type box. To see a list of files with a particular extension, type an asterisk (*), a period,
and the three-character extension, and then press ENTER. To see files with more than one filename extension, type
a semicolon (;), a second asterisk (*), a period, and another three-character extension. For example, if you want to
see all files with the .RDS extension and all files with the .RDD extension, type *.rds;*.rdd

List Files Of Type

Select the type of files you want to see in the File Name list.

Look In

Select the drive and directory that contains the file you want to import.



Save Export

Save Options

File Name

To save a document with a new name, in a different file format, or in a different location, type a new filename.

To save a document with an existing filename, select the name in the list or type the current name. When you choose
the OK button, Studio asks if you want to overwrite the existing document.

Save File As Type

Studio can save documents in many file formats. Choose a format that will work with the program you are exporting
to.

Drives

Select the drive where you want to store the document.
Directories

Select the directory where you want to store the document.
Options

Displays the Options dialog box, where you can add comments, specify preview settings, and choose format options
for free form objects.



Time Line Objects Tab

For information, see:

The Time Line Hierarchy Window
The Time Line Area

Changing the Property Display in the Time Line Window
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Time Line Masters Tab

For information, see:

The Time Line Hierarchy Window
The Time Line Area

Changing the Property Display in the Time Line Window
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Text Tool

For information, see:

Text Objects
About the 2D Text Tool

Creating Text Objects



Time Line Effects Tab

For information, see:

The Time Line Hierarchy Window

The Time Line Area

Changing the Property Display in the Time Line Window
Hierarchy Area Obijects, Masters, and Effects Tabs

Overview /il . Related Topics



General Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

e When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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General Light Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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General Camera Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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General Working Box Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Working Box Color Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Working Box Grid Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Master Object Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Group Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Properties Window

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.

See also Specifying Object Properties
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Transform Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Light Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical

position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Gel Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Camera Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Deformer Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Behavior Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Mapping Mode Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Shading Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Link Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical

position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Rendering Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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URL Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.



Miscellaneous Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Distance Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.

See Measuring and Setting the Distance of Objects
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Shadow Properties Tab

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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No Properties

When nothing is selected, no Properties can be displayed.
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Free Form Modeler

The Free Form modeler lets you create by converting 2D shapes into 3D objects. The modeler tools let you draw 2D
shapes called cross-sections and then convert them to 3D object by extruding them. Once you've created a 3D
object, you can refine its shape using an extrusion envelope.

The Free Form modeler is based on a concept called extrusion. You create an object by drawing a 2D shape, then
drawing a sweep path perpendicular to the shape. Ray Dream Studio sweeps the shape along the path to form a 3D
object.
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Mesh Form Modeler

The Mesh Form modeler lets you sculpt three-dimensional objects by directly manipulating their surfaces. When you
use the Mesh Form modeler, you’re not limited to creating objects that can only be modeled as extrusions, you can
model objects by directly edit an object’s surface.

You can start with a predefined object, such as a sphere or cube, or use the polymesh modeling tools to generate
extrusions, sweeps, lathed objects, and lofted objects. Once you've created an object, you can reshape and refine it
by editing the points that define its surface.

For more information:

Mesh Form Modeling Concepts

Mesh Form Modeling Window Overview
Mesh Form Modeling Window Features
Working in the Window
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Renderer

When you’ve built a scene, set lights, and chosen a viewpoint, you are ready for rendering. You'll probably render
your scene several times—the first couple of renderings will be low resolution proofs, so you can check your work.

You can also use the Render Preview tool to marquee an area of your scene and ray trace it directly in the
Perspective window. (The ray tracing prepared by the Render Preview tool will not show your Reflected
Background/Backdrop.)

At each proof stage, you may want to change your Rendering Settings, depending on the image aspects you want to
check. For example, if you just want to look at the objects, you might use the Production Z-Buffer. Or if you're
concerned only with shading and shadows, you might turn off the other ray-tracing options, like reflections and
transparency, which add to rendering time. Then, after correcting anything that didn’t turn out as expected, you can
generate the final, high resolution rendering.
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Render Output Tab

When you’ve built a scene, set lights, and chosen a viewpoint, you are ready for rendering. You'll probably render
your scene several times—the first couple of renderings will be low resolution proofs, so you can check your work.

You can also use the Render Preview tool to marquee an area of your scene and ray trace it directly in the
Perspective window. (The ray tracing prepared by the Render Preview tool will not show your Reflected
Background/Backdrop.)

At each proof stage, you may want to change your Rendering Settings, depending on the image aspects you want to
check. For example, if you just want to look at the objects, you might use the Production Z-Buffer. Or if you're
concerned only with shading and shadows, you might turn off the other ray-tracing options, like reflections and
transparency, which add to rendering time. Then, after correcting anything that didn’t turn out as expected, you can
generate the final, high resolution rendering.
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Render Effects Tab

Studio offers four rendering engines to choose from: Adaptive, Draft Z-Buffer, Ray Tracer, and Natural Media. Each
has an advantage when you’re looking for a particular result.

¢ The Adaptive renderer adapts the rendering method for different regions of the scene. It uses ray tracing where it's
required for bump maps, reflections, shadows, etc. And it switches to an accelerated A-Buffer renderer for other
regions. The Adaptive renderer produces anti-aliased edges on objects.

e The Draft Z-Buffer is an excellent choice for fast proofing. The quality it produces is similar to that of Better Preview
mode in the Perspective window.

¢ The Ray Tracer calculates the effects of light rays from your light sources as they encounter the objects in your
scene. Ray tracing shows most of the “real world” lighting effects, including transparency, shadow, reflection, and
bump maps.

e The Natural Media renderer produces interesting, stylistic renderings of the scene.
To choose the renderer you want to use:

1. Display the Scene Settings window: Renderer tab.

2.Choose the renderer you want from the pop-up menu.
The panel updates to show the options for this rendering engine.
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Render Filters Tab

The render filters create special effects in the image after it has been rendered. Actually, they’re post-render filters.

The filters include lens effects that simulate the results obtained from photographic cameras and special lighting
effects.
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Render Miscellaneous Tab

When you’ve built a scene, set lights, and chosen a viewpoint, you are ready for rendering. You'll probably render
your scene several times—the first couple of renderings will be low resolution proofs, so you can check your work.

You can also use the Render Preview tool to marquee an area of your scene and ray trace it directly in the
Perspective window. (The ray tracing prepared by the Render Preview tool will not show your Reflected
Background/Backdrop.)

At each proof stage, you may want to change your Rendering Settings, depending on the image aspects you want to
check. For example, if you just want to look at the objects, you might use the Production Z-Buffer. Or if you're
concerned only with shading and shadows, you might turn off the other ray-tracing options, like reflections and
transparency, which add to rendering time. Then, after correcting anything that didn’t turn out as expected, you can
generate the final, high resolution rendering.
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General Preferences

For information, see:

Overview (il Related Topics



Scratch Disk Preferences

Ray Dream Studio 5 uses free space on your hard drive to store portions of the scene you are working on. The
program periodically reads and writes to this disk space as you zoom in or make changes in your scene. The disk
space used by Ray Dream Studio 5 for this purpose is called the “scratch disk.”

Ray Dream Studio 5 works more efficiently when the selected scratch disk is fast and has plenty of free space. If
scratch disk space and memory are limited, zooming is limited. You may want to use a disk utility to keep your scratch
disk optimized.

By default, Ray Dream Studio 5 chooses the disk where the application is installed as the scratch disk. However, you
can select any of your hard disks as the scratch disk.



Shader Editor Preferences

The Shader Editor gives you complete control over the appearance of your shaders. You can use the Shader Editor
to edit shaders stored in the Shaders Browser or shaders you’ve applied to objects in your scene.

Each shader channel is on a different tab in the editor. The preview shows you how your shader will appear on the
surface of an object and provides you with immediate feedback when you change shading parameters.
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3D Paint Preferences

When you want to apply a shader to a limited region on the surface of an object, you'll use Studio’s 3D Paint tools.
The 3D Paint tools allow you to create paint shapes directly on the surface of an object in the Perspective or
Modeling window. A paint shape may be rectangular, elliptical, polygonal, or freely brushed.

Because the 3D Paint tools work with the shaders in the Shaders Browser, you’re not limited to painting with color.
You can load your brush with gold, marble, or concrete and apply not only color, but bump, reflection, transparency,
and the other shading attributes as well.

Once you’ve created paint shapes, you can move them, resize them, layer them, and delete them. You may create
any number of paint shapes on the surface of an object.
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Free Form Modeler Preferences

The Free Form modeler lets you create by converting 2D shapes into 3D objects. The modeler tools let you draw 2D
shapes called cross-sections and then convert them to 3D object by extruding them. Once you've created a 3D
object, you can refine its shape using an extrusion envelope.

The Free Form modeler is based on a concept called extrusion. You create an object by drawing a 2D shape, then
drawing a sweep path perpendicular to the shape. Ray Dream Studio sweeps the shape along the path to form a 3D
object.
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Perspective Preferences

The Perspective window shows a view of the 3D workspace, where objects, lights and camera are arranged to create
a scene. The workspace itself is called the universe. The view of your scene shown in the Perspective window is
taken through a camera. You can move this camera to see different views of your scene or you can add other
cameras to get more viewpoints.

The current zoom ratio (1:1, 2:1, etc....) is shown in the lower left of the window and the status (idle, drawing,
shading, etc.) of the application is displayed in the status area.
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Hierarchy Preferences

The structure of a scene organizes the elements of a scene according to spatial or logical relationships. Structure
simplifies arrangement operations and can save you time and trouble.

Working primarily in the hierarchy, you can structure a scene by grouping and linking objects. The term “object” refers
also to lights, cameras, and closed groups. You'll find it’s far easier to keep track of objects that you’ve specifically
named than it is to manage generically named objects.

Every object in your scene appears in the hierarchy. The hierarchy is shown as a tree of elements, each represented
by a listing or named icon. The hierarchy of a scene changes as you introduce objects, group them, and create links.

Elements may be objects, groups, cameras, or light sources. The highest level of the hierarchy is the root. It is
represented by an icon entitled “Universe.” It encompasses your entire scene. Beneath the universe, you may have
any number of branches and sub-branches.
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Browser Preferences

All the items in a Ray Dream scene can be stored as separate files on your system. The Browser lets you load theses
files and view them as visual libraries complete with previews of each item. You can retrieve any item by dragging
them out the Browser and into either the Hierarchy or Perspective windows.

Each tab can display a multiple number of directories. You can use the Browser commands to add and remove
directories from your hard disk. You can also add some items from the Hierarchy window by dragging them directly
into the Browser. You can view Browser items by small icon, large icon, or text using the Browser:View commands.
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Mesh Form Modeler Preferences

In Mesh Form modeling, three-dimensional objects can be described as sets of vertices, edges and polygons. A
vertex defines a position in three-dimensional space and an edge is the line that connects two vertices. For example,
eight vertices and twelve edges describe a cube. Each face of the cube is a filled polygon.

A polyline is a selected set of connected edges. A polyline that forms a closed loop is referred to as a “closed”
polyline. A closed polyline is not equivalent to a polygon—a closed polyline might encompass several polygons.
However, if you fill a closed polyline that doesn’t encompass any other edges or vertices, it becomes a polygon.

A collection of vertices, edges and the polygons that they form is called a polymesh. A polymesh can form a closed
volume, such as a cube, or an open object resembling a sheet of wire mesh.

Polymesh modeling is the process of creating three-dimensional objects by directly manipulating vertices, edges and
polygons. Instead of modeling all objects as extrusions, you can “sculpt” objects by changing the number and location
of their vertices, edges and polygons.

By combining the modeling techniques used in the Free Form modeler with the ability to directly edit vertices and
edges, the Mesh Form modeler makes it easy to create complex models. For example, you can use the Mesh Form
modeler to create a complex cross section and extrusion path, extrude an object, and then directly edit the object’s
vertices and edges to refine its appearance.

MRelated Topics



Render Features Preferences

Arendering is a separate file and is stored on disk in a different format. Ray Dream lets you save renderings in many
popular image formats: PICT and EPS (Macintosh only), Windows Bitmap (BMP), TIFF, Adobe PhotoShop, and
others. You can print your renderings, open them in an image-editing program, or place them into virtually any
application.

The G-Buffer is a special feature of Ray Dream Studio 5 that allows you to include special information in data
channels that are saved with the rendered image. These channels can be manipulated in an image editing program
to create special effects.
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Colors Preferences

The Color component allows you to specify any color. Although you can place the Color component anywhere on the
shader tree, it's best suited for use in the Color, Highlight, Reflection, Transparency, and Glow channels, which are
designed for color input.

¢ In the Bump channel, the Color component produces no effect because it gives a constant value across the surface
of an object. To create the illusion of bumpiness, the Bump channel requires variation across an object’s surface.

¢ |n a non-color channel—Shininess or Refraction—colors are converted to values. Dark colors convert to low
values, light colors to high values.

When you place the Color component on the shader tree, it appears as a color swatch.
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Motion Path Preferences

To help you visualize the movements of your animated objects, you can choose to display motion paths. A motion
path is a line curving through space that describes where an object is located throughout the animation. Motion paths
are 3D and cast projections.

The knobs on the path describe the relative spacing of transition frames. When you change the tweener, the spacing
of the knobs changes to describe the new transition.
Note: The motion path is a visualization tool. You cannot change an object’s trajectory by editing the path directly.

Motion paths apply to objects individually, so you can show or hide them for any particular object. The control for
viewing motion paths is on the Time Controller Toolbar.
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Shaded Preview Preferences

The Perspective window has five modes for displaying your objects:
¢ No Preview

¢ Bounding Box

e Wireframe

¢ Preview (Gouraud)

e Better Preview (Phong)

Better Preview mode shows details of the shape and color of your objects, but takes longer to calculate and draw. To
increase application efficiency, you might want to work in Wireframe or Preview mode at the outset of a project, then
switch to Better Preview mode as specific details become important.

You can also make specific objects invisible in the Perspective window. The Object Invisible command in the View
menu. Invisible object(s) will still appear in the Hierarchy/Timeline window with their names italicized.
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Drag and Drop Preferences

Drag a subshaders or component onto the branch of the shader tree where you want it.
¢ You can drag a shader from the Browser.

¢ You can drag a component or subshader from an open shader Browser document. This has the advantage of
bringing all of its parameters with it.

Studio copies the component or subshader you drag onto the branch where you drop it, replacing any contents that
may have been there before.

When you drop a shader onto any branch of a Composite shader, only the contents of the applicable channel are
placed on the branch. If the shader you're dropping has no components in the applicable channel, Studio will notify
you, and nothing will be added to the branch.

Note: When you drop a shader onto the left or right branch of a Global Mix shader, the entire shader you’re dropping
(all eight channels) is placed on the tree.
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Properties Palette Preferences

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.
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Toolbars

Ray Dream Studio’s toolbars provide quick access to many of Ray Dream’s frequently used commands and
functions. There are eight different toolbars available in Ray Dream:

e Standard

e Zoom

¢ Rendering

e Time Controller
e Status

¢ Tools

* Planes

¢ Internet

You can use the Toolbar dialog available from the View menu to choose which toolbars you want to be displayed. The
tools available in the Tools toolbar change as you change between the Perspective, Mesh Form and Free Form
windows.

Toolbars can be docked to application window or undocked as floating windows. When you float toolbars they appear
as windowson top of all other Ray Dream windows.
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FTP

For information, see:
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Batch Queue

For information, see:

The Batch Queue
Adding Files to the Batch Queue
Changing Settings for a File in the Batch Queue

Starting a Batch Process
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Register Ray Dream Studio

Enter your name and organization to have them appear in the splash screen when Ray Dream Studio starts up.
You must enter the serial number you received with Ray Dream Studio in order to successfully install the application.



Register Ray Dream Studio Extensions

Enter the information needed in order to register your Ray Dream Studio Extensions.

Ray Dream Studio 5 is designed along an extensible, open architecture. Application developers can create
extensions to integrate with Studio. Extensions might include a new modeler (a tool set for shaping objects),
procedural shaders, new types of lights, cameras, or even an alternative rendering engine.

The complete Extensions Toolkit and API for creating Ray Dream Studio extensions is available on the Ray Dream
Studio CD-ROM. Refer to the Extensions Portfolio User Guide for more information on developing extensions.



Font Size

For information, see:

Creating Text Objects

Text Objects
About the 2D Text Tool



Font List

For information, see:

Creating Text Objects

Text Objects
About the 2D Text Tool



Polygon Sides

Click once to position each vertex of your polygonal paint shape. As you position vertices, the line segments
connecting the vertices are drawn. Double-click at the last vertex to automatically close the shape.

Although you can later resize or “stretch” a polygonal paint shape, you won'’t be able to re-edit its vertices.
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Numerical Slider

When you create an object, you model it at a particular size. Once in the scene, you can scale the object to new
dimensions. The most important aspect of an object’s size is its relationship to other objects. For example, if the cork
is larger than the wine bottle, one of them has the wrong scale.

Because Ray Dream Studio allows you to work with real world units (inches feet, centimeters, meters, etc.), many
artists scale objects equivalent to their size in the real world. For example, a soft drink can is 4.75 inches tall and 2.5
inches in diameter, so it makes sense to scale a can object to these dimensions. When you put a pencil object (0.62
inches in diameter and 7.4 inches long, unsharpened) next to the can, the two objects have the correct size
relationship.

Note: Scaling in the scene does not change the size of the original (master) object.

Ray Dream Studio allows you to resize an object or group in one of two ways: by dragging its bounding box or 2D
projection handles (free resizing), or by using the Properties palette: Transform tab: Size & Scaling controls. In both
cases, you can resize an object proportionally or disproportionally.

The size you create objects has little relationship to the size they appear in the final rendered image. The size of
objects in the rendered image is determined not only by their dimensions, but more importantly by their distance from
the point of view. This is just like in the real world: a car right in front of you appears larger than when it's parked
down the block. In Ray Dream Studio 5, the point of view is the camera, so if you want to make objects appear larger
in the rendering, either move the camera closer, or increase its focal length.
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Camera Editor

Cameras provide viewpoints for the Perspective window and for renderings. As you build your scene, the cameras
can be positioned to get the best view for working. You can place several cameras and switch among them to get
alternate perspectives of your scene. You can even create a second Perspective window to view your scene from two
different angles at once.

When you are ready to render, you can select one camera as the viewpoint. The camera position and settings
combine with the production frame position and rendering format to determine the scale and framing of the scene.

Ray Dream Studio also lets you create camera effects, like lens flare and depth of field. These effects help you
achieve results you’d expect from photography.
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Create Camera

Cameras provide viewpoints for the Perspective window and for renderings. As you build your scene, the cameras
can be positioned to get the best view for working. You can place several cameras and switch among them to get
alternate perspectives of your scene. You can even create a second Perspective window to view your scene from two
different angles at once.

When you are ready to render, you can select one camera as the viewpoint. The camera position and settings
combine with the production frame position and rendering format to determine the scale and framing of the scene.

Ray Dream Studio also lets you create camera effects, like lens flare and depth of field. These effects help you
achieve results you’d expect from photography.
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New Perspective

The default view of your scene is through the default camera. The camera can be sent to a number of default

positions and oriented using the Camera tools.
You can also add additional camera to the scene, You can use the new camera to view your scene from different

angles.
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Tweener Editor

Tweeners make it easy to create more interesting and subtle changes in the transitions between key events.
Tweeners will save you time by automatically creating movements and changes that would be extremely difficult with
key events alone. Tweeners make your animation motions and other changes more natural and sophisticated.

The time period between any two key events is considered a transition. In the Time Line, you'll see the transition as
the “gap” between key event markers. Studio uses a formula (the “tweener”) to create the transitional states so that
the object or effect changes smoothly between the two key events.

You won’t always want a smooth, linear transition. Sometimes you’ll want an abrupt change of state. Other times
you’ll want a transition that starts slowly and accelerates to finish in a rush. You might even want a transition that
quickly alternates between the before and after states, like a florescent light flickering on.

All of these transitions are possible by setting your options for the tweener used between each pair of key frames. A
tweener requires a beginning and an ending key event, although you can place the ending key event far out in time.
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Add Component

For information, see:

About Shader Components
Moving Components by Dragging
Color Component

Value Component

Texture Map Component
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Unknown Component

No information is available about this component.



Abort Rendering

When you abort rendering, all the rendered information to that point is lost.



Load and Remove Render Settings

Ray Dream offers a number of options and settings for controlling rendering. To get the rendering results you want,
you’ll need to make several choices and adjustments.

Your choices will be based on your expectations
—whether you’re creating a draft rendering to check the objects, rendering final artwork, or rendering an animation.
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Save Render Settings

Ray Dream offers a number of options and settings for controlling rendering. To get the rendering results you want,
you’ll need to make several choices and adjustments.

Your choices will be based on your expectations

—whether you’re creating a draft rendering to check the objects, rendering final artwork, or rendering an animation.
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New Document

New Document Options

New

Select either the Document or Template option button.
Document

Creates a new document.



Remove Light

The appearance of objects in the Ray Dream Studio universe is determined greatly by the light in which they are
viewed.

A good set of lighting conditions is an important step toward creating high quality artwork. The same scene rendered
under different light can provide strikingly different results. For example, rendering with all lighting at zero brightness

is like taking a photograph—uwithout a flash—in the bottom of a coal mine. Conversely, too much lighting washes out
subtle effects.

Ray Dream Studio also lets you create visible light spheres and cones. The visible light cone effect is like a
searchlight cutting through the fog.



Open Map Options

Most shader content is two-dimensional. Texture maps, for example, are nothing more than 2D images. Many
procedural shader functions—including Studio’s checkers and wires—also produce two-dimensional image data.
Studio uses a process called mapping to apply this 2D shading information to the surface of a 3D object.

Studio’s 3D Paint interface allows you to shade objects without worrying about the internal *

nuts and bolts” of mapping. Most of the time, you can simply paint on objects with the 3D Paint tools and let Studio
take care of the details. Occasionally, however, you may find that changing an object’s mapping mode makes it easier
for you to achieve the results you want.

When you change an object’s mapping mode, Studio changes the method it uses to map 2D shapes and images to
the object’s surface. As a result, the 3D Paint tools behave differently on the object. Depending on the shape of your
object and the mapping mode you choose, the difference may be subtle or quite dramatic.



Movie Time

The time line area of the Time Line window displays a time track for each element (group, object, effect, property
category, or individual property) currently shown in the hierarchy.

An animation’s key events are represented by key event markers on the tracks of the time line. A marker may
represent a single key event or several coincident key events, each relating to different properties of the same object.
The key event marker appears on the track for the object or effect to which it relates. The location of a key event
marker along its track indicates the time at which the key even occurs.



Sequenced Movie Options

Movie formats include QuickTime Movie, AVI Movie, Sequenced Corel Photo Paint, Sequenced GIF, Sequenced
JPEG, Sequenced PICT, Sequenced Photoshop, Sequenced TIFF, Sequenced Targa, Sequenced Painter RIFF.

The “Movie” formats (QuickTime and AVI) generate a single file that includes all of the frames.

The “sequenced” formats generate a single file for each frame. The files are numbered 000, 001, 002, and so forth, to
keep them in sequence. Sequenced files are often used for transferring the animation to other programs, such as
Adobe Premiere™.
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Properties Palette

The Properties palette is a dynamic palette that display the properties of any element selected in the Perspective or
Time Line windows. The controls available in the Properties palette change as you select different items:

¢ When you select an object in the Perspective window, the palette displays controls to change the object’'s name,
position, deformers, shading, behaviors, links and rendering settings.

¢ When a light is selected, the palette displays the light's properties and controls for changing the light type, color
and other properties.

¢ When a camera is selected, the palette displays the camera’s name, position and camera type properties.
¢ When you select a point in the Free Form modeler, the palette displays the point’s position and angle.

¢ When you select an object in the Mesh Form modeler, the palette displays controls for adjusting its numerical
position.
Many of the tools in the Mesh Form modeler also have a number of properties. When a tool has no properties,
the palette is blank.



Edit Wireframe

The Mesh Form modeler lets you freely move the drawing plane to any plane in the model. When you move the
drawing plane, you often need to change your viewpoint to get a better view of the objects you're working with.

You can use the preset viewing positions in the View menu to change your viewpoint, like you can in the Free Form
modeler.

When you're viewing and editing your model, you'll also frequently want to change between the wireframe editing

mode and the preview modes. The Mesh Form modeler provides the same preview modes as the Free Form
modeler.



Auto Apply

For information, see:
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Add Data Component

About Shader Components
Moving Components by Dragging
Color Component

Value Component

Texture Map Component
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Component Settings
For information about component settings, see:

About Shader Components
Moving Components by Dragging
Color Component

Value Component

Texture Map Component



Hierarchy

The structure of a scene organizes the elements of a scene according to spatial or logical relationships. Structure
simplifies arrangement operations and can save you time and trouble.

Working primarily in the hierarchy, you can structure a scene by grouping and linking objects. The term “object” refers
also to lights, cameras, and closed groups. You'll find it’s far easier to keep track of objects that you’ve specifically
named than it is to manage generically named objects.

Every object in your scene appears in the hierarchy. The hierarchy is shown as a tree of elements, each represented
by a listing or named icon. The hierarchy of a scene changes as you introduce objects, group them, and create links.

Elements may be objects, groups, cameras, or light sources. The highest level of the hierarchy is the root. It is
represented by an icon entitled “Universe.” It encompasses your entire scene. Beneath the universe, you may have
any number of branches and sub-branches.
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Drag and Drop

Drag a subshaders or component onto the branch of the shader tree where you want it.
¢ You can drag a shader from the Browser.

¢ You can drag a component or subshader from an open shader Browser document. This has the advantage of
bringing all of its parameters with it.

Studio copies the component or subshader you drag onto the branch where you drop it, replacing any contents that
may have been there before.

When you drop a shader onto any branch of a Composite shader, only the contents of the applicable channel are
placed on the branch. If the shader you're dropping has no components in the applicable channel, Studio will notify
you, and nothing will be added to the branch.

Note: When you drop a shader onto the left or right branch of a Global Mix shader, the entire shader you’re dropping
(all eight channels) is placed on the tree.
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Drag and Drop List

Drag a subshaders or component onto the branch of the shader tree where you want it.
¢ You can drag a shader from the Browser.

¢ You can drag a component or subshader from an open shader Browser document. This has the advantage of
bringing all of its parameters with it.

Studio copies the component or subshader you drag onto the branch where you drop it, replacing any contents that
may have been there before.

When you drop a shader onto any branch of a Composite shader, only the contents of the applicable channel are
placed on the branch. If the shader you're dropping has no components in the applicable channel, Studio will notify
you, and nothing will be added to the branch.

Note: When you drop a shader onto the left or right branch of a Global Mix shader, the entire shader you’re dropping
(all eight channels) is placed on the tree.
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Drag and Drop Group

Drag a subshaders or component onto the branch of the shader tree where you want it.
¢ You can drag a shader from the Browser.

¢ You can drag a component or subshader from an open shader Browser document. This has the advantage of
bringing all of its parameters with it.

Studio copies the component or subshader you drag onto the branch where you drop it, replacing any contents that
may have been there before.

When you drop a shader onto any branch of a Composite shader, only the contents of the applicable channel are
placed on the branch. If the shader you're dropping has no components in the applicable channel, Studio will notify
you, and nothing will be added to the branch.

Note: When you drop a shader onto the left or right branch of a Global Mix shader, the entire shader you’re dropping
(all eight channels) is placed on the tree.
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Choose Modeler

For information, see:
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Open Scene

For information, see:

Creating an Empty Scene

Automatically Launching the Scene Wizard
Creating a Scene with the Scene Wizard
Adding to a file with the Scene Wizard
Opening an Existing File



Jump in Instance

When you jump into an instance object, Ray Dream Studio displays a dialog alerting you. In the dialog, you may
choose to modify the master object of this class or create a new master from this instance.

You may have multiple instances with the same name, but you may not have two master objects with the same
name. When you create a new master object by modifying an object instance, Ray Dream Studio names the new
class object by appending a number to the old name.

If you modify an instance when you had intended to modify the master object, you can easily get back on track by
replacing the master with your modified instance.

You can create new instances of the master object by duplicating an existing instance, copying and pasting, or by
dragging the object from the Master tab into the scene.



New Camera

Cameras provide viewpoints for the Perspective window and for renderings. As you build your scene, the cameras
can be positioned to get the best view for working. You can place several cameras and switch among them to get
alternate perspectives of your scene. You can even create a second Perspective window to view your scene from two
different angles at once.

When you are ready to render, you can select one camera as the viewpoint. The camera position and settings
combine with the production frame position and rendering format to determine the scale and framing of the scene.



Edit Class Name

For information, see:
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Render Size Ratio

For information, see:
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Edit Name

New objects are named by default Type n, where Type is the object description (Free Form, Sphere, Text, etc...) and
n is the number of similar objects in the order created—Free Form 1, Free Form 2 and so forth.

You can change the name of objects and groups. Giving objects and groups descriptive names can make them
easier to locate and select.
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Edit Object Name

New objects are named by default Type n, where Type is the object description (Free Form, Sphere, Text, etc...) and
n is the number of similar objects in the order created—Free Form 1, Free Form 2 and so forth.

You can change the name of objects and groups. Giving objects and groups descriptive names can make them
easier to locate and select.
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Group Objects

For information, see:

overview (i Wl aica Topics



Modeler Name

New objects are named by default Type n, where Type is the object description (Free Form, Sphere, Text, etc...) and
n is the number of similar objects in the order created—Free Form 1, Free Form 2 and so forth.

You can change the name of objects and groups. Giving objects and groups descriptive names can make them
easier to locate and select.
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Behavior

For information, see:

overview (i Wl aica Topics



Modify Linked Object

For information, see:
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Camera Increment

For information, see:
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Find

For information, see:
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Camera Properties

For information, see:
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Grid

For information, see:
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Save Camera Position

For information, see:
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Delete Camera Position

For information, see:
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Past Object

For information, see:
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Perspective Window

For information, see:
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Modular Section Options

For information, see:
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Create Multiple Cross Sections

For information, see:
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Go To Cross Section

For information, see:
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Modular Shape Number

For information, see:
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Modular Scale

For information, see:
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Rotate

For information, see:
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Import Art

Import Options

File Name

Select or type the name of the document you want to open. This box lists documents with the filename extension
selected in the List Files Of Type box. To see a list of files with a particular extension, type an asterisk (*), a period,
and the three-character extension, and then press ENTER. To see files with more than one filename extension, type
a semicolon (;), a second asterisk (*), a period, and another three-character extension. For example, if you want to
see all files with the .RDS extension and all files with the .RDD extension, type *.rds;*.rdd

List Files Of Type

Select the type of files you want to see in the File Name list.

Look In

Select the drive and directory that contains the file you want to import.



Round Rectangle

For information, see:
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Modeling Box Size

For information, see:
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Modular Spiral

For information, see:
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Modular Torus

For information, see:

overview (i Wl aica Topics



Surface Fidelity

For information, see:
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Shader Editor

For information, see:
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Shader Document

For information, see:
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Multiple Shader Channels

For information, see:

overview (i Wl aica Topics



Shader Color

For information, see:
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Shader Value

For information, see:
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No Shader Channel

For information, see:
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Brush Palette

For information, see:
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3D Paint Advice

For information, see:
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3D Paint Layer Advice

For information, see:
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Numeric Shape

For information, see:
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Numeric Shape

For information, see:
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Preferences Window

For information, see:
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Save Workspace

For information, see:
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Remove Workspace

For information, see:
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Set Time Axis

For information, see:
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Browser Window

For information, see:
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Browser File Info

For information, see:
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New Browser File

For information, see:
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Scene Settings Window

For information, see:

Creating a New Scene
The Scene Wizard

Scene Setting Effects

MRelated Topics



Save Scene Settings

For information, see:

Creating a New Scene
The Scene Wizard

Scene Setting Effects
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Load and Remove Scene Settings

For information, see:

Creating a New Scene
The Scene Wizard

Scene Setting Effects
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Ray Dream 3D Key Features

Properties and Browser Palettes

The Properties palette displays the controls and data for any object you select. As you select different scene
elements, the palette’s controls change.

To learn more about the Properties palette see Properties Palette.

The Browser palette acts like warehouse of all the items you can use to create a scene. You can use the Browser
palette to store Objects, Shaders, Deformers, Behaviors, Lights, Cameras and more.

To learn more about the Browser see Using the Browser Palette.

Direct Manipulation Controls

The Direct Manipulation controls let you adjust the properties of many scene elements directly on screen. When you
click an element that has Direct Manipulation controls, its control handles appear. As you drag these handles, you
change the elements properties.

There are several scene elements that have direct manipulation controls:
¢ To learn more about Light controls, see Controlling a Spot Light Directly.
¢ To learn more about Camera controls, see Controlling a Camera Directly.

And More

In addition to the features listed here, Ray Dream 3D features dozens of powerful features for creating 3D
illustrations.






